mirror of
https://github.com/openwrt/openwrt.git
synced 2025-03-22 12:05:32 +00:00
kernel: bump 4.19 to 4.19.108
Refreshed all patches. Compile-tested on: cns3xxx Runtime-tested on: cns3xxx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
parent
d5a3536631
commit
e64564920a
@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
|
||||
endif
|
||||
|
||||
LINUX_VERSION-4.14 = .172
|
||||
LINUX_VERSION-4.19 = .106
|
||||
LINUX_VERSION-4.19 = .108
|
||||
LINUX_VERSION-5.4 = .22
|
||||
|
||||
LINUX_KERNEL_HASH-4.14.172 = 2318a1ab937580a079351ed20557c336a3d95b664f667b14e3ba49e3271b217a
|
||||
LINUX_KERNEL_HASH-4.19.106 = 63c8bd76a9b282e18112f8ff9e3fd41e3d1df9f9b7248ea1a370b05a827e9cda
|
||||
LINUX_KERNEL_HASH-4.19.108 = 09aeeca5b08efea2f54b977b2999afb60d42f93b9f65b2b0111969f183f750a3
|
||||
LINUX_KERNEL_HASH-5.4.22 = 661bcb8d7e390dcc28e53795485e648f2bdc9b697b731459cc2bcc9ceb4a7d1a
|
||||
|
||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||
|
@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
|
||||
|
||||
#include "xhci.h"
|
||||
#include "xhci-trace.h"
|
||||
@@ -262,6 +264,458 @@ static void xhci_pme_acpi_rtd3_enable(st
|
||||
@@ -264,6 +266,458 @@ static void xhci_pme_acpi_rtd3_enable(st
|
||||
static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
|
||||
#endif /* CONFIG_ACPI */
|
||||
|
||||
@ -503,7 +503,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
|
||||
/* called during probe() after chip reset completes */
|
||||
static int xhci_pci_setup(struct usb_hcd *hcd)
|
||||
{
|
||||
@@ -300,6 +754,22 @@ static int xhci_pci_probe(struct pci_dev
|
||||
@@ -305,6 +759,22 @@ static int xhci_pci_probe(struct pci_dev
|
||||
struct hc_driver *driver;
|
||||
struct usb_hcd *hcd;
|
||||
|
||||
@ -526,7 +526,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
|
||||
driver = (struct hc_driver *)id->driver_data;
|
||||
|
||||
/* Prevent runtime suspending between USB-2 and USB-3 initialization */
|
||||
@@ -361,6 +831,16 @@ static void xhci_pci_remove(struct pci_d
|
||||
@@ -363,6 +833,16 @@ static void xhci_pci_remove(struct pci_d
|
||||
{
|
||||
struct xhci_hcd *xhci;
|
||||
|
||||
|
@ -13,7 +13,7 @@ produce a noisy warning.
|
||||
|
||||
--- a/drivers/usb/host/xhci-pci.c
|
||||
+++ b/drivers/usb/host/xhci-pci.c
|
||||
@@ -215,6 +215,7 @@ static void xhci_pci_quirks(struct devic
|
||||
@@ -217,6 +217,7 @@ static void xhci_pci_quirks(struct devic
|
||||
pdev->device == 0x0015) {
|
||||
xhci->quirks |= XHCI_RESET_ON_RESUME;
|
||||
xhci->quirks |= XHCI_ZERO_64B_REGS;
|
||||
@ -43,7 +43,7 @@ produce a noisy warning.
|
||||
hcd->msi_enabled = 1;
|
||||
--- a/drivers/usb/host/xhci.h
|
||||
+++ b/drivers/usb/host/xhci.h
|
||||
@@ -1876,6 +1876,7 @@ struct xhci_hcd {
|
||||
@@ -1883,6 +1883,7 @@ struct xhci_hcd {
|
||||
/* support xHCI 0.96 spec USB2 software LPM */
|
||||
unsigned sw_lpm_support:1;
|
||||
/* support xHCI 1.0 spec USB2 hardware LPM */
|
||||
|
@ -917,7 +917,7 @@ Fixes https://github.com/raspberrypi/linux/issues/2408
|
||||
}
|
||||
--- a/drivers/usb/core/hub.c
|
||||
+++ b/drivers/usb/core/hub.c
|
||||
@@ -5222,7 +5222,7 @@ static void port_event(struct usb_hub *h
|
||||
@@ -5228,7 +5228,7 @@ static void port_event(struct usb_hub *h
|
||||
u16 status = 0, unused;
|
||||
port_dev->over_current_count++;
|
||||
|
||||
|
@ -62,8 +62,8 @@ Signed-off-by: Stefan Wahren <wahrenst@gmx.net>
|
||||
+ const struct brcmstb_thermal_of_data *socdata;
|
||||
};
|
||||
|
||||
static void avs_tmon_get_coeffs(struct thermal_zone_device *tz, int *slope,
|
||||
@@ -164,17 +171,18 @@ static inline u32 avs_tmon_temp_to_code(
|
||||
/* Convert a HW code to a temperature reading (millidegree celsius) */
|
||||
@@ -151,17 +158,18 @@ static inline u32 avs_tmon_temp_to_code(
|
||||
static int brcmstb_get_temp(void *data, int *temp)
|
||||
{
|
||||
struct brcmstb_thermal_priv *priv = data;
|
||||
@ -84,7 +84,7 @@ Signed-off-by: Stefan Wahren <wahrenst@gmx.net>
|
||||
|
||||
t = avs_tmon_code_to_temp(priv->thermal, val);
|
||||
if (t < 0)
|
||||
@@ -299,13 +307,34 @@ static int brcmstb_set_trips(void *data,
|
||||
@@ -286,13 +294,34 @@ static int brcmstb_set_trips(void *data,
|
||||
return 0;
|
||||
}
|
||||
|
||||
@ -121,7 +121,7 @@ Signed-off-by: Stefan Wahren <wahrenst@gmx.net>
|
||||
{},
|
||||
};
|
||||
MODULE_DEVICE_TABLE(of, brcmstb_thermal_id_table);
|
||||
@@ -326,10 +355,27 @@ static int brcmstb_thermal_probe(struct
|
||||
@@ -313,10 +342,27 @@ static int brcmstb_thermal_probe(struct
|
||||
if (IS_ERR(priv->tmon_base))
|
||||
return PTR_ERR(priv->tmon_base);
|
||||
|
||||
@ -150,7 +150,7 @@ Signed-off-by: Stefan Wahren <wahrenst@gmx.net>
|
||||
if (IS_ERR(thermal)) {
|
||||
ret = PTR_ERR(thermal);
|
||||
dev_err(&pdev->dev, "could not register sensor: %d\n", ret);
|
||||
@@ -369,6 +415,9 @@ static int brcmstb_thermal_exit(struct p
|
||||
@@ -356,6 +402,9 @@ static int brcmstb_thermal_exit(struct p
|
||||
if (thermal)
|
||||
thermal_zone_of_sensor_unregister(&pdev->dev, priv->thermal);
|
||||
|
||||
|
@ -10,7 +10,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
||||
|
||||
--- a/drivers/usb/host/xhci-pci.c
|
||||
+++ b/drivers/usb/host/xhci-pci.c
|
||||
@@ -222,6 +222,10 @@ static void xhci_pci_quirks(struct devic
|
||||
@@ -224,6 +224,10 @@ static void xhci_pci_quirks(struct devic
|
||||
pdev->device == 0x3432)
|
||||
xhci->quirks |= XHCI_BROKEN_STREAMS;
|
||||
|
||||
|
@ -23,7 +23,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
|
||||
|
||||
--- a/drivers/usb/host/xhci-pci.c
|
||||
+++ b/drivers/usb/host/xhci-pci.c
|
||||
@@ -223,8 +223,10 @@ static void xhci_pci_quirks(struct devic
|
||||
@@ -225,8 +225,10 @@ static void xhci_pci_quirks(struct devic
|
||||
xhci->quirks |= XHCI_BROKEN_STREAMS;
|
||||
|
||||
if (pdev->vendor == PCI_VENDOR_ID_VIA &&
|
||||
@ -80,7 +80,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
|
||||
/*
|
||||
--- a/drivers/usb/host/xhci.h
|
||||
+++ b/drivers/usb/host/xhci.h
|
||||
@@ -1865,6 +1865,7 @@ struct xhci_hcd {
|
||||
@@ -1872,6 +1872,7 @@ struct xhci_hcd {
|
||||
#define XHCI_ZERO_64B_REGS BIT_ULL(32)
|
||||
#define XHCI_RESET_PLL_ON_DISCONNECT BIT_ULL(34)
|
||||
#define XHCI_SNPS_BROKEN_SUSPEND BIT_ULL(35)
|
||||
|
@ -22,7 +22,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
|
||||
|
||||
--- a/drivers/usb/host/xhci-mem.c
|
||||
+++ b/drivers/usb/host/xhci-mem.c
|
||||
@@ -2495,9 +2495,11 @@ int xhci_mem_init(struct xhci_hcd *xhci,
|
||||
@@ -2516,9 +2516,11 @@ int xhci_mem_init(struct xhci_hcd *xhci,
|
||||
* Event ring setup: Allocate a normal ring, but also setup
|
||||
* the event ring segment table (ERST). Section 4.9.3.
|
||||
*/
|
||||
@ -36,7 +36,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
|
||||
if (!xhci->event_ring)
|
||||
goto fail;
|
||||
if (xhci_check_trb_in_td_math(xhci) < 0)
|
||||
@@ -2510,7 +2512,7 @@ int xhci_mem_init(struct xhci_hcd *xhci,
|
||||
@@ -2531,7 +2533,7 @@ int xhci_mem_init(struct xhci_hcd *xhci,
|
||||
/* set ERST count with the number of entries in the segment table */
|
||||
val = readl(&xhci->ir_set->erst_size);
|
||||
val &= ERST_SIZE_MASK;
|
||||
|
@ -127,7 +127,7 @@ it on BCM4708 family.
|
||||
/*
|
||||
--- a/drivers/usb/host/xhci.h
|
||||
+++ b/drivers/usb/host/xhci.h
|
||||
@@ -1865,6 +1865,7 @@ struct xhci_hcd {
|
||||
@@ -1872,6 +1872,7 @@ struct xhci_hcd {
|
||||
#define XHCI_ZERO_64B_REGS BIT_ULL(32)
|
||||
#define XHCI_RESET_PLL_ON_DISCONNECT BIT_ULL(34)
|
||||
#define XHCI_SNPS_BROKEN_SUSPEND BIT_ULL(35)
|
||||
|
@ -28,8 +28,6 @@ Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
|
||||
tools/iio/iio_event_monitor.c | 10 ++++++++++
|
||||
4 files changed, 36 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Documentation/ABI/testing/sysfs-bus-iio b/Documentation/ABI/testing/sysfs-bus-iio
|
||||
index 8127a08e366d..67fd88bf7910 100644
|
||||
--- a/Documentation/ABI/testing/sysfs-bus-iio
|
||||
+++ b/Documentation/ABI/testing/sysfs-bus-iio
|
||||
@@ -1684,4 +1684,19 @@ KernelVersion: 4.18
|
||||
@ -54,11 +52,9 @@ index 8127a08e366d..67fd88bf7910 100644
|
||||
+ Mass concentration reading of particulate matter in ug / m3.
|
||||
+ pmX consists of particles with aerodynamic diameter less or
|
||||
+ equal to X micrometers.
|
||||
diff --git a/drivers/iio/industrialio-core.c b/drivers/iio/industrialio-core.c
|
||||
index 4f5cd9f60870..4700fd5d8c90 100644
|
||||
--- a/drivers/iio/industrialio-core.c
|
||||
+++ b/drivers/iio/industrialio-core.c
|
||||
@@ -87,6 +87,7 @@ static const char * const iio_chan_type_name_spec[] = {
|
||||
@@ -87,6 +87,7 @@ static const char * const iio_chan_type_
|
||||
[IIO_GRAVITY] = "gravity",
|
||||
[IIO_POSITIONRELATIVE] = "positionrelative",
|
||||
[IIO_PHASE] = "phase",
|
||||
@ -66,7 +62,7 @@ index 4f5cd9f60870..4700fd5d8c90 100644
|
||||
};
|
||||
|
||||
static const char * const iio_modifier_names[] = {
|
||||
@@ -127,6 +128,10 @@ static const char * const iio_modifier_names[] = {
|
||||
@@ -127,6 +128,10 @@ static const char * const iio_modifier_n
|
||||
[IIO_MOD_Q] = "q",
|
||||
[IIO_MOD_CO2] = "co2",
|
||||
[IIO_MOD_VOC] = "voc",
|
||||
@ -77,8 +73,6 @@ index 4f5cd9f60870..4700fd5d8c90 100644
|
||||
};
|
||||
|
||||
/* relies on pairs of these shared then separate */
|
||||
diff --git a/include/uapi/linux/iio/types.h b/include/uapi/linux/iio/types.h
|
||||
index 92baabc103ac..c59adac24b1c 100644
|
||||
--- a/include/uapi/linux/iio/types.h
|
||||
+++ b/include/uapi/linux/iio/types.h
|
||||
@@ -46,6 +46,7 @@ enum iio_chan_type {
|
||||
@ -100,11 +94,9 @@ index 92baabc103ac..c59adac24b1c 100644
|
||||
};
|
||||
|
||||
enum iio_event_type {
|
||||
diff --git a/tools/iio/iio_event_monitor.c b/tools/iio/iio_event_monitor.c
|
||||
index ac2de6b7e89f..f6b8003fbe3c 100644
|
||||
--- a/tools/iio/iio_event_monitor.c
|
||||
+++ b/tools/iio/iio_event_monitor.c
|
||||
@@ -60,6 +60,7 @@ static const char * const iio_chan_type_name_spec[] = {
|
||||
@@ -60,6 +60,7 @@ static const char * const iio_chan_type_
|
||||
[IIO_GRAVITY] = "gravity",
|
||||
[IIO_POSITIONRELATIVE] = "positionrelative",
|
||||
[IIO_PHASE] = "phase",
|
||||
@ -112,7 +104,7 @@ index ac2de6b7e89f..f6b8003fbe3c 100644
|
||||
};
|
||||
|
||||
static const char * const iio_ev_type_text[] = {
|
||||
@@ -115,6 +116,10 @@ static const char * const iio_modifier_names[] = {
|
||||
@@ -115,6 +116,10 @@ static const char * const iio_modifier_n
|
||||
[IIO_MOD_Q] = "q",
|
||||
[IIO_MOD_CO2] = "co2",
|
||||
[IIO_MOD_VOC] = "voc",
|
||||
@ -123,7 +115,7 @@ index ac2de6b7e89f..f6b8003fbe3c 100644
|
||||
};
|
||||
|
||||
static bool event_is_known(struct iio_event_data *event)
|
||||
@@ -156,6 +161,7 @@ static bool event_is_known(struct iio_event_data *event)
|
||||
@@ -156,6 +161,7 @@ static bool event_is_known(struct iio_ev
|
||||
case IIO_GRAVITY:
|
||||
case IIO_POSITIONRELATIVE:
|
||||
case IIO_PHASE:
|
||||
@ -131,7 +123,7 @@ index ac2de6b7e89f..f6b8003fbe3c 100644
|
||||
break;
|
||||
default:
|
||||
return false;
|
||||
@@ -200,6 +206,10 @@ static bool event_is_known(struct iio_event_data *event)
|
||||
@@ -200,6 +206,10 @@ static bool event_is_known(struct iio_ev
|
||||
case IIO_MOD_Q:
|
||||
case IIO_MOD_CO2:
|
||||
case IIO_MOD_VOC:
|
||||
|
@ -14,8 +14,6 @@ Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
|
||||
3 files changed, 419 insertions(+)
|
||||
create mode 100644 drivers/iio/chemical/sps30.c
|
||||
|
||||
diff --git a/drivers/iio/chemical/Kconfig b/drivers/iio/chemical/Kconfig
|
||||
index b8e005be4f87..57832b4360e9 100644
|
||||
--- a/drivers/iio/chemical/Kconfig
|
||||
+++ b/drivers/iio/chemical/Kconfig
|
||||
@@ -61,6 +61,17 @@ config IAQCORE
|
||||
@ -36,8 +34,6 @@ index b8e005be4f87..57832b4360e9 100644
|
||||
config VZ89X
|
||||
tristate "SGX Sensortech MiCS VZ89X VOC sensor"
|
||||
depends on I2C
|
||||
diff --git a/drivers/iio/chemical/Makefile b/drivers/iio/chemical/Makefile
|
||||
index 2f4c4ba4d781..9f42f4252151 100644
|
||||
--- a/drivers/iio/chemical/Makefile
|
||||
+++ b/drivers/iio/chemical/Makefile
|
||||
@@ -9,4 +9,5 @@ obj-$(CONFIG_BME680_I2C) += bme680_i2c.o
|
||||
@ -46,9 +42,6 @@ index 2f4c4ba4d781..9f42f4252151 100644
|
||||
obj-$(CONFIG_IAQCORE) += ams-iaq-core.o
|
||||
+obj-$(CONFIG_SPS30) += sps30.o
|
||||
obj-$(CONFIG_VZ89X) += vz89x.o
|
||||
diff --git a/drivers/iio/chemical/sps30.c b/drivers/iio/chemical/sps30.c
|
||||
new file mode 100644
|
||||
index 000000000000..fa3cd409b90b
|
||||
--- /dev/null
|
||||
+++ b/drivers/iio/chemical/sps30.c
|
||||
@@ -0,0 +1,407 @@
|
||||
|
@ -21,9 +21,6 @@ Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
|
||||
2 files changed, 42 insertions(+), 1 deletion(-)
|
||||
create mode 100644 Documentation/ABI/testing/sysfs-bus-iio-sps30
|
||||
|
||||
diff --git a/Documentation/ABI/testing/sysfs-bus-iio-sps30 b/Documentation/ABI/testing/sysfs-bus-iio-sps30
|
||||
new file mode 100644
|
||||
index 000000000000..e7ce2c57635e
|
||||
--- /dev/null
|
||||
+++ b/Documentation/ABI/testing/sysfs-bus-iio-sps30
|
||||
@@ -0,0 +1,8 @@
|
||||
@ -35,8 +32,6 @@ index 000000000000..e7ce2c57635e
|
||||
+ Writing 1 starts sensor self cleaning. Internal fan accelerates
|
||||
+ to its maximum speed and keeps spinning for about 10 seconds in
|
||||
+ order to blow out accumulated dust.
|
||||
diff --git a/drivers/iio/chemical/sps30.c b/drivers/iio/chemical/sps30.c
|
||||
index fa3cd409b90b..f3b4390c8f5c 100644
|
||||
--- a/drivers/iio/chemical/sps30.c
|
||||
+++ b/drivers/iio/chemical/sps30.c
|
||||
@@ -7,7 +7,6 @@
|
||||
@ -55,7 +50,7 @@ index fa3cd409b90b..f3b4390c8f5c 100644
|
||||
|
||||
enum {
|
||||
PM1,
|
||||
@@ -104,6 +104,7 @@ static int sps30_do_cmd(struct sps30_state *state, u16 cmd, u8 *data, int size)
|
||||
@@ -104,6 +104,7 @@ static int sps30_do_cmd(struct sps30_sta
|
||||
break;
|
||||
case SPS30_STOP_MEAS:
|
||||
case SPS30_RESET:
|
||||
@ -63,7 +58,7 @@ index fa3cd409b90b..f3b4390c8f5c 100644
|
||||
ret = sps30_write_then_read(state, buf, 2, NULL, 0);
|
||||
break;
|
||||
case SPS30_READ_DATA_READY_FLAG:
|
||||
@@ -275,7 +276,39 @@ static int sps30_read_raw(struct iio_dev *indio_dev,
|
||||
@@ -275,7 +276,39 @@ static int sps30_read_raw(struct iio_dev
|
||||
return -EINVAL;
|
||||
}
|
||||
|
||||
|
@ -14,8 +14,6 @@ Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
|
||||
drivers/iio/chemical/sps30.c | 143 +++++++++++++++---
|
||||
2 files changed, 145 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/Documentation/ABI/testing/sysfs-bus-iio-sps30 b/Documentation/ABI/testing/sysfs-bus-iio-sps30
|
||||
index e7ce2c57635e..143df8e89d08 100644
|
||||
--- a/Documentation/ABI/testing/sysfs-bus-iio-sps30
|
||||
+++ b/Documentation/ABI/testing/sysfs-bus-iio-sps30
|
||||
@@ -6,3 +6,23 @@ Description:
|
||||
@ -42,8 +40,6 @@ index e7ce2c57635e..143df8e89d08 100644
|
||||
+ The range of available values in seconds represented as the
|
||||
+ minimum value, the step and the maximum value, all enclosed in
|
||||
+ square brackets.
|
||||
diff --git a/drivers/iio/chemical/sps30.c b/drivers/iio/chemical/sps30.c
|
||||
index f3b4390c8f5c..376fac41ecb5 100644
|
||||
--- a/drivers/iio/chemical/sps30.c
|
||||
+++ b/drivers/iio/chemical/sps30.c
|
||||
@@ -5,9 +5,6 @@
|
||||
@ -104,7 +100,7 @@ index f3b4390c8f5c..376fac41ecb5 100644
|
||||
};
|
||||
|
||||
DECLARE_CRC8_TABLE(sps30_crc8_table);
|
||||
@@ -107,6 +117,9 @@ static int sps30_do_cmd(struct sps30_state *state, u16 cmd, u8 *data, int size)
|
||||
@@ -107,6 +117,9 @@ static int sps30_do_cmd(struct sps30_sta
|
||||
case SPS30_START_FAN_CLEANING:
|
||||
ret = sps30_write_then_read(state, buf, 2, NULL, 0);
|
||||
break;
|
||||
@ -114,7 +110,7 @@ index f3b4390c8f5c..376fac41ecb5 100644
|
||||
case SPS30_READ_DATA_READY_FLAG:
|
||||
case SPS30_READ_DATA:
|
||||
case SPS30_READ_SERIAL:
|
||||
@@ -114,6 +127,15 @@ static int sps30_do_cmd(struct sps30_state *state, u16 cmd, u8 *data, int size)
|
||||
@@ -114,6 +127,15 @@ static int sps30_do_cmd(struct sps30_sta
|
||||
size += size / 2;
|
||||
ret = sps30_write_then_read(state, buf, 2, buf, size);
|
||||
break;
|
||||
@ -130,7 +126,7 @@ index f3b4390c8f5c..376fac41ecb5 100644
|
||||
}
|
||||
|
||||
if (ret)
|
||||
@@ -170,6 +192,14 @@ static int sps30_do_meas(struct sps30_state *state, s32 *data, int size)
|
||||
@@ -170,6 +192,14 @@ static int sps30_do_meas(struct sps30_st
|
||||
int i, ret, tries = 5;
|
||||
u8 tmp[16];
|
||||
|
||||
@ -145,7 +141,7 @@ index f3b4390c8f5c..376fac41ecb5 100644
|
||||
while (tries--) {
|
||||
ret = sps30_do_cmd(state, SPS30_READ_DATA_READY_FLAG, tmp, 2);
|
||||
if (ret)
|
||||
@@ -276,6 +306,24 @@ static int sps30_read_raw(struct iio_dev *indio_dev,
|
||||
@@ -276,6 +306,24 @@ static int sps30_read_raw(struct iio_dev
|
||||
return -EINVAL;
|
||||
}
|
||||
|
||||
@ -170,7 +166,7 @@ index f3b4390c8f5c..376fac41ecb5 100644
|
||||
static ssize_t start_cleaning_store(struct device *dev,
|
||||
struct device_attribute *attr,
|
||||
const char *buf, size_t len)
|
||||
@@ -296,10 +344,82 @@ static ssize_t start_cleaning_store(struct device *dev,
|
||||
@@ -296,10 +344,82 @@ static ssize_t start_cleaning_store(stru
|
||||
return len;
|
||||
}
|
||||
|
||||
@ -253,7 +249,7 @@ index f3b4390c8f5c..376fac41ecb5 100644
|
||||
NULL
|
||||
};
|
||||
|
||||
@@ -362,6 +482,7 @@ static int sps30_probe(struct i2c_client *client)
|
||||
@@ -362,6 +482,7 @@ static int sps30_probe(struct i2c_client
|
||||
state = iio_priv(indio_dev);
|
||||
i2c_set_clientdata(client, indio_dev);
|
||||
state->client = client;
|
||||
@ -261,7 +257,7 @@ index f3b4390c8f5c..376fac41ecb5 100644
|
||||
indio_dev->dev.parent = &client->dev;
|
||||
indio_dev->info = &sps30_info;
|
||||
indio_dev->name = client->name;
|
||||
@@ -373,19 +494,11 @@ static int sps30_probe(struct i2c_client *client)
|
||||
@@ -373,19 +494,11 @@ static int sps30_probe(struct i2c_client
|
||||
mutex_init(&state->lock);
|
||||
crc8_populate_msb(sps30_crc8_table, SPS30_CRC8_POLYNOMIAL);
|
||||
|
||||
@ -282,7 +278,7 @@ index f3b4390c8f5c..376fac41ecb5 100644
|
||||
|
||||
ret = sps30_do_cmd(state, SPS30_READ_SERIAL, buf, sizeof(buf));
|
||||
if (ret) {
|
||||
@@ -395,12 +508,6 @@ static int sps30_probe(struct i2c_client *client)
|
||||
@@ -395,12 +508,6 @@ static int sps30_probe(struct i2c_client
|
||||
/* returned serial number is already NUL terminated */
|
||||
dev_info(&client->dev, "serial number: %s\n", buf);
|
||||
|
||||
|
@ -12,8 +12,6 @@ Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
|
||||
drivers/iio/chemical/sps30.c | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/iio/chemical/sps30.c b/drivers/iio/chemical/sps30.c
|
||||
index 376fac41ecb5..e03a28a67146 100644
|
||||
--- a/drivers/iio/chemical/sps30.c
|
||||
+++ b/drivers/iio/chemical/sps30.c
|
||||
@@ -7,8 +7,6 @@
|
||||
|
@ -13,11 +13,9 @@ Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
|
||||
drivers/iio/chemical/sps30.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/iio/chemical/sps30.c b/drivers/iio/chemical/sps30.c
|
||||
index e03a28a67146..375df5060ed5 100644
|
||||
--- a/drivers/iio/chemical/sps30.c
|
||||
+++ b/drivers/iio/chemical/sps30.c
|
||||
@@ -210,7 +210,7 @@ static int sps30_do_meas(struct sps30_state *state, s32 *data, int size)
|
||||
@@ -210,7 +210,7 @@ static int sps30_do_meas(struct sps30_st
|
||||
msleep_interruptible(300);
|
||||
}
|
||||
|
||||
|
@ -13,11 +13,9 @@ Acked-by: Tomasz Duszynski <tduszyns@gmail.com>
|
||||
drivers/iio/chemical/sps30.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/drivers/iio/chemical/sps30.c b/drivers/iio/chemical/sps30.c
|
||||
index 375df5060ed5..edbb956e81e8 100644
|
||||
--- a/drivers/iio/chemical/sps30.c
|
||||
+++ b/drivers/iio/chemical/sps30.c
|
||||
@@ -118,6 +118,7 @@ static int sps30_do_cmd(struct sps30_state *state, u16 cmd, u8 *data, int size)
|
||||
@@ -118,6 +118,7 @@ static int sps30_do_cmd(struct sps30_sta
|
||||
case SPS30_READ_AUTO_CLEANING_PERIOD:
|
||||
buf[0] = SPS30_AUTO_CLEANING_PERIOD >> 8;
|
||||
buf[1] = (u8)SPS30_AUTO_CLEANING_PERIOD;
|
||||
@ -25,7 +23,7 @@ index 375df5060ed5..edbb956e81e8 100644
|
||||
case SPS30_READ_DATA_READY_FLAG:
|
||||
case SPS30_READ_DATA:
|
||||
case SPS30_READ_SERIAL:
|
||||
@@ -295,6 +296,8 @@ static int sps30_read_raw(struct iio_dev *indio_dev,
|
||||
@@ -295,6 +296,8 @@ static int sps30_read_raw(struct iio_dev
|
||||
*val2 = 10000;
|
||||
|
||||
return IIO_VAL_INT_PLUS_MICRO;
|
||||
|
@ -18,11 +18,9 @@ Acked-by: Tomasz Duszynski <tduszyns@gmail.com>
|
||||
drivers/iio/chemical/sps30.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/iio/chemical/sps30.c b/drivers/iio/chemical/sps30.c
|
||||
index edbb956e81e8..acb9f8ecbb3d 100644
|
||||
--- a/drivers/iio/chemical/sps30.c
|
||||
+++ b/drivers/iio/chemical/sps30.c
|
||||
@@ -117,7 +117,7 @@ static int sps30_do_cmd(struct sps30_state *state, u16 cmd, u8 *data, int size)
|
||||
@@ -117,7 +117,7 @@ static int sps30_do_cmd(struct sps30_sta
|
||||
break;
|
||||
case SPS30_READ_AUTO_CLEANING_PERIOD:
|
||||
buf[0] = SPS30_AUTO_CLEANING_PERIOD >> 8;
|
||||
|
@ -17,11 +17,9 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
|
||||
drivers/iio/chemical/Kconfig | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/drivers/iio/chemical/Kconfig b/drivers/iio/chemical/Kconfig
|
||||
index 0b91de4df8f4..a7e65a59bf42 100644
|
||||
--- a/drivers/iio/chemical/Kconfig
|
||||
+++ b/drivers/iio/chemical/Kconfig
|
||||
@@ -91,6 +91,8 @@ config SPS30
|
||||
@@ -65,6 +65,8 @@ config SPS30
|
||||
tristate "SPS30 particulate matter sensor"
|
||||
depends on I2C
|
||||
select CRC8
|
||||
|
@ -189,7 +189,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||
}
|
||||
--- a/kernel/irq/proc.c
|
||||
+++ b/kernel/irq/proc.c
|
||||
@@ -333,6 +333,9 @@ void register_irq_proc(unsigned int irq,
|
||||
@@ -355,6 +355,9 @@ void register_irq_proc(unsigned int irq,
|
||||
void __maybe_unused *irqp = (void *)(unsigned long) irq;
|
||||
char name [MAX_NAMELEN];
|
||||
|
||||
@ -199,7 +199,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||
if (!root_irq_dir || (desc->irq_data.chip == &no_irq_chip))
|
||||
return;
|
||||
|
||||
@@ -386,6 +389,9 @@ void unregister_irq_proc(unsigned int ir
|
||||
@@ -408,6 +411,9 @@ void unregister_irq_proc(unsigned int ir
|
||||
{
|
||||
char name [MAX_NAMELEN];
|
||||
|
||||
@ -209,7 +209,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||
if (!root_irq_dir || !desc->dir)
|
||||
return;
|
||||
#ifdef CONFIG_SMP
|
||||
@@ -424,6 +430,9 @@ void init_irq_proc(void)
|
||||
@@ -446,6 +452,9 @@ void init_irq_proc(void)
|
||||
unsigned int irq;
|
||||
struct irq_desc *desc;
|
||||
|
||||
|
@ -185,7 +185,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||
cfg->fc_flags |= RTF_REJECT;
|
||||
|
||||
if (rtm->rtm_type == RTN_LOCAL)
|
||||
@@ -5084,6 +5115,8 @@ static int ip6_route_dev_notify(struct n
|
||||
@@ -5085,6 +5116,8 @@ static int ip6_route_dev_notify(struct n
|
||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||
net->ipv6.ip6_prohibit_entry->dst.dev = dev;
|
||||
net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
|
||||
@ -194,7 +194,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||
net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
|
||||
net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
|
||||
#endif
|
||||
@@ -5095,6 +5128,7 @@ static int ip6_route_dev_notify(struct n
|
||||
@@ -5096,6 +5129,7 @@ static int ip6_route_dev_notify(struct n
|
||||
in6_dev_put_clear(&net->ipv6.ip6_null_entry->rt6i_idev);
|
||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||
in6_dev_put_clear(&net->ipv6.ip6_prohibit_entry->rt6i_idev);
|
||||
@ -202,7 +202,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||
in6_dev_put_clear(&net->ipv6.ip6_blk_hole_entry->rt6i_idev);
|
||||
#endif
|
||||
}
|
||||
@@ -5289,6 +5323,15 @@ static int __net_init ip6_route_net_init
|
||||
@@ -5290,6 +5324,15 @@ static int __net_init ip6_route_net_init
|
||||
net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
|
||||
dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
|
||||
ip6_template_metrics, true);
|
||||
@ -218,7 +218,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||
#endif
|
||||
|
||||
net->ipv6.sysctl.flush_delay = 0;
|
||||
@@ -5307,6 +5350,8 @@ out:
|
||||
@@ -5308,6 +5351,8 @@ out:
|
||||
return ret;
|
||||
|
||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||
@ -227,7 +227,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||
out_ip6_prohibit_entry:
|
||||
kfree(net->ipv6.ip6_prohibit_entry);
|
||||
out_ip6_null_entry:
|
||||
@@ -5327,6 +5372,7 @@ static void __net_exit ip6_route_net_exi
|
||||
@@ -5328,6 +5373,7 @@ static void __net_exit ip6_route_net_exi
|
||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||
kfree(net->ipv6.ip6_prohibit_entry);
|
||||
kfree(net->ipv6.ip6_blk_hole_entry);
|
||||
@ -235,7 +235,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||
#endif
|
||||
dst_entries_destroy(&net->ipv6.ip6_dst_ops);
|
||||
}
|
||||
@@ -5403,6 +5449,9 @@ void __init ip6_route_init_special_entri
|
||||
@@ -5404,6 +5450,9 @@ void __init ip6_route_init_special_entri
|
||||
init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
|
||||
init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
|
||||
init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
|
||||
|
@ -14,7 +14,7 @@ Signed-off-by: Tudor Ambarus <tudor.ambarus@microchip.com>
|
||||
|
||||
--- a/drivers/mtd/spi-nor/spi-nor.c
|
||||
+++ b/drivers/mtd/spi-nor/spi-nor.c
|
||||
@@ -1252,7 +1252,9 @@ static const struct flash_info spi_nor_i
|
||||
@@ -1257,7 +1257,9 @@ static const struct flash_info spi_nor_i
|
||||
{ "w25q80", INFO(0xef5014, 0, 64 * 1024, 16, SECT_4K) },
|
||||
{ "w25q80bl", INFO(0xef4014, 0, 64 * 1024, 16, SECT_4K) },
|
||||
{ "w25q128", INFO(0xef4018, 0, 64 * 1024, 256, SECT_4K) },
|
||||
|
@ -8,7 +8,7 @@
|
||||
{ "mx25u25635f", INFO(0xc22539, 0, 64 * 1024, 512, SECT_4K | SPI_NOR_4B_OPCODES) },
|
||||
{ "mx25l25655e", INFO(0xc22619, 0, 64 * 1024, 512, 0) },
|
||||
{ "mx66l51235l", INFO(0xc2201a, 0, 64 * 1024, 1024, SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ | SPI_NOR_4B_OPCODES) },
|
||||
@@ -1284,11 +1285,12 @@ static const struct flash_info spi_nor_i
|
||||
@@ -1286,11 +1287,12 @@ static const struct flash_info spi_nor_i
|
||||
{ },
|
||||
};
|
||||
|
||||
@ -23,7 +23,7 @@
|
||||
|
||||
tmp = nor->read_reg(nor, SPINOR_OP_RDID, id, SPI_NOR_MAX_ID_LEN);
|
||||
if (tmp < 0) {
|
||||
@@ -1299,10 +1301,16 @@ static const struct flash_info *spi_nor_
|
||||
@@ -1301,10 +1303,16 @@ static const struct flash_info *spi_nor_
|
||||
for (tmp = 0; tmp < ARRAY_SIZE(spi_nor_ids) - 1; tmp++) {
|
||||
info = &spi_nor_ids[tmp];
|
||||
if (info->id_len) {
|
||||
@ -42,7 +42,7 @@
|
||||
dev_err(nor->dev, "unrecognized JEDEC id bytes: %02x, %02x, %02x\n",
|
||||
id[0], id[1], id[2]);
|
||||
return ERR_PTR(-ENODEV);
|
||||
@@ -2836,7 +2844,7 @@ int spi_nor_scan(struct spi_nor *nor, co
|
||||
@@ -2838,7 +2846,7 @@ int spi_nor_scan(struct spi_nor *nor, co
|
||||
info = spi_nor_match_id(name);
|
||||
/* Try to auto-detect if chip name wasn't specified or not found */
|
||||
if (!info)
|
||||
@ -51,7 +51,7 @@
|
||||
if (IS_ERR_OR_NULL(info))
|
||||
return -ENOENT;
|
||||
|
||||
@@ -2847,7 +2855,7 @@ int spi_nor_scan(struct spi_nor *nor, co
|
||||
@@ -2849,7 +2857,7 @@ int spi_nor_scan(struct spi_nor *nor, co
|
||||
if (name && info->id_len) {
|
||||
const struct flash_info *jinfo;
|
||||
|
||||
|
@ -19,7 +19,7 @@
|
||||
},
|
||||
[PORT_NPCM] = {
|
||||
.name = "Nuvoton 16550",
|
||||
@@ -2644,6 +2644,11 @@ serial8250_do_set_termios(struct uart_po
|
||||
@@ -2648,6 +2648,11 @@ serial8250_do_set_termios(struct uart_po
|
||||
unsigned long flags;
|
||||
unsigned int baud, quot, frac = 0;
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user