mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-18 21:28:02 +00:00
tools/mkimage: pass --static via PKG_CONFIG_EXTRAARGS
Remove the then unnecessary patch doing exactly that individually.
See also 09465d80
"u-boot.mk: always link host libraries static".
Signed-off-by: Andre Heider <a.heider@gmail.com>
This commit is contained in:
parent
15e55a2190
commit
e37dffbf35
@ -32,6 +32,7 @@ define Host/Compile
|
|||||||
$(MAKE) -C $(HOST_BUILD_DIR) \
|
$(MAKE) -C $(HOST_BUILD_DIR) \
|
||||||
HOSTCFLAGS="$(HOST_CFLAGS)" \
|
HOSTCFLAGS="$(HOST_CFLAGS)" \
|
||||||
HOSTLDFLAGS="$(HOST_LDFLAGS)" \
|
HOSTLDFLAGS="$(HOST_LDFLAGS)" \
|
||||||
|
PKG_CONFIG_EXTRAARGS="--static" \
|
||||||
no-dot-config-targets=tools-only \
|
no-dot-config-targets=tools-only \
|
||||||
CONFIG_MKIMAGE_DTC_PATH=dtc \
|
CONFIG_MKIMAGE_DTC_PATH=dtc \
|
||||||
CONFIG_FIT=y \
|
CONFIG_FIT=y \
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
OpenWrt links the libressl statically against mkimage, make sure all the
|
|
||||||
needed dependencies are added too.
|
|
||||||
|
|
||||||
--- a/tools/Makefile
|
|
||||||
+++ b/tools/Makefile
|
|
||||||
@@ -158,7 +158,7 @@ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CON
|
|
||||||
HOSTCFLAGS_kwbimage.o += \
|
|
||||||
$(shell pkg-config --cflags libssl libcrypto 2> /dev/null || echo "")
|
|
||||||
HOSTLDLIBS_mkimage += \
|
|
||||||
- $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
|
|
||||||
+ $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
|
|
||||||
|
|
||||||
# OS X deprecate openssl in favour of CommonCrypto, supress deprecation
|
|
||||||
# warnings on those systems
|
|
Loading…
Reference in New Issue
Block a user