mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-18 21:28:02 +00:00
kernel: r8125: update to v9.014.01
Changelog: https://github.com/openwrt/rtl8125/compare/9.013.02...9.014.01 Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
09a8b4920c
commit
e29bc67f9d
@ -1,12 +1,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=r8125
|
PKG_NAME:=r8125
|
||||||
PKG_VERSION:=9.013.02
|
PKG_VERSION:=9.014.01
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=https://github.com/openwrt/rtl8125/releases/download/$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/openwrt/rtl8125/releases/download/$(PKG_VERSION)
|
||||||
PKG_HASH:=d36410ee99c956f250d9cd08340d8c36567d190f420a8ee128ff6e51225aac0c
|
PKG_HASH:=f006aa95501738ca55c522812c9d1b473ac781675f3ad88ce341a09316b8aa13
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_LICENSE:=GPLv2
|
PKG_LICENSE:=GPLv2
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
From cd20cf48c0ec2a01fd9f512e25218a6ac8131794 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
|
|
||||||
Date: Sat, 17 Aug 2024 22:07:23 +0200
|
|
||||||
Subject: [PATCH] r8125_rss: silence rxnfc log
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
This log is noisy and useless, just ignore it.
|
|
||||||
|
|
||||||
Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
|
|
||||||
---
|
|
||||||
src/r8125_rss.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/src/r8125_rss.c
|
|
||||||
+++ b/src/r8125_rss.c
|
|
||||||
@@ -91,7 +91,7 @@ int rtl8125_get_rxnfc(struct net_device
|
|
||||||
struct rtl8125_private *tp = netdev_priv(dev);
|
|
||||||
int ret = -EOPNOTSUPP;
|
|
||||||
|
|
||||||
- netif_info(tp, drv, tp->dev, "rss get rxnfc\n");
|
|
||||||
+ netif_dbg(tp, drv, tp->dev, "rss get rxnfc\n");
|
|
||||||
|
|
||||||
if (!(dev->features & NETIF_F_RXHASH))
|
|
||||||
return ret;
|
|
@ -18,7 +18,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
|||||||
|
|
||||||
--- a/src/r8125.h
|
--- a/src/r8125.h
|
||||||
+++ b/src/r8125.h
|
+++ b/src/r8125.h
|
||||||
@@ -1563,6 +1563,8 @@ enum RTL8125_register_content {
|
@@ -1672,6 +1672,8 @@ enum RTL8125_register_content {
|
||||||
LinkStatus = 0x02,
|
LinkStatus = 0x02,
|
||||||
FullDup = 0x01,
|
FullDup = 0x01,
|
||||||
|
|
||||||
@ -37,7 +37,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
|||||||
#include <linux/netdevice.h>
|
#include <linux/netdevice.h>
|
||||||
#include <linux/etherdevice.h>
|
#include <linux/etherdevice.h>
|
||||||
#include <linux/delay.h>
|
#include <linux/delay.h>
|
||||||
@@ -5112,6 +5113,38 @@ rtl8125_link_down_patch(struct net_devic
|
@@ -5116,6 +5117,38 @@ rtl8125_link_down_patch(struct net_devic
|
||||||
#endif
|
#endif
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -74,10 +74,10 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
|||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
static void
|
static void
|
||||||
_rtl8125_check_link_status(struct net_device *dev)
|
_rtl8125_check_link_status(struct net_device *dev, unsigned int link_state)
|
||||||
{
|
{
|
||||||
@@ -5120,11 +5153,18 @@ _rtl8125_check_link_status(struct net_de
|
@@ -5128,11 +5161,18 @@ _rtl8125_check_link_status(struct net_de
|
||||||
if (tp->link_ok(dev)) {
|
if (link_state == R8125_LINK_STATE_ON) {
|
||||||
rtl8125_link_on_patch(dev);
|
rtl8125_link_on_patch(dev);
|
||||||
|
|
||||||
- if (netif_msg_ifup(tp))
|
- if (netif_msg_ifup(tp))
|
||||||
|
Loading…
Reference in New Issue
Block a user