mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-02 01:08:05 +00:00
openssl: bump to 1.1.1m
This is a bugfix release. Changelog: *) Avoid loading of a dynamic engine twice. *) Fixed building on Debian with kfreebsd kernels *) Prioritise DANE TLSA issuer certs over peer certs *) Fixed random API for MacOS prior to 10.12 Patches were refreshed. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
This commit is contained in:
parent
86d019d116
commit
def9565be6
@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=openssl
|
PKG_NAME:=openssl
|
||||||
PKG_BASE:=1.1.1
|
PKG_BASE:=1.1.1
|
||||||
PKG_BUGFIX:=l
|
PKG_BUGFIX:=m
|
||||||
PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
|
PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
PKG_USE_MIPS16:=0
|
PKG_USE_MIPS16:=0
|
||||||
ENGINES_DIR=engines-1.1
|
ENGINES_DIR=engines-1.1
|
||||||
|
|
||||||
@ -26,7 +26,7 @@ PKG_SOURCE_URL:= \
|
|||||||
ftp://ftp.pca.dfn.de/pub/tools/net/openssl/source/ \
|
ftp://ftp.pca.dfn.de/pub/tools/net/openssl/source/ \
|
||||||
ftp://ftp.pca.dfn.de/pub/tools/net/openssl/source/old/$(PKG_BASE)/
|
ftp://ftp.pca.dfn.de/pub/tools/net/openssl/source/old/$(PKG_BASE)/
|
||||||
|
|
||||||
PKG_HASH:=0b7a3e5e59c34827fe0c3a74b7ec8baef302b98fa80088d7f9153aa16fa76bd1
|
PKG_HASH:=f89199be8b23ca45fc7cb9f1d8d3ee67312318286ad030f5316aca6462db6c96
|
||||||
|
|
||||||
PKG_LICENSE:=OpenSSL
|
PKG_LICENSE:=OpenSSL
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From 34ab13b7d8e3e723adb60be8142e38b7c9cd382a Mon Sep 17 00:00:00 2001
|
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||||
From: Andy Polyakov <appro@openssl.org>
|
From: Andy Polyakov <appro@openssl.org>
|
||||||
Date: Sun, 5 May 2019 18:25:50 +0200
|
Date: Sun, 5 May 2019 18:25:50 +0200
|
||||||
Subject: [PATCH] crypto/perlasm/ppc-xlate.pl: add linux64v2 flavour
|
Subject: crypto/perlasm/ppc-xlate.pl: add linux64v2 flavour
|
||||||
MIME-Version: 1.0
|
MIME-Version: 1.0
|
||||||
Content-Type: text/plain; charset=UTF-8
|
Content-Type: text/plain; charset=UTF-8
|
||||||
Content-Transfer-Encoding: 8bit
|
Content-Transfer-Encoding: 8bit
|
||||||
@ -14,12 +14,8 @@ endian nowadays (Adélie Linux, Void Linux, possibly Gentoo, etc.)
|
|||||||
Reviewed-by: Paul Dale <paul.dale@oracle.com>
|
Reviewed-by: Paul Dale <paul.dale@oracle.com>
|
||||||
Reviewed-by: Richard Levitte <levitte@openssl.org>
|
Reviewed-by: Richard Levitte <levitte@openssl.org>
|
||||||
(Merged from https://github.com/openssl/openssl/pull/8883)
|
(Merged from https://github.com/openssl/openssl/pull/8883)
|
||||||
---
|
|
||||||
crypto/perlasm/ppc-xlate.pl | 8 ++++----
|
|
||||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/crypto/perlasm/ppc-xlate.pl b/crypto/perlasm/ppc-xlate.pl
|
diff --git a/crypto/perlasm/ppc-xlate.pl b/crypto/perlasm/ppc-xlate.pl
|
||||||
index e52f2f6ea6..5fcd0526df 100755
|
|
||||||
--- a/crypto/perlasm/ppc-xlate.pl
|
--- a/crypto/perlasm/ppc-xlate.pl
|
||||||
+++ b/crypto/perlasm/ppc-xlate.pl
|
+++ b/crypto/perlasm/ppc-xlate.pl
|
||||||
@@ -49,7 +49,7 @@ my $globl = sub {
|
@@ -49,7 +49,7 @@ my $globl = sub {
|
||||||
@ -49,7 +45,7 @@ index e52f2f6ea6..5fcd0526df 100755
|
|||||||
my $mtspr = sub {
|
my $mtspr = sub {
|
||||||
my ($f,$idx,$ra) = @_;
|
my ($f,$idx,$ra) = @_;
|
||||||
if ($idx == 256 && $no_vrsave) {
|
if ($idx == 256 && $no_vrsave) {
|
||||||
@@ -320,7 +320,7 @@ while($line=<>) {
|
@@ -318,7 +318,7 @@ while($line=<>) {
|
||||||
if ($label) {
|
if ($label) {
|
||||||
my $xlated = ($GLOBALS{$label} or $label);
|
my $xlated = ($GLOBALS{$label} or $label);
|
||||||
print "$xlated:";
|
print "$xlated:";
|
||||||
@ -58,6 +54,3 @@ index e52f2f6ea6..5fcd0526df 100755
|
|||||||
if ($TYPES{$label} =~ /function/) {
|
if ($TYPES{$label} =~ /function/) {
|
||||||
printf "\n.localentry %s,0\n",$xlated;
|
printf "\n.localentry %s,0\n",$xlated;
|
||||||
}
|
}
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ diff --git a/Configure b/Configure
|
|||||||
index 5a699836f3..74d057c219 100755
|
index 5a699836f3..74d057c219 100755
|
||||||
--- a/Configure
|
--- a/Configure
|
||||||
+++ b/Configure
|
+++ b/Configure
|
||||||
@@ -1545,7 +1545,9 @@ unless ($disabled{"crypto-mdebug-backtrace"})
|
@@ -1548,7 +1548,9 @@ unless ($disabled{"crypto-mdebug-backtrace"})
|
||||||
|
|
||||||
unless ($disabled{afalgeng}) {
|
unless ($disabled{afalgeng}) {
|
||||||
$config{afalgeng}="";
|
$config{afalgeng}="";
|
||||||
|
Loading…
x
Reference in New Issue
Block a user