mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-18 02:40:19 +00:00
tools/elfutils: remove no-op copy of tdestroy()
A false tdestroy() function was added in order to make elfutils build on macOS again. A previous commit added declarations for a real version of tdestroy() into gnulib, which is already imported, as well as the preprocessor flags and the triggers for the Makefile.am conditional in order to include the source to be built. Tested-by: Georgi Valkov <gvalkov@gmail.com> # MacOS Signed-off-by: Michael Pratt <mcpratt@pm.me> Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
This commit is contained in:
parent
20ed56ec8b
commit
ddb7177c57
@ -344,20 +344,6 @@
|
||||
+{
|
||||
+ return ppc_check_object_attribute(ebl, vendor, tag, value, tag_name, value_name);
|
||||
+}
|
||||
--- a/lib/libeu.h
|
||||
+++ b/lib/libeu.h
|
||||
@@ -45,4 +45,11 @@ extern char *xasprintf(const char *fmt,
|
||||
extern uint32_t crc32 (uint32_t crc, unsigned char *buf, size_t len);
|
||||
extern int crc32_file (int fd, uint32_t *resp);
|
||||
|
||||
+#ifdef __APPLE__
|
||||
+static inline void tdestroy(void *root __attribute__ ((unused)),
|
||||
+ void (*freekey)(void *) __attribute__ ((unused)))
|
||||
+{
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
#endif
|
||||
--- a/libdwfl/libdwflP.h
|
||||
+++ b/libdwfl/libdwflP.h
|
||||
@@ -31,6 +31,8 @@
|
||||
|
Loading…
Reference in New Issue
Block a user