mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-18 21:28:02 +00:00
firmware-utils: bump to git HEAD
a170683 firmware-utils: fix use of NULL string progname 89875fc tplink-safeloader: CPE510: add Canadian support 9e211d2 mktplinkfw2: add support to extract bootloader images c18f662 mktplinkfw2: add support to pack bootloader 3dc1339 mktplinkfw2: show exact exceed bytes when the image is to big d16ff79 tplink-safeloader: WPA8631: add v4 AU, US 0fa1cc5 zytrx: add LTE5398-M904 6354661 firmware-utils: ptgen: add SiFive GPT partition support The removed patch was applied upstream. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
cea62f45cc
commit
da52c6f50e
@ -11,9 +11,9 @@ PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL=$(PROJECT_GIT)/project/firmware-utils.git
|
||||
PKG_SOURCE_DATE:=2023-06-29
|
||||
PKG_SOURCE_VERSION:=9e2de8515be15e2b61ae518ce592e5b446ef2d48
|
||||
PKG_MIRROR_HASH:=e43d1796dd482ec364e5196f224bb1563dbb0494f0f28fb4e206ef7ef31260fb
|
||||
PKG_SOURCE_DATE:=2023-10-29
|
||||
PKG_SOURCE_VERSION:=635466123429ba8682b575245bbf52e3b33b7163
|
||||
PKG_MIRROR_HASH:=316181644733b9a1592aad04ae379cc5f93ff31f03ac76225a1ad5a720265915
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
@ -1,38 +0,0 @@
|
||||
diff -ruN firmware-utils-2022-02-28-002cfaf0.old/src/ptgen.c firmware-utils-2022-02-28-002cfaf0/src/ptgen.c
|
||||
--- firmware-utils-2022-02-28-002cfaf0.old/src/ptgen.c 2022-04-23 19:02:07.307896842 +0200
|
||||
+++ firmware-utils-2022-02-28-002cfaf0/src/ptgen.c 2022-04-22 18:48:54.477970950 +0200
|
||||
@@ -82,6 +82,14 @@
|
||||
GUID_INIT( 0x0fc63daf, 0x8483, 0x4772, \
|
||||
0x8e, 0x79, 0x3d, 0x69, 0xd8, 0x47, 0x7d, 0xe4)
|
||||
|
||||
+#define GUID_PARTITION_SIFIVE_SPL \
|
||||
+ GUID_INIT( 0x5b193300, 0xfc78, 0x40cd, \
|
||||
+ 0x80, 0x02, 0xe8, 0x6c, 0x45, 0x58, 0x0b, 0x47)
|
||||
+
|
||||
+#define GUID_PARTITION_SIFIVE_UBOOT \
|
||||
+ GUID_INIT( 0x2e54b353, 0x1271, 0x4842, \
|
||||
+ 0x80, 0x6f, 0xe4, 0x36, 0xd6, 0xaf, 0x69, 0x85)
|
||||
+
|
||||
#define GPT_HEADER_SIZE 92
|
||||
#define GPT_ENTRY_SIZE 128
|
||||
#define GPT_ENTRY_MAX 128
|
||||
@@ -276,6 +284,19 @@
|
||||
(1ULL << 56); /* success=1 */
|
||||
return true;
|
||||
}
|
||||
+
|
||||
+ if (!strcmp(type, "sifiveu_spl")) {
|
||||
+ part->has_guid = true;
|
||||
+ part->guid = GUID_PARTITION_SIFIVE_SPL;
|
||||
+ return true;
|
||||
+ }
|
||||
+
|
||||
+ if (!strcmp(type, "sifiveu_uboot")) {
|
||||
+ part->has_guid = true;
|
||||
+ part->guid = GUID_PARTITION_SIFIVE_UBOOT;
|
||||
+ return true;
|
||||
+ }
|
||||
+
|
||||
return false;
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user