From d9bd55d9d0fe103d126bd4b680c5850578e15ad5 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 9 Apr 2005 21:05:39 +0000
Subject: [PATCH] add speex (required for asterisk)

SVN-Revision: 607
---
 openwrt/package/Config.in           |  1 +
 openwrt/package/Makefile            |  1 +
 openwrt/package/speex/Config.in     |  5 ++
 openwrt/package/speex/Makefile      | 72 +++++++++++++++++++++++++++++
 openwrt/package/speex/speex.control |  6 +++
 5 files changed, 85 insertions(+)
 create mode 100644 openwrt/package/speex/Config.in
 create mode 100644 openwrt/package/speex/Makefile
 create mode 100644 openwrt/package/speex/speex.control

diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index c8aa3f7c75d..fbebbf7c6c1 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -65,6 +65,7 @@ source "package/libnet/Config.in"
 source "package/mysql/Config.in"
 source "package/postgresql/Config.in"
 source "package/fuse/Config.in"
+source "package/speex/Config.in"
 
 endmenu
 
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 706d81d8af6..743d2dfcdbd 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -49,6 +49,7 @@ package-$(BR2_PACKAGE_RADVD) += radvd
 package-$(BR2_PACKAGE_SER) += ser
 package-$(BR2_PACKAGE_SETSERIAL) += setserial
 package-$(BR2_PACKAGE_SHFS) += shfs
+package-$(BR2_PACKAGE_SPEEX) += speex
 package-$(BR2_PACKAGE_STRACE) += strace
 package-$(BR2_PACKAGE_TCPDUMP) += tcpdump
 package-$(BR2_PACKAGE_WIRELESS_TOOLS) += wireless-tools
diff --git a/openwrt/package/speex/Config.in b/openwrt/package/speex/Config.in
new file mode 100644
index 00000000000..6891a443de2
--- /dev/null
+++ b/openwrt/package/speex/Config.in
@@ -0,0 +1,5 @@
+config BR2_PACKAGE_SPEEX
+	tristate "speex"
+	default m
+	help
+	  An open source patent-free speech compression codec
diff --git a/openwrt/package/speex/Makefile b/openwrt/package/speex/Makefile
new file mode 100644
index 00000000000..d9c1c16c7b6
--- /dev/null
+++ b/openwrt/package/speex/Makefile
@@ -0,0 +1,72 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME := speex
+PKG_VERSION := 1.0.4
+PKG_RELEASE := 1
+PKG_MD5SUM := 15a0686b7e1f81d352a648044b350fcc
+
+PKG_SOURCE_SITE := http://www.speex.org/download
+PKG_SOURCE_FILE := $(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_CAT := zcat
+PKG_SOURCE_DIR := $(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
+PKG_IPK := $(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+
+$(DL_DIR)/$(PKG_SOURCE_FILE):
+	mkdir -p $(DL_DIR)
+	$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) $(PKG_MD5SUM) $(PKG_SOURCE_SITE)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE_FILE)
+	mkdir -p $(TOOL_BUILD_DIR)
+	$(PKG_SOURCE_CAT) $(DL_DIR)/$(PKG_SOURCE_FILE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+	touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
+	(cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+		$(TARGET_CONFIGURE_OPTS) \
+		./configure \
+		--target=$(GNU_TARGET_NAME) \
+		--host=$(GNU_TARGET_NAME) \
+		--build=$(GNU_HOST_NAME) \
+		--prefix=/ \
+		--exec-prefix=/ \
+		--bindir=/bin \
+		--sbindir=/sbin \
+		--libexecdir=/lib \
+		--sysconfdir=/etc \
+		--localstatedir=/var \
+		--enable-shared \
+	);
+	touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/src/libspeex.la: $(PKG_BUILD_DIR)/.configured
+	$(MAKE) -C $(PKG_BUILD_DIR)
+
+$(STAGING_DIR)/lib/libspeex.a: $(PKG_BUILD_DIR)/src/libspeex.la
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+	  CC=$(TARGET_CC) \
+	  DESTDIR="$(STAGING_DIR)" \
+	  install
+
+$(PKG_IPK): $(STAGING_DIR)/lib/libspeex.a
+	mkdir -p $(PACKAGE_DIR)
+	$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_BUILD_DIR)/ipkg/speex speex.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+	mkdir -p $(PKG_BUILD_DIR)/ipkg/speex/usr/lib
+	cp -a $(STAGING_DIR)/lib/libspeex.so* $(PKG_BUILD_DIR)/ipkg/speex/usr/lib
+	$(STRIP) $(PKG_BUILD_DIR)/ipkg/speex/usr/lib/*
+	$(IPKG_BUILD) $(PKG_BUILD_DIR)/ipkg/speex $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/speex.list: $(PKG_IPK)
+	$(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE_FILE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(STAGING_DIR)/lib/libspeex.a $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/speex.list
+
+clean:
+	rm -rf $(PKG_BUILD_DIR)
+	rm -f $(STAGING_DIR)/lib/libspeex*
+	rm -f $(PACKAGE_DIR)/speex\*.ipk
diff --git a/openwrt/package/speex/speex.control b/openwrt/package/speex/speex.control
new file mode 100644
index 00000000000..c59fa6be6a6
--- /dev/null
+++ b/openwrt/package/speex/speex.control
@@ -0,0 +1,6 @@
+Package: speex
+Priority: optional
+Section: libs
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: an open source patent-free speech compression codec