mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
imx6: refresh patches
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 47513
This commit is contained in:
parent
71a92988e3
commit
d8d318f344
@ -33,8 +33,6 @@ Signed-off-by: Shawn Guo <shawn.guo@linaro.org>
|
||||
create mode 100644 arch/arm/boot/dts/imx6q-gw551x.dts
|
||||
create mode 100644 arch/arm/boot/dts/imx6qdl-gw551x.dtsi
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 86217db..8932e6e 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -262,6 +262,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
|
||||
@ -53,9 +51,6 @@ index 86217db..8932e6e 100644
|
||||
imx6q-gw552x.dtb \
|
||||
imx6q-hummingboard.dtb \
|
||||
imx6q-nitrogen6x.dtb \
|
||||
diff --git a/arch/arm/boot/dts/imx6dl-gw551x.dts b/arch/arm/boot/dts/imx6dl-gw551x.dts
|
||||
new file mode 100644
|
||||
index 0000000..82d5f85
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx6dl-gw551x.dts
|
||||
@@ -0,0 +1,55 @@
|
||||
@ -114,9 +109,6 @@ index 0000000..82d5f85
|
||||
+ model = "Gateworks Ventana i.MX6 DualLite/Solo GW551X";
|
||||
+ compatible = "gw,imx6dl-gw551x", "gw,ventana", "fsl,imx6dl";
|
||||
+};
|
||||
diff --git a/arch/arm/boot/dts/imx6q-gw551x.dts b/arch/arm/boot/dts/imx6q-gw551x.dts
|
||||
new file mode 100644
|
||||
index 0000000..2c7feee
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx6q-gw551x.dts
|
||||
@@ -0,0 +1,55 @@
|
||||
@ -175,9 +167,6 @@ index 0000000..2c7feee
|
||||
+ model = "Gateworks Ventana i.MX6 Dual/Quad GW551X";
|
||||
+ compatible = "gw,imx6q-gw551x", "gw,ventana", "fsl,imx6q";
|
||||
+};
|
||||
diff --git a/arch/arm/boot/dts/imx6qdl-gw551x.dtsi b/arch/arm/boot/dts/imx6qdl-gw551x.dtsi
|
||||
new file mode 100644
|
||||
index 0000000..d1866a0
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx6qdl-gw551x.dtsi
|
||||
@@ -0,0 +1,314 @@
|
||||
@ -495,6 +484,3 @@ index 0000000..d1866a0
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
--
|
||||
2.5.1
|
||||
|
||||
|
@ -13,11 +13,9 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
|
||||
arch/arm/boot/dts/imx6qdl-gw54xx.dtsi | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi b/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi
|
||||
index 31d86f7..2108d1c 100644
|
||||
--- a/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi
|
||||
+++ b/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi
|
||||
@@ -265,6 +265,8 @@
|
||||
@@ -260,6 +260,8 @@
|
||||
swbst_reg: swbst {
|
||||
regulator-min-microvolt = <5000000>;
|
||||
regulator-max-microvolt = <5150000>;
|
||||
@ -26,6 +24,3 @@ index 31d86f7..2108d1c 100644
|
||||
};
|
||||
|
||||
snvs_reg: vsnvs {
|
||||
--
|
||||
1.9.1
|
||||
|
||||
|
@ -9,8 +9,6 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
|
||||
arch/arm/boot/dts/imx6qdl-gw54xx.dtsi | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/imx6qdl-gw53xx.dtsi b/arch/arm/boot/dts/imx6qdl-gw53xx.dtsi
|
||||
index 7c51839..5172de0 100644
|
||||
--- a/arch/arm/boot/dts/imx6qdl-gw53xx.dtsi
|
||||
+++ b/arch/arm/boot/dts/imx6qdl-gw53xx.dtsi
|
||||
@@ -247,7 +247,7 @@
|
||||
@ -22,11 +20,9 @@ index 7c51839..5172de0 100644
|
||||
fsl,data-mapping = "spwg";
|
||||
fsl,data-width = <18>;
|
||||
status = "okay";
|
||||
diff --git a/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi b/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi
|
||||
index 2108d1c..77a56be 100644
|
||||
--- a/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi
|
||||
+++ b/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi
|
||||
@@ -343,7 +343,7 @@
|
||||
@@ -338,7 +338,7 @@
|
||||
&ldb {
|
||||
status = "okay";
|
||||
|
||||
@ -35,6 +31,3 @@ index 2108d1c..77a56be 100644
|
||||
fsl,data-mapping = "spwg";
|
||||
fsl,data-width = <18>;
|
||||
status = "okay";
|
||||
--
|
||||
1.9.1
|
||||
|
||||
|
@ -20,8 +20,6 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
|
||||
arch/arm/boot/dts/imx6qdl-gw54xx.dtsi | 7 +++++++
|
||||
3 files changed, 21 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/imx6qdl-gw52xx.dtsi b/arch/arm/boot/dts/imx6qdl-gw52xx.dtsi
|
||||
index 1b66328..9709728 100644
|
||||
--- a/arch/arm/boot/dts/imx6qdl-gw52xx.dtsi
|
||||
+++ b/arch/arm/boot/dts/imx6qdl-gw52xx.dtsi
|
||||
@@ -151,6 +151,13 @@
|
||||
@ -38,8 +36,6 @@ index 1b66328..9709728 100644
|
||||
&fec {
|
||||
pinctrl-names = "default";
|
||||
pinctrl-0 = <&pinctrl_enet>;
|
||||
diff --git a/arch/arm/boot/dts/imx6qdl-gw53xx.dtsi b/arch/arm/boot/dts/imx6qdl-gw53xx.dtsi
|
||||
index 5172de0..dc1cd13 100644
|
||||
--- a/arch/arm/boot/dts/imx6qdl-gw53xx.dtsi
|
||||
+++ b/arch/arm/boot/dts/imx6qdl-gw53xx.dtsi
|
||||
@@ -152,6 +152,13 @@
|
||||
@ -56,8 +52,6 @@ index 5172de0..dc1cd13 100644
|
||||
&fec {
|
||||
pinctrl-names = "default";
|
||||
pinctrl-0 = <&pinctrl_enet>;
|
||||
diff --git a/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi b/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi
|
||||
index 77a56be..7ef9fbe 100644
|
||||
--- a/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi
|
||||
+++ b/arch/arm/boot/dts/imx6qdl-gw54xx.dtsi
|
||||
@@ -142,6 +142,13 @@
|
||||
@ -74,6 +68,3 @@ index 77a56be..7ef9fbe 100644
|
||||
&fec {
|
||||
pinctrl-names = "default";
|
||||
pinctrl-0 = <&pinctrl_enet>;
|
||||
--
|
||||
1.9.1
|
||||
|
||||
|
@ -94,7 +94,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
|
||||
#include <linux/delay.h>
|
||||
#include <linux/interrupt.h>
|
||||
#include <linux/ip.h>
|
||||
@@ -2231,6 +2232,126 @@ static s32 igb_init_i2c(struct igb_adapt
|
||||
@@ -2234,6 +2235,126 @@ static s32 igb_init_i2c(struct igb_adapt
|
||||
return status;
|
||||
}
|
||||
|
||||
@ -221,7 +221,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
|
||||
/**
|
||||
* igb_probe - Device Initialization Routine
|
||||
* @pdev: PCI device information struct
|
||||
@@ -2653,6 +2774,13 @@ static int igb_probe(struct pci_dev *pde
|
||||
@@ -2656,6 +2777,13 @@ static int igb_probe(struct pci_dev *pde
|
||||
}
|
||||
}
|
||||
pm_runtime_put_noidle(&pdev->dev);
|
||||
@ -235,7 +235,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
|
||||
return 0;
|
||||
|
||||
err_register:
|
||||
@@ -2796,6 +2924,10 @@ static void igb_remove(struct pci_dev *p
|
||||
@@ -2799,6 +2927,10 @@ static void igb_remove(struct pci_dev *p
|
||||
struct e1000_hw *hw = &adapter->hw;
|
||||
|
||||
pm_runtime_get_noresume(&pdev->dev);
|
||||
@ -246,7 +246,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
|
||||
#ifdef CONFIG_IGB_HWMON
|
||||
igb_sysfs_exit(adapter);
|
||||
#endif
|
||||
@@ -3101,6 +3233,12 @@ static int __igb_open(struct net_device
|
||||
@@ -3112,6 +3244,12 @@ static int __igb_open(struct net_device
|
||||
if (!resuming)
|
||||
pm_runtime_put(&pdev->dev);
|
||||
|
||||
@ -259,7 +259,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
|
||||
/* start the watchdog. */
|
||||
hw->mac.get_link_status = 1;
|
||||
schedule_work(&adapter->watchdog_task);
|
||||
@@ -7097,21 +7235,41 @@ void igb_alloc_rx_buffers(struct igb_rin
|
||||
@@ -7146,21 +7284,41 @@ void igb_alloc_rx_buffers(struct igb_rin
|
||||
static int igb_mii_ioctl(struct net_device *netdev, struct ifreq *ifr, int cmd)
|
||||
{
|
||||
struct igb_adapter *adapter = netdev_priv(netdev);
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -292,6 +292,14 @@ endif # RTL8366_SMI
|
||||
@@ -293,6 +293,14 @@ endif # RTL8366_SMI
|
||||
|
||||
source "drivers/net/phy/b53/Kconfig"
|
||||
|
||||
|
@ -14,7 +14,7 @@
|
||||
&i2c3 {
|
||||
--- a/arch/arm/boot/dts/imx6qdl-gw52xx.dtsi
|
||||
+++ b/arch/arm/boot/dts/imx6qdl-gw52xx.dtsi
|
||||
@@ -233,6 +233,11 @@
|
||||
@@ -225,6 +225,11 @@
|
||||
pinctrl-names = "default";
|
||||
pinctrl-0 = <&pinctrl_i2c2>;
|
||||
status = "okay";
|
||||
|
Loading…
Reference in New Issue
Block a user