mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
readline: fix pkgconfig usage
ncurses is built with wide support enabled, which enables libncursesw. The problem is, the ncurses build system only supplies ncursesw or ncurses.pc but not both. The other problem is, the readline build tests for libncurses before the w variant, making its pc file unusable as there is no ncurses.pc file to satisfy the Required: ncurses section. Just override the library. Signed-off-by: Rosen Penev <rosenp@gmail.com> Link: https://github.com/openwrt/openwrt/pull/15864 Signed-off-by: Robert Marko <robimarko@gmail.com>
This commit is contained in:
parent
1b141cb3d1
commit
d7a76fc351
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=readline
|
||||
PKG_VERSION:=8.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/readline
|
||||
@ -51,6 +51,7 @@ CONFIGURE_ARGS += --with-curses --disable-install-examples
|
||||
CONFIGURE_VARS += \
|
||||
bash_cv_wcwidth_broken=no \
|
||||
bash_cv_func_sigsetjmp=yes \
|
||||
bash_cv_termcap_lib=libncursesw
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
HOST_CFLAGS += $(FPIC)
|
||||
|
20
package/libs/readline/patches/010-ncursesw-first.patch
Normal file
20
package/libs/readline/patches/010-ncursesw-first.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -7305,6 +7305,9 @@ TERMCAP_DEP=
|
||||
elif test $bash_cv_termcap_lib = libncurses; then
|
||||
TERMCAP_LIB=-lncurses
|
||||
TERMCAP_DEP=
|
||||
+elif test $bash_cv_termcap_lib = libncursesw; then
|
||||
+TERMCAP_LIB=-lncursesw
|
||||
+TERMCAP_DEP=
|
||||
elif test $bash_cv_termcap_lib = libc; then
|
||||
TERMCAP_LIB=
|
||||
TERMCAP_DEP=
|
||||
@@ -7340,6 +7343,7 @@ case "$TERMCAP_LIB" in
|
||||
-ltinfo) TERMCAP_PKG_CONFIG_LIB=tinfo ;;
|
||||
-lcurses) TERMCAP_PKG_CONFIG_LIB=ncurses ;;
|
||||
-lncurses) TERMCAP_PKG_CONFIG_LIB=ncurses ;;
|
||||
+-lncursesw) TERMCAP_PKG_CONFIG_LIB=ncursesw ;;
|
||||
-ltermcap) TERMCAP_PKG_CONFIG_LIB=termcap ;;
|
||||
*) TERMCAP_PKG_CONFIG_LIB=termcap ;;
|
||||
esac
|
Loading…
Reference in New Issue
Block a user