mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-20 17:32:57 +00:00
arm-trusted-firmware-mediatek: update to release 2023-10-13
Drop local patches now upstream. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
a78c4e0c57
commit
d6a06acaa5
@ -9,13 +9,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=arm-trusted-firmware-mediatek
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL=https://github.com/mtk-openwrt/arm-trusted-firmware.git
|
||||
PKG_SOURCE_DATE:=2023-07-24
|
||||
PKG_SOURCE_VERSION:=00ac6db375b76e57e1f5e9e9bffa033e907c3581
|
||||
PKG_MIRROR_HASH:=74fc18395532c4292f530da8d00fa1873ada4e05e600c0077a7b7f85ace0d913
|
||||
PKG_SOURCE_DATE:=2023-10-13
|
||||
PKG_SOURCE_VERSION:=0ea67d76ae8be127c91caa3fcdf449b1fe533175
|
||||
PKG_MIRROR_HASH:=b102f6ffaa7cd2202161c44cab4d27f426d9d74c311ea9eb4d2f371ea2af4a2e
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/plat/mediatek/mt7988/bl2/bl2_plat_init.c
|
||||
+++ b/plat/mediatek/mt7988/bl2/bl2_plat_init.c
|
||||
@@ -90,6 +90,8 @@ static void mtk_i2p5g_phy_init(void)
|
||||
* clear bit 22 to use external MDIO.
|
||||
*/
|
||||
mmio_setbits_32(GBE_TOP_REG, I2P5G_MDIO);
|
||||
+ /* Internal 2.5Gphy power on sequence */
|
||||
+ eth_2p5g_phy_mtcmos_ctrl(true);
|
||||
}
|
||||
|
||||
static void mt7988_i2c_init(void)
|
@ -1,28 +0,0 @@
|
||||
From 9e8cb08bc64530e7511b86a131cfad1ae0199586 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Golle <daniel@makrotopia.org>
|
||||
Date: Sun, 10 Sep 2023 23:35:47 +0100
|
||||
Subject: [PATCH] mt7622: move wdt init after dram init
|
||||
|
||||
resolves hang on reboot
|
||||
---
|
||||
plat/mediatek/mt7622/bl2/bl2_plat_init.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/plat/mediatek/mt7622/bl2/bl2_plat_init.c
|
||||
+++ b/plat/mediatek/mt7622/bl2/bl2_plat_init.c
|
||||
@@ -40,7 +40,6 @@ bool plat_is_my_cpu_primary(void)
|
||||
const struct initcall bl2_initcalls[] = {
|
||||
INITCALL(plat_mt_cpuxgpt_init),
|
||||
INITCALL(generic_delay_timer_init),
|
||||
- INITCALL(mtk_wdt_init),
|
||||
INITCALL(mtk_print_cpu),
|
||||
INITCALL(mtk_pin_init),
|
||||
#ifndef IMAGE_BL2PL
|
||||
@@ -49,6 +48,7 @@ const struct initcall bl2_initcalls[] =
|
||||
INITCALL(mtk_pwrap_init),
|
||||
INITCALL(mtk_pmic_init),
|
||||
INITCALL(mtk_mem_init),
|
||||
+ INITCALL(mtk_wdt_init),
|
||||
|
||||
INITCALL(NULL)
|
||||
};
|
Loading…
x
Reference in New Issue
Block a user