generic: Convert incorrect generic/5.10 patches

OpenWRT's developer guide prefers having actual patches so they an be
sent upstream more easily.

However, in this case, Adding proper fields also allows for `git am` to
properly function. Some of these patches are quite old, and lack much
traceable history.

This commit tries to rectify that, by digging in the history to find
where and how it was first added.

It is by no means perfect and also shows some patches that should have
been long gone.

Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
This commit is contained in:
Olliver Schinagl 2022-09-20 12:01:48 +02:00 committed by Christian Marangi
parent 5d09118f8e
commit d5bf46bbe8
No known key found for this signature in database
GPG Key ID: AC001D09ADBFEAD7
30 changed files with 508 additions and 163 deletions

View File

@ -1,8 +1,7 @@
commit 8610037e8106b48c79cfe0afb92b2b2466e51c3d From 8610037e8106b48c79cfe0afb92b2b2466e51c3d Mon Sep 17 00:00:00 2001
Author: Joe Damato <jdamato@fastly.com> From: Joe Damato <jdamato@fastly.com>
Date: Tue Mar 1 23:55:47 2022 -0800 Date: Tue, 1 Mar 2022 23:55:47 -0800
Subject: [PATCH] page_pool: Add allocation stats
page_pool: Add allocation stats
Add per-pool statistics counters for the allocation path of a page pool. Add per-pool statistics counters for the allocation path of a page pool.
These stats are incremented in softirq context, so no locking or per-cpu These stats are incremented in softirq context, so no locking or per-cpu
@ -24,7 +23,14 @@ Date: Tue Mar 1 23:55:47 2022 -0800
Acked-by: Jesper Dangaard Brouer <brouer@redhat.com> Acked-by: Jesper Dangaard Brouer <brouer@redhat.com>
Reviewed-by: Ilias Apalodimas <ilias.apalodimas@linaro.org> Reviewed-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Signed-off-by: David S. Miller <davem@davemloft.net> Signed-off-by: David S. Miller <davem@davemloft.net>
---
include/net/page_pool.h | 18 ++++++++++++++++++
net/Kconfig | 13 +++++++++++++
net/core/page_pool.c | 24 ++++++++++++++++++++----
3 files changed, 51 insertions(+), 4 deletions(-)
diff --git a/include/net/page_pool.h b/include/net/page_pool.h
index 97c3c19872ff..1f27e8a48830 100644
--- a/include/net/page_pool.h --- a/include/net/page_pool.h
+++ b/include/net/page_pool.h +++ b/include/net/page_pool.h
@@ -82,6 +82,19 @@ struct page_pool_params { @@ -82,6 +82,19 @@ struct page_pool_params {

View File

@ -1,8 +1,7 @@
commit ad6fa1e1ab1b8164f1ba296b1b4dc556a483bcad From ad6fa1e1ab1b8164f1ba296b1b4dc556a483bcad Mon Sep 17 00:00:00 2001
Author: Joe Damato <jdamato@fastly.com> From: Joe Damato <jdamato@fastly.com>
Date: Tue Mar 1 23:55:48 2022 -0800 Date: Tue, 1 Mar 2022 23:55:48 -0800
Subject: [PATCH 2/3] page_pool: Add recycle stats
page_pool: Add recycle stats
Add per-cpu stats tracking page pool recycling events: Add per-cpu stats tracking page pool recycling events:
- cached: recycling placed page in the page pool cache - cached: recycling placed page in the page pool cache
@ -15,7 +14,13 @@ Date: Tue Mar 1 23:55:48 2022 -0800
Acked-by: Jesper Dangaard Brouer <brouer@redhat.com> Acked-by: Jesper Dangaard Brouer <brouer@redhat.com>
Reviewed-by: Ilias Apalodimas <ilias.apalodimas@linaro.org> Reviewed-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Signed-off-by: David S. Miller <davem@davemloft.net> Signed-off-by: David S. Miller <davem@davemloft.net>
---
include/net/page_pool.h | 16 ++++++++++++++++
net/core/page_pool.c | 30 ++++++++++++++++++++++++++++--
2 files changed, 44 insertions(+), 2 deletions(-)
diff --git a/include/net/page_pool.h b/include/net/page_pool.h
index 1f27e8a48830..298af95bbf96 100644
--- a/include/net/page_pool.h --- a/include/net/page_pool.h
+++ b/include/net/page_pool.h +++ b/include/net/page_pool.h
@@ -93,6 +93,18 @@ struct page_pool_alloc_stats { @@ -93,6 +93,18 @@ struct page_pool_alloc_stats {

View File

@ -1,8 +1,7 @@
commit 6b95e3388b1ea0ca63500c5a6e39162dbf828433 From 6b95e3388b1ea0ca63500c5a6e39162dbf828433 Mon Sep 17 00:00:00 2001
Author: Joe Damato <jdamato@fastly.com> From: Joe Damato <jdamato@fastly.com>
Date: Tue Mar 1 23:55:49 2022 -0800 Date: Tue, 1 Mar 2022 23:55:49 -0800
Subject: [PATCH 3/3] page_pool: Add function to batch and return stats
page_pool: Add function to batch and return stats
Adds a function page_pool_get_stats which can be used by drivers to obtain Adds a function page_pool_get_stats which can be used by drivers to obtain
stats for a specified page_pool. stats for a specified page_pool.
@ -11,7 +10,13 @@ Date: Tue Mar 1 23:55:49 2022 -0800
Acked-by: Jesper Dangaard Brouer <brouer@redhat.com> Acked-by: Jesper Dangaard Brouer <brouer@redhat.com>
Reviewed-by: Ilias Apalodimas <ilias.apalodimas@linaro.org> Reviewed-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Signed-off-by: David S. Miller <davem@davemloft.net> Signed-off-by: David S. Miller <davem@davemloft.net>
---
include/net/page_pool.h | 17 +++++++++++++++++
net/core/page_pool.c | 25 +++++++++++++++++++++++++
2 files changed, 42 insertions(+)
diff --git a/include/net/page_pool.h b/include/net/page_pool.h
index 298af95bbf96..ea5fb70e5101 100644
--- a/include/net/page_pool.h --- a/include/net/page_pool.h
+++ b/include/net/page_pool.h +++ b/include/net/page_pool.h
@@ -105,6 +105,23 @@ struct page_pool_recycle_stats { @@ -105,6 +105,23 @@ struct page_pool_recycle_stats {

View File

@ -1,8 +1,7 @@
commit 590032a4d2133ecc10d3078a8db1d85a4842f12c From 590032a4d2133ecc10d3078a8db1d85a4842f12c Mon Sep 17 00:00:00 2001
Author: Lorenzo Bianconi <lorenzo@kernel.org> From: Lorenzo Bianconi <lorenzo@kernel.org>
Date: Mon Apr 11 16:05:26 2022 +0200 Date: Mon, 11 Apr 2022 16:05:26 +0200
Subject: [PATCH] page_pool: Add recycle stats to page_pool_put_page_bulk
page_pool: Add recycle stats to page_pool_put_page_bulk
Add missing recycle stats to page_pool_put_page_bulk routine. Add missing recycle stats to page_pool_put_page_bulk routine.
@ -11,7 +10,12 @@ Date: Mon Apr 11 16:05:26 2022 +0200
Reviewed-by: Ilias Apalodimas <ilias.apalodimas@linaro.org> Reviewed-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Link: https://lore.kernel.org/r/3712178b51c007cfaed910ea80e68f00c916b1fa.1649685634.git.lorenzo@kernel.org Link: https://lore.kernel.org/r/3712178b51c007cfaed910ea80e68f00c916b1fa.1649685634.git.lorenzo@kernel.org
Signed-off-by: Paolo Abeni <pabeni@redhat.com> Signed-off-by: Paolo Abeni <pabeni@redhat.com>
---
net/core/page_pool.c | 15 +++++++++++++--
1 file changed, 13 insertions(+), 2 deletions(-)
diff --git a/net/core/page_pool.c b/net/core/page_pool.c
index 1943c0f0307d..4af55d28ffa3 100644
--- a/net/core/page_pool.c --- a/net/core/page_pool.c
+++ b/net/core/page_pool.c +++ b/net/core/page_pool.c
@@ -36,6 +36,12 @@ @@ -36,6 +36,12 @@

View File

@ -1,8 +1,7 @@
commit f3c5264f452a5b0ac1de1f2f657efbabdea3c76a From f3c5264f452a5b0ac1de1f2f657efbabdea3c76a Mon Sep 17 00:00:00 2001
Author: Lorenzo Bianconi <lorenzo@kernel.org> From: Lorenzo Bianconi <lorenzo@kernel.org>
Date: Tue Apr 12 18:31:58 2022 +0200 Date: Tue, 12 Apr 2022 18:31:58 +0200
Subject: [PATCH] net: page_pool: introduce ethtool stats
net: page_pool: introduce ethtool stats
Introduce page_pool APIs to report stats through ethtool and reduce Introduce page_pool APIs to report stats through ethtool and reduce
duplicated code in each driver. duplicated code in each driver.
@ -11,7 +10,13 @@ Date: Tue Apr 12 18:31:58 2022 +0200
Reviewed-by: Jakub Kicinski <kuba@kernel.org> Reviewed-by: Jakub Kicinski <kuba@kernel.org>
Reviewed-by: Ilias Apalodimas <ilias.apalodimas@linaro.org> Reviewed-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Signed-off-by: David S. Miller <davem@davemloft.net> Signed-off-by: David S. Miller <davem@davemloft.net>
---
include/net/page_pool.h | 21 ++++++++++++++
net/core/page_pool.c | 63 ++++++++++++++++++++++++++++++++++++++++-
2 files changed, 83 insertions(+), 1 deletion(-)
diff --git a/include/net/page_pool.h b/include/net/page_pool.h
index ea5fb70e5101..813c93499f20 100644
--- a/include/net/page_pool.h --- a/include/net/page_pool.h
+++ b/include/net/page_pool.h +++ b/include/net/page_pool.h
@@ -115,6 +115,10 @@ struct page_pool_stats { @@ -115,6 +115,10 @@ struct page_pool_stats {

View File

@ -1,8 +1,7 @@
commit 2e88d4ff03013937028f5397268b21e10cf68713 From 2e88d4ff03013937028f5397268b21e10cf68713 Mon Sep 17 00:00:00 2001
Author: Lorenzo Bianconi <lorenzo@kernel.org> From: Lorenzo Bianconi <lorenzo@kernel.org>
Date: Fri Jan 21 11:09:45 2022 +0100 Date: Fri, 21 Jan 2022 11:09:45 +0100
Subject: [PATCH] xdp: introduce flags field in xdp_buff/xdp_frame
xdp: introduce flags field in xdp_buff/xdp_frame
Introduce flags field in xdp_frame and xdp_buffer data structures Introduce flags field in xdp_frame and xdp_buffer data structures
to define additional buffer features. At the moment the only to define additional buffer features. At the moment the only
@ -19,7 +18,12 @@ Date: Fri Jan 21 11:09:45 2022 +0100
Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org> Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org>
Link: https://lore.kernel.org/r/e389f14f3a162c0a5bc6a2e1aa8dd01a90be117d.1642758637.git.lorenzo@kernel.org Link: https://lore.kernel.org/r/e389f14f3a162c0a5bc6a2e1aa8dd01a90be117d.1642758637.git.lorenzo@kernel.org
Signed-off-by: Alexei Starovoitov <ast@kernel.org> Signed-off-by: Alexei Starovoitov <ast@kernel.org>
---
include/net/xdp.h | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
diff --git a/include/net/xdp.h b/include/net/xdp.h
index 8f0812e4996d..485e9495a690 100644
--- a/include/net/xdp.h --- a/include/net/xdp.h
+++ b/include/net/xdp.h +++ b/include/net/xdp.h
@@ -66,6 +66,10 @@ struct xdp_txq_info { @@ -66,6 +66,10 @@ struct xdp_txq_info {

View File

@ -1,8 +1,7 @@
commit 7c48cb0176c6d6d3b55029f7ff4ffa05faee6446 From 7c48cb0176c6d6d3b55029f7ff4ffa05faee6446 Mon Sep 17 00:00:00 2001
Author: Lorenzo Bianconi <lorenzo@kernel.org> From: Lorenzo Bianconi <lorenzo@kernel.org>
Date: Fri Jan 21 11:09:50 2022 +0100 Date: Fri, 21 Jan 2022 11:09:50 +0100
Subject: [PATCH] xdp: add frags support to xdp_return_{buff/frame}
xdp: add frags support to xdp_return_{buff/frame}
Take into account if the received xdp_buff/xdp_frame is non-linear Take into account if the received xdp_buff/xdp_frame is non-linear
recycling/returning the frame memory to the allocator or into recycling/returning the frame memory to the allocator or into
@ -13,7 +12,13 @@ Date: Fri Jan 21 11:09:50 2022 +0100
Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org> Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org>
Link: https://lore.kernel.org/r/a961069febc868508ce1bdf5e53a343eb4e57cb2.1642758637.git.lorenzo@kernel.org Link: https://lore.kernel.org/r/a961069febc868508ce1bdf5e53a343eb4e57cb2.1642758637.git.lorenzo@kernel.org
Signed-off-by: Alexei Starovoitov <ast@kernel.org> Signed-off-by: Alexei Starovoitov <ast@kernel.org>
---
include/net/xdp.h | 18 ++++++++++++++--
net/core/xdp.c | 54 ++++++++++++++++++++++++++++++++++++++++++++++-
2 files changed, 69 insertions(+), 3 deletions(-)
diff --git a/include/net/xdp.h b/include/net/xdp.h
index 1f8641ec658e..8463dea8b4db 100644
--- a/include/net/xdp.h --- a/include/net/xdp.h
+++ b/include/net/xdp.h +++ b/include/net/xdp.h
@@ -275,10 +275,24 @@ void __xdp_release_frame(void *data, str @@ -275,10 +275,24 @@ void __xdp_release_frame(void *data, str

View File

@ -1,8 +1,7 @@
commit d16697cb6261d4cc23422e6b1cb2759df8aa76d0 From d16697cb6261d4cc23422e6b1cb2759df8aa76d0 Mon Sep 17 00:00:00 2001
Author: Lorenzo Bianconi <lorenzo@kernel.org> From: Lorenzo Bianconi <lorenzo@kernel.org>
Date: Fri Jan 21 11:09:44 2022 +0100 Date: Fri, 21 Jan 2022 11:09:44 +0100
Subject: [PATCH] net: skbuff: add size metadata to skb_shared_info for xdp
net: skbuff: add size metadata to skb_shared_info for xdp
Introduce xdp_frags_size field in skb_shared_info data structure Introduce xdp_frags_size field in skb_shared_info data structure
to store xdp_buff/xdp_frame frame paged size (xdp_frags_size will to store xdp_buff/xdp_frame frame paged size (xdp_frags_size will
@ -16,7 +15,12 @@ Date: Fri Jan 21 11:09:44 2022 +0100
Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org> Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org>
Link: https://lore.kernel.org/r/8a849819a3e0a143d540f78a3a5add76e17e980d.1642758637.git.lorenzo@kernel.org Link: https://lore.kernel.org/r/8a849819a3e0a143d540f78a3a5add76e17e980d.1642758637.git.lorenzo@kernel.org
Signed-off-by: Alexei Starovoitov <ast@kernel.org> Signed-off-by: Alexei Starovoitov <ast@kernel.org>
---
include/linux/skbuff.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/linux/skbuff.h b/include/linux/skbuff.h
index bf11e1fbd69b..8131d0de7559 100644
--- a/include/linux/skbuff.h --- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h +++ b/include/linux/skbuff.h
@@ -567,6 +567,7 @@ struct skb_shared_info { @@ -567,6 +567,7 @@ struct skb_shared_info {

View File

@ -1,8 +1,7 @@
commit 5142239a22219921a7863cf00c9ab853c00689d8 From 5142239a22219921a7863cf00c9ab853c00689d8 Mon Sep 17 00:00:00 2001
Author: Lorenzo Bianconi <lorenzo@kernel.org> From: Lorenzo Bianconi <lorenzo@kernel.org>
Date: Fri Mar 11 10:14:18 2022 +0100 Date: Fri, 11 Mar 2022 10:14:18 +0100
Subject: [PATCH] net: veth: Account total xdp_frame len running ndo_xdp_xmit
net: veth: Account total xdp_frame len running ndo_xdp_xmit
Even if this is a theoretical issue since it is not possible to perform Even if this is a theoretical issue since it is not possible to perform
XDP_REDIRECT on a non-linear xdp_frame, veth driver does not account XDP_REDIRECT on a non-linear xdp_frame, veth driver does not account
@ -16,7 +15,13 @@ Date: Fri Mar 11 10:14:18 2022 +0100
Acked-by: Toke Hoiland-Jorgensen <toke@redhat.com> Acked-by: Toke Hoiland-Jorgensen <toke@redhat.com>
Acked-by: John Fastabend <john.fastabend@gmail.com> Acked-by: John Fastabend <john.fastabend@gmail.com>
Link: https://lore.kernel.org/bpf/54f9fd3bb65d190daf2c0bbae2f852ff16cfbaa0.1646989407.git.lorenzo@kernel.org Link: https://lore.kernel.org/bpf/54f9fd3bb65d190daf2c0bbae2f852ff16cfbaa0.1646989407.git.lorenzo@kernel.org
---
drivers/net/veth.c | 4 ++--
include/net/xdp.h | 14 ++++++++++++++
2 files changed, 16 insertions(+), 2 deletions(-)
diff --git a/drivers/net/veth.c b/drivers/net/veth.c
index 58b20ea171dd..b77ce3fdcfe8 100644
--- a/drivers/net/veth.c --- a/drivers/net/veth.c
+++ b/drivers/net/veth.c +++ b/drivers/net/veth.c
@@ -501,7 +501,7 @@ static int veth_xdp_xmit(struct net_devi @@ -501,7 +501,7 @@ static int veth_xdp_xmit(struct net_devi

View File

@ -1,8 +1,10 @@
commit 7cda76d858a4e71ac4a04066c093679a12e1312c From 7cda76d858a4e71ac4a04066c093679a12e1312c Mon Sep 17 00:00:00 2001
Author: Lorenzo Bianconi <lorenzo@kernel.org> From: Lorenzo Bianconi <lorenzo@kernel.org>
Date: Fri Mar 11 10:14:20 2022 +0100 Date: Fri, 11 Mar 2022 10:14:20 +0100
Subject: [PATCH] veth: Allow jumbo frames in xdp mode
veth: Allow jumbo frames in xdp mode MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Allow increasing the MTU over page boundaries on veth devices Allow increasing the MTU over page boundaries on veth devices
if the attached xdp program declares to support xdp fragments. if the attached xdp program declares to support xdp fragments.
@ -12,7 +14,12 @@ Date: Fri Mar 11 10:14:20 2022 +0100
Acked-by: Toke Høiland-Jørgensen <toke@redhat.com> Acked-by: Toke Høiland-Jørgensen <toke@redhat.com>
Acked-by: John Fastabend <john.fastabend@gmail.com> Acked-by: John Fastabend <john.fastabend@gmail.com>
Link: https://lore.kernel.org/bpf/d5dc039c3d4123426e7023a488c449181a7bc57f.1646989407.git.lorenzo@kernel.org Link: https://lore.kernel.org/bpf/d5dc039c3d4123426e7023a488c449181a7bc57f.1646989407.git.lorenzo@kernel.org
---
drivers/net/veth.c | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)
diff --git a/drivers/net/veth.c b/drivers/net/veth.c
index bfae15ec902b..1b5714926d81 100644
--- a/drivers/net/veth.c --- a/drivers/net/veth.c
+++ b/drivers/net/veth.c +++ b/drivers/net/veth.c
@@ -1470,9 +1470,14 @@ static int veth_xdp_set(struct net_devic @@ -1470,9 +1470,14 @@ static int veth_xdp_set(struct net_devic

View File

@ -1,3 +1,20 @@
From: David Bauer <mail@david-bauer.net>
Subject: Kconfig: exit on unset symbol
When a target configuration has unset Kconfig symbols, the build will
fail when OpenWrt is compiled with V=s and stdin is connected to a tty.
In case OpenWrt is compiled without either of these preconditions, the
build will succeed with the symbols in question being unset.
Modify the kernel configuration in a way it fails on unset symbols
regardless of the aforementioned preconditions.
Submitted-by: David Bauer <mail@david-bauer.net>
---
scripts/kconfig/conf.c | 2 +
1 files changed, 2 insertions(+)
--- a/scripts/kconfig/conf.c --- a/scripts/kconfig/conf.c
+++ b/scripts/kconfig/conf.c +++ b/scripts/kconfig/conf.c
@@ -215,6 +215,8 @@ static int conf_sym(struct menu *menu) @@ -215,6 +215,8 @@ static int conf_sym(struct menu *menu)

View File

@ -1,3 +1,15 @@
From: Rosen Penev <rosenp@gmail.com>
Subject: Kconfig: add help text to kernel config
These options will be used for ksmbd. Once kernel 5.15
makes it in, this patch can go away.
Submitted-by: Rosen Penev <rosenp@gmail.com>
---
init/Kconfig | 2 +-
lib/Kconfig | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
--- a/init/Kconfig --- a/init/Kconfig
+++ b/init/Kconfig +++ b/init/Kconfig
@@ -2384,7 +2384,7 @@ config PADATA @@ -2384,7 +2384,7 @@ config PADATA
@ -19,4 +31,3 @@
+ tristate "OID" + tristate "OID"
help help
Enable fast lookup object identifier registry. Enable fast lookup object identifier registry.

View File

@ -1,7 +1,20 @@
From: Koen Vandeputte <koen.vandeputte@ncentric.com>
Subject: crypto: arc4 unhide
This makes it possible to select CONFIG_CRYPTO_LIB_ARC4 directly. We This makes it possible to select CONFIG_CRYPTO_LIB_ARC4 directly. We
need this to be able to compile this into the kernel and make use of it need this to be able to compile this into the kernel and make use of it
from backports. from backports.
Submitted-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Submitted-by: David Bauer <mail@david-bauer.net>
Submitted-by: Christian Lamparter <chunkeey@gmail.com>
Submitted-by: Ansuel Smith <ansuelsmth@gmail.com>
Submitted-by: Robert Marko <robimarko@gmail.com>
Submitted-by: Hauke Mehrtens <hauke@hauke-m.de>
---
lib/crypto/Kconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/lib/crypto/Kconfig --- a/lib/crypto/Kconfig
+++ b/lib/crypto/Kconfig +++ b/lib/crypto/Kconfig
@@ -6,7 +6,7 @@ config CRYPTO_LIB_AES @@ -6,7 +6,7 @@ config CRYPTO_LIB_AES

View File

@ -1,3 +1,30 @@
From: Daniel Golle <daniel@makrotopia.org>
Subject: [PATCH] kernel: fix FIT partition parser compatibility issues
The uImage.FIT partition parser used to squeeze in FIT partitions in
the range where partition editor tools (fdisk and such) expect the
regular partition. This is confusing people and tools when adding
additional partitions on top of the partition used for OpenWrt's
uImage.FIT.
Instead of squeezing in the additional partitions, rather start with
all uImage.FIT partitions at offset 64.
Submitted-by: Daniel Golle <daniel@makrotopia.org>
---
block/blk.h | 2 ++
block/partitions/Kconfig | 7 +++
block/partitions/Makefile | 1 +
block/partitions/check.h | 3 ++
block/partitions/core.c | 15 +++++++
drivers/mtd/ubi/block.c | 7 +++
block/partitions/efi.c | 8 +++++++
block/partitions/efi.h | 3 ++
drivers/mtd/mtdblock.c | 4 +++
drivers/mtd/mtd_blkdevs.c | 14 +------
block/partitions/msdos.c | 10 ++++++
include/linux/msdos_partition.h | 1 +
12 files changed, 52 insertions(+), 13 deletions(-)
--- a/block/blk.h --- a/block/blk.h
+++ b/block/blk.h +++ b/block/blk.h
@@ -361,6 +361,8 @@ char *disk_name(struct gendisk *hd, int @@ -361,6 +361,8 @@ char *disk_name(struct gendisk *hd, int
@ -221,4 +248,3 @@
+ FIT_PARTITION = 0x2e, /* U-Boot uImage.FIT */ + FIT_PARTITION = 0x2e, /* U-Boot uImage.FIT */
SOLARIS_X86_PARTITION = 0x82, /* also Linux swap partitions */ SOLARIS_X86_PARTITION = 0x82, /* also Linux swap partitions */
NEW_SOLARIS_X86_PARTITION = 0xbf, NEW_SOLARIS_X86_PARTITION = 0xbf,

View File

@ -1,3 +1,14 @@
From 11425c9de29c8b9c5e4d7eec163a6afbb7fbdce2 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@nbd.name>
Date: Thu, 9 Apr 2020 09:53:24 +0200
Subject: mediatek: Implement bad-block management table support
Submitted-by: Felix Fietkau <nbd@nbd.name>
---
drivers/mtd/nand/Kconfig | 4 ++++
drivers/mtd/nand/Makefile | 1 +
2 files changed, 5 insertions(+)
--- a/drivers/mtd/nand/Kconfig --- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig +++ b/drivers/mtd/nand/Kconfig
@@ -15,6 +15,10 @@ config MTD_NAND_ECC @@ -15,6 +15,10 @@ config MTD_NAND_ECC

View File

@ -1,3 +1,31 @@
From: Felix Fietkau <nbd@nbd.name>
Subject: bridge: Add a fast path for the bridge code
This caches flows between MAC addresses on separate ports, including their VLAN
in order to bypass the normal bridge forwarding code.
In my test on MT7622, this reduces LAN->WLAN bridging CPU usage by 6-10%,
potentially even more on weaker platforms
Submitted-by: Felix Fietkau <nbd@nbd.name>
---
include/linux/if_bridge.h | 1 +
net/bridge/Makefile | 2 +-
net/bridge/br.c | 8 +++
net/bridge/br_device.c | 7 +++
net/bridge/br_forward.c | 3 ++
net/bridge/br_if.c | 7 ++-
net/bridge/br_input.c | 5 ++
net/bridge/br_offload.c | 436 +++++++++++++++
net/bridge/br_private.h | 22 ++++-
net/bridge/br_private_offload.h | 21 +++++
net/bridge/br_stp.c | 3 +
net/bridge/br_sysfs_br.c | 35 ++++++
net/bridge/br_sysfs_if.c | 2 +
net/bridge/br_vlan_tunnel.c | 3 ++
14 files changed, 552 insertions(+), 3 deletions(-)
create mode 100644 net/bridge/br_offload.c
create mode 100644 net/bridge/br_private_offload.h
--- a/include/linux/if_bridge.h --- a/include/linux/if_bridge.h
+++ b/include/linux/if_bridge.h +++ b/include/linux/if_bridge.h
@@ -57,6 +57,7 @@ struct br_ip_list { @@ -57,6 +57,7 @@ struct br_ip_list {

View File

@ -1,3 +1,32 @@
From: DENG Qingfang <dqfext@gmail.com>
Subject: DSA: roaming fix for Marvell mv88e6xxx
Marvell mv88e6xxx switch series cannot perform MAC learning from
CPU-injected (FROM_CPU) DSA frames, which results in 2 issues.
- excessive flooding, due to the fact that DSA treats those addresses
as unknown
- the risk of stale routes, which can lead to temporary packet loss
Backport those patch series from netdev mailing list, which solve these
issues by adding and clearing static entries to the switch's FDB.
Add a hack patch to set default VID to 1 in port_fdb_{add,del}. Otherwise
the static entries will be added to the switch's private FDB if VLAN
filtering disabled, which will not work.
The switch may generate an "ATU violation" warning when a client moves
from the CPU port to a switch port because the static ATU entry added by
DSA core still points to the CPU port. DSA core will then clear the static
entry so it is not fatal. Disable the warning so it will not confuse users.
Link: https://lore.kernel.org/netdev/20210106095136.224739-1-olteanv@gmail.com/
Link: https://lore.kernel.org/netdev/20210116012515.3152-1-tobias@waldekranz.com/
Ref: https://gitlab.nic.cz/turris/turris-build/-/issues/165
Submitted-by: DENG Qingfang <dqfext@gmail.com>
---
drivers/net/dsa/mv88e6xxx/chip.c | 3 +++
3 files changed, 3 insertions(+)
--- a/drivers/net/dsa/mv88e6xxx/chip.c --- a/drivers/net/dsa/mv88e6xxx/chip.c
+++ b/drivers/net/dsa/mv88e6xxx/chip.c +++ b/drivers/net/dsa/mv88e6xxx/chip.c
@@ -2705,6 +2705,9 @@ static int mv88e6xxx_setup_port(struct m @@ -2705,6 +2705,9 @@ static int mv88e6xxx_setup_port(struct m

View File

@ -1,3 +1,17 @@
From: Daniel Golle <daniel@makrotopia.org>
Subject: wwan: Add MeigLink SLM750 modem support
Add patch found in Teltonika RUT9_R_00.07.01.4 GPL SDK download[1]
adding USB IDs of the MeigLink SLM750 to the relevant kernel drivers.
Newer versions of Teltonika's 2G/3G/4G RUT9XX WWAN router series come
with this kind of modem.
[1]: https://wiki.teltonika-networks.com/view/GPL
Submitted-by: Daniel Golle <daniel@makrotopia.org>
---
drivers/net/usb/qmi_wwan.c | 8 ++++++
1 file changed, 8 insertions(+)
--- a/drivers/net/usb/qmi_wwan.c --- a/drivers/net/usb/qmi_wwan.c
+++ b/drivers/net/usb/qmi_wwan.c +++ b/drivers/net/usb/qmi_wwan.c
@@ -1024,6 +1024,7 @@ static const struct usb_device_id produc @@ -1024,6 +1024,7 @@ static const struct usb_device_id produc

View File

@ -1,3 +1,19 @@
From a9968d9cb8cb10030491fa05e24b00bd42f6d3a9 Mon Sep 17 00:00:00 2001
From: John Crispin <john@openwrt.org>
Date: Thu, 30 May 2013 16:00:42 +0000
Subject: fdt: enable retrieving kernel args from bootloader
This patch is a device tree enhancement that IMHO is worthy of mainline.
It allows the bootloader's commandline to be preserved even when the
device tree specifies one.
Submitted-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>
SVN-Revision: 36780
---
drivers/of/fdt.c | 3 +++
1 file changed, 3 insertions(+)
--- a/drivers/of/fdt.c --- a/drivers/of/fdt.c
+++ b/drivers/of/fdt.c +++ b/drivers/of/fdt.c
@@ -1055,6 +1055,9 @@ int __init early_init_dt_scan_chosen(uns @@ -1055,6 +1055,9 @@ int __init early_init_dt_scan_chosen(uns

View File

@ -1,3 +1,11 @@
From: Felix Fietkau <nbd@nbd.name>
Subject: uapi: Fix an issue with kernel headers that broke perf
Submitted-by: Felix Fietkau <nbd@nbd.name>
---
include/uapi/linux/swab.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/include/uapi/linux/swab.h --- a/include/uapi/linux/swab.h
+++ b/include/uapi/linux/swab.h +++ b/include/uapi/linux/swab.h
@@ -3,7 +3,7 @@ @@ -3,7 +3,7 @@

View File

@ -1,3 +1,25 @@
From: Gabor Juhos <juhosg@openwrt.org>
Subject: mtd: Add new Kconfig option for firmware partition split
Add a new kernel config option for generic firmware partition
split support and change the uImage split support to depend on
the new option. Aslo rename the MTD_UIMAGE_SPLIT_NAME option to
MTD_SPLIT_FIRMWARE_NAME to make it more generic.
The patch is in preparation for multiple firmware format
support.
Submitted-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38002
---
drivers/mtd/Kconfig | 19 +
drivers/mtd/mtdpart.c | 144 +++++++++++++-----
include/linux/mtd/partitions.h | 7 +
drivers/mtd/Makefile | 2 +
include/linux/mtd/mtd.h | 25 +
5 files changed, 171 insertions(+), 25 deletions(-)
--- a/drivers/mtd/Kconfig --- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig +++ b/drivers/mtd/Kconfig
@@ -12,6 +12,25 @@ menuconfig MTD @@ -12,6 +12,25 @@ menuconfig MTD

View File

@ -1,3 +1,12 @@
From: Roman Yeryomin <roman@advem.lv>
Subject: mtd/spi-nor/gigadevice: Add gd25q512 SPI NOR flash
Submitted-by: Roman Yeryomin <roman@advem.lv>
Submitted-by: John Crispin <john@phrozen.org>
---
drivers/mtd/spi-nor/gigadevice.c | 3 +++
1 files changed, 3 insertions(+)
--- a/drivers/mtd/spi-nor/gigadevice.c --- a/drivers/mtd/spi-nor/gigadevice.c
+++ b/drivers/mtd/spi-nor/gigadevice.c +++ b/drivers/mtd/spi-nor/gigadevice.c
@@ -53,6 +53,9 @@ static const struct flash_info gigadevic @@ -53,6 +53,9 @@ static const struct flash_info gigadevic

View File

@ -1,3 +1,16 @@
From: Jihoon Han <rapid_renard@renard.ga>
Subject: mtd/spi-nor/esmt: Add support for ESMT F25L16PA(2S) SPI-NOR
This fixes support for Dongwon T&I DW02-412H which uses F25L16PA(2S) flash.
Submitted-by: Jihoon Han <rapid_renard@renard.ga>
Reviewed-by: Sungbo Eo <mans0n@gorani.run>
[refresh patches]
Submitted-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
drivers/mtd/spi-nor/esmt.c | 2 ++
1 files changed, 2 insertions(+)
--- a/drivers/mtd/spi-nor/esmt.c --- a/drivers/mtd/spi-nor/esmt.c
+++ b/drivers/mtd/spi-nor/esmt.c +++ b/drivers/mtd/spi-nor/esmt.c
@@ -10,6 +10,8 @@ @@ -10,6 +10,8 @@

View File

@ -1,3 +1,14 @@
From: Langhua Ye <y1248289414@outlook.com>
Subject: mtd/spi-nor/xmc: add support for XMC XM25QH128C
The XMC XM25QH128C is a 16MB SPI NOR chip. The patch is verified on Ruijie RG-EW3200GX PRO.
Datasheet available at https://www.xmcwh.com/uploads/435/XM25QH128C.pdf
Submitted-by: Langhua Ye <y1248289414@outlook.com>
---
drivers/mtd/spi-nor/xmc.c | 2 ++
1 file changed, 2 insertions(+)
--- a/drivers/mtd/spi-nor/xmc.c --- a/drivers/mtd/spi-nor/xmc.c
+++ b/drivers/mtd/spi-nor/xmc.c +++ b/drivers/mtd/spi-nor/xmc.c
@@ -14,6 +14,8 @@ static const struct flash_info xmc_parts @@ -14,6 +14,8 @@ static const struct flash_info xmc_parts

View File

@ -1,3 +1,14 @@
From: Felix Fietkau <nbd@nbd.name>
Subject: fs: Add CDROM dependencies
Submitted-by: Felix Fietkau <nbd@nbd.name>
---
fs/hfs/Kconfig | 1 +
fs/hfsplus/Kconfig | 1 +
fs/isofs/Kconfig | 1 +
fs/udf/Kconfig | 1 +
4 files changed, 4 insertions(+)
--- a/fs/hfs/Kconfig --- a/fs/hfs/Kconfig
+++ b/fs/hfs/Kconfig +++ b/fs/hfs/Kconfig
@@ -2,6 +2,7 @@ @@ -2,6 +2,7 @@

View File

@ -1,3 +1,19 @@
From: David Bauer <mail@david-bauer.net>
Subject: of/net: Add MAC address to of tree
The label-mac logic relies on the mac-address property of a netdev
devices of-node. However, the mac address can also be stored as a
different property or read from e.g. an mtd device.
Create this node when reading a mac-address from OF if it does not
already exist and copy the mac-address used for the device to this
property. This way, the MAC address can be accessed using procfs.
Submitted-by: David Bauer <mail@david-bauer.net>
---
drivers/of/of_net.c | 22 ++++++++++++++
1 files changed, 22 insertions(+)
--- a/drivers/of/of_net.c --- a/drivers/of/of_net.c
+++ b/drivers/of/of_net.c +++ b/drivers/of/of_net.c
@@ -95,6 +95,27 @@ static int of_get_mac_addr_nvmem(struct @@ -95,6 +95,27 @@ static int of_get_mac_addr_nvmem(struct

View File

@ -1,3 +1,43 @@
From f32085fc0b87049491b07e198d924d738a1a2834 Mon Sep 17 00:00:00 2001
From: Daniel Danzberger <daniel@dd-wrt.com>
Date: Wed, 3 Aug 2022 17:31:03 +0200
Subject: [PATCH] mtd: spinand: Add support for Etron EM73D044VCx
Airoha is a new ARM platform based on Cortex-A53 which has recently been
merged into linux-next.
Due to BootROM limitations on this platform, the Cortex-A53 can't run in
Aarch64 mode and code must be compiled for 32-Bit ARM.
This support is based mostly on those linux-next commits backported
for kernel 5.15.
Patches:
1 - platform support = linux-next
2 - clock driver = linux-next
3 - gpio driver = linux-next
4 - linux,usable-memory-range dts support = linux-next
5 - mtd spinand driver
6 - spi driver
7 - pci driver (kconfig only, uses mediatek PCI) = linux-next
Still missing:
- Ethernet driver
- Sysupgrade support
A.t.m there exists one subtarget EN7523 with only one evaluation
board.
The initramfs can be run with the following commands from u-boot:
-
u-boot> setenv bootfile \
openwrt-airoha-airoha_en7523-evb-initramfs-kernel.bin
u-boot> tftpboot
u-boot> bootm 0x81800000
-
Submitted-by: Daniel Danzberger <daniel@dd-wrt.com>
--- a/drivers/mtd/nand/spi/Makefile --- a/drivers/mtd/nand/spi/Makefile
+++ b/drivers/mtd/nand/spi/Makefile +++ b/drivers/mtd/nand/spi/Makefile
@@ -1,3 +1,3 @@ @@ -1,3 +1,3 @@