mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
valgrind: bump to 3.19.0
Patches automatically rebased. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
This commit is contained in:
parent
e21fea9289
commit
d075bb3f4a
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=valgrind
|
PKG_NAME:=valgrind
|
||||||
PKG_VERSION:=3.18.1
|
PKG_VERSION:=3.19.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://sourceware.org/pub/valgrind/
|
PKG_SOURCE_URL:=http://sourceware.org/pub/valgrind/
|
||||||
PKG_HASH:=00859aa13a772eddf7822225f4b46ee0d39afbe071d32778da4d99984081f7f5
|
PKG_HASH:=dd5e34486f1a483ff7be7300cc16b4d6b24690987877c3278d797534d6738f02
|
||||||
|
|
||||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||||
PKG_LICENSE:=GPL-2.0+
|
PKG_LICENSE:=GPL-2.0+
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -345,7 +345,7 @@ case "${host_os}" in
|
@@ -368,7 +368,7 @@ case "${host_os}" in
|
||||||
# Ok, this is linux. Check the kernel version
|
# Ok, this is linux. Check the kernel version
|
||||||
AC_MSG_CHECKING([for the kernel version])
|
AC_MSG_CHECKING([for the kernel version])
|
||||||
|
|
||||||
|
@ -6,7 +6,7 @@ Last-Update: 2013-11-30
|
|||||||
|
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -252,7 +252,7 @@ case "${host_cpu}" in
|
@@ -275,7 +275,7 @@ case "${host_cpu}" in
|
||||||
ARCH_MAX="s390x"
|
ARCH_MAX="s390x"
|
||||||
;;
|
;;
|
||||||
|
|
||||||
|
@ -48,7 +48,7 @@ This fixes the following error message when compiling with a GCC 10 MIPS BE 32:
|
|||||||
|
|
||||||
--- a/coregrind/m_machine.c
|
--- a/coregrind/m_machine.c
|
||||||
+++ b/coregrind/m_machine.c
|
+++ b/coregrind/m_machine.c
|
||||||
@@ -2103,6 +2103,7 @@ Bool VG_(machine_get_hwcaps)( void )
|
@@ -2106,6 +2106,7 @@ Bool VG_(machine_get_hwcaps)( void )
|
||||||
we are using alternative way to determine FP mode */
|
we are using alternative way to determine FP mode */
|
||||||
ULong result = 0;
|
ULong result = 0;
|
||||||
|
|
||||||
@ -56,7 +56,7 @@ This fixes the following error message when compiling with a GCC 10 MIPS BE 32:
|
|||||||
if (!VG_MINIMAL_SETJMP(env_unsup_insn)) {
|
if (!VG_MINIMAL_SETJMP(env_unsup_insn)) {
|
||||||
__asm__ volatile (
|
__asm__ volatile (
|
||||||
".set push\n\t"
|
".set push\n\t"
|
||||||
@@ -2120,6 +2121,9 @@ Bool VG_(machine_get_hwcaps)( void )
|
@@ -2123,6 +2124,9 @@ Bool VG_(machine_get_hwcaps)( void )
|
||||||
|
|
||||||
fpmode = (result != 0x3FF0000000000000ull);
|
fpmode = (result != 0x3FF0000000000000ull);
|
||||||
}
|
}
|
||||||
|
Loading…
Reference in New Issue
Block a user