openssl: update to 1.0.2m

don't set no-ssl3-method when CONFIG_OPENSSL_WITH_SSL3 di disabled otherwise the compile breaks with this error:

../libssl.so: undefined reference to `SSLv3_client_method'

Fixes CVE: CVE-2017-3735, CVE-2017-3736

Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
Peter Wagner 2017-11-10 00:35:35 +01:00 committed by Alexander Couzens
parent 421754191d
commit cda8ec7dd8
No known key found for this signature in database
GPG Key ID: C29E9DA6A0DF8604
2 changed files with 4 additions and 4 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl PKG_NAME:=openssl
PKG_BASE:=1.0.2 PKG_BASE:=1.0.2
PKG_BUGFIX:=k PKG_BUGFIX:=m
PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX) PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_USE_MIPS16:=0 PKG_USE_MIPS16:=0
@ -23,7 +23,7 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
http://www.openssl.org/source/old/$(PKG_BASE)/ \ http://www.openssl.org/source/old/$(PKG_BASE)/ \
ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \ ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/ ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
PKG_HASH:=6b3977c61f2aedf0f96367dcfb5c6e578cf37e7b8d913b4ecb6643c3cb88d8c0 PKG_HASH:=8c6ff15ec6b319b50788f42c7abc2890c08ba5a1cdcd3810eb9092deada37b0f
PKG_LICENSE:=OpenSSL PKG_LICENSE:=OpenSSL
PKG_LICENSE_FILES:=LICENSE PKG_LICENSE_FILES:=LICENSE
@ -120,7 +120,7 @@ ifndef CONFIG_OPENSSL_WITH_EC2M
endif endif
ifndef CONFIG_OPENSSL_WITH_SSL3 ifndef CONFIG_OPENSSL_WITH_SSL3
OPENSSL_OPTIONS += no-ssl3 no-ssl3-method OPENSSL_OPTIONS += no-ssl3
endif endif
ifndef CONFIG_OPENSSL_HARDWARE_SUPPORT ifndef CONFIG_OPENSSL_HARDWARE_SUPPORT

View File

@ -1,6 +1,6 @@
--- a/Configure --- a/Configure
+++ b/Configure +++ b/Configure
@@ -2128,6 +2128,11 @@ EOF @@ -2130,6 +2130,11 @@ EOF
close(OUT); close(OUT);
} }