From cc7ba0e90eff499ad8223254280ca7a1df65979e Mon Sep 17 00:00:00 2001
From: Thomas Nixon <tom@tomn.co.uk>
Date: Sat, 9 Jan 2021 22:04:48 +0000
Subject: [PATCH] tools/ccache: find libzstd using rpath

Previously, ccache would end up using the system libzstd, which is not
supposed to be a build requirement.

Signed-off-by: Thomas Nixon <tom@tomn.co.uk>
Signed-off-by: maurerr <mariusd84@gmail.com>
---
 tools/ccache/Makefile | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index e016e0beb3b..ff0204ae19e 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -21,7 +21,10 @@ include $(INCLUDE_DIR)/cmake.mk
 
 CMAKE_HOST_OPTIONS += \
 	-DCMAKE_C_COMPILER_LAUNCHER="" \
-	-DCMAKE_CXX_COMPILER_LAUNCHER=""
+	-DCMAKE_CXX_COMPILER_LAUNCHER="" \
+	-DCMAKE_SKIP_RPATH=FALSE \
+	-DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+
 
 define Host/Install/ccache
 	$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/