From c1e0f99ef8066b4a5032409b7e81516fed166008 Mon Sep 17 00:00:00 2001
From: Paul Spooren <mail@aparcar.org>
Date: Mon, 20 May 2024 18:08:28 +0300
Subject: [PATCH] apk: disable rootfs repositories during build

Since we set the root for APK it tries to use those during the build,
which shouldn't happen since local package are used instead.

Disable the repositories by manually setting an empty repository.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 include/rootfs.mk | 1 +
 1 file changed, 1 insertion(+)

diff --git a/include/rootfs.mk b/include/rootfs.mk
index c2a32fa102d..9fb7d8cfdfe 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -47,6 +47,7 @@ apk = \
   IPKG_INSTROOT=$(1) \
   $(FAKEROOT) $(STAGING_DIR_HOST)/bin/apk \
 	--root $(1) \
+	--repositories-file /dev/zero \
 	--keys-dir $(TOPDIR) \
 	--no-cache \
 	--no-logfile \