mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-21 01:41:41 +00:00
ccache: update to 4.6.3
Release Notes: https://ccache.dev/releasenotes.html#_ccache_4_6_3 Refresh patch: - 100-honour-copts.patch Signed-off-by: Nick Hainke <vincent@systemli.org> (cherry picked from commit 83ea2e11b4b7872642bc7ac587361ccd783308f2)
This commit is contained in:
parent
80653f0c07
commit
c1ccae54ce
@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
PKG_NAME:=ccache
|
||||
PKG_VERSION:=4.6.2
|
||||
PKG_VERSION:=4.6.3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
|
||||
PKG_HASH:=789a2435d7fde2eaef5ec7b3ecf2366e546f764253e9999fdf008d2dd7f3b10c
|
||||
PKG_HASH:=1e3a251bb112632553b8255a78661fe526c3a16598496d51128c32b218fd8b22
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/src/ccache.cpp
|
||||
+++ b/src/ccache.cpp
|
||||
@@ -1750,6 +1750,7 @@ calculate_result_and_manifest_key(Contex
|
||||
@@ -1756,6 +1756,7 @@ calculate_result_and_manifest_key(Contex
|
||||
"CPLUS_INCLUDE_PATH",
|
||||
"OBJC_INCLUDE_PATH",
|
||||
"OBJCPLUS_INCLUDE_PATH", // clang
|
||||
|
@ -1,32 +0,0 @@
|
||||
From a69bdc87d7a4a7b019c4086cb007a0b48a007f4a Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Thu, 25 Aug 2022 12:36:18 -0700
|
||||
Subject: [PATCH] fix: Fix build with musl when using GCC 12 (#1145)
|
||||
|
||||
(cherry picked from commit bb72cc26bc91bc56567dbef608088a9437f836bb)
|
||||
---
|
||||
src/Config.hpp | 2 ++
|
||||
src/core/Statistics.hpp | 1 +
|
||||
2 files changed, 3 insertions(+)
|
||||
|
||||
--- a/src/Config.hpp
|
||||
+++ b/src/Config.hpp
|
||||
@@ -25,6 +25,8 @@
|
||||
|
||||
#include "third_party/nonstd/optional.hpp"
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#include <cstdint>
|
||||
#include <functional>
|
||||
#include <limits>
|
||||
--- a/src/core/Statistics.hpp
|
||||
+++ b/src/core/Statistics.hpp
|
||||
@@ -22,6 +22,7 @@
|
||||
|
||||
#include <cstdint>
|
||||
#include <string>
|
||||
+#include <ctime>
|
||||
#include <unordered_map>
|
||||
#include <vector>
|
||||
|
Loading…
x
Reference in New Issue
Block a user