mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-01 00:45:28 +00:00
tools/pkgconf: update to 1.7.3
Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
b1952dc259
commit
c0e6b785f0
@ -7,11 +7,11 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=pkgconf
|
PKG_NAME:=pkgconf
|
||||||
PKG_VERSION:=1.6.3
|
PKG_VERSION:=1.7.3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://distfiles.dereferenced.org/pkgconf
|
PKG_SOURCE_URL:=https://distfiles.dereferenced.org/pkgconf
|
||||||
PKG_HASH:=61f0b31b0d5ea0e862b454a80c170f57bad47879c0c42bd8de89200ff62ea210
|
PKG_HASH:=b846aea51cf696c3392a0ae58bef93e2e72f8e7073ca6ad1ed8b01c85871f9c0
|
||||||
|
|
||||||
HOST_BUILD_PARALLEL:=1
|
HOST_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
From 62bbd3b664d4b03011a4b382ed20353a91c30406 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ariadne Conill <ariadne@dereferenced.org>
|
|
||||||
Date: Tue, 21 Jan 2020 10:32:36 -0600
|
|
||||||
Subject: [PATCH] cli: remove --version to --modversion remapping
|
|
||||||
|
|
||||||
This has been a source of frequent complaints, so we drop it.
|
|
||||||
Resolves: https://todo.sr.ht/~kaniini/pkgconf/6
|
|
||||||
---
|
|
||||||
cli/main.c | 14 ++------------
|
|
||||||
1 file changed, 2 insertions(+), 12 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/cli/main.c b/cli/main.c
|
|
||||||
index 563ec8f0cfcd..fc698a4f9191 100644
|
|
||||||
--- a/cli/main.c
|
|
||||||
+++ b/cli/main.c
|
|
||||||
@@ -1005,18 +1005,8 @@ main(int argc, char *argv[])
|
|
||||||
|
|
||||||
if ((want_flags & PKG_VERSION) == PKG_VERSION)
|
|
||||||
{
|
|
||||||
- if (argc > 2)
|
|
||||||
- {
|
|
||||||
- fprintf(stderr, "%s: --version specified with other options or module names, assuming --modversion.\n", argv[0]);
|
|
||||||
-
|
|
||||||
- want_flags &= ~PKG_VERSION;
|
|
||||||
- want_flags |= PKG_MODVERSION;
|
|
||||||
- }
|
|
||||||
- else
|
|
||||||
- {
|
|
||||||
- version();
|
|
||||||
- return EXIT_SUCCESS;
|
|
||||||
- }
|
|
||||||
+ version();
|
|
||||||
+ return EXIT_SUCCESS;
|
|
||||||
}
|
|
||||||
|
|
||||||
if ((want_flags & PKG_HELP) == PKG_HELP)
|
|
Loading…
x
Reference in New Issue
Block a user