From c00198216acadd88560baacbd30987e9392fe943 Mon Sep 17 00:00:00 2001
From: Zoltan Herpai <wigyori@uid0.hu>
Date: Fri, 21 Aug 2015 10:08:07 +0000
Subject: [PATCH] sunxi: reorganize kmod-ata-sunxi dependencies

Signed-off-by: Daniel Golle <daniel@makrotopia.org>

SVN-Revision: 46702
---
 target/linux/sunxi/modules.mk | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index a4c71b9b864..0981fe553fa 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -61,10 +61,8 @@ $(eval $(call KernelPackage,eeprom-sunxi))
 define KernelPackage/ata-sunxi
     TITLE:=AllWinner sunXi AHCI SATA support
     SUBMENU:=$(BLOCK_MENU)
-    DEPENDS:=@TARGET_sunxi +kmod-scsi-core
-    KCONFIG:=\
-	CONFIG_AHCI_SUNXI \
-	CONFIG_SATA_AHCI_PLATFORM
+    DEPENDS:=@TARGET_sunxi +kmod-ata-ahci-platform +kmod-scsi-core
+    KCONFIG:=CONFIG_AHCI_SUNXI
     FILES:=$(LINUX_DIR)/drivers/ata/ahci_sunxi.ko
     AUTOLOAD:=$(call AutoLoad,41,ahci_sunxi,1)
 endef