mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-18 21:28:02 +00:00
ucode: update to latest HEAD
b0b5d93 Merge pull request #234 from IdWV/fs 60e7a88 Merge pull request #232 from sebastianertz/lib-digest 1752779 digest: implement compile time option to exclude less common algorithms c7268a1 ci: include libmd in MacOS CI builds fcb6f70 lib: introduce digest library 1323a27 Merge pull request #246 from jow-/fix-upvalue-resolve ed5ce8f types: resolve upvalue values in arrays and objects a6e0641 vm: resolve upvalues before pushing them onto the stack ef1baab ci: drop OpenWrt tests for now 63e18ea fs: eliminate the usage of global variables b1bd7b5 types: add ucv_resource_create() helper 3408edf Merge pull request #244 from nbd168/nl80211 8af77e7 nl80211: add new attributes for multi-radio support 1423ad7 nl80211: cover extended feature and EHT rate info attributes ee1d6d8 Merge pull request #237 from sebastianertz/math 4b18a9b Merge pull request #213 from jow-/improve-vector-macros 1f022c0 math: removed global variable for thread safety e5fe6b1 treewide: refactor vector usage code 20307ee utils: improve vector utilities aa18952 Merge pull request #241 from jow-/socket-local-fanout-decl 79ccd9c socket: provide local definition of `struct fanout_args` 402280d Merge pull request #239 from jow-/safe-insert-during-obj-iteration 07afe96 Merge pull request #240 from jow-/stricter-number-conversion 736d450 types: fix potential use after free on adding keys during iteration 4134e71 vallist: more thoroughly check for trailing garbage after numeric string 9cf53dd Merge pull request #226 from jow-/lexer-improvements 2b2e732 lexer: make api functions public 855854f lexer: emit comment and template statement block tokens 328a50f lexer: improve token position reporting fa22732 Merge pull request #225 from jow-/compiler-fix-keyword-property-labels-after-spread 6e88c62 Merge pull request #224 from jow-/lib-fs-readline-leak 94d1211 compiler: properly treat property names after spread expressions 67cd123 fs: fix potential memory leak on i/o errors in .read() Signed-off-by: John Crispin <john@phrozen.org>
This commit is contained in:
parent
304fd40592
commit
ba9cdbeea8
@ -8,17 +8,18 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ucode
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL=https://github.com/jow-/ucode.git
|
||||
PKG_SOURCE_DATE:=2024-07-22
|
||||
PKG_SOURCE_VERSION:=b610860dd4a0591ff586dd71a50f556a0ddafced
|
||||
PKG_MIRROR_HASH:=a5ec51dd989174422d3b19b022ff4f863d57eb559c9f08d54c0d10651f598357
|
||||
PKG_SOURCE_DATE:=2024-12-02
|
||||
PKG_SOURCE_VERSION:=b0b5d93846a1fb9d1d94992d5fdf508ef345e87d
|
||||
PKG_MIRROR_HASH:=b43fcb38a85469552d5fb641ade271c346634a52c3628155d3215953ff2c25e1
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
||||
PKG_LICENSE:=ISC
|
||||
|
||||
PKG_ABI_VERSION:=20230711
|
||||
PKG_BUILD_DEPENDS:=libmd
|
||||
HOST_BUILD_DEPENDS:=libjson-c/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
@ -51,7 +52,8 @@ CMAKE_HOST_OPTIONS += \
|
||||
-DUCI_SUPPORT=OFF \
|
||||
-DULOOP_SUPPORT=OFF \
|
||||
-DDEBUG_SUPPORT=ON \
|
||||
-DLOG_SUPPORT=OFF
|
||||
-DLOG_SUPPORT=OFF \
|
||||
-DDIGEST_SUPPORT=OFF
|
||||
|
||||
|
||||
define Package/ucode/default
|
||||
@ -178,6 +180,10 @@ $(eval $(call UcodeModule, \
|
||||
uloop, ULOOP_SUPPORT, +libubox, \
|
||||
The uloop module allows ucode scripts to interact with OpenWrt uloop event loop implementation.))
|
||||
|
||||
$(eval $(call UcodeModule, \
|
||||
digest, DIGEST_SUPPORT, , \
|
||||
The digest module allows ucode scripts to use libmd digests.))
|
||||
|
||||
$(eval $(call BuildPackage,libucode))
|
||||
$(eval $(call BuildPackage,ucode))
|
||||
|
||||
|
@ -1,40 +0,0 @@
|
||||
--- a/include/linux/nl80211.h
|
||||
+++ b/include/linux/nl80211.h
|
||||
@@ -2868,6 +2868,9 @@ enum nl80211_commands {
|
||||
* nested item, it contains attributes defined in
|
||||
* &enum nl80211_if_combination_attrs.
|
||||
*
|
||||
+ * @NL80211_ATTR_VIF_RADIO_MASK: Bitmask of allowed radios (u32).
|
||||
+ * A value of 0 means all radios.
|
||||
+ *
|
||||
* @NUM_NL80211_ATTR: total number of nl80211_attrs available
|
||||
* @NL80211_ATTR_MAX: highest attribute number currently defined
|
||||
* @__NL80211_ATTR_AFTER_LAST: internal use
|
||||
@@ -3416,6 +3419,8 @@ enum nl80211_attrs {
|
||||
NL80211_ATTR_WIPHY_RADIOS,
|
||||
NL80211_ATTR_WIPHY_INTERFACE_COMBINATIONS,
|
||||
|
||||
+ NL80211_ATTR_VIF_RADIO_MASK,
|
||||
+
|
||||
/* add attributes here, update the policy in nl80211.c */
|
||||
|
||||
__NL80211_ATTR_AFTER_LAST,
|
||||
--- a/lib/nl80211.c
|
||||
+++ b/lib/nl80211.c
|
||||
@@ -829,7 +829,7 @@ static const uc_nl_nested_spec_t nl80211
|
||||
|
||||
static const uc_nl_nested_spec_t nl80211_msg = {
|
||||
.headsize = 0,
|
||||
- .nattrs = 128,
|
||||
+ .nattrs = 129,
|
||||
.attrs = {
|
||||
{ NL80211_ATTR_4ADDR, "4addr", DT_U8, 0, NULL },
|
||||
{ NL80211_ATTR_AIRTIME_WEIGHT, "airtime_weight", DT_U16, 0, NULL },
|
||||
@@ -959,6 +959,7 @@ static const uc_nl_nested_spec_t nl80211
|
||||
{ NL80211_ATTR_MAX_AP_ASSOC_STA, "max_ap_assoc", DT_U16, 0, NULL },
|
||||
{ NL80211_ATTR_SURVEY_INFO, "survey_info", DT_NESTED, 0, &nl80211_survey_info_nla },
|
||||
{ NL80211_ATTR_WIPHY_RADIOS, "radios", DT_NESTED, DF_MULTIPLE|DF_AUTOIDX, &nl80211_wiphy_radio_nla },
|
||||
+ { NL80211_ATTR_VIF_RADIO_MASK, "vif_radio_mask", DT_U32, 0, NULL },
|
||||
}
|
||||
};
|
||||
|
Loading…
Reference in New Issue
Block a user