mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-20 03:36:29 +00:00
kernel: bump 4.14 to 4.14.129
Refreshed all patches. Compile-tested on: cns3xxx Runtime-tested on: cns3xxx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
parent
69b988c994
commit
b8fc9c1580
@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
|
||||
endif
|
||||
|
||||
LINUX_VERSION-4.9 = .180
|
||||
LINUX_VERSION-4.14 = .128
|
||||
LINUX_VERSION-4.14 = .129
|
||||
LINUX_VERSION-4.19 = .48
|
||||
|
||||
LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
|
||||
LINUX_KERNEL_HASH-4.14.128 = e93c2c754f1f9c610314b2fe9f27a9636ad3a7f43983469bb8e0f44a531f2913
|
||||
LINUX_KERNEL_HASH-4.14.129 = 7548482b03aea1784e728e4d29fe75a2abc61c9dbf9851ec925a7fbecf9336e4
|
||||
LINUX_KERNEL_HASH-4.19.48 = 01d0db4f10cc8e384241a605e29413e32c442aa6853c116877538b07c16893fa
|
||||
|
||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/gpio/Kconfig
|
||||
+++ b/drivers/gpio/Kconfig
|
||||
@@ -1298,4 +1298,12 @@ config GPIO_VIPERBOARD
|
||||
@@ -1299,4 +1299,12 @@ config GPIO_VIPERBOARD
|
||||
|
||||
endmenu
|
||||
|
||||
|
@ -109,7 +109,7 @@
|
||||
+#endif
|
||||
--- a/drivers/gpio/Kconfig
|
||||
+++ b/drivers/gpio/Kconfig
|
||||
@@ -1250,7 +1250,6 @@ menu "SPI GPIO expanders"
|
||||
@@ -1251,7 +1251,6 @@ menu "SPI GPIO expanders"
|
||||
|
||||
config GPIO_74X164
|
||||
tristate "74x164 serial-in/parallel-out 8-bits shift register"
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/gpio/Kconfig
|
||||
+++ b/drivers/gpio/Kconfig
|
||||
@@ -1305,4 +1305,9 @@ config GPIO_NXP_74HC153
|
||||
@@ -1306,4 +1306,9 @@ config GPIO_NXP_74HC153
|
||||
Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
|
||||
provides a GPIO interface supporting input mode only.
|
||||
|
||||
|
@ -159,7 +159,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
||||
net->nf.proc_netfilter = proc_net_mkdir(net, "netfilter",
|
||||
--- a/net/netfilter/nf_queue.c
|
||||
+++ b/net/netfilter/nf_queue.c
|
||||
@@ -201,6 +201,23 @@ repeat:
|
||||
@@ -202,6 +202,23 @@ repeat:
|
||||
return NF_ACCEPT;
|
||||
}
|
||||
|
||||
@ -183,7 +183,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
||||
/* Caller must hold rcu read-side lock */
|
||||
void nf_reinject(struct nf_queue_entry *entry, unsigned int verdict)
|
||||
{
|
||||
@@ -216,12 +233,12 @@ void nf_reinject(struct nf_queue_entry *
|
||||
@@ -217,12 +234,12 @@ void nf_reinject(struct nf_queue_entry *
|
||||
net = entry->state.net;
|
||||
pf = entry->state.pf;
|
||||
|
||||
|
@ -152,7 +152,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
||||
#endif
|
||||
--- a/net/netfilter/nf_queue.c
|
||||
+++ b/net/netfilter/nf_queue.c
|
||||
@@ -204,8 +204,10 @@ repeat:
|
||||
@@ -205,8 +205,10 @@ repeat:
|
||||
static struct nf_hook_entries *nf_hook_entries_head(const struct net *net, u8 pf, u8 hooknum)
|
||||
{
|
||||
switch (pf) {
|
||||
|
@ -171,7 +171,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
||||
|
||||
--- a/net/netfilter/nf_queue.c
|
||||
+++ b/net/netfilter/nf_queue.c
|
||||
@@ -266,7 +266,6 @@ void nf_reinject(struct nf_queue_entry *
|
||||
@@ -267,7 +267,6 @@ void nf_reinject(struct nf_queue_entry *
|
||||
const struct nf_hook_entry *hook_entry;
|
||||
const struct nf_hook_entries *hooks;
|
||||
struct sk_buff *skb = entry->skb;
|
||||
@ -179,7 +179,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
||||
const struct net *net;
|
||||
unsigned int i;
|
||||
int err;
|
||||
@@ -293,8 +292,7 @@ void nf_reinject(struct nf_queue_entry *
|
||||
@@ -294,8 +293,7 @@ void nf_reinject(struct nf_queue_entry *
|
||||
verdict = nf_hook_entry_hookfn(hook_entry, skb, &entry->state);
|
||||
|
||||
if (verdict == NF_ACCEPT) {
|
||||
|
@ -55,9 +55,6 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
||||
create mode 100644 include/uapi/linux/tc_act/tc_ctinfo.h
|
||||
create mode 100644 net/sched/act_ctinfo.c
|
||||
|
||||
diff --git a/include/net/tc_act/tc_ctinfo.h b/include/net/tc_act/tc_ctinfo.h
|
||||
new file mode 100644
|
||||
index 000000000000..f071c1d70a25
|
||||
--- /dev/null
|
||||
+++ b/include/net/tc_act/tc_ctinfo.h
|
||||
@@ -0,0 +1,33 @@
|
||||
@ -94,8 +91,6 @@ index 000000000000..f071c1d70a25
|
||||
+#define to_ctinfo(a) ((struct tcf_ctinfo *)a)
|
||||
+
|
||||
+#endif /* __NET_TC_CTINFO_H */
|
||||
diff --git a/include/uapi/linux/pkt_cls.h b/include/uapi/linux/pkt_cls.h
|
||||
index 46c506615f4a..408b02fbb34a 100644
|
||||
--- a/include/uapi/linux/pkt_cls.h
|
||||
+++ b/include/uapi/linux/pkt_cls.h
|
||||
@@ -66,7 +66,8 @@ enum {
|
||||
@ -108,9 +103,6 @@ index 46c506615f4a..408b02fbb34a 100644
|
||||
};
|
||||
|
||||
#define TCA_ID_MAX __TCA_ID_MAX
|
||||
diff --git a/include/uapi/linux/tc_act/tc_ctinfo.h b/include/uapi/linux/tc_act/tc_ctinfo.h
|
||||
new file mode 100644
|
||||
index 000000000000..f5f26d95d0e7
|
||||
--- /dev/null
|
||||
+++ b/include/uapi/linux/tc_act/tc_ctinfo.h
|
||||
@@ -0,0 +1,29 @@
|
||||
@ -143,8 +135,6 @@ index 000000000000..f5f26d95d0e7
|
||||
+#define TCA_CTINFO_MAX (__TCA_CTINFO_MAX - 1)
|
||||
+
|
||||
+#endif
|
||||
diff --git a/net/sched/Kconfig b/net/sched/Kconfig
|
||||
index e70ed26485a2..962d90f72f54 100644
|
||||
--- a/net/sched/Kconfig
|
||||
+++ b/net/sched/Kconfig
|
||||
@@ -808,6 +808,19 @@ config NET_ACT_CONNMARK
|
||||
@ -167,8 +157,6 @@ index e70ed26485a2..962d90f72f54 100644
|
||||
config NET_ACT_SKBMOD
|
||||
tristate "skb data modification action"
|
||||
depends on NET_CLS_ACT
|
||||
diff --git a/net/sched/Makefile b/net/sched/Makefile
|
||||
index 9e43a4721ef8..44ee5b87b895 100644
|
||||
--- a/net/sched/Makefile
|
||||
+++ b/net/sched/Makefile
|
||||
@@ -21,6 +21,7 @@ obj-$(CONFIG_NET_ACT_CSUM) += act_csum.o
|
||||
@ -179,9 +167,6 @@ index 9e43a4721ef8..44ee5b87b895 100644
|
||||
obj-$(CONFIG_NET_ACT_SKBMOD) += act_skbmod.o
|
||||
obj-$(CONFIG_NET_ACT_IFE) += act_ife.o
|
||||
obj-$(CONFIG_NET_IFE_SKBMARK) += act_meta_mark.o
|
||||
diff --git a/net/sched/act_ctinfo.c b/net/sched/act_ctinfo.c
|
||||
new file mode 100644
|
||||
index 000000000000..e65344e32801
|
||||
--- /dev/null
|
||||
+++ b/net/sched/act_ctinfo.c
|
||||
@@ -0,0 +1,394 @@
|
||||
@ -579,6 +564,3 @@ index 000000000000..e65344e32801
|
||||
+MODULE_AUTHOR("Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>");
|
||||
+MODULE_DESCRIPTION("Conntrack mark to DSCP restoring");
|
||||
+MODULE_LICENSE("GPL");
|
||||
--
|
||||
2.20.1 (Apple Git-117)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user