mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
dropbear: honor CONFIG_TARGET_INIT_PATH
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 48679
This commit is contained in:
parent
cc289e0adb
commit
b78aae793e
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=dropbear
|
PKG_NAME:=dropbear
|
||||||
PKG_VERSION:=2015.71
|
PKG_VERSION:=2015.71
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
@ -23,10 +23,14 @@ PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
|
|||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_USE_MIPS16:=0
|
PKG_USE_MIPS16:=0
|
||||||
|
|
||||||
PKG_CONFIG_DEPENDS:=CONFIG_DROPBEAR_ECC CONFIG_DROPBEAR_CURVE25519
|
PKG_CONFIG_DEPENDS:=CONFIG_TARGET_INIT_PATH CONFIG_DROPBEAR_ECC CONFIG_DROPBEAR_CURVE25519
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
ifneq ($(DUMP),1)
|
||||||
|
STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) echo $(CONFIG_TARGET_INIT_PATH) | md5s)
|
||||||
|
endif
|
||||||
|
|
||||||
define Package/dropbear/Default
|
define Package/dropbear/Default
|
||||||
URL:=http://matt.ucc.asn.au/dropbear/
|
URL:=http://matt.ucc.asn.au/dropbear/
|
||||||
endef
|
endef
|
||||||
@ -74,12 +78,15 @@ CONFIGURE_ARGS += \
|
|||||||
--disable-zlib \
|
--disable-zlib \
|
||||||
--enable-bundled-libtom
|
--enable-bundled-libtom
|
||||||
|
|
||||||
TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
|
TARGET_CFLAGS += -DDEFAULT_PATH=\\\"$(TARGET_INIT_PATH)\\\" -DARGTYPE=3 -ffunction-sections -fdata-sections
|
||||||
TARGET_LDFLAGS += -Wl,--gc-sections
|
TARGET_LDFLAGS += -Wl,--gc-sections
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
$(Build/Configure/Default)
|
$(Build/Configure/Default)
|
||||||
|
|
||||||
|
$(SED) 's,^#define DEFAULT_PATH .*$$$$,#define DEFAULT_PATH "$(TARGET_INIT_PATH)",g' \
|
||||||
|
$(PKG_BUILD_DIR)/options.h
|
||||||
|
|
||||||
awk 'BEGIN { rc = 1 } \
|
awk 'BEGIN { rc = 1 } \
|
||||||
/'DROPBEAR_CURVE25519'/ { $$$$0 = "$(if $(CONFIG_DROPBEAR_CURVE25519),,// )#define 'DROPBEAR_CURVE25519'"; rc = 0 } \
|
/'DROPBEAR_CURVE25519'/ { $$$$0 = "$(if $(CONFIG_DROPBEAR_CURVE25519),,// )#define 'DROPBEAR_CURVE25519'"; rc = 0 } \
|
||||||
{ print } \
|
{ print } \
|
||||||
@ -97,6 +104,9 @@ define Build/Configure
|
|||||||
>$(PKG_BUILD_DIR)/options.h.new && \
|
>$(PKG_BUILD_DIR)/options.h.new && \
|
||||||
mv $(PKG_BUILD_DIR)/options.h.new $(PKG_BUILD_DIR)/options.h || exit 1; \
|
mv $(PKG_BUILD_DIR)/options.h.new $(PKG_BUILD_DIR)/options.h || exit 1; \
|
||||||
done
|
done
|
||||||
|
|
||||||
|
# Enforce rebuild of svr-chansession.c
|
||||||
|
rm -f $(PKG_BUILD_DIR)/svr-chansession.o
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
|
@ -1,11 +1,12 @@
|
|||||||
--- a/options.h
|
--- a/options.h
|
||||||
+++ b/options.h
|
+++ b/options.h
|
||||||
@@ -347,7 +347,7 @@ be overridden at runtime with -I. 0 disa
|
@@ -347,7 +347,9 @@ be overridden at runtime with -I. 0 disa
|
||||||
#define DEFAULT_IDLE_TIMEOUT 0
|
#define DEFAULT_IDLE_TIMEOUT 0
|
||||||
|
|
||||||
/* The default path. This will often get replaced by the shell */
|
/* The default path. This will often get replaced by the shell */
|
||||||
-#define DEFAULT_PATH "/usr/bin:/bin"
|
+#ifndef DEFAULT_PATH
|
||||||
+#define DEFAULT_PATH "/bin:/sbin:/usr/bin:/usr/sbin"
|
#define DEFAULT_PATH "/usr/bin:/bin"
|
||||||
|
+#endif
|
||||||
|
|
||||||
/* Some other defines (that mostly should be left alone) are defined
|
/* Some other defines (that mostly should be left alone) are defined
|
||||||
* in sysoptions.h */
|
* in sysoptions.h */
|
||||||
|
Loading…
Reference in New Issue
Block a user