firmware-utils: move patch to maintaince branch

Patch "firmware-utils: ptgen: add SiFive GPT partition support" was
included as a separate change in 23.05. Now that we have a maintenance
branch for firmware-utils, the patch can be backported there and
included with other changes.

Signed-off-by: Sander Vanheule <sander@svanheule.net>
This commit is contained in:
Sander Vanheule 2024-01-07 12:54:06 +01:00
parent 34e30fb53a
commit b54f7105df
2 changed files with 2 additions and 40 deletions

View File

@ -12,8 +12,8 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/firmware-utils.git
PKG_SOURCE_DATE:=2024-01-07
PKG_SOURCE_VERSION:=9afd8f42bd2390ae95b30e756d310820393811ef
PKG_MIRROR_HASH:=ae30305d09f7e8d73d9004bb186f8e5e54055b26ce52cebb8d54beef71c93733
PKG_SOURCE_VERSION:=40da9034bb4926ef04ec95c3fd38d850aed68142
PKG_MIRROR_HASH:=ee1694d4cddba32e32fcba85aeeaed6c5524e06ed29fca9d56cc466097aaa6f9
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk

View File

@ -1,38 +0,0 @@
diff -ruN firmware-utils-2022-02-28-002cfaf0.old/src/ptgen.c firmware-utils-2022-02-28-002cfaf0/src/ptgen.c
--- firmware-utils-2022-02-28-002cfaf0.old/src/ptgen.c 2022-04-23 19:02:07.307896842 +0200
+++ firmware-utils-2022-02-28-002cfaf0/src/ptgen.c 2022-04-22 18:48:54.477970950 +0200
@@ -82,6 +82,14 @@
GUID_INIT( 0x0fc63daf, 0x8483, 0x4772, \
0x8e, 0x79, 0x3d, 0x69, 0xd8, 0x47, 0x7d, 0xe4)
+#define GUID_PARTITION_SIFIVE_SPL \
+ GUID_INIT( 0x5b193300, 0xfc78, 0x40cd, \
+ 0x80, 0x02, 0xe8, 0x6c, 0x45, 0x58, 0x0b, 0x47)
+
+#define GUID_PARTITION_SIFIVE_UBOOT \
+ GUID_INIT( 0x2e54b353, 0x1271, 0x4842, \
+ 0x80, 0x6f, 0xe4, 0x36, 0xd6, 0xaf, 0x69, 0x85)
+
#define GPT_HEADER_SIZE 92
#define GPT_ENTRY_SIZE 128
#define GPT_ENTRY_MAX 128
@@ -276,6 +284,19 @@
(1ULL << 56); /* success=1 */
return true;
}
+
+ if (!strcmp(type, "sifiveu_spl")) {
+ part->has_guid = true;
+ part->guid = GUID_PARTITION_SIFIVE_SPL;
+ return true;
+ }
+
+ if (!strcmp(type, "sifiveu_uboot")) {
+ part->has_guid = true;
+ part->guid = GUID_PARTITION_SIFIVE_UBOOT;
+ return true;
+ }
+
return false;
}