realtek: 6.6: refresh patch net-phy-add-an-MDIO-SMBus-library

No content changes. Two hooks had to be adapted to take over the
new patch locations.

Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de>
This commit is contained in:
Markus Stockhausen 2024-09-09 04:24:24 -04:00 committed by Sander Vanheule
parent 850d64da96
commit b13c0b57b2

View File

@ -35,10 +35,10 @@ Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
depends on ARCH_XGENE || COMPILE_TEST depends on ARCH_XGENE || COMPILE_TEST
--- a/drivers/net/mdio/Makefile --- a/drivers/net/mdio/Makefile
+++ b/drivers/net/mdio/Makefile +++ b/drivers/net/mdio/Makefile
@@ -19,6 +19,7 @@ obj-$(CONFIG_MDIO_MOXART) += mdio-moxar @@ -20,6 +20,7 @@ obj-$(CONFIG_MDIO_MSCC_MIIM) += mdio-ms
obj-$(CONFIG_MDIO_MSCC_MIIM) += mdio-mscc-miim.o
obj-$(CONFIG_MDIO_MVUSB) += mdio-mvusb.o obj-$(CONFIG_MDIO_MVUSB) += mdio-mvusb.o
obj-$(CONFIG_MDIO_OCTEON) += mdio-octeon.o obj-$(CONFIG_MDIO_OCTEON) += mdio-octeon.o
obj-$(CONFIG_MDIO_REGMAP) += mdio-regmap.o
+obj-$(CONFIG_MDIO_SMBUS) += mdio-smbus.o +obj-$(CONFIG_MDIO_SMBUS) += mdio-smbus.o
obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i.o obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i.o
obj-$(CONFIG_MDIO_THUNDER) += mdio-thunder.o obj-$(CONFIG_MDIO_THUNDER) += mdio-thunder.o
@ -110,7 +110,7 @@ Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
+MODULE_LICENSE("GPL"); +MODULE_LICENSE("GPL");
--- a/drivers/net/phy/Kconfig --- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig +++ b/drivers/net/phy/Kconfig
@@ -61,6 +61,7 @@ config SFP @@ -65,6 +65,7 @@ config SFP
depends on I2C && PHYLINK depends on I2C && PHYLINK
depends on HWMON || HWMON=n depends on HWMON || HWMON=n
select MDIO_I2C select MDIO_I2C
@ -120,10 +120,10 @@ Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
--- a/include/linux/mdio/mdio-i2c.h --- a/include/linux/mdio/mdio-i2c.h
+++ b/include/linux/mdio/mdio-i2c.h +++ b/include/linux/mdio/mdio-i2c.h
@@ -12,5 +12,8 @@ struct i2c_adapter; @@ -20,5 +20,8 @@ enum mdio_i2c_proto {
struct mii_bus;
struct mii_bus *mdio_i2c_alloc(struct device *parent, struct i2c_adapter *i2c); struct mii_bus *mdio_i2c_alloc(struct device *parent, struct i2c_adapter *i2c,
enum mdio_i2c_proto protocol);
+struct mii_bus *mdio_smbus_alloc(struct device *parent, struct i2c_adapter *i2c); +struct mii_bus *mdio_smbus_alloc(struct device *parent, struct i2c_adapter *i2c);
+bool i2c_mii_valid_phy_id(int phy_id); +bool i2c_mii_valid_phy_id(int phy_id);
+unsigned int i2c_mii_phy_addr(int phy_id); +unsigned int i2c_mii_phy_addr(int phy_id);
@ -131,7 +131,7 @@ Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
#endif #endif
--- a/drivers/net/mdio/mdio-i2c.c --- a/drivers/net/mdio/mdio-i2c.c
+++ b/drivers/net/mdio/mdio-i2c.c +++ b/drivers/net/mdio/mdio-i2c.c
@@ -18,12 +18,12 @@ @@ -20,12 +20,12 @@
* specified to be present in SFP modules. These correspond with PHY * specified to be present in SFP modules. These correspond with PHY
* addresses 16 and 17. Disallow access to these "phy" addresses. * addresses 16 and 17. Disallow access to these "phy" addresses.
*/ */