ath10k-ct: update to latest version

Changelog:
- ath10k-ct: Fix invalid use of ath-cb struct

Runtime-tested on ath79 (TP-Link Archer C7 v2) and ipq806x (Netgear R7800).

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: maurerr <mariusd84@gmail.com>
This commit is contained in:
Álvaro Fernández Rojas 2020-12-28 16:18:22 +01:00 committed by maurerr
parent 17d5bb3f70
commit b0a25ed4d7
4 changed files with 13 additions and 13 deletions

View File

@ -1,16 +1,16 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=ath10k-ct PKG_NAME:=ath10k-ct
PKG_RELEASE=3 PKG_RELEASE=1
PKG_LICENSE:=GPLv2 PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:= PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
PKG_SOURCE_PROTO:=git PKG_SOURCE_PROTO:=git
PKG_SOURCE_DATE:=2020-10-08 PKG_SOURCE_DATE:=2020-12-24
PKG_SOURCE_VERSION:=1d28d176e5b6e63a6583f497adf68e1d9c1dc962 PKG_SOURCE_VERSION:=b753e8bf22b94297acbaa370b4cb0be87e3da4b8
PKG_MIRROR_HASH:=f611762647822742f7c8f9da242e33d9bf6da0a14976b87408af28f280802ae0 PKG_MIRROR_HASH:=e026296208e0c20fd0775704c2167da5a447aef4080cedc5fba0797f0e180d8d
# Build the 5.8 ath10k-ct driver version. # Build the 5.8 ath10k-ct driver version.
# Probably this should match as closely as # Probably this should match as closely as

View File

@ -11,7 +11,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
--- a/ath10k-5.8/mac.c --- a/ath10k-5.8/mac.c
+++ b/ath10k-5.8/mac.c +++ b/ath10k-5.8/mac.c
@@ -6653,6 +6653,7 @@ static void ath10k_recalculate_mgmt_rate @@ -6691,6 +6691,7 @@ static void ath10k_recalculate_mgmt_rate
return; return;
} }
@ -19,7 +19,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
vdev_param = ar->wmi.vdev_param->mgmt_rate; vdev_param = ar->wmi.vdev_param->mgmt_rate;
ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id, vdev_param, ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id, vdev_param,
hw_rate_code); hw_rate_code);
@@ -6879,6 +6880,7 @@ static void ath10k_bss_info_changed(stru @@ -6917,6 +6918,7 @@ static void ath10k_bss_info_changed(stru
"mac vdev %d mcast_rate %x\n", "mac vdev %d mcast_rate %x\n",
arvif->vdev_id, rate); arvif->vdev_id, rate);
@ -27,7 +27,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
vdev_param = ar->wmi.vdev_param->mcast_data_rate; vdev_param = ar->wmi.vdev_param->mcast_data_rate;
ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id, ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
vdev_param, rate); vdev_param, rate);
@@ -6887,6 +6889,7 @@ static void ath10k_bss_info_changed(stru @@ -6925,6 +6927,7 @@ static void ath10k_bss_info_changed(stru
"failed to set mcast rate on vdev %i: %d\n", "failed to set mcast rate on vdev %i: %d\n",
arvif->vdev_id, ret); arvif->vdev_id, ret);

View File

@ -161,7 +161,7 @@ v13:
.patch_load_addr = QCA9888_HW_2_0_PATCH_LOAD_ADDR, .patch_load_addr = QCA9888_HW_2_0_PATCH_LOAD_ADDR,
.uart_pin = 7, .uart_pin = 7,
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH, .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
@@ -3675,6 +3681,10 @@ int ath10k_core_start(struct ath10k *ar, @@ -3688,6 +3694,10 @@ int ath10k_core_start(struct ath10k *ar,
ath10k_wmi_check_apply_board_power_ctl_table(ar); ath10k_wmi_check_apply_board_power_ctl_table(ar);
} }
@ -172,7 +172,7 @@ v13:
return 0; return 0;
err_hif_stop: err_hif_stop:
@@ -3933,9 +3943,18 @@ static void ath10k_core_register_work(st @@ -3946,9 +3956,18 @@ static void ath10k_core_register_work(st
goto err_spectral_destroy; goto err_spectral_destroy;
} }
@ -191,7 +191,7 @@ v13:
err_spectral_destroy: err_spectral_destroy:
ath10k_spectral_destroy(ar); ath10k_spectral_destroy(ar);
err_debug_destroy: err_debug_destroy:
@@ -3995,6 +4014,8 @@ void ath10k_core_unregister(struct ath10 @@ -4008,6 +4027,8 @@ void ath10k_core_unregister(struct ath10
if (!test_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags)) if (!test_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags))
return; return;
@ -210,7 +210,7 @@ v13:
#include "htt.h" #include "htt.h"
#include "htc.h" #include "htc.h"
@@ -1523,6 +1524,13 @@ struct ath10k { @@ -1530,6 +1531,13 @@ struct ath10k {
} testmode; } testmode;
struct { struct {

View File

@ -16,7 +16,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
--- a/ath10k-5.8/core.h --- a/ath10k-5.8/core.h
+++ b/ath10k-5.8/core.h +++ b/ath10k-5.8/core.h
@@ -1631,6 +1631,10 @@ struct ath10k { @@ -1638,6 +1638,10 @@ struct ath10k {
u8 csi_data[4096]; u8 csi_data[4096];
u16 csi_data_len; u16 csi_data_len;
@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
if (ret) if (ret)
--- a/ath10k-5.8/mac.c --- a/ath10k-5.8/mac.c
+++ b/ath10k-5.8/mac.c +++ b/ath10k-5.8/mac.c
@@ -10680,7 +10680,7 @@ int ath10k_mac_register(struct ath10k *a @@ -10718,7 +10718,7 @@ int ath10k_mac_register(struct ath10k *a
ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER; ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
#ifdef CPTCFG_MAC80211_LEDS #ifdef CPTCFG_MAC80211_LEDS