mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-21 09:42:09 +00:00
tools/mkimage: update to 2024.01
Update to latest version. Refresh patch: - 030-allow-to-use-different-magic.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
This commit is contained in:
parent
6fbe36a618
commit
ae7a7ef5da
@ -7,14 +7,14 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mkimage
|
PKG_NAME:=mkimage
|
||||||
PKG_VERSION:=2023.10
|
PKG_VERSION:=2024.01
|
||||||
|
|
||||||
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
https://mirror.cyberbits.eu/u-boot \
|
https://mirror.cyberbits.eu/u-boot \
|
||||||
https://ftp.denx.de/pub/u-boot \
|
https://ftp.denx.de/pub/u-boot \
|
||||||
ftp://ftp.denx.de/pub/u-boot
|
ftp://ftp.denx.de/pub/u-boot
|
||||||
PKG_HASH:=e00e6c6f014e046101739d08d06f328811cebcf5ae101348f409cbbd55ce6900
|
PKG_HASH:=b99611f1ed237bf3541bdc8434b68c96a6e05967061f992443cb30aabebef5b3
|
||||||
|
|
||||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
|
||||||
|
|
||||||
|
@ -50,7 +50,7 @@ This patch makes it possible to set a custom image magic.
|
|||||||
break;
|
break;
|
||||||
--- a/tools/default_image.c
|
--- a/tools/default_image.c
|
||||||
+++ b/tools/default_image.c
|
+++ b/tools/default_image.c
|
||||||
@@ -68,7 +68,7 @@ static int image_verify_header(unsigned
|
@@ -67,7 +67,7 @@ static int image_verify_header(unsigned
|
||||||
*/
|
*/
|
||||||
memcpy(hdr, ptr, sizeof(struct legacy_img_hdr));
|
memcpy(hdr, ptr, sizeof(struct legacy_img_hdr));
|
||||||
|
|
||||||
@ -59,7 +59,7 @@ This patch makes it possible to set a custom image magic.
|
|||||||
debug("%s: Bad Magic Number: \"%s\" is no valid image\n",
|
debug("%s: Bad Magic Number: \"%s\" is no valid image\n",
|
||||||
params->cmdname, params->imagefile);
|
params->cmdname, params->imagefile);
|
||||||
return -FDT_ERR_BADMAGIC;
|
return -FDT_ERR_BADMAGIC;
|
||||||
@@ -147,7 +147,7 @@ static void image_set_header(void *ptr,
|
@@ -146,7 +146,7 @@ static void image_set_header(void *ptr,
|
||||||
}
|
}
|
||||||
|
|
||||||
/* Build new header */
|
/* Build new header */
|
||||||
|
Loading…
x
Reference in New Issue
Block a user