mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-21 03:55:06 +00:00
uboot-mvebu: update to v2020.10-rc4
TODO: switch to release v2020.10 once released. Remove one merged patch, refresh the rest. Signed-off-by: Andre Heider <a.heider@gmail.com>
This commit is contained in:
parent
5582fbd613
commit
ae2e521b34
@ -8,10 +8,10 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_VERSION:=2019.04
|
||||
PKG_VERSION:=2020.10-rc4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_HASH:=76b7772d156b3ddd7644c8a1736081e55b78828537ff714065d21dbade229bef
|
||||
PKG_HASH:=0a7bdd2c7df2c14daf2730fcf3277fd917aadfaae935529e29c7412314bbf260
|
||||
|
||||
include $(INCLUDE_DIR)/u-boot.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -1,7 +1,7 @@
|
||||
--- a/drivers/mtd/spi/spi-nor-ids.c
|
||||
+++ b/drivers/mtd/spi/spi-nor-ids.c
|
||||
@@ -136,6 +136,7 @@ const struct flash_info spi_nor_ids[] =
|
||||
{ INFO("mx25u1635e", 0xc22535, 0, 64 * 1024, 32, SECT_4K) },
|
||||
@@ -151,6 +151,7 @@ const struct flash_info spi_nor_ids[] =
|
||||
{ INFO("mx25u3235f", 0xc22536, 0, 4 * 1024, 1024, SECT_4K) },
|
||||
{ INFO("mx25u6435f", 0xc22537, 0, 64 * 1024, 128, SECT_4K) },
|
||||
{ INFO("mx25l12805d", 0xc22018, 0, 64 * 1024, 256, 0) },
|
||||
+ { INFO("mx25u12835f", 0xc22538, 0, 64 * 1024, 256, SECT_4K) },
|
||||
|
@ -9,5 +9,5 @@ This is required in order to boot itb images.
|
||||
#define CONFIG_SYS_SDRAM_BASE 0x00000000
|
||||
+#define CONFIG_SYS_BOOTM_LEN (64 << 20) /* Increase max gunzip size */
|
||||
|
||||
#define CONFIG_NR_DRAM_BANKS 1
|
||||
/* auto boot */
|
||||
|
||||
|
@ -3,10 +3,10 @@ needed dependencies are added too.
|
||||
|
||||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -145,7 +145,7 @@ endif
|
||||
# MXSImage needs LibSSL
|
||||
ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_ARMADA_38X)$(CONFIG_ARMADA_39X)$(CONFIG_FIT_SIGNATURE),)
|
||||
HOSTLOADLIBES_mkimage += \
|
||||
@@ -158,7 +158,7 @@ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CON
|
||||
HOSTCFLAGS_kwbimage.o += \
|
||||
$(shell pkg-config --cflags libssl libcrypto 2> /dev/null || echo "")
|
||||
HOSTLDLIBS_mkimage += \
|
||||
- $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
|
||||
+ $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lpthread -lcrypto")
|
||||
|
||||
|
@ -1,43 +0,0 @@
|
||||
--- a/arch/arm/dts/armada-3720-uDPU.dts
|
||||
+++ b/arch/arm/dts/armada-3720-uDPU.dts
|
||||
@@ -109,11 +109,11 @@
|
||||
&comphy {
|
||||
phy0 {
|
||||
phy-type = <PHY_TYPE_SGMII1>;
|
||||
- phy-speed = <PHY_SPEED_1_25G>;
|
||||
+ phy-speed = <PHY_SPEED_3_125G>;
|
||||
};
|
||||
phy1 {
|
||||
phy-type = <PHY_TYPE_SGMII0>;
|
||||
- phy-speed = <PHY_SPEED_1_25G>;
|
||||
+ phy-speed = <PHY_SPEED_3_125G>;
|
||||
};
|
||||
|
||||
phy2 {
|
||||
@@ -125,22 +125,16 @@
|
||||
ð0 {
|
||||
pinctrl-0 = <&pcie_pins>;
|
||||
status = "okay";
|
||||
- phy-mode = "sgmii";
|
||||
+ phy-mode = "sgmii-2500";
|
||||
+ managed = "in-band-status";
|
||||
phy = <ðphy0>;
|
||||
- fixed-link {
|
||||
- speed = <1000>;
|
||||
- full-duplex;
|
||||
- };
|
||||
};
|
||||
|
||||
ð1 {
|
||||
status = "okay";
|
||||
- phy-mode = "sgmii";
|
||||
+ phy-mode = "sgmii-2500";
|
||||
+ managed = "in-band-status";
|
||||
phy = <ðphy1>;
|
||||
- fixed-link {
|
||||
- speed = <1000>;
|
||||
- full-duplex;
|
||||
- };
|
||||
};
|
||||
|
||||
&i2c0 {
|
Loading…
Reference in New Issue
Block a user