mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-22 10:01:03 +00:00
dnsmasq: fix ipv6 ipset bug
During upstream removal of conditional ipv6 support an order swap error was made in a ternary operator usage. This patch sent upstream. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
This commit is contained in:
parent
1ff98ddff7
commit
ad8a5aa06a
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=dnsmasq
|
PKG_NAME:=dnsmasq
|
||||||
PKG_VERSION:=2.80
|
PKG_VERSION:=2.80
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=4
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
||||||
|
@ -0,0 +1,21 @@
|
|||||||
|
From 46de5d4954b470db155098001cffc357b51e50f4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
||||||
|
Date: Wed, 12 Dec 2018 11:35:12 +0000
|
||||||
|
Subject: [PATCH] ipset fix ternary order swap
|
||||||
|
|
||||||
|
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
||||||
|
---
|
||||||
|
src/ipset.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
--- a/src/ipset.c
|
||||||
|
+++ b/src/ipset.c
|
||||||
|
@@ -120,7 +120,7 @@ static int new_add_to_ipset(const char *
|
||||||
|
struct my_nfgenmsg *nfg;
|
||||||
|
struct my_nlattr *nested[2];
|
||||||
|
uint8_t proto;
|
||||||
|
- int addrsz = (af == AF_INET6) ? INADDRSZ : IN6ADDRSZ;
|
||||||
|
+ int addrsz = (af == AF_INET6) ? IN6ADDRSZ : INADDRSZ;
|
||||||
|
|
||||||
|
if (strlen(setname) >= IPSET_MAXNAMELEN)
|
||||||
|
{
|
Loading…
x
Reference in New Issue
Block a user