From ab5540228b9bae9c677bb3f146c5181e3aab7e5b Mon Sep 17 00:00:00 2001
From: Nicolas Thill <nico@openwrt.org>
Date: Sat, 17 Jun 2006 09:43:57 +0000
Subject: [PATCH] move shfs from target/linux/package/ to package/.

SVN-Revision: 3970
---
 .../{target/linux => }/package/shfs/Makefile  | 32 ++++++++++++-------
 .../package/shfs/patches/101-kmod_build.patch |  0
 .../package/shfs/patches/102-gcc4_fix.patch   |  0
 .../package/shfs/patches/103-dentry.patch     |  0
 openwrt/target/linux/package/shfs/Config.in   | 22 -------------
 .../linux/package/shfs/ipkg/kmod-shfs.control |  4 ---
 6 files changed, 21 insertions(+), 37 deletions(-)
 rename openwrt/{target/linux => }/package/shfs/Makefile (51%)
 rename openwrt/{target/linux => }/package/shfs/patches/101-kmod_build.patch (100%)
 rename openwrt/{target/linux => }/package/shfs/patches/102-gcc4_fix.patch (100%)
 rename openwrt/{target/linux => }/package/shfs/patches/103-dentry.patch (100%)
 delete mode 100644 openwrt/target/linux/package/shfs/Config.in
 delete mode 100644 openwrt/target/linux/package/shfs/ipkg/kmod-shfs.control

diff --git a/openwrt/target/linux/package/shfs/Makefile b/openwrt/package/shfs/Makefile
similarity index 51%
rename from openwrt/target/linux/package/shfs/Makefile
rename to openwrt/package/shfs/Makefile
index 4625bdb12e1..dacbf8d75f5 100644
--- a/openwrt/target/linux/package/shfs/Makefile
+++ b/openwrt/package/shfs/Makefile
@@ -1,7 +1,7 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include ../../rules.mk
+include $(TOPDIR)/package/kernel.mk
 
 PKG_NAME:=shfs
 PKG_VERSION:=0.35
@@ -17,12 +17,21 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(TOPDIR)/package/rules.mk
 
-$(eval $(call PKG_template,KMOD_SHFS,kmod-shfs,$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))))
+define Package/kmod-shfs
+ SECTION:=drivers
+ CATEGORY:=Drivers
+ DEPENDS:=
+ TITLE:=Shell FileSystem (ShFS)
+ DESCRIPTION:=Shell FileSystem (ShFS) \\\
+ShFS is a simple and easy to use Linux kernel module which allows you to \\\
+mount remote filesystems using a plain shell (SSH) connection. When using \\\
+ShFS, you can access all remote files just like the local ones, only the \\\
+access is governed through the transport security of SSH.
+ URL:=http://shfs.sourceforge.net/
+ VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+endef
 
-$(PKG_BUILD_DIR)/.configured:
-	touch $@
-
-$(PKG_BUILD_DIR)/.built: 
+define Build/Compile
 	rm -rf $(PKG_INSTALL_DIR)
 	mkdir -p $(PKG_INSTALL_DIR)
 	$(MAKE) -C $(PKG_BUILD_DIR) \
@@ -36,11 +45,12 @@ $(PKG_BUILD_DIR)/.built:
 		KERNEL_SOURCES="$(LINUX_DIR)" \
 		ROOT="$(PKG_INSTALL_DIR)" \
 		module module-install
-	touch $@
+endef
 
-$(IPKG_KMOD_SHFS):
-	install -m0755 -d $(IDIR_KMOD_SHFS)/lib/modules/$(LINUX_VERSION)
+define Package/kmod-shfs/install
+	install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
 	$(CP) $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX) \
-	 $(IDIR_KMOD_SHFS)/lib/modules/$(LINUX_VERSION)/
-	$(IPKG_BUILD) $(IDIR_KMOD_SHFS) $(PACKAGE_DIR)
+		$(1)/lib/modules/$(LINUX_VERSION)/
+endef
 
+$(eval $(call BuildPackage,kmod-shfs))
diff --git a/openwrt/target/linux/package/shfs/patches/101-kmod_build.patch b/openwrt/package/shfs/patches/101-kmod_build.patch
similarity index 100%
rename from openwrt/target/linux/package/shfs/patches/101-kmod_build.patch
rename to openwrt/package/shfs/patches/101-kmod_build.patch
diff --git a/openwrt/target/linux/package/shfs/patches/102-gcc4_fix.patch b/openwrt/package/shfs/patches/102-gcc4_fix.patch
similarity index 100%
rename from openwrt/target/linux/package/shfs/patches/102-gcc4_fix.patch
rename to openwrt/package/shfs/patches/102-gcc4_fix.patch
diff --git a/openwrt/target/linux/package/shfs/patches/103-dentry.patch b/openwrt/package/shfs/patches/103-dentry.patch
similarity index 100%
rename from openwrt/target/linux/package/shfs/patches/103-dentry.patch
rename to openwrt/package/shfs/patches/103-dentry.patch
diff --git a/openwrt/target/linux/package/shfs/Config.in b/openwrt/target/linux/package/shfs/Config.in
deleted file mode 100644
index 71cc327073a..00000000000
--- a/openwrt/target/linux/package/shfs/Config.in
+++ /dev/null
@@ -1,22 +0,0 @@
-config PACKAGE_KMOD_SHFS
-	prompt "kmod-shfs......................... Shell FileSystem kernel module (ShFS) kernel module"
-	tristate
-	default m if DEVEL
-	help
-	  ShFS is a simple and easy to use Linux kernel module which 
-	  allows you to mount remote filesystems using a plain shell 
-	  (SSH) connection. When using ShFS, you can access all remote 
-	  files just like the local ones, only the access is governed 
-	  through the transport security of SSH.
-	  
-	  ShFS supports some nice features:
-	  
-	   * file cache for access speedup
-	   * perl and shell code for the remote (server) side
-	   * could preserve uid/gid (root connection)
-	   * number of remote host platforms (Linux, Solaris, Cygwin, ...)
-	   * Linux kernel 2.4.10+ and 2.6
-	   * arbitrary command used for connection (instead of SSH)
-	   * persistent connection (reconnect after SSH dies) 
-	  
-	  http://shfs.sourceforge.net/
diff --git a/openwrt/target/linux/package/shfs/ipkg/kmod-shfs.control b/openwrt/target/linux/package/shfs/ipkg/kmod-shfs.control
deleted file mode 100644
index 240efe60be4..00000000000
--- a/openwrt/target/linux/package/shfs/ipkg/kmod-shfs.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: kmod-shfs
-Priority: optional
-Section: sys
-Description: SHell FileSystem Linux kernel module