refresh patches

SVN-Revision: 10644
This commit is contained in:
Gabor Juhos 2008-03-22 15:36:37 +00:00
parent 6e13173800
commit aaaa8b73a8
19 changed files with 114 additions and 114 deletions

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/arch/mips/Kconfig Index: linux-2.6.24.2/arch/mips/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/arch/mips/Kconfig --- linux-2.6.24.2.orig/arch/mips/Kconfig
+++ linux-2.6.24/arch/mips/Kconfig +++ linux-2.6.24.2/arch/mips/Kconfig
@@ -16,6 +16,20 @@ choice @@ -16,6 +16,20 @@ choice
prompt "System type" prompt "System type"
default SGI_IP22 default SGI_IP22
@ -31,10 +31,10 @@ Index: linux-2.6.24/arch/mips/Kconfig
source "arch/mips/au1000/Kconfig" source "arch/mips/au1000/Kconfig"
source "arch/mips/jazz/Kconfig" source "arch/mips/jazz/Kconfig"
source "arch/mips/lasat/Kconfig" source "arch/mips/lasat/Kconfig"
Index: linux-2.6.24/arch/mips/Makefile Index: linux-2.6.24.2/arch/mips/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/arch/mips/Makefile --- linux-2.6.24.2.orig/arch/mips/Makefile
+++ linux-2.6.24/arch/mips/Makefile +++ linux-2.6.24.2/arch/mips/Makefile
@@ -166,6 +166,16 @@ cflags-$(CONFIG_MACH_JAZZ) += -Iinclude/ @@ -166,6 +166,16 @@ cflags-$(CONFIG_MACH_JAZZ) += -Iinclude/
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000 load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
@ -52,10 +52,10 @@ Index: linux-2.6.24/arch/mips/Makefile
# Common Alchemy Au1x00 stuff # Common Alchemy Au1x00 stuff
# #
core-$(CONFIG_SOC_AU1X00) += arch/mips/au1000/common/ core-$(CONFIG_SOC_AU1X00) += arch/mips/au1000/common/
Index: linux-2.6.24/include/asm-mips/bootinfo.h Index: linux-2.6.24.2/include/asm-mips/bootinfo.h
=================================================================== ===================================================================
--- linux-2.6.24.orig/include/asm-mips/bootinfo.h --- linux-2.6.24.2.orig/include/asm-mips/bootinfo.h
+++ linux-2.6.24/include/asm-mips/bootinfo.h +++ linux-2.6.24.2/include/asm-mips/bootinfo.h
@@ -198,6 +198,58 @@ @@ -198,6 +198,58 @@
#define MACH_GROUP_BRCM 23 /* Broadcom */ #define MACH_GROUP_BRCM 23 /* Broadcom */
#define MACH_BCM47XX 1 /* Broadcom BCM47XX */ #define MACH_BCM47XX 1 /* Broadcom BCM47XX */

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/mtd/maps/Kconfig Index: linux-2.6.24.2/drivers/mtd/maps/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/mtd/maps/Kconfig --- linux-2.6.24.2.orig/drivers/mtd/maps/Kconfig
+++ linux-2.6.24/drivers/mtd/maps/Kconfig +++ linux-2.6.24.2/drivers/mtd/maps/Kconfig
@@ -597,5 +597,9 @@ config MTD_PLATRAM @@ -597,5 +597,9 @@ config MTD_PLATRAM
This selection automatically selects the map_ram driver. This selection automatically selects the map_ram driver.
@ -12,10 +12,10 @@ Index: linux-2.6.24/drivers/mtd/maps/Kconfig
+ +
endmenu endmenu
Index: linux-2.6.24/drivers/mtd/maps/Makefile Index: linux-2.6.24.2/drivers/mtd/maps/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/mtd/maps/Makefile --- linux-2.6.24.2.orig/drivers/mtd/maps/Makefile
+++ linux-2.6.24/drivers/mtd/maps/Makefile +++ linux-2.6.24.2/drivers/mtd/maps/Makefile
@@ -45,6 +45,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash. @@ -45,6 +45,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
obj-$(CONFIG_MTD_PCI) += pci.o obj-$(CONFIG_MTD_PCI) += pci.o

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/net/Kconfig Index: linux-2.6.24.2/drivers/net/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/net/Kconfig --- linux-2.6.24.2.orig/drivers/net/Kconfig
+++ linux-2.6.24/drivers/net/Kconfig +++ linux-2.6.24.2/drivers/net/Kconfig
@@ -601,6 +601,10 @@ config MIPS_AU1X00_ENET @@ -601,6 +601,10 @@ config MIPS_AU1X00_ENET
If you have an Alchemy Semi AU1X00 based system If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N. say Y. Otherwise, say N.
@ -13,10 +13,10 @@ Index: linux-2.6.24/drivers/net/Kconfig
config SGI_IOC3_ETH config SGI_IOC3_ETH
bool "SGI IOC3 Ethernet" bool "SGI IOC3 Ethernet"
depends on PCI && SGI_IP27 depends on PCI && SGI_IP27
Index: linux-2.6.24/drivers/net/Makefile Index: linux-2.6.24.2/drivers/net/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/net/Makefile --- linux-2.6.24.2.orig/drivers/net/Makefile
+++ linux-2.6.24/drivers/net/Makefile +++ linux-2.6.24.2/drivers/net/Makefile
@@ -183,6 +183,7 @@ obj-$(CONFIG_SC92031) += sc92031.o @@ -183,6 +183,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
# This is also a 82596 and should probably be merged # This is also a 82596 and should probably be merged
obj-$(CONFIG_LP486E) += lp486e.o obj-$(CONFIG_LP486E) += lp486e.o

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/usb/host/Kconfig Index: linux-2.6.24.2/drivers/usb/host/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/usb/host/Kconfig --- linux-2.6.24.2.orig/drivers/usb/host/Kconfig
+++ linux-2.6.24/drivers/usb/host/Kconfig +++ linux-2.6.24.2/drivers/usb/host/Kconfig
@@ -261,3 +261,6 @@ config USB_R8A66597_HCD @@ -261,3 +261,6 @@ config USB_R8A66597_HCD
To compile this driver as a module, choose M here: the To compile this driver as a module, choose M here: the
module will be called r8a66597-hcd. module will be called r8a66597-hcd.
@ -9,10 +9,10 @@ Index: linux-2.6.24/drivers/usb/host/Kconfig
+config USB_ADM5120_HCD +config USB_ADM5120_HCD
+ tristate "ADM5120 HCD support (EXPERIMENTAL)" + tristate "ADM5120 HCD support (EXPERIMENTAL)"
+ depends on USB && MIPS_ADM5120 && EXPERIMENTAL + depends on USB && MIPS_ADM5120 && EXPERIMENTAL
Index: linux-2.6.24/drivers/usb/host/Makefile Index: linux-2.6.24.2/drivers/usb/host/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/usb/host/Makefile --- linux-2.6.24.2.orig/drivers/usb/host/Makefile
+++ linux-2.6.24/drivers/usb/host/Makefile +++ linux-2.6.24.2/drivers/usb/host/Makefile
@@ -8,6 +8,7 @@ endif @@ -8,6 +8,7 @@ endif
obj-$(CONFIG_PCI) += pci-quirks.o obj-$(CONFIG_PCI) += pci-quirks.o
@ -21,10 +21,10 @@ Index: linux-2.6.24/drivers/usb/host/Makefile
obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
obj-$(CONFIG_USB_OHCI_HCD) += ohci-hcd.o obj-$(CONFIG_USB_OHCI_HCD) += ohci-hcd.o
Index: linux-2.6.24/drivers/usb/Makefile Index: linux-2.6.24.2/drivers/usb/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/usb/Makefile --- linux-2.6.24.2.orig/drivers/usb/Makefile
+++ linux-2.6.24/drivers/usb/Makefile +++ linux-2.6.24.2/drivers/usb/Makefile
@@ -16,6 +16,7 @@ obj-$(CONFIG_USB_UHCI_HCD) += host/ @@ -16,6 +16,7 @@ obj-$(CONFIG_USB_UHCI_HCD) += host/
obj-$(CONFIG_USB_SL811_HCD) += host/ obj-$(CONFIG_USB_SL811_HCD) += host/
obj-$(CONFIG_USB_U132_HCD) += host/ obj-$(CONFIG_USB_U132_HCD) += host/

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/leds/Kconfig Index: linux-2.6.24.2/drivers/leds/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/leds/Kconfig --- linux-2.6.24.2.orig/drivers/leds/Kconfig
+++ linux-2.6.24/drivers/leds/Kconfig +++ linux-2.6.24.2/drivers/leds/Kconfig
@@ -18,6 +18,21 @@ config LEDS_CLASS @@ -18,6 +18,21 @@ config LEDS_CLASS
comment "LED drivers" comment "LED drivers"
@ -24,10 +24,10 @@ Index: linux-2.6.24/drivers/leds/Kconfig
config LEDS_CORGI config LEDS_CORGI
tristate "LED Support for the Sharp SL-C7x0 series" tristate "LED Support for the Sharp SL-C7x0 series"
depends on LEDS_CLASS && PXA_SHARP_C7xx depends on LEDS_CLASS && PXA_SHARP_C7xx
Index: linux-2.6.24/drivers/leds/Makefile Index: linux-2.6.24.2/drivers/leds/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/leds/Makefile --- linux-2.6.24.2.orig/drivers/leds/Makefile
+++ linux-2.6.24/drivers/leds/Makefile +++ linux-2.6.24.2/drivers/leds/Makefile
@@ -5,6 +5,7 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o @@ -5,6 +5,7 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o
obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o

View File

@ -1,16 +1,16 @@
Index: linux-2.6.24/arch/mips/pci/Makefile Index: linux-2.6.24.2/arch/mips/pci/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/arch/mips/pci/Makefile --- linux-2.6.24.2.orig/arch/mips/pci/Makefile
+++ linux-2.6.24/arch/mips/pci/Makefile +++ linux-2.6.24.2/arch/mips/pci/Makefile
@@ -48,3 +48,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup- @@ -48,3 +48,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+obj-$(CONFIG_PCI_ADM5120) += pci-adm5120.o +obj-$(CONFIG_PCI_ADM5120) += pci-adm5120.o
Index: linux-2.6.24/include/linux/pci_ids.h Index: linux-2.6.24.2/include/linux/pci_ids.h
=================================================================== ===================================================================
--- linux-2.6.24.orig/include/linux/pci_ids.h --- linux-2.6.24.2.orig/include/linux/pci_ids.h
+++ linux-2.6.24/include/linux/pci_ids.h +++ linux-2.6.24.2/include/linux/pci_ids.h
@@ -1703,6 +1703,9 @@ @@ -1703,6 +1703,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe #define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111 #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111

View File

@ -1,10 +1,10 @@
Index: linux-2.6.24/drivers/leds/Kconfig Index: linux-2.6.24.2/drivers/leds/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/leds/Kconfig --- linux-2.6.24.2.orig/drivers/leds/Kconfig
+++ linux-2.6.24/drivers/leds/Kconfig +++ linux-2.6.24.2/drivers/leds/Kconfig
@@ -171,4 +171,12 @@ config LEDS_TRIGGER_MORSE @@ -178,4 +178,12 @@ config LEDS_TRIGGER_DEFAULT_ON
tristate "LED Morse Trigger" This allows LEDs to be initialised in the ON state.
depends on LEDS_TRIGGERS If unsure, say Y.
+config LEDS_TRIGGER_ADM5120_SWITCH +config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger" + tristate "LED ADM5120 Switch Port Status Trigger"
@ -15,12 +15,12 @@ Index: linux-2.6.24/drivers/leds/Kconfig
+ If unsure, say N. + If unsure, say N.
+ +
endif # NEW_LEDS endif # NEW_LEDS
Index: linux-2.6.24/drivers/leds/Makefile Index: linux-2.6.24.2/drivers/leds/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/leds/Makefile --- linux-2.6.24.2.orig/drivers/leds/Makefile
+++ linux-2.6.24/drivers/leds/Makefile +++ linux-2.6.24.2/drivers/leds/Makefile
@@ -27,3 +27,4 @@ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledt @@ -28,3 +28,4 @@ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += l
obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o +obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/mtd/Kconfig Index: linux-2.6.24.2/drivers/mtd/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/mtd/Kconfig --- linux-2.6.24.2.orig/drivers/mtd/Kconfig
+++ linux-2.6.24/drivers/mtd/Kconfig +++ linux-2.6.24.2/drivers/mtd/Kconfig
@@ -160,6 +160,22 @@ config MTD_AFS_PARTS @@ -160,6 +160,22 @@ config MTD_AFS_PARTS
for your particular device. It won't happen automatically. The for your particular device. It won't happen automatically. The
'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example. 'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
@ -25,10 +25,10 @@ Index: linux-2.6.24/drivers/mtd/Kconfig
comment "User Modules And Translation Layers" comment "User Modules And Translation Layers"
config MTD_CHAR config MTD_CHAR
Index: linux-2.6.24/drivers/mtd/Makefile Index: linux-2.6.24.2/drivers/mtd/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/mtd/Makefile --- linux-2.6.24.2.orig/drivers/mtd/Makefile
+++ linux-2.6.24/drivers/mtd/Makefile +++ linux-2.6.24.2/drivers/mtd/Makefile
@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o @@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/mtd/chips/cfi_cmdset_0002.c Index: linux-2.6.24.2/drivers/mtd/chips/cfi_cmdset_0002.c
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/mtd/chips/cfi_cmdset_0002.c --- linux-2.6.24.2.orig/drivers/mtd/chips/cfi_cmdset_0002.c
+++ linux-2.6.24/drivers/mtd/chips/cfi_cmdset_0002.c +++ linux-2.6.24.2/drivers/mtd/chips/cfi_cmdset_0002.c
@@ -47,12 +47,19 @@ @@ -47,12 +47,19 @@
#define MANUFACTURER_AMD 0x0001 #define MANUFACTURER_AMD 0x0001
#define MANUFACTURER_ATMEL 0x001F #define MANUFACTURER_ATMEL 0x001F
@ -74,10 +74,10 @@ Index: linux-2.6.24/drivers/mtd/chips/cfi_cmdset_0002.c
{ 0, 0, NULL, NULL } { 0, 0, NULL, NULL }
}; };
static struct cfi_fixup jedec_fixup_table[] = { static struct cfi_fixup jedec_fixup_table[] = {
Index: linux-2.6.24/drivers/mtd/chips/Kconfig Index: linux-2.6.24.2/drivers/mtd/chips/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/mtd/chips/Kconfig --- linux-2.6.24.2.orig/drivers/mtd/chips/Kconfig
+++ linux-2.6.24/drivers/mtd/chips/Kconfig +++ linux-2.6.24.2/drivers/mtd/chips/Kconfig
@@ -196,6 +196,14 @@ config MTD_CFI_AMDSTD @@ -196,6 +196,14 @@ config MTD_CFI_AMDSTD
provides support for one of those command sets, used on chips provides support for one of those command sets, used on chips
including the AMD Am29LV320. including the AMD Am29LV320.

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/mtd/chips/jedec_probe.c Index: linux-2.6.24.2/drivers/mtd/chips/jedec_probe.c
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/mtd/chips/jedec_probe.c --- linux-2.6.24.2.orig/drivers/mtd/chips/jedec_probe.c
+++ linux-2.6.24/drivers/mtd/chips/jedec_probe.c +++ linux-2.6.24.2/drivers/mtd/chips/jedec_probe.c
@@ -121,6 +121,10 @@ @@ -121,6 +121,10 @@
#define UPD29F064115 0x221C #define UPD29F064115 0x221C

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/mtd/Kconfig Index: linux-2.6.24.2/drivers/mtd/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/mtd/Kconfig --- linux-2.6.24.2.orig/drivers/mtd/Kconfig
+++ linux-2.6.24/drivers/mtd/Kconfig +++ linux-2.6.24.2/drivers/mtd/Kconfig
@@ -57,6 +57,11 @@ config MTD_ROOTFS_SPLIT @@ -57,6 +57,11 @@ config MTD_ROOTFS_SPLIT
depends on MTD_PARTITIONS depends on MTD_PARTITIONS
default y default y
@ -14,10 +14,10 @@ Index: linux-2.6.24/drivers/mtd/Kconfig
config MTD_REDBOOT_PARTS config MTD_REDBOOT_PARTS
tristate "RedBoot partition table parsing" tristate "RedBoot partition table parsing"
depends on MTD_PARTITIONS depends on MTD_PARTITIONS
Index: linux-2.6.24/drivers/mtd/Makefile Index: linux-2.6.24.2/drivers/mtd/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/mtd/Makefile --- linux-2.6.24.2.orig/drivers/mtd/Makefile
+++ linux-2.6.24/drivers/mtd/Makefile +++ linux-2.6.24.2/drivers/mtd/Makefile
@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o @@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/ata/Makefile Index: linux-2.6.24.2/drivers/ata/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/ata/Makefile --- linux-2.6.24.2.orig/drivers/ata/Makefile
+++ linux-2.6.24/drivers/ata/Makefile +++ linux-2.6.24.2/drivers/ata/Makefile
@@ -69,6 +69,7 @@ obj-$(CONFIG_PATA_BF54X) += pata_bf54x.o @@ -69,6 +69,7 @@ obj-$(CONFIG_PATA_BF54X) += pata_bf54x.o
obj-$(CONFIG_PATA_PLATFORM) += pata_platform.o obj-$(CONFIG_PATA_PLATFORM) += pata_platform.o
obj-$(CONFIG_PATA_OF_PLATFORM) += pata_of_platform.o obj-$(CONFIG_PATA_OF_PLATFORM) += pata_of_platform.o
@ -10,10 +10,10 @@ Index: linux-2.6.24/drivers/ata/Makefile
# Should be last but two libata driver # Should be last but two libata driver
obj-$(CONFIG_PATA_ACPI) += pata_acpi.o obj-$(CONFIG_PATA_ACPI) += pata_acpi.o
# Should be last but one libata driver # Should be last but one libata driver
Index: linux-2.6.24/drivers/ata/Kconfig Index: linux-2.6.24.2/drivers/ata/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/ata/Kconfig --- linux-2.6.24.2.orig/drivers/ata/Kconfig
+++ linux-2.6.24/drivers/ata/Kconfig +++ linux-2.6.24.2/drivers/ata/Kconfig
@@ -660,4 +660,13 @@ config PATA_BF54X @@ -660,4 +660,13 @@ config PATA_BF54X
If unsure, say N. If unsure, say N.

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/arch/mips/kernel/head.S Index: linux-2.6.24.2/arch/mips/kernel/head.S
=================================================================== ===================================================================
--- linux-2.6.24.orig/arch/mips/kernel/head.S --- linux-2.6.24.2.orig/arch/mips/kernel/head.S
+++ linux-2.6.24/arch/mips/kernel/head.S +++ linux-2.6.24.2/arch/mips/kernel/head.S
@@ -126,7 +126,12 @@ @@ -126,7 +126,12 @@
/* /*
* Reserved space for exception handlers. * Reserved space for exception handlers.

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/serial/amba-pl010.c Index: linux-2.6.24.2/drivers/serial/amba-pl010.c
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/serial/amba-pl010.c --- linux-2.6.24.2.orig/drivers/serial/amba-pl010.c
+++ linux-2.6.24/drivers/serial/amba-pl010.c +++ linux-2.6.24.2/drivers/serial/amba-pl010.c
@@ -52,11 +52,10 @@ @@ -52,11 +52,10 @@
#include <asm/io.h> #include <asm/io.h>
@ -264,11 +264,11 @@ Index: linux-2.6.24/drivers/serial/amba-pl010.c
.cons = AMBA_CONSOLE, .cons = AMBA_CONSOLE,
}; };
Index: linux-2.6.24/drivers/serial/Kconfig Index: linux-2.6.24.2/drivers/serial/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/serial/Kconfig --- linux-2.6.24.2.orig/drivers/serial/Kconfig
+++ linux-2.6.24/drivers/serial/Kconfig +++ linux-2.6.24.2/drivers/serial/Kconfig
@@ -303,10 +303,25 @@ config SERIAL_AMBA_PL010 @@ -287,10 +287,25 @@ config SERIAL_AMBA_PL010
help help
This selects the ARM(R) AMBA(R) PrimeCell PL010 UART. If you have This selects the ARM(R) AMBA(R) PrimeCell PL010 UART. If you have
an Integrator/AP or Integrator/PP2 platform, or if you have a an Integrator/AP or Integrator/PP2 platform, or if you have a

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/amba/bus.c Index: linux-2.6.24.2/drivers/amba/bus.c
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/amba/bus.c --- linux-2.6.24.2.orig/drivers/amba/bus.c
+++ linux-2.6.24/drivers/amba/bus.c +++ linux-2.6.24.2/drivers/amba/bus.c
@@ -17,6 +17,10 @@ @@ -17,6 +17,10 @@
#include <asm/io.h> #include <asm/io.h>
#include <asm/sizes.h> #include <asm/sizes.h>

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/pci/Kconfig Index: linux-2.6.24.2/drivers/pci/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/pci/Kconfig --- linux-2.6.24.2.orig/drivers/pci/Kconfig
+++ linux-2.6.24/drivers/pci/Kconfig +++ linux-2.6.24.2/drivers/pci/Kconfig
@@ -42,6 +42,12 @@ config PCI_DEBUG @@ -42,6 +42,12 @@ config PCI_DEBUG
When in doubt, say N. When in doubt, say N.
@ -15,10 +15,10 @@ Index: linux-2.6.24/drivers/pci/Kconfig
config HT_IRQ config HT_IRQ
bool "Interrupts on hypertransport devices" bool "Interrupts on hypertransport devices"
default y default y
Index: linux-2.6.24/drivers/pci/quirks.c Index: linux-2.6.24.2/drivers/pci/quirks.c
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/pci/quirks.c --- linux-2.6.24.2.orig/drivers/pci/quirks.c
+++ linux-2.6.24/drivers/pci/quirks.c +++ linux-2.6.24.2/drivers/pci/quirks.c
@@ -23,6 +23,7 @@ @@ -23,6 +23,7 @@
#include <linux/acpi.h> #include <linux/acpi.h>
#include "pci.h" #include "pci.h"

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/leds/leds-gpio.c Index: linux-2.6.24.2/drivers/leds/leds-gpio.c
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/leds/leds-gpio.c --- linux-2.6.24.2.orig/drivers/leds/leds-gpio.c
+++ linux-2.6.24/drivers/leds/leds-gpio.c +++ linux-2.6.24.2/drivers/leds/leds-gpio.c
@@ -41,13 +41,17 @@ static void gpio_led_set(struct led_clas @@ -41,13 +41,17 @@ static void gpio_led_set(struct led_clas
container_of(led_cdev, struct gpio_led_data, cdev); container_of(led_cdev, struct gpio_led_data, cdev);
int level; int level;

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/i2c/busses/Kconfig Index: linux-2.6.24.2/drivers/i2c/busses/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/i2c/busses/Kconfig --- linux-2.6.24.2.orig/drivers/i2c/busses/Kconfig
+++ linux-2.6.24/drivers/i2c/busses/Kconfig +++ linux-2.6.24.2/drivers/i2c/busses/Kconfig
@@ -146,6 +146,17 @@ config I2C_GPIO @@ -146,6 +146,17 @@ config I2C_GPIO
This is a very simple bitbanging I2C driver utilizing the This is a very simple bitbanging I2C driver utilizing the
arch-neutral GPIO API to control the SCL and SDA lines. arch-neutral GPIO API to control the SCL and SDA lines.
@ -20,10 +20,10 @@ Index: linux-2.6.24/drivers/i2c/busses/Kconfig
config I2C_HYDRA config I2C_HYDRA
tristate "CHRP Apple Hydra Mac I/O I2C interface" tristate "CHRP Apple Hydra Mac I/O I2C interface"
depends on PCI && PPC_CHRP && EXPERIMENTAL depends on PCI && PPC_CHRP && EXPERIMENTAL
Index: linux-2.6.24/drivers/i2c/busses/Makefile Index: linux-2.6.24.2/drivers/i2c/busses/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/i2c/busses/Makefile --- linux-2.6.24.2.orig/drivers/i2c/busses/Makefile
+++ linux-2.6.24/drivers/i2c/busses/Makefile +++ linux-2.6.24.2/drivers/i2c/busses/Makefile
@@ -14,6 +14,7 @@ obj-$(CONFIG_I2C_BLACKFIN_TWI) += i2c-bf @@ -14,6 +14,7 @@ obj-$(CONFIG_I2C_BLACKFIN_TWI) += i2c-bf
obj-$(CONFIG_I2C_DAVINCI) += i2c-davinci.o obj-$(CONFIG_I2C_DAVINCI) += i2c-davinci.o
obj-$(CONFIG_I2C_ELEKTOR) += i2c-elektor.o obj-$(CONFIG_I2C_ELEKTOR) += i2c-elektor.o

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24/drivers/watchdog/Kconfig Index: linux-2.6.24.2/drivers/watchdog/Kconfig
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/watchdog/Kconfig --- linux-2.6.24.2.orig/drivers/watchdog/Kconfig
+++ linux-2.6.24/drivers/watchdog/Kconfig +++ linux-2.6.24.2/drivers/watchdog/Kconfig
@@ -607,6 +607,18 @@ config SBC_EPX_C3_WATCHDOG @@ -607,6 +607,18 @@ config SBC_EPX_C3_WATCHDOG
# MIPS Architecture # MIPS Architecture
@ -21,10 +21,10 @@ Index: linux-2.6.24/drivers/watchdog/Kconfig
config INDYDOG config INDYDOG
tristate "Indy/I2 Hardware Watchdog" tristate "Indy/I2 Hardware Watchdog"
depends on SGI_IP22 depends on SGI_IP22
Index: linux-2.6.24/drivers/watchdog/Makefile Index: linux-2.6.24.2/drivers/watchdog/Makefile
=================================================================== ===================================================================
--- linux-2.6.24.orig/drivers/watchdog/Makefile --- linux-2.6.24.2.orig/drivers/watchdog/Makefile
+++ linux-2.6.24/drivers/watchdog/Makefile +++ linux-2.6.24.2/drivers/watchdog/Makefile
@@ -89,6 +89,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc @@ -89,6 +89,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
# M68KNOMMU Architecture # M68KNOMMU Architecture