mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-18 02:40:19 +00:00
tools/mkimage: update to 2023.10
Update to latest version.
Remove "100-increase-tmpfile-name-length-limit.patch" because project
is now using limits.h with PATH_MAX [0].
Automatically refreshed:
- 030-allow-to-use-different-magic.patch
[0] - 99d430f344
Signed-off-by: Nick Hainke <vincent@systemli.org>
This commit is contained in:
parent
551963662b
commit
a82c9699c4
@ -7,14 +7,14 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mkimage
|
||||
PKG_VERSION:=2023.04
|
||||
PKG_VERSION:=2023.10
|
||||
|
||||
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:= \
|
||||
https://mirror.cyberbits.eu/u-boot \
|
||||
https://ftp.denx.de/pub/u-boot \
|
||||
ftp://ftp.denx.de/pub/u-boot
|
||||
PKG_HASH:=e31cac91545ff41b71cec5d8c22afd695645cd6e2a442ccdacacd60534069341
|
||||
PKG_HASH:=e00e6c6f014e046101739d08d06f328811cebcf5ae101348f409cbbd55ce6900
|
||||
|
||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
|
||||
|
||||
|
@ -50,7 +50,7 @@ This patch makes it possible to set a custom image magic.
|
||||
break;
|
||||
--- a/tools/default_image.c
|
||||
+++ b/tools/default_image.c
|
||||
@@ -63,7 +63,7 @@ static int image_verify_header(unsigned
|
||||
@@ -68,7 +68,7 @@ static int image_verify_header(unsigned
|
||||
*/
|
||||
memcpy(hdr, ptr, sizeof(struct legacy_img_hdr));
|
||||
|
||||
@ -59,7 +59,7 @@ This patch makes it possible to set a custom image magic.
|
||||
debug("%s: Bad Magic Number: \"%s\" is no valid image\n",
|
||||
params->cmdname, params->imagefile);
|
||||
return -FDT_ERR_BADMAGIC;
|
||||
@@ -142,7 +142,7 @@ static void image_set_header(void *ptr,
|
||||
@@ -147,7 +147,7 @@ static void image_set_header(void *ptr,
|
||||
}
|
||||
|
||||
/* Build new header */
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/tools/mkimage.h
|
||||
+++ b/tools/mkimage.h
|
||||
@@ -44,7 +44,7 @@ static inline ulong map_to_sysmem(void *
|
||||
#define ALLOC_CACHE_ALIGN_BUFFER(type, name, size) type name[size]
|
||||
|
||||
#define MKIMAGE_TMPFILE_SUFFIX ".tmp"
|
||||
-#define MKIMAGE_MAX_TMPFILE_LEN 256
|
||||
+#define MKIMAGE_MAX_TMPFILE_LEN 1024
|
||||
#define MKIMAGE_DEFAULT_DTC_OPTIONS "-I dts -O dtb -p 500"
|
||||
#define MKIMAGE_MAX_DTC_CMDLINE_LEN 2 * MKIMAGE_MAX_TMPFILE_LEN + 35
|
||||
|
Loading…
Reference in New Issue
Block a user