mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
update to 2.6.28.4
SVN-Revision: 14441
This commit is contained in:
parent
7f04c52b92
commit
a7782176f9
@ -31,8 +31,8 @@ endif
|
||||
ifeq ($(LINUX_VERSION),2.6.27.15)
|
||||
LINUX_KERNEL_MD5SUM:=0756284efb091dccd012eec61def2004
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.28.2)
|
||||
LINUX_KERNEL_MD5SUM:=8fce853ebfe658f0833d34bb1dc14d86
|
||||
ifeq ($(LINUX_VERSION),2.6.28.4)
|
||||
LINUX_KERNEL_MD5SUM:=8228bb7804d6d0099eadfabf701c295b
|
||||
endif
|
||||
|
||||
# disable the md5sum check for unknown kernel versions
|
||||
|
@ -10,7 +10,7 @@ ARCH:=avr32
|
||||
BOARD:=avr32
|
||||
BOARDNAME:=Atmel AVR32
|
||||
FEATURES:=squashfs
|
||||
LINUX_VERSION:=2.6.28.2
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -8,7 +8,7 @@
|
||||
depends on NETFILTER_ADVANCED
|
||||
help
|
||||
H.323 is a VoIP signalling protocol from ITU-T. As one of the most
|
||||
@@ -488,7 +487,6 @@ config NETFILTER_XT_TARGET_TARPIT
|
||||
@@ -455,7 +454,6 @@ config NETFILTER_XT_TARGET_SECMARK
|
||||
|
||||
config NETFILTER_XT_TARGET_TCPMSS
|
||||
tristate '"TCPMSS" target support'
|
||||
|
@ -5,8 +5,6 @@ Date: Tue Feb 3 00:16:19 2009 +0100
|
||||
struct serial_rs485 contains __32 fields and is exported to userspace so it
|
||||
needs linux/types.h in userspace aswell.
|
||||
|
||||
diff --git a/include/linux/serial.h b/include/linux/serial.h
|
||||
index 1ea8d92..fa72b39 100644
|
||||
--- a/include/linux/serial.h
|
||||
+++ b/include/linux/serial.h
|
||||
@@ -10,8 +10,8 @@
|
||||
|
@ -95,7 +95,7 @@
|
||||
* We enter with non-exclusive mmap_sem (to exclude vma changes,
|
||||
--- a/mm/vmalloc.c
|
||||
+++ b/mm/vmalloc.c
|
||||
@@ -981,6 +981,7 @@ void unmap_kernel_range(unsigned long ad
|
||||
@@ -992,6 +992,7 @@ void unmap_kernel_range(unsigned long ad
|
||||
vunmap_page_range(addr, end);
|
||||
flush_tlb_kernel_range(addr, end);
|
||||
}
|
||||
@ -103,7 +103,7 @@
|
||||
|
||||
int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
|
||||
{
|
||||
@@ -1086,6 +1087,7 @@ struct vm_struct *get_vm_area(unsigned l
|
||||
@@ -1097,6 +1098,7 @@ struct vm_struct *get_vm_area(unsigned l
|
||||
return __get_vm_area_node(size, flags, VMALLOC_START, VMALLOC_END,
|
||||
-1, GFP_KERNEL, __builtin_return_address(0));
|
||||
}
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
|
||||
FEATURES:=squashfs
|
||||
SUBTARGETS=generic harddisk
|
||||
|
||||
LINUX_VERSION:=2.6.28.2
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/arch/arm/mach-ixp4xx/Kconfig
|
||||
+++ b/arch/arm/mach-ixp4xx/Kconfig
|
||||
@@ -98,6 +98,14 @@ config MACH_SIDEWINDER
|
||||
@@ -97,6 +97,14 @@ config MACH_SIDEWINDER
|
||||
Engineering Sidewinder board. For more information on this
|
||||
platform, see http://www.adiengineering.com
|
||||
|
||||
|
@ -11,7 +11,7 @@ BOARD:=orion
|
||||
BOARDNAME:=Marvell Orion
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=2.6.28.2
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -11,7 +11,7 @@ BOARD:=ppc44x
|
||||
BOARDNAME:=AMCC/IBM PPC44x
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=2.6.28.2
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
LINUX_KARCH:=powerpc
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
@ -69,7 +69,7 @@
|
||||
POB0: opb {
|
||||
compatible = "ibm,opb-460ex", "ibm,opb";
|
||||
#address-cells = <1>;
|
||||
@@ -222,6 +282,12 @@
|
||||
@@ -222,6 +270,12 @@
|
||||
reg = <0xef600700 0x00000014>;
|
||||
interrupt-parent = <&UIC0>;
|
||||
interrupts = <0x2 0x4>;
|
||||
@ -82,7 +82,7 @@
|
||||
};
|
||||
|
||||
IIC1: i2c@ef600800 {
|
||||
@@ -331,6 +397,7 @@
|
||||
@@ -331,6 +385,7 @@
|
||||
* later cannot be changed
|
||||
*/
|
||||
ranges = <0x02000000 0x00000000 0x80000000 0x0000000d 0x80000000 0x00000000 0x80000000
|
||||
@ -90,7 +90,7 @@
|
||||
0x01000000 0x00000000 0x00000000 0x0000000c 0x08000000 0x00000000 0x00010000>;
|
||||
|
||||
/* Inbound 2GB range starting at 0 */
|
||||
@@ -361,6 +428,7 @@
|
||||
@@ -361,6 +416,7 @@
|
||||
* later cannot be changed
|
||||
*/
|
||||
ranges = <0x02000000 0x00000000 0x80000000 0x0000000e 0x00000000 0x00000000 0x80000000
|
||||
@ -98,7 +98,7 @@
|
||||
0x01000000 0x00000000 0x00000000 0x0000000f 0x80000000 0x00000000 0x00010000>;
|
||||
|
||||
/* Inbound 2GB range starting at 0 */
|
||||
@@ -402,6 +470,7 @@
|
||||
@@ -402,6 +458,7 @@
|
||||
* later cannot be changed
|
||||
*/
|
||||
ranges = <0x02000000 0x00000000 0x80000000 0x0000000e 0x80000000 0x00000000 0x80000000
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/arch/powerpc/boot/dts/canyonlands.dts
|
||||
+++ b/arch/powerpc/boot/dts/canyonlands.dts
|
||||
@@ -195,28 +195,6 @@
|
||||
@@ -243,28 +243,6 @@
|
||||
interrupts = <0x1 0x4>;
|
||||
};
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- a/arch/powerpc/boot/dts/taishan.dts 2009-01-18 19:45:37.000000000 +0100
|
||||
+++ b/arch/powerpc/boot/dts/taishan.dts 2009-01-29 18:55:40.000000000 +0100
|
||||
--- a/arch/powerpc/boot/dts/taishan.dts
|
||||
+++ b/arch/powerpc/boot/dts/taishan.dts
|
||||
@@ -423,5 +423,6 @@
|
||||
|
||||
chosen {
|
||||
|
@ -11,7 +11,7 @@ BOARD:=s3c24xx
|
||||
BOARDNAME:=s3c24xx
|
||||
FEATURES:=jffs2
|
||||
|
||||
LINUX_VERSION:=2.6.28.2
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
|
||||
DEVICE_TYPE=phone
|
||||
|
||||
|
@ -1,14 +0,0 @@
|
||||
Does not compile. --mb
|
||||
|
||||
---
|
||||
--- a/net/netfilter/Kconfig
|
||||
+++ b/net/netfilter/Kconfig
|
||||
@@ -314,7 +314,7 @@ if NETFILTER_XTABLES
|
||||
|
||||
config NETFILTER_XT_TARGET_CHAOS
|
||||
tristate '"CHAOS" target support'
|
||||
- depends on NETFILTER_XTABLES
|
||||
+ depends on NETFILTER_XTABLES && BROKEN
|
||||
help
|
||||
This option adds a `CHAOS' target.
|
||||
|
@ -11,7 +11,7 @@ BOARD:=sibyte
|
||||
BOARDNAME:=Broadcom/SiByte SB-1
|
||||
FEATURES:=broken
|
||||
|
||||
LINUX_VERSION:=2.6.28.2
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=x86
|
||||
FEATURES:=squashfs jffs2 ext2 vdi vmdk
|
||||
SUBTARGETS=generic
|
||||
|
||||
LINUX_VERSION:=2.6.28.2
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
LINUX_KARCH:=x86
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
Loading…
Reference in New Issue
Block a user