mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-24 15:56:49 +00:00
dnsmasq: update to dnsmasq v2.76
Update to dnsmasq2.76. Refresh patches. Add new patch to fix musl 'poll.h' location warning. Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
This commit is contained in:
parent
0cc58a0f98
commit
a6e96998fb
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dnsmasq
|
PKG_NAME:=dnsmasq
|
||||||
PKG_VERSION:=2.75
|
PKG_VERSION:=2.76
|
||||||
PKG_RELEASE:=7
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
||||||
PKG_MD5SUM:=887236f1ddde6eb57cdb9d01916c9f72
|
PKG_MD5SUM:=00f5ee66b4e4b7f14538bf62ae3c9461
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-2.0
|
PKG_LICENSE:=GPL-2.0
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
@ -1,15 +1,15 @@
|
|||||||
--- a/src/dhcp.c
|
--- a/src/dhcp.c
|
||||||
+++ b/src/dhcp.c
|
+++ b/src/dhcp.c
|
||||||
@@ -146,7 +146,7 @@ void dhcp_packet(time_t now, int pxe_fd)
|
@@ -147,7 +147,7 @@ void dhcp_packet(time_t now, int pxe_fd)
|
||||||
struct iovec iov;
|
|
||||||
ssize_t sz;
|
ssize_t sz;
|
||||||
int iface_index = 0, unicast_dest = 0, is_inform = 0;
|
int iface_index = 0, unicast_dest = 0, is_inform = 0;
|
||||||
|
int rcvd_iface_index;
|
||||||
- struct in_addr iface_addr;
|
- struct in_addr iface_addr;
|
||||||
+ struct in_addr iface_addr, *addrp = NULL;
|
+ struct in_addr iface_addr, *addrp = NULL;
|
||||||
struct iface_param parm;
|
struct iface_param parm;
|
||||||
#ifdef HAVE_LINUX_NETWORK
|
#ifdef HAVE_LINUX_NETWORK
|
||||||
struct arpreq arp_req;
|
struct arpreq arp_req;
|
||||||
@@ -275,11 +275,9 @@ void dhcp_packet(time_t now, int pxe_fd)
|
@@ -277,11 +277,9 @@ void dhcp_packet(time_t now, int pxe_fd)
|
||||||
{
|
{
|
||||||
ifr.ifr_addr.sa_family = AF_INET;
|
ifr.ifr_addr.sa_family = AF_INET;
|
||||||
if (ioctl(daemon->dhcpfd, SIOCGIFADDR, &ifr) != -1 )
|
if (ioctl(daemon->dhcpfd, SIOCGIFADDR, &ifr) != -1 )
|
||||||
@ -23,7 +23,7 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
for (tmp = daemon->dhcp_except; tmp; tmp = tmp->next)
|
for (tmp = daemon->dhcp_except; tmp; tmp = tmp->next)
|
||||||
@@ -298,7 +296,7 @@ void dhcp_packet(time_t now, int pxe_fd)
|
@@ -300,7 +298,7 @@ void dhcp_packet(time_t now, int pxe_fd)
|
||||||
parm.relay_local.s_addr = 0;
|
parm.relay_local.s_addr = 0;
|
||||||
parm.ind = iface_index;
|
parm.ind = iface_index;
|
||||||
|
|
||||||
@ -32,7 +32,7 @@
|
|||||||
{
|
{
|
||||||
/* If we failed to match the primary address of the interface, see if we've got a --listen-address
|
/* If we failed to match the primary address of the interface, see if we've got a --listen-address
|
||||||
for a secondary */
|
for a secondary */
|
||||||
@@ -318,6 +316,12 @@ void dhcp_packet(time_t now, int pxe_fd)
|
@@ -320,6 +318,12 @@ void dhcp_packet(time_t now, int pxe_fd)
|
||||||
complete_context(match.addr, iface_index, NULL, match.netmask, match.broadcast, &parm);
|
complete_context(match.addr, iface_index, NULL, match.netmask, match.broadcast, &parm);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -10,7 +10,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
|
|||||||
|
|
||||||
--- a/src/dnssec.c
|
--- a/src/dnssec.c
|
||||||
+++ b/src/dnssec.c
|
+++ b/src/dnssec.c
|
||||||
@@ -429,17 +429,24 @@ static time_t timestamp_time;
|
@@ -462,17 +462,24 @@ static time_t timestamp_time;
|
||||||
int setup_timestamp(void)
|
int setup_timestamp(void)
|
||||||
{
|
{
|
||||||
struct stat statbuf;
|
struct stat statbuf;
|
||||||
@ -36,7 +36,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
|
|||||||
{
|
{
|
||||||
/* time already OK, update timestamp, and do key checking from the start. */
|
/* time already OK, update timestamp, and do key checking from the start. */
|
||||||
if (utime(daemon->timestamp_file, NULL) == -1)
|
if (utime(daemon->timestamp_file, NULL) == -1)
|
||||||
@@ -460,7 +467,7 @@ int setup_timestamp(void)
|
@@ -493,7 +500,7 @@ int setup_timestamp(void)
|
||||||
|
|
||||||
close(fd);
|
close(fd);
|
||||||
|
|
||||||
|
@ -0,0 +1,18 @@
|
|||||||
|
dnsmasq: fix warning with poll.h include on musl
|
||||||
|
|
||||||
|
Warning is:
|
||||||
|
#warning redirecting incorrect #include <sys/poll.h> to <poll.h>
|
||||||
|
|
||||||
|
Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
|
||||||
|
|
||||||
|
--- a/src/dnsmasq.h
|
||||||
|
+++ b/src/dnsmasq.h
|
||||||
|
@@ -82,7 +82,7 @@ typedef unsigned long long u64;
|
||||||
|
#if defined(HAVE_SOLARIS_NETWORK)
|
||||||
|
# include <sys/sockio.h>
|
||||||
|
#endif
|
||||||
|
-#include <sys/poll.h>
|
||||||
|
+#include <poll.h>
|
||||||
|
#include <sys/wait.h>
|
||||||
|
#include <sys/time.h>
|
||||||
|
#include <sys/un.h>
|
Loading…
Reference in New Issue
Block a user