mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-12 07:53:07 +00:00
separate ath9k debugfs support from ath9k debugging, use the mac80211 debugfs config option to enable it
SVN-Revision: 18505
This commit is contained in:
parent
d6cb068098
commit
9fce92753f
@ -22,6 +22,9 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
|
|||||||
|
|
||||||
PKG_CONFIG_DEPENDS:= \
|
PKG_CONFIG_DEPENDS:= \
|
||||||
CONFIG_PACKAGE_kmod-mac80211 \
|
CONFIG_PACKAGE_kmod-mac80211 \
|
||||||
|
CONFIG_PACKAGE_MAC80211_DEBUGFS \
|
||||||
|
CONFIG_PACKAGE_ATH_DEBUG \
|
||||||
|
CONFIG_ATH_USER_REGD \
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -498,8 +501,7 @@ BUILDFLAGS:= \
|
|||||||
$(if $(CONFIG_PCI),-DCONFIG_SSB_SPROM) \
|
$(if $(CONFIG_PCI),-DCONFIG_SSB_SPROM) \
|
||||||
$(if $(CONFIG_LEDS_TRIGGERS), -DCONFIG_MAC80211_LEDS -DCONFIG_LEDS_TRIGGERS -DCONFIG_B43_LEDS -DCONFIG_B43LEGACY_LEDS -DCONFIG_AR9170_LEDS) \
|
$(if $(CONFIG_LEDS_TRIGGERS), -DCONFIG_MAC80211_LEDS -DCONFIG_LEDS_TRIGGERS -DCONFIG_B43_LEDS -DCONFIG_B43LEGACY_LEDS -DCONFIG_AR9170_LEDS) \
|
||||||
-DCONFIG_B43_HWRNG -DCONFIG_B43LEGACY_HWRNG \
|
-DCONFIG_B43_HWRNG -DCONFIG_B43LEGACY_HWRNG \
|
||||||
$(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS),-DCONFIG_MAC80211_DEBUGFS) \
|
$(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS),-DCONFIG_MAC80211_DEBUGFS -DCONFIG_ATH9K_DEBUGFS) \
|
||||||
$(if $(CONFIG_PACKAGE_ATH9K_DEBUG),-DCONFIG_ATH9K_DEBUG) \
|
|
||||||
$(if $(CONFIG_PACKAGE_ATH_DEBUG),-DCONFIG_ATH_DEBUG) \
|
$(if $(CONFIG_PACKAGE_ATH_DEBUG),-DCONFIG_ATH_DEBUG) \
|
||||||
-D__CONFIG_MAC80211_RC_DEFAULT=minstrel \
|
-D__CONFIG_MAC80211_RC_DEFAULT=minstrel \
|
||||||
$(if $(CONFIG_ATH_USER_REGD),-DATH_USER_REGD=1)
|
$(if $(CONFIG_ATH_USER_REGD),-DATH_USER_REGD=1)
|
||||||
@ -530,7 +532,7 @@ MAKE_OPTS:= \
|
|||||||
CONFIG_ATH_DEBUG=$(if $(CONFIG_PACKAGE_ATH_DEBUG),y) \
|
CONFIG_ATH_DEBUG=$(if $(CONFIG_PACKAGE_ATH_DEBUG),y) \
|
||||||
CONFIG_ATH5K=$(if $(CONFIG_PACKAGE_kmod-ath5k),m) \
|
CONFIG_ATH5K=$(if $(CONFIG_PACKAGE_kmod-ath5k),m) \
|
||||||
CONFIG_ATH9K=$(if $(CONFIG_PACKAGE_kmod-ath9k),m) \
|
CONFIG_ATH9K=$(if $(CONFIG_PACKAGE_kmod-ath9k),m) \
|
||||||
CONFIG_ATH9K_DEBUG=$(if $(CONFIG_PACKAGE_ATH9K_DEBUG),y) \
|
CONFIG_ATH9K_DEBUGFS=$(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS),y) \
|
||||||
CONFIG_ZD1211RW=$(if $(CONFIG_PACKAGE_kmod-zd1211rw),m) \
|
CONFIG_ZD1211RW=$(if $(CONFIG_PACKAGE_kmod-zd1211rw),m) \
|
||||||
CONFIG_P54_COMMON=$(if $(CONFIG_PACKAGE_kmod-p54-common),m) \
|
CONFIG_P54_COMMON=$(if $(CONFIG_PACKAGE_kmod-p54-common),m) \
|
||||||
CONFIG_P54_PCI=$(if $(CONFIG_PACKAGE_kmod-p54-pci),m) \
|
CONFIG_P54_PCI=$(if $(CONFIG_PACKAGE_kmod-p54-pci),m) \
|
||||||
|
81
package/mac80211/patches/520-ath9k_debugfs_config.patch
Normal file
81
package/mac80211/patches/520-ath9k_debugfs_config.patch
Normal file
@ -0,0 +1,81 @@
|
|||||||
|
--- a/drivers/net/wireless/ath/ath9k/Makefile
|
||||||
|
+++ b/drivers/net/wireless/ath/ath9k/Makefile
|
||||||
|
@@ -7,7 +7,7 @@ ath9k-y += beacon.o \
|
||||||
|
|
||||||
|
ath9k-$(CONFIG_PCI) += pci.o
|
||||||
|
ath9k-$(CONFIG_ATHEROS_AR71XX) += ahb.o
|
||||||
|
-ath9k-$(CONFIG_ATH9K_DEBUG) += debug.o
|
||||||
|
+ath9k-$(CONFIG_ATH9K_DEBUGFS) += debug.o
|
||||||
|
|
||||||
|
obj-$(CONFIG_ATH9K) += ath9k.o
|
||||||
|
|
||||||
|
--- a/drivers/net/wireless/ath/ath9k/ath9k.h
|
||||||
|
+++ b/drivers/net/wireless/ath/ath9k/ath9k.h
|
||||||
|
@@ -483,7 +483,7 @@ struct ath_softc {
|
||||||
|
|
||||||
|
int beacon_interval;
|
||||||
|
|
||||||
|
-#ifdef CONFIG_ATH9K_DEBUG
|
||||||
|
+#ifdef CONFIG_ATH9K_DEBUGFS
|
||||||
|
struct ath9k_debug debug;
|
||||||
|
#endif
|
||||||
|
struct ath_beacon_config cur_beacon_conf;
|
||||||
|
--- a/drivers/net/wireless/ath/ath9k/debug.c
|
||||||
|
+++ b/drivers/net/wireless/ath/ath9k/debug.c
|
||||||
|
@@ -31,6 +31,8 @@ static int ath9k_debugfs_open(struct ino
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifdef CONFIG_ATH_DEBUG
|
||||||
|
+
|
||||||
|
static ssize_t read_file_debug(struct file *file, char __user *user_buf,
|
||||||
|
size_t count, loff_t *ppos)
|
||||||
|
{
|
||||||
|
@@ -71,6 +73,8 @@ static const struct file_operations fops
|
||||||
|
.owner = THIS_MODULE
|
||||||
|
};
|
||||||
|
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
static ssize_t read_file_dma(struct file *file, char __user *user_buf,
|
||||||
|
size_t count, loff_t *ppos)
|
||||||
|
{
|
||||||
|
@@ -563,10 +567,12 @@ int ath9k_init_debug(struct ath_hw *ah)
|
||||||
|
if (!sc->debug.debugfs_phy)
|
||||||
|
goto err;
|
||||||
|
|
||||||
|
+#ifdef CONFIG_ATH_DEBUG
|
||||||
|
sc->debug.debugfs_debug = debugfs_create_file("debug",
|
||||||
|
S_IRUSR | S_IWUSR, sc->debug.debugfs_phy, sc, &fops_debug);
|
||||||
|
if (!sc->debug.debugfs_debug)
|
||||||
|
goto err;
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
sc->debug.debugfs_dma = debugfs_create_file("dma", S_IRUSR,
|
||||||
|
sc->debug.debugfs_phy, sc, &fops_dma);
|
||||||
|
--- a/drivers/net/wireless/ath/ath9k/debug.h
|
||||||
|
+++ b/drivers/net/wireless/ath/ath9k/debug.h
|
||||||
|
@@ -23,13 +23,13 @@
|
||||||
|
struct ath_txq;
|
||||||
|
struct ath_buf;
|
||||||
|
|
||||||
|
-#ifdef CONFIG_ATH9K_DEBUG
|
||||||
|
+#ifdef CONFIG_ATH9K_DEBUGFS
|
||||||
|
#define TX_STAT_INC(q, c) sc->debug.stats.txstats[q].c++
|
||||||
|
#else
|
||||||
|
#define TX_STAT_INC(q, c) do { } while (0)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#ifdef CONFIG_ATH9K_DEBUG
|
||||||
|
+#ifdef CONFIG_ATH9K_DEBUGFS
|
||||||
|
|
||||||
|
/**
|
||||||
|
* struct ath_interrupt_stats - Contains statistics about interrupts
|
||||||
|
@@ -186,6 +186,6 @@ static inline void ath_debug_stat_retrie
|
||||||
|
{
|
||||||
|
}
|
||||||
|
|
||||||
|
-#endif /* CONFIG_ATH9K_DEBUG */
|
||||||
|
+#endif /* CONFIG_ATH9K_DEBUGFS */
|
||||||
|
|
||||||
|
#endif /* DEBUG_H */
|
@ -1,8 +1,8 @@
|
|||||||
--- a/drivers/net/wireless/ath/ath9k/debug.c
|
--- a/drivers/net/wireless/ath/ath9k/debug.c
|
||||||
+++ b/drivers/net/wireless/ath/ath9k/debug.c
|
+++ b/drivers/net/wireless/ath/ath9k/debug.c
|
||||||
@@ -71,6 +71,90 @@ static const struct file_operations fops
|
@@ -75,6 +75,90 @@ static const struct file_operations fops
|
||||||
.owner = THIS_MODULE
|
|
||||||
};
|
#endif
|
||||||
|
|
||||||
+static ssize_t read_file_tx_chainmask(struct file *file, char __user *user_buf,
|
+static ssize_t read_file_tx_chainmask(struct file *file, char __user *user_buf,
|
||||||
+ size_t count, loff_t *ppos)
|
+ size_t count, loff_t *ppos)
|
||||||
@ -91,9 +91,9 @@
|
|||||||
static ssize_t read_file_dma(struct file *file, char __user *user_buf,
|
static ssize_t read_file_dma(struct file *file, char __user *user_buf,
|
||||||
size_t count, loff_t *ppos)
|
size_t count, loff_t *ppos)
|
||||||
{
|
{
|
||||||
@@ -568,6 +652,16 @@ int ath9k_init_debug(struct ath_hw *ah)
|
@@ -574,6 +658,16 @@ int ath9k_init_debug(struct ath_hw *ah)
|
||||||
if (!sc->debug.debugfs_debug)
|
|
||||||
goto err;
|
goto err;
|
||||||
|
#endif
|
||||||
|
|
||||||
+ sc->debug.debugfs_rx_chainmask = debugfs_create_file("rx_chainmask",
|
+ sc->debug.debugfs_rx_chainmask = debugfs_create_file("rx_chainmask",
|
||||||
+ S_IRUSR | S_IWUSR, sc->debug.debugfs_phy, sc, &fops_rx_chainmask);
|
+ S_IRUSR | S_IWUSR, sc->debug.debugfs_phy, sc, &fops_rx_chainmask);
|
||||||
@ -108,7 +108,7 @@
|
|||||||
sc->debug.debugfs_dma = debugfs_create_file("dma", S_IRUSR,
|
sc->debug.debugfs_dma = debugfs_create_file("dma", S_IRUSR,
|
||||||
sc->debug.debugfs_phy, sc, &fops_dma);
|
sc->debug.debugfs_phy, sc, &fops_dma);
|
||||||
if (!sc->debug.debugfs_dma)
|
if (!sc->debug.debugfs_dma)
|
||||||
@@ -611,6 +705,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
|
@@ -617,6 +711,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
|
||||||
struct ath_common *common = ath9k_hw_common(ah);
|
struct ath_common *common = ath9k_hw_common(ah);
|
||||||
struct ath_softc *sc = (struct ath_softc *) common->priv;
|
struct ath_softc *sc = (struct ath_softc *) common->priv;
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/wireless/ath/ath9k/debug.c
|
--- a/drivers/net/wireless/ath/ath9k/debug.c
|
||||||
+++ b/drivers/net/wireless/ath/ath9k/debug.c
|
+++ b/drivers/net/wireless/ath/ath9k/debug.c
|
||||||
@@ -634,6 +634,86 @@ static const struct file_operations fops
|
@@ -638,6 +638,86 @@ static const struct file_operations fops
|
||||||
.owner = THIS_MODULE
|
.owner = THIS_MODULE
|
||||||
};
|
};
|
||||||
|
|
||||||
@ -87,7 +87,7 @@
|
|||||||
int ath9k_init_debug(struct ath_hw *ah)
|
int ath9k_init_debug(struct ath_hw *ah)
|
||||||
{
|
{
|
||||||
struct ath_common *common = ath9k_hw_common(ah);
|
struct ath_common *common = ath9k_hw_common(ah);
|
||||||
@@ -694,6 +774,17 @@ int ath9k_init_debug(struct ath_hw *ah)
|
@@ -700,6 +780,17 @@ int ath9k_init_debug(struct ath_hw *ah)
|
||||||
if (!sc->debug.debugfs_xmit)
|
if (!sc->debug.debugfs_xmit)
|
||||||
goto err;
|
goto err;
|
||||||
|
|
||||||
@ -105,7 +105,7 @@
|
|||||||
return 0;
|
return 0;
|
||||||
err:
|
err:
|
||||||
ath9k_exit_debug(ah);
|
ath9k_exit_debug(ah);
|
||||||
@@ -707,6 +798,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
|
@@ -713,6 +804,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
|
||||||
|
|
||||||
debugfs_remove(sc->debug.debugfs_tx_chainmask);
|
debugfs_remove(sc->debug.debugfs_tx_chainmask);
|
||||||
debugfs_remove(sc->debug.debugfs_rx_chainmask);
|
debugfs_remove(sc->debug.debugfs_rx_chainmask);
|
Loading…
Reference in New Issue
Block a user