mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
kernel: bump 4.14 to 4.14.128
Refreshed all patches. Compile-tested on: cns3xxx Runtime-tested on: cns3xxx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
parent
76c963bb01
commit
9ed98198cb
@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
|
||||
endif
|
||||
|
||||
LINUX_VERSION-4.9 = .180
|
||||
LINUX_VERSION-4.14 = .127
|
||||
LINUX_VERSION-4.14 = .128
|
||||
LINUX_VERSION-4.19 = .48
|
||||
|
||||
LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
|
||||
LINUX_KERNEL_HASH-4.14.127 = d7464c2379cdee46548ae9f848671f4669d4003af4034f3f738f2f0511ec75b3
|
||||
LINUX_KERNEL_HASH-4.14.128 = e93c2c754f1f9c610314b2fe9f27a9636ad3a7f43983469bb8e0f44a531f2913
|
||||
LINUX_KERNEL_HASH-4.19.48 = 01d0db4f10cc8e384241a605e29413e32c442aa6853c116877538b07c16893fa
|
||||
|
||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||
|
@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
||||
|
||||
--- a/drivers/rtc/rtc-pcf8523.c
|
||||
+++ b/drivers/rtc/rtc-pcf8523.c
|
||||
@@ -178,8 +178,28 @@ static int pcf8523_rtc_read_time(struct
|
||||
@@ -198,8 +198,28 @@ static int pcf8523_rtc_read_time(struct
|
||||
if (err < 0)
|
||||
return err;
|
||||
|
||||
@ -46,7 +46,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
||||
|
||||
tm->tm_sec = bcd2bin(regs[0] & 0x7f);
|
||||
tm->tm_min = bcd2bin(regs[1] & 0x7f);
|
||||
@@ -215,7 +235,6 @@ static int pcf8523_rtc_set_time(struct d
|
||||
@@ -235,7 +255,6 @@ static int pcf8523_rtc_set_time(struct d
|
||||
return err;
|
||||
|
||||
regs[0] = REG_SECONDS;
|
||||
|
@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
|
||||
|
||||
--- a/drivers/usb/serial/option.c
|
||||
+++ b/drivers/usb/serial/option.c
|
||||
@@ -1941,7 +1941,8 @@ static const struct usb_device_id option
|
||||
@@ -1947,7 +1947,8 @@ static const struct usb_device_id option
|
||||
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) }, /* D-Link DWM-156 (variant) */
|
||||
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
|
||||
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
|
||||
|
@ -63,7 +63,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
|
||||
/**
|
||||
* dwc2_enable_host_interrupts() - Enables the Host mode interrupts
|
||||
*
|
||||
@@ -3342,6 +3359,7 @@ static void dwc2_conn_id_status_change(s
|
||||
@@ -3346,6 +3363,7 @@ static void dwc2_conn_id_status_change(s
|
||||
|
||||
/* B-Device connector (Device Mode) */
|
||||
if (gotgctl & GOTGCTL_CONID_B) {
|
||||
@ -71,7 +71,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
|
||||
/* Wait for switch to device mode */
|
||||
dev_dbg(hsotg->dev, "connId B\n");
|
||||
if (hsotg->bus_suspended) {
|
||||
@@ -4448,6 +4466,9 @@ static int _dwc2_hcd_start(struct usb_hc
|
||||
@@ -4455,6 +4473,9 @@ static int _dwc2_hcd_start(struct usb_hc
|
||||
}
|
||||
|
||||
spin_unlock_irqrestore(&hsotg->lock, flags);
|
||||
@ -81,7 +81,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
|
||||
return 0;
|
||||
}
|
||||
|
||||
@@ -4475,6 +4496,8 @@ static void _dwc2_hcd_stop(struct usb_hc
|
||||
@@ -4482,6 +4503,8 @@ static void _dwc2_hcd_stop(struct usb_hc
|
||||
clear_bit(HCD_FLAG_HW_ACCESSIBLE, &hcd->flags);
|
||||
spin_unlock_irqrestore(&hsotg->lock, flags);
|
||||
|
||||
@ -90,7 +90,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
|
||||
usleep_range(1000, 3000);
|
||||
}
|
||||
|
||||
@@ -4511,6 +4534,7 @@ static int _dwc2_hcd_suspend(struct usb_
|
||||
@@ -4518,6 +4541,7 @@ static int _dwc2_hcd_suspend(struct usb_
|
||||
hprt0 |= HPRT0_SUSP;
|
||||
hprt0 &= ~HPRT0_PWR;
|
||||
dwc2_writel(hprt0, hsotg->regs + HPRT0);
|
||||
@ -98,7 +98,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
|
||||
}
|
||||
|
||||
/* Enter hibernation */
|
||||
@@ -4591,6 +4615,8 @@ static int _dwc2_hcd_resume(struct usb_h
|
||||
@@ -4598,6 +4622,8 @@ static int _dwc2_hcd_resume(struct usb_h
|
||||
spin_unlock_irqrestore(&hsotg->lock, flags);
|
||||
dwc2_port_resume(hsotg);
|
||||
} else {
|
||||
|
@ -42,7 +42,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
|
||||
|
||||
return regulator_enable(hsotg->vbus_supply);
|
||||
}
|
||||
@@ -4467,9 +4472,7 @@ static int _dwc2_hcd_start(struct usb_hc
|
||||
@@ -4474,9 +4479,7 @@ static int _dwc2_hcd_start(struct usb_hc
|
||||
|
||||
spin_unlock_irqrestore(&hsotg->lock, flags);
|
||||
|
||||
|
@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||
depends on BROKEN || !FRV
|
||||
--- a/kernel/Makefile
|
||||
+++ b/kernel/Makefile
|
||||
@@ -112,6 +112,7 @@ obj-$(CONFIG_CONTEXT_TRACKING) += contex
|
||||
@@ -113,6 +113,7 @@ obj-$(CONFIG_CONTEXT_TRACKING) += contex
|
||||
obj-$(CONFIG_TORTURE_TEST) += torture.o
|
||||
|
||||
obj-$(CONFIG_HAS_IOMEM) += memremap.o
|
||||
|
@ -30,9 +30,9 @@ Signed-off-by: Antti Seppälä <a.seppala@gmail.com>
|
||||
|
||||
if (!(urb->transfer_flags & URB_ALIGNED_TEMP_BUFFER))
|
||||
return;
|
||||
@@ -2677,9 +2678,14 @@ static void dwc2_free_dma_aligned_buffer
|
||||
memcpy(&stored_xfer_buffer, urb->transfer_buffer +
|
||||
urb->transfer_buffer_length, sizeof(urb->transfer_buffer));
|
||||
@@ -2679,9 +2680,14 @@ static void dwc2_free_dma_aligned_buffer
|
||||
dma_get_cache_alignment()),
|
||||
sizeof(urb->transfer_buffer));
|
||||
|
||||
- if (usb_urb_dir_in(urb))
|
||||
- memcpy(stored_xfer_buffer, urb->transfer_buffer,
|
||||
|
@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
||||
/**
|
||||
* ata_build_rw_tf - Build ATA taskfile for given read/write request
|
||||
* @tf: Target ATA taskfile
|
||||
@@ -5121,6 +5134,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
|
||||
@@ -5124,6 +5137,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
|
||||
if (tag < 0)
|
||||
return NULL;
|
||||
}
|
||||
@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
||||
|
||||
qc = __ata_qc_from_tag(ap, tag);
|
||||
qc->tag = tag;
|
||||
@@ -6022,6 +6038,9 @@ struct ata_port *ata_port_alloc(struct a
|
||||
@@ -6025,6 +6041,9 @@ struct ata_port *ata_port_alloc(struct a
|
||||
ap->stats.unhandled_irq = 1;
|
||||
ap->stats.idle_irq = 1;
|
||||
#endif
|
||||
@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
||||
ata_sff_port_init(ap);
|
||||
|
||||
return ap;
|
||||
@@ -6043,6 +6062,12 @@ static void ata_host_release(struct devi
|
||||
@@ -6046,6 +6065,12 @@ static void ata_host_release(struct devi
|
||||
|
||||
kfree(ap->pmp_link);
|
||||
kfree(ap->slave_link);
|
||||
@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
||||
kfree(ap);
|
||||
host->ports[i] = NULL;
|
||||
}
|
||||
@@ -6489,7 +6514,23 @@ int ata_host_register(struct ata_host *h
|
||||
@@ -6492,7 +6517,23 @@ int ata_host_register(struct ata_host *h
|
||||
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
|
||||
host->ports[i]->local_port_no = i + 1;
|
||||
}
|
||||
|
@ -93,7 +93,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
|
||||
|
||||
#include "io-pgtable.h"
|
||||
#include "arm-smmu-regs.h"
|
||||
@@ -1465,6 +1466,8 @@ static struct iommu_group *arm_smmu_devi
|
||||
@@ -1474,6 +1475,8 @@ static struct iommu_group *arm_smmu_devi
|
||||
|
||||
if (dev_is_pci(dev))
|
||||
group = pci_device_group(dev);
|
||||
@ -102,7 +102,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
|
||||
else
|
||||
group = generic_device_group(dev);
|
||||
|
||||
@@ -2043,6 +2046,10 @@ static void arm_smmu_bus_init(void)
|
||||
@@ -2052,6 +2055,10 @@ static void arm_smmu_bus_init(void)
|
||||
bus_set_iommu(&pci_bus_type, &arm_smmu_ops);
|
||||
}
|
||||
#endif
|
||||
|
@ -15,7 +15,7 @@
|
||||
/* initialize internal qc */
|
||||
|
||||
/* XXX: Tag 0 is used for drivers with legacy EH as some
|
||||
@@ -5128,6 +5136,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
|
||||
@@ -5131,6 +5139,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
|
||||
if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
|
||||
return NULL;
|
||||
|
||||
@ -25,7 +25,7 @@
|
||||
/* libsas case */
|
||||
if (ap->flags & ATA_FLAG_SAS_HOST) {
|
||||
tag = ata_sas_allocate_tag(ap);
|
||||
@@ -5173,6 +5184,8 @@ void ata_qc_free(struct ata_queued_cmd *
|
||||
@@ -5176,6 +5187,8 @@ void ata_qc_free(struct ata_queued_cmd *
|
||||
qc->tag = ATA_TAG_POISON;
|
||||
if (ap->flags & ATA_FLAG_SAS_HOST)
|
||||
ata_sas_free_tag(tag, ap);
|
||||
|
@ -18,7 +18,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
||||
|
||||
#include <linux/usb/hcd.h>
|
||||
#include <linux/usb/ch11.h>
|
||||
@@ -5206,6 +5207,8 @@ int dwc2_hcd_init(struct dwc2_hsotg *hso
|
||||
@@ -5215,6 +5216,8 @@ int dwc2_hcd_init(struct dwc2_hsotg *hso
|
||||
|
||||
retval = -ENOMEM;
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user