mirror of
https://github.com/openwrt/openwrt.git
synced 2025-03-30 15:46:31 +00:00
Add the RDC PCI ids for a fancier PCI device table.Return the system name on boot.
SVN-Revision: 9327
This commit is contained in:
parent
8c96b88b25
commit
9dc51096e6
target/linux/rdc
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Makefile for the RDC321x specific parts of the kernel
|
# Makefile for the RDC321x specific parts of the kernel
|
||||||
#
|
#
|
||||||
obj-$(CONFIG_X86_RDC) := gpio.o platform.o wdt.o
|
obj-$(CONFIG_X86_RDC) := gpio.o platform.o wdt.o setup.o
|
||||||
|
|
||||||
|
14
target/linux/rdc/files/arch/i386/mach-rdc/setup.c
Normal file
14
target/linux/rdc/files/arch/i386/mach-rdc/setup.c
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
/*
|
||||||
|
* Machine specific setup for generic
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include <linux/init.h>
|
||||||
|
#include <linux/interrupt.h>
|
||||||
|
#include <asm/arch_hooks.h>
|
||||||
|
#include <asm/io.h>
|
||||||
|
#include <asm/setup.h>
|
||||||
|
|
||||||
|
char * __init machine_specific_memory_setup(void)
|
||||||
|
{
|
||||||
|
return "RDC R-321x";
|
||||||
|
}
|
@ -67,7 +67,7 @@ diff -urN linux-2.6.19/arch/i386/Makefile linux-2.6.19.new/arch/i386/Makefile
|
|||||||
};
|
};
|
||||||
|
|
||||||
static struct device_fixup fixups_table[] = {
|
static struct device_fixup fixups_table[] = {
|
||||||
+{ 0x17F3, 0x6030, r8610_reset },
|
+{ PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_R6030, r8610_reset },
|
||||||
{ PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
|
{ PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
|
||||||
{ PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
|
{ PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
|
||||||
};
|
};
|
||||||
|
18
target/linux/rdc/patches/006-pci_ids.patch
Normal file
18
target/linux/rdc/patches/006-pci_ids.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
|
||||||
|
index 55f307f..4a1aa34 100644
|
||||||
|
--- a/include/linux/pci_ids.h
|
||||||
|
+++ b/include/linux/pci_ids.h
|
||||||
|
@@ -2076,6 +2076,13 @@
|
||||||
|
#define PCI_DEVICE_ID_HERC_WIN 0x5732
|
||||||
|
#define PCI_DEVICE_ID_HERC_UNI 0x5832
|
||||||
|
|
||||||
|
+#define PCI_VENDOR_ID_RDC 0x17f3
|
||||||
|
+#define PCI_DEVICE_ID_RDC_R6020 0x6020
|
||||||
|
+#define PCI_DEVICE_ID_RDC_R6030 0x6030
|
||||||
|
+#define PCI_DEVICE_ID_RDC_R6040 0x6040
|
||||||
|
+#define PCI_DEVICE_ID_RDC_R6060 0x6060
|
||||||
|
+#define PCI_DEVICE_ID_RDC_R6061 0x6061
|
||||||
|
+
|
||||||
|
#define PCI_VENDOR_ID_SITECOM 0x182d
|
||||||
|
#define PCI_DEVICE_ID_SITECOM_DC105V2 0x3069
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user