mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
mtd-utils: merge ubi/nand-utils into one package
Signed-off-by: John Crispin <john@phrozen.org>
This commit is contained in:
parent
17f4d3967e
commit
9352603fff
@ -7,17 +7,16 @@
|
|||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ubi-utils
|
PKG_NAME:=mtd-utils
|
||||||
PKG_REV:=7d2839b8dede3ae368780364b4a07473d2303219
|
PKG_REV:=aea36417067dade75192bafa03af70b6eb2677b1
|
||||||
PKG_VERSION:=1.5.1
|
PKG_VERSION:=1.5.2
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=git://git.infradead.org/mtd-utils.git
|
PKG_SOURCE_URL:=git://git.infradead.org/mtd-utils.git
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||||
PKG_MIRROR_MD5SUM:=69b68adcfcbe786584771e5978534ab4
|
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
@ -30,18 +29,31 @@ PKG_MAINTAINER:=John Crispin <john@phrozen.org>
|
|||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/ubi-utils
|
define Package/mtd-utils/Default
|
||||||
TITLE:=Utilities for ubi info/debug
|
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
URL:=http://www.linux-mtd.infradead.org/
|
URL:=http://www.linux-mtd.infradead.org/
|
||||||
DEPENDS:=@NAND_SUPPORT
|
DEPENDS:=@NAND_SUPPORT
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/ubi-utils
|
||||||
|
$(call Package/mtd-utils/Default)
|
||||||
|
TITLE:=Utilities for ubi info/debug
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/ubi-utils/description
|
define Package/ubi-utils/description
|
||||||
Utilities for manipulating memory technology devices.
|
Utilities for manipulating memory technology devices.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/nand-utils
|
||||||
|
$(call Package/mtd-utils/Default)
|
||||||
|
TITLE:=Utilities for nand flash read/write/test
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/nand-utils/description
|
||||||
|
Utilities for NAND devices.
|
||||||
|
endef
|
||||||
|
|
||||||
MAKE_FLAGS += \
|
MAKE_FLAGS += \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
BUILDDIR="$(PKG_BUILD_DIR)" \
|
BUILDDIR="$(PKG_BUILD_DIR)" \
|
||||||
@ -57,5 +69,11 @@ define Package/ubi-utils/install
|
|||||||
$(PKG_INSTALL_DIR)/usr/sbin/{ubinfo,ubinize,ubirename,ubirmvol,ubirsvol,ubiupdatevol} $(1)/usr/sbin/
|
$(PKG_INSTALL_DIR)/usr/sbin/{ubinfo,ubinize,ubirename,ubirmvol,ubirsvol,ubiupdatevol} $(1)/usr/sbin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/nand-utils/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
|
$(INSTALL_BIN) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/sbin/{nanddump,nandwrite,nandtest,mtdinfo} $(1)/usr/sbin/
|
||||||
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,ubi-utils))
|
$(eval $(call BuildPackage,ubi-utils))
|
||||||
|
$(eval $(call BuildPackage,nand-utils))
|
10
package/utils/mtd-utils/patches/100-fix_includes.patch
Normal file
10
package/utils/mtd-utils/patches/100-fix_includes.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- a/lib/libfec.c
|
||||||
|
+++ b/lib/libfec.c
|
||||||
|
@@ -45,6 +45,7 @@
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
#include <string.h>
|
||||||
|
+#include <sys/types.h>
|
||||||
|
|
||||||
|
/*
|
||||||
|
* stuff used for testing purposes only
|
@ -1,53 +0,0 @@
|
|||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=nand-utils
|
|
||||||
PKG_REV:=d9076259b7f2654599bdf3416ec8ce0ad3b22610
|
|
||||||
PKG_VERSION:=1.5.2
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=git://git.infradead.org/mtd-utils.git
|
|
||||||
PKG_SOURCE_PROTO:=git
|
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
|
|
||||||
PKG_LICENSE:=GPLv2
|
|
||||||
PKG_LICENSE_FILES:=
|
|
||||||
|
|
||||||
PKG_MAINTAINER:=Sergey Sergeev <adron@yapic.net>
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/nand-utils
|
|
||||||
TITLE:=Utilities for nand flash read/write/test
|
|
||||||
SECTION:=utils
|
|
||||||
CATEGORY:=Utilities
|
|
||||||
URL:=http://www.linux-mtd.infradead.org/
|
|
||||||
DEPENDS:=@NAND_SUPPORT
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/nand-utils/description
|
|
||||||
Utilities for NAND devices.
|
|
||||||
endef
|
|
||||||
|
|
||||||
MAKE_FLAGS += \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
BUILDDIR="$(PKG_BUILD_DIR)" \
|
|
||||||
LDLIBS+="$(LIBGCC_S)" \
|
|
||||||
WITHOUT_XATTR=1 \
|
|
||||||
WITHOUT_LZO=1
|
|
||||||
|
|
||||||
define Package/nand-utils/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
|
||||||
$(INSTALL_BIN) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/sbin/{nanddump,nandwrite,nandtest,mtdinfo} $(1)/usr/sbin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,nand-utils))
|
|
@ -1,30 +0,0 @@
|
|||||||
--- a/lib/libfec.c
|
|
||||||
+++ b/lib/libfec.c
|
|
||||||
@@ -45,6 +45,7 @@
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <string.h>
|
|
||||||
+#include <sys/types.h>
|
|
||||||
|
|
||||||
/*
|
|
||||||
* stuff used for testing purposes only
|
|
||||||
--- a/serve_image.c
|
|
||||||
+++ b/serve_image.c
|
|
||||||
@@ -3,7 +3,6 @@
|
|
||||||
|
|
||||||
#include <time.h>
|
|
||||||
#include <errno.h>
|
|
||||||
-#include <error.h>
|
|
||||||
#include <netdb.h>
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
--- a/recv_image.c
|
|
||||||
+++ b/recv_image.c
|
|
||||||
@@ -4,7 +4,6 @@
|
|
||||||
#define _BSD_SOURCE /* struct ip_mreq */
|
|
||||||
|
|
||||||
#include <errno.h>
|
|
||||||
-#include <error.h>
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <netdb.h>
|
|
||||||
#include <stdlib.h>
|
|
@ -1,41 +0,0 @@
|
|||||||
--- a/mkfs.ubifs/hashtable/hashtable_itr.c
|
|
||||||
+++ b/mkfs.ubifs/hashtable/hashtable_itr.c
|
|
||||||
@@ -35,18 +35,6 @@ hashtable_iterator(struct hashtable *h)
|
|
||||||
}
|
|
||||||
|
|
||||||
/*****************************************************************************/
|
|
||||||
-/* key - return the key of the (key,value) pair at the current position */
|
|
||||||
-/* value - return the value of the (key,value) pair at the current position */
|
|
||||||
-
|
|
||||||
-void *
|
|
||||||
-hashtable_iterator_key(struct hashtable_itr *i)
|
|
||||||
-{ return i->e->k; }
|
|
||||||
-
|
|
||||||
-void *
|
|
||||||
-hashtable_iterator_value(struct hashtable_itr *i)
|
|
||||||
-{ return i->e->v; }
|
|
||||||
-
|
|
||||||
-/*****************************************************************************/
|
|
||||||
/* advance - advance the iterator to the next element
|
|
||||||
* returns zero if advanced to end of table */
|
|
||||||
|
|
||||||
--- a/mkfs.ubifs/hashtable/hashtable_itr.h
|
|
||||||
+++ b/mkfs.ubifs/hashtable/hashtable_itr.h
|
|
||||||
@@ -28,7 +28,7 @@ hashtable_iterator(struct hashtable *h);
|
|
||||||
/* hashtable_iterator_key
|
|
||||||
* - return the value of the (key,value) pair at the current position */
|
|
||||||
|
|
||||||
-extern inline void *
|
|
||||||
+static inline void *
|
|
||||||
hashtable_iterator_key(struct hashtable_itr *i)
|
|
||||||
{
|
|
||||||
return i->e->k;
|
|
||||||
@@ -37,7 +37,7 @@ hashtable_iterator_key(struct hashtable_
|
|
||||||
/*****************************************************************************/
|
|
||||||
/* value - return the value of the (key,value) pair at the current position */
|
|
||||||
|
|
||||||
-extern inline void *
|
|
||||||
+static inline void *
|
|
||||||
hashtable_iterator_value(struct hashtable_itr *i)
|
|
||||||
{
|
|
||||||
return i->e->v;
|
|
Loading…
Reference in New Issue
Block a user