kernel: bump 5.10 to 5.10.183

All patches automatically rebased.

Deactivate new option CONFIG_DRM_RCAR_USE_LVDS by default.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
Hauke Mehrtens 2023-06-15 12:46:46 +02:00
parent ac5e37f832
commit 920f2d9237
13 changed files with 27 additions and 26 deletions

View File

@ -1,2 +1,2 @@
LINUX_VERSION-5.10 = .182
LINUX_KERNEL_HASH-5.10.182 = de8ec58929460e3a14c1b0502f4a449f24c988a7a4a03ff04a82fb2d665fe9f6
LINUX_VERSION-5.10 = .183
LINUX_KERNEL_HASH-5.10.183 = 409497c635caf49614de21950ec091eb621a5d5fe1f63fc418ef68ac38b56119

View File

@ -21,7 +21,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
--- a/drivers/dma/at_xdmac.c
+++ b/drivers/dma/at_xdmac.c
@@ -866,7 +866,7 @@ at_xdmac_interleaved_queue_desc(struct d
@@ -868,7 +868,7 @@ at_xdmac_interleaved_queue_desc(struct d
* match the one of another channel. If not, it could lead to spurious
* flag status.
*/
@ -30,7 +30,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
| AT_XDMAC_CC_DIF(0)
| AT_XDMAC_CC_SIF(0)
| AT_XDMAC_CC_MBSIZE_SIXTEEN
@@ -1048,7 +1048,7 @@ at_xdmac_prep_dma_memcpy(struct dma_chan
@@ -1053,7 +1053,7 @@ at_xdmac_prep_dma_memcpy(struct dma_chan
* match the one of another channel. If not, it could lead to spurious
* flag status.
*/
@ -39,7 +39,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
| AT_XDMAC_CC_DAM_INCREMENTED_AM
| AT_XDMAC_CC_SAM_INCREMENTED_AM
| AT_XDMAC_CC_DIF(0)
@@ -1154,7 +1154,7 @@ static struct at_xdmac_desc *at_xdmac_me
@@ -1160,7 +1160,7 @@ static struct at_xdmac_desc *at_xdmac_me
* match the one of another channel. If not, it could lead to spurious
* flag status.
*/

View File

@ -171,7 +171,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
csize = ffs(atchan->sconfig.dst_maxburst) - 1;
if (csize < 0) {
dev_err(chan2dev(chan), "invalid src maxburst value\n");
@@ -865,10 +909,12 @@ at_xdmac_interleaved_queue_desc(struct d
@@ -867,10 +911,12 @@ at_xdmac_interleaved_queue_desc(struct d
* ERRATA: Even if useless for memory transfers, the PERID has to not
* match the one of another channel. If not, it could lead to spurious
* flag status.
@ -186,7 +186,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
| AT_XDMAC_CC_MBSIZE_SIXTEEN
| AT_XDMAC_CC_TYPE_MEM_TRAN;
@@ -1047,12 +1093,14 @@ at_xdmac_prep_dma_memcpy(struct dma_chan
@@ -1052,12 +1098,14 @@ at_xdmac_prep_dma_memcpy(struct dma_chan
* ERRATA: Even if useless for memory transfers, the PERID has to not
* match the one of another channel. If not, it could lead to spurious
* flag status.
@ -203,7 +203,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
| AT_XDMAC_CC_MBSIZE_SIXTEEN
| AT_XDMAC_CC_TYPE_MEM_TRAN;
unsigned long irqflags;
@@ -1153,12 +1201,14 @@ static struct at_xdmac_desc *at_xdmac_me
@@ -1159,12 +1207,14 @@ static struct at_xdmac_desc *at_xdmac_me
* ERRATA: Even if useless for memory transfers, the PERID has to not
* match the one of another channel. If not, it could lead to spurious
* flag status.
@ -220,7 +220,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
| AT_XDMAC_CC_MBSIZE_SIXTEEN
| AT_XDMAC_CC_MEMSET_HW_MODE
| AT_XDMAC_CC_TYPE_MEM_TRAN;
@@ -1437,7 +1487,7 @@ at_xdmac_tx_status(struct dma_chan *chan
@@ -1443,7 +1493,7 @@ at_xdmac_tx_status(struct dma_chan *chan
mask = AT_XDMAC_CC_TYPE | AT_XDMAC_CC_DSYNC;
value = AT_XDMAC_CC_TYPE_PER_TRAN | AT_XDMAC_CC_DSYNC_PER2MEM;
if ((desc->lld.mbr_cfg & mask) == value) {
@ -229,7 +229,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
while (!(at_xdmac_chan_read(atchan, AT_XDMAC_CIS) & AT_XDMAC_CIS_FIS))
cpu_relax();
}
@@ -1495,7 +1545,7 @@ at_xdmac_tx_status(struct dma_chan *chan
@@ -1501,7 +1551,7 @@ at_xdmac_tx_status(struct dma_chan *chan
* FIFO flush ensures that data are really written.
*/
if ((desc->lld.mbr_cfg & mask) == value) {
@ -238,7 +238,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
while (!(at_xdmac_chan_read(atchan, AT_XDMAC_CIS) & AT_XDMAC_CIS_FIS))
cpu_relax();
}
@@ -1763,7 +1813,7 @@ static int at_xdmac_device_pause(struct
@@ -1758,7 +1808,7 @@ static int at_xdmac_device_pause(struct
return 0;
spin_lock_irqsave(&atchan->lock, flags);
@ -247,7 +247,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
while (at_xdmac_chan_read(atchan, AT_XDMAC_CC)
& (AT_XDMAC_CC_WRIP | AT_XDMAC_CC_RDIP))
cpu_relax();
@@ -1786,7 +1836,7 @@ static int at_xdmac_device_resume(struct
@@ -1781,7 +1831,7 @@ static int at_xdmac_device_resume(struct
return 0;
}
@ -256,7 +256,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
clear_bit(AT_XDMAC_CHAN_IS_PAUSED, &atchan->status);
spin_unlock_irqrestore(&atchan->lock, flags);
@@ -1995,6 +2045,10 @@ static int at_xdmac_probe(struct platfor
@@ -1993,6 +2043,10 @@ static int at_xdmac_probe(struct platfor
atxdmac->regs = base;
atxdmac->irq = irq;
@ -267,7 +267,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
atxdmac->clk = devm_clk_get(&pdev->dev, "dma_clk");
if (IS_ERR(atxdmac->clk)) {
dev_err(&pdev->dev, "can't get dma_clk\n");
@@ -2137,6 +2191,10 @@ static const struct dev_pm_ops atmel_xdm
@@ -2135,6 +2189,10 @@ static const struct dev_pm_ops atmel_xdm
static const struct of_device_id atmel_xdmac_dt_ids[] = {
{
.compatible = "atmel,sama5d4-dma",

View File

@ -71,7 +71,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
};
static inline void __iomem *at_xdmac_chan_reg_base(struct at_xdmac *atxdmac, unsigned int chan_nb)
@@ -2006,6 +2027,30 @@ static int atmel_xdmac_resume(struct dev
@@ -2004,6 +2025,30 @@ static int atmel_xdmac_resume(struct dev
}
#endif /* CONFIG_PM_SLEEP */
@ -102,7 +102,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
static int at_xdmac_probe(struct platform_device *pdev)
{
struct at_xdmac *atxdmac;
@@ -2150,6 +2195,8 @@ static int at_xdmac_probe(struct platfor
@@ -2148,6 +2193,8 @@ static int at_xdmac_probe(struct platfor
dev_info(&pdev->dev, "%d channels, mapped at 0x%p\n",
nr_channels, atxdmac->regs);

View File

@ -23,7 +23,7 @@ Link: https://lore.kernel.org/r/20210628120452.74408-4-eugen.hristev@microchip.c
CONFIG_ARCH_BCM=y
CONFIG_ARCH_BCM_CYGNUS=y
CONFIG_ARCH_BCM_HR2=y
@@ -967,6 +968,7 @@ CONFIG_APQ_MMCC_8084=y
@@ -966,6 +967,7 @@ CONFIG_APQ_MMCC_8084=y
CONFIG_MSM_GCC_8660=y
CONFIG_MSM_MMCC_8960=y
CONFIG_MSM_MMCC_8974=y

View File

@ -292,7 +292,7 @@
#endif /* _LINUX_TYPES_H */
--- a/net/ipv4/af_inet.c
+++ b/net/ipv4/af_inet.c
@@ -1469,8 +1469,8 @@ struct sk_buff *inet_gro_receive(struct
@@ -1471,8 +1471,8 @@ struct sk_buff *inet_gro_receive(struct
if (unlikely(ip_fast_csum((u8 *)iph, 5)))
goto out_unlock;

View File

@ -9,7 +9,7 @@ Subject: [PATCH] Added Device IDs for August DVB-T 205
--- a/drivers/media/usb/dvb-usb-v2/rtl28xxu.c
+++ b/drivers/media/usb/dvb-usb-v2/rtl28xxu.c
@@ -1953,6 +1953,10 @@ static const struct usb_device_id rtl28x
@@ -1973,6 +1973,10 @@ static const struct usb_device_id rtl28x
&rtl28xxu_props, "Compro VideoMate U650F", NULL) },
{ DVB_USB_DEVICE(USB_VID_KWORLD_2, 0xd394,
&rtl28xxu_props, "MaxMedia HU394-T", NULL) },

View File

@ -33,7 +33,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
#define USB_VENDOR_ID_BELKIN 0x050d
#define USB_DEVICE_ID_FLIP_KVM 0x3201
@@ -1280,6 +1283,9 @@
@@ -1281,6 +1284,9 @@
#define USB_VENDOR_ID_XAT 0x2505
#define USB_DEVICE_ID_XAT_CSR 0x0220

View File

@ -24,7 +24,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
--- a/Makefile
+++ b/Makefile
@@ -1378,6 +1378,9 @@ ifneq ($(dtstree),)
@@ -1382,6 +1382,9 @@ ifneq ($(dtstree),)
%.dtb: include/config/kernel.release scripts_dtc
$(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@

View File

@ -15,7 +15,7 @@ Signed-off-by: Nataliya Korovkina <malus.brandywine@gmail.com>
--- a/Makefile
+++ b/Makefile
@@ -1378,7 +1378,7 @@ ifneq ($(dtstree),)
@@ -1382,7 +1382,7 @@ ifneq ($(dtstree),)
%.dtb: include/config/kernel.release scripts_dtc
$(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@

View File

@ -1565,6 +1565,7 @@ CONFIG_DQL=y
# CONFIG_DRM_RADEON_USERPTR is not set
# CONFIG_DRM_RCAR_DW_HDMI is not set
# CONFIG_DRM_RCAR_LVDS is not set
# CONFIG_DRM_RCAR_USE_LVDS is not set
# CONFIG_DRM_SII902X is not set
# CONFIG_DRM_SII9234 is not set
# CONFIG_DRM_SIL_SII8620 is not set

View File

@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#include <linux/mutex.h>
#include <linux/err.h>
#include <linux/property.h>
@@ -3298,3 +3299,5 @@ static int __init regmap_initcall(void)
@@ -3300,3 +3301,5 @@ static int __init regmap_initcall(void)
return 0;
}
postcore_initcall(regmap_initcall);

View File

@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
@@ -3340,6 +3342,7 @@ static int packet_create(struct net *net
@@ -3342,6 +3344,7 @@ static int packet_create(struct net *net
mutex_init(&po->pg_vec_lock);
po->rollover = NULL;
po->prot_hook.func = packet_rcv;
@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
@@ -3980,6 +3983,16 @@ packet_setsockopt(struct socket *sock, i
@@ -3982,6 +3985,16 @@ packet_setsockopt(struct socket *sock, i
WRITE_ONCE(po->xmit, val ? packet_direct_xmit : dev_queue_xmit);
return 0;
}
@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
default:
return -ENOPROTOOPT;
}
@@ -4036,6 +4049,13 @@ static int packet_getsockopt(struct sock
@@ -4038,6 +4051,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;