mirror of
https://github.com/openwrt/openwrt.git
synced 2025-03-29 07:06:20 +00:00
dnsmasq: backport tweak ICMP ping logic for DHCPv4
Don't start ping-check of address in DHCP discover if there already exists a lease for the address. It has been reported under some circumstances android and netbooted windows devices can reply to ICMP pings if they have a lease and thus block the allocation of the IP address the device already has during boot. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
This commit is contained in:
parent
cca765f64c
commit
91d41b6305
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=dnsmasq
|
PKG_NAME:=dnsmasq
|
||||||
PKG_VERSION:=2.77
|
PKG_VERSION:=2.77
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/
|
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/
|
||||||
|
@ -0,0 +1,25 @@
|
|||||||
|
From 4bb68866a8aeb31db8100492bceae051e33be5d0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Simon Kelley <simon@thekelleys.org.uk>
|
||||||
|
Date: Thu, 15 Jun 2017 23:18:44 +0100
|
||||||
|
Subject: [PATCH] Tweak ICMP ping check logic for DHCPv4.
|
||||||
|
|
||||||
|
---
|
||||||
|
src/rfc2131.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/rfc2131.c b/src/rfc2131.c
|
||||||
|
index 1c850e5..75792da 100644
|
||||||
|
--- a/src/rfc2131.c
|
||||||
|
+++ b/src/rfc2131.c
|
||||||
|
@@ -1040,7 +1040,7 @@ size_t dhcp_reply(struct dhcp_context *context, char *iface_name, int int_index,
|
||||||
|
else if (have_config(config, CONFIG_DECLINED) &&
|
||||||
|
difftime(now, config->decline_time) < (float)DECLINE_BACKOFF)
|
||||||
|
my_syslog(MS_DHCP | LOG_WARNING, _("not using configured address %s because it was previously declined"), addrs);
|
||||||
|
- else if (!do_icmp_ping(now, config->addr, 0, loopback))
|
||||||
|
+ else if ((!lease || lease->addr.s_addr != config->addr.s_addr) && !do_icmp_ping(now, config->addr, 0, loopback))
|
||||||
|
my_syslog(MS_DHCP | LOG_WARNING, _("not using configured address %s because it is in use by another host"), addrs);
|
||||||
|
else
|
||||||
|
conf = config->addr;
|
||||||
|
--
|
||||||
|
1.9.1
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user