mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
kernel: bump 4.14 to 4.14.122
Refreshed all patches. Compile-tested on: ar71xx, cns3xxx, imx6, x86_64 Runtime-tested on: ar71xx, cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
parent
a0f7bdfc71
commit
8f6fd53db9
@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
|
|||||||
endif
|
endif
|
||||||
|
|
||||||
LINUX_VERSION-4.9 = .179
|
LINUX_VERSION-4.9 = .179
|
||||||
LINUX_VERSION-4.14 = .121
|
LINUX_VERSION-4.14 = .122
|
||||||
LINUX_VERSION-4.19 = .45
|
LINUX_VERSION-4.19 = .45
|
||||||
|
|
||||||
LINUX_KERNEL_HASH-4.9.179 = 532e4b7b0103806dad9124fd09d15d19594eca08e7f900e94ff805d3b4171ee3
|
LINUX_KERNEL_HASH-4.9.179 = 532e4b7b0103806dad9124fd09d15d19594eca08e7f900e94ff805d3b4171ee3
|
||||||
LINUX_KERNEL_HASH-4.14.121 = 2eecd6825a0998c8b6dd686cd4cd76e9f0d195bbace89f0b82495cc11ddb2884
|
LINUX_KERNEL_HASH-4.14.122 = c8a3f40ef877e18b3d2890e0954f2d81b6d012a7321836ca4e5b036ef93f68f5
|
||||||
LINUX_KERNEL_HASH-4.19.45 = eb31e62fbb30aaeedb892cecdd8ac9746d42cbbef2ef2356f9ca8e13514b9d2b
|
LINUX_KERNEL_HASH-4.19.45 = eb31e62fbb30aaeedb892cecdd8ac9746d42cbbef2ef2356f9ca8e13514b9d2b
|
||||||
|
|
||||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||||
|
@ -12,7 +12,7 @@
|
|||||||
# ZLIB_INFLATE; DECOMPRESS_GZIP is just a wrapper.)
|
# ZLIB_INFLATE; DECOMPRESS_GZIP is just a wrapper.)
|
||||||
--- a/lib/Makefile
|
--- a/lib/Makefile
|
||||||
+++ b/lib/Makefile
|
+++ b/lib/Makefile
|
||||||
@@ -135,6 +135,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
|
@@ -146,6 +146,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
|
||||||
obj-$(CONFIG_RAID6_PQ) += raid6/
|
obj-$(CONFIG_RAID6_PQ) += raid6/
|
||||||
obj-$(CONFIG_LZMA_COMPRESS) += lzma/
|
obj-$(CONFIG_LZMA_COMPRESS) += lzma/
|
||||||
obj-$(CONFIG_LZMA_DECOMPRESS) += lzma/
|
obj-$(CONFIG_LZMA_DECOMPRESS) += lzma/
|
||||||
|
@ -12,7 +12,7 @@
|
|||||||
/* For Max performance, the MRRS must be set to the largest supported
|
/* For Max performance, the MRRS must be set to the largest supported
|
||||||
--- a/include/linux/pci.h
|
--- a/include/linux/pci.h
|
||||||
+++ b/include/linux/pci.h
|
+++ b/include/linux/pci.h
|
||||||
@@ -845,7 +845,7 @@ enum pcie_bus_config_types {
|
@@ -847,7 +847,7 @@ enum pcie_bus_config_types {
|
||||||
PCIE_BUS_DEFAULT, /* ensure MPS matches upstream bridge */
|
PCIE_BUS_DEFAULT, /* ensure MPS matches upstream bridge */
|
||||||
PCIE_BUS_SAFE, /* use largest MPS boot-time devices support */
|
PCIE_BUS_SAFE, /* use largest MPS boot-time devices support */
|
||||||
PCIE_BUS_PERFORMANCE, /* use MPS and MRRS for best performance */
|
PCIE_BUS_PERFORMANCE, /* use MPS and MRRS for best performance */
|
||||||
|
@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
*/
|
*/
|
||||||
--- a/include/linux/skbuff.h
|
--- a/include/linux/skbuff.h
|
||||||
+++ b/include/linux/skbuff.h
|
+++ b/include/linux/skbuff.h
|
||||||
@@ -2512,6 +2512,10 @@ static inline int pskb_trim(struct sk_bu
|
@@ -2514,6 +2514,10 @@ static inline int pskb_trim(struct sk_bu
|
||||||
return (len < skb->len) ? __pskb_trim(skb, len) : 0;
|
return (len < skb->len) ? __pskb_trim(skb, len) : 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
/**
|
/**
|
||||||
* pskb_trim_unique - remove end from a paged unique (not cloned) buffer
|
* pskb_trim_unique - remove end from a paged unique (not cloned) buffer
|
||||||
* @skb: buffer to alter
|
* @skb: buffer to alter
|
||||||
@@ -2642,16 +2646,6 @@ static inline struct sk_buff *dev_alloc_
|
@@ -2645,16 +2649,6 @@ static inline struct sk_buff *dev_alloc_
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
|
@ -1119,7 +1119,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
|
|||||||
ifdef CONFIG_FUNCTION_TRACER
|
ifdef CONFIG_FUNCTION_TRACER
|
||||||
ORIG_CFLAGS := $(KBUILD_CFLAGS)
|
ORIG_CFLAGS := $(KBUILD_CFLAGS)
|
||||||
KBUILD_CFLAGS = $(subst $(CC_FLAGS_FTRACE),,$(ORIG_CFLAGS))
|
KBUILD_CFLAGS = $(subst $(CC_FLAGS_FTRACE),,$(ORIG_CFLAGS))
|
||||||
@@ -123,6 +133,8 @@ obj-$(CONFIG_ZSTD_COMPRESS) += zstd/
|
@@ -134,6 +144,8 @@ obj-$(CONFIG_ZSTD_COMPRESS) += zstd/
|
||||||
obj-$(CONFIG_ZSTD_DECOMPRESS) += zstd/
|
obj-$(CONFIG_ZSTD_DECOMPRESS) += zstd/
|
||||||
obj-$(CONFIG_XZ_DEC) += xz/
|
obj-$(CONFIG_XZ_DEC) += xz/
|
||||||
obj-$(CONFIG_RAID6_PQ) += raid6/
|
obj-$(CONFIG_RAID6_PQ) += raid6/
|
||||||
|
@ -9,7 +9,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
|
|
||||||
--- a/include/linux/skbuff.h
|
--- a/include/linux/skbuff.h
|
||||||
+++ b/include/linux/skbuff.h
|
+++ b/include/linux/skbuff.h
|
||||||
@@ -2476,7 +2476,7 @@ static inline int pskb_network_may_pull(
|
@@ -2478,7 +2478,7 @@ static inline int pskb_network_may_pull(
|
||||||
* NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
|
* NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
|
||||||
*/
|
*/
|
||||||
#ifndef NET_SKB_PAD
|
#ifndef NET_SKB_PAD
|
||||||
|
@ -32,7 +32,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
/* The Mellanox Tavor device gives false positive parity errors
|
/* The Mellanox Tavor device gives false positive parity errors
|
||||||
* Mark this device with a broken_parity_status, to allow
|
* Mark this device with a broken_parity_status, to allow
|
||||||
* PCI scanning code to "skip" this now blacklisted device.
|
* PCI scanning code to "skip" this now blacklisted device.
|
||||||
@@ -3077,6 +3078,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
@@ -3094,6 +3095,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
||||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65f9, quirk_intel_mc_errata);
|
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65f9, quirk_intel_mc_errata);
|
||||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65fa, quirk_intel_mc_errata);
|
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65fa, quirk_intel_mc_errata);
|
||||||
|
|
||||||
@ -40,7 +40,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
* Ivytown NTB BAR sizes are misreported by the hardware due to an erratum. To
|
* Ivytown NTB BAR sizes are misreported by the hardware due to an erratum. To
|
||||||
@@ -3133,6 +3135,8 @@ static void fixup_debug_report(struct pc
|
@@ -3150,6 +3152,8 @@ static void fixup_debug_report(struct pc
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -49,7 +49,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
/*
|
/*
|
||||||
* Some BIOS implementations leave the Intel GPU interrupts enabled,
|
* Some BIOS implementations leave the Intel GPU interrupts enabled,
|
||||||
* even though no one is handling them (f.e. i915 driver is never loaded).
|
* even though no one is handling them (f.e. i915 driver is never loaded).
|
||||||
@@ -3171,6 +3175,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
|
@@ -3188,6 +3192,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
|
||||||
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x010a, disable_igfx_irq);
|
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x010a, disable_igfx_irq);
|
||||||
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0152, disable_igfx_irq);
|
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0152, disable_igfx_irq);
|
||||||
|
|
||||||
|
@ -5494,7 +5494,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||||||
(transaction layer end-to-end CRC checking).
|
(transaction layer end-to-end CRC checking).
|
||||||
--- a/include/linux/pci.h
|
--- a/include/linux/pci.h
|
||||||
+++ b/include/linux/pci.h
|
+++ b/include/linux/pci.h
|
||||||
@@ -1302,6 +1302,8 @@ void pci_walk_bus(struct pci_bus *top, i
|
@@ -1304,6 +1304,8 @@ void pci_walk_bus(struct pci_bus *top, i
|
||||||
void *userdata);
|
void *userdata);
|
||||||
int pci_cfg_space_size(struct pci_dev *dev);
|
int pci_cfg_space_size(struct pci_dev *dev);
|
||||||
unsigned char pci_bus_max_busnr(struct pci_bus *bus);
|
unsigned char pci_bus_max_busnr(struct pci_bus *bus);
|
||||||
|
@ -241,7 +241,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
|
|||||||
void __kfree_skb(struct sk_buff *skb);
|
void __kfree_skb(struct sk_buff *skb);
|
||||||
extern struct kmem_cache *skbuff_head_cache;
|
extern struct kmem_cache *skbuff_head_cache;
|
||||||
|
|
||||||
@@ -3294,6 +3295,7 @@ static inline void skb_free_datagram_loc
|
@@ -3297,6 +3298,7 @@ static inline void skb_free_datagram_loc
|
||||||
}
|
}
|
||||||
int skb_kill_datagram(struct sock *sk, struct sk_buff *skb, unsigned int flags);
|
int skb_kill_datagram(struct sock *sk, struct sk_buff *skb, unsigned int flags);
|
||||||
int skb_copy_bits(const struct sk_buff *skb, int offset, void *to, int len);
|
int skb_copy_bits(const struct sk_buff *skb, int offset, void *to, int len);
|
||||||
|
@ -558,9 +558,9 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
|
|||||||
* them, we have to fall back to INTx or other interrupts, e.g., a
|
* them, we have to fall back to INTx or other interrupts, e.g., a
|
||||||
--- a/drivers/pci/quirks.c
|
--- a/drivers/pci/quirks.c
|
||||||
+++ b/drivers/pci/quirks.c
|
+++ b/drivers/pci/quirks.c
|
||||||
@@ -3376,6 +3376,13 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_A
|
@@ -3394,6 +3394,13 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_A
|
||||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_ATHEROS, 0x003c, quirk_no_bus_reset);
|
|
||||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_ATHEROS, 0x0033, quirk_no_bus_reset);
|
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_ATHEROS, 0x0033, quirk_no_bus_reset);
|
||||||
|
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_ATHEROS, 0x0034, quirk_no_bus_reset);
|
||||||
|
|
||||||
+/*
|
+/*
|
||||||
+ * NXP (Freescale Vendor ID) LS1088 chips do not behave correctly after
|
+ * NXP (Freescale Vendor ID) LS1088 chips do not behave correctly after
|
||||||
@ -572,9 +572,9 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
|
|||||||
static void quirk_no_pm_reset(struct pci_dev *dev)
|
static void quirk_no_pm_reset(struct pci_dev *dev)
|
||||||
{
|
{
|
||||||
/*
|
/*
|
||||||
@@ -4859,3 +4866,11 @@ static void quirk_no_ats(struct pci_dev
|
@@ -4878,3 +4885,11 @@ static void quirk_no_ats(struct pci_dev
|
||||||
/* AMD Stoney platform GPU */
|
|
||||||
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_ATI, 0x98e4, quirk_no_ats);
|
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_ATI, 0x98e4, quirk_no_ats);
|
||||||
|
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_ATI, 0x6900, quirk_no_ats);
|
||||||
#endif /* CONFIG_PCI_ATS */
|
#endif /* CONFIG_PCI_ATS */
|
||||||
+
|
+
|
||||||
+/* Freescale PCIe doesn't support MSI in RC mode */
|
+/* Freescale PCIe doesn't support MSI in RC mode */
|
||||||
@ -586,7 +586,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
|
|||||||
+DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_FREESCALE, PCI_ANY_ID, quirk_fsl_no_msi);
|
+DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_FREESCALE, PCI_ANY_ID, quirk_fsl_no_msi);
|
||||||
--- a/include/linux/pci.h
|
--- a/include/linux/pci.h
|
||||||
+++ b/include/linux/pci.h
|
+++ b/include/linux/pci.h
|
||||||
@@ -1944,6 +1944,7 @@ void pcibios_release_device(struct pci_d
|
@@ -1946,6 +1946,7 @@ void pcibios_release_device(struct pci_d
|
||||||
void pcibios_penalize_isa_irq(int irq, int active);
|
void pcibios_penalize_isa_irq(int irq, int active);
|
||||||
int pcibios_alloc_irq(struct pci_dev *dev);
|
int pcibios_alloc_irq(struct pci_dev *dev);
|
||||||
void pcibios_free_irq(struct pci_dev *dev);
|
void pcibios_free_irq(struct pci_dev *dev);
|
||||||
|
Loading…
Reference in New Issue
Block a user