mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-10 12:51:59 +00:00
uboot-mvebu: update to v2021.01
u-boot now detects emmc variants at runtime, we don't need to build seperate binaries anymore. Signed-off-by: Andre Heider <a.heider@gmail.com> Signed-off-by: maurerr <mariusd84@gmail.com>
This commit is contained in:
parent
1b12a5e4a9
commit
8d1b621451
@ -8,10 +8,10 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_VERSION:=2020.10
|
PKG_VERSION:=2021.01
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_HASH:=0d481bbdc05c0ee74908ec2f56a6daa53166cc6a78a0e4fac2ac5d025770a622
|
PKG_HASH:=b407e1510a74e863b8b5cb42a24625344f0e0c2fc7582d8c866bd899367d0454
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/u-boot.mk
|
include $(INCLUDE_DIR)/u-boot.mk
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
@ -42,13 +42,6 @@ define U-Boot/espressobin
|
|||||||
UBOOT_CONFIG:=mvebu_espressobin-88f3720
|
UBOOT_CONFIG:=mvebu_espressobin-88f3720
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define U-Boot/espressobin-emmc
|
|
||||||
NAME:=Marvell ESPRESSObin
|
|
||||||
BUILD_SUBTARGET:=cortexa53
|
|
||||||
UBOOT_CONFIG:=mvebu_espressobin-88f3720
|
|
||||||
UBOOT_MAKE_FLAGS+=DEVICE_TREE=armada-3720-espressobin-emmc
|
|
||||||
endef
|
|
||||||
|
|
||||||
define U-Boot/uDPU
|
define U-Boot/uDPU
|
||||||
NAME:=Methode uDPU
|
NAME:=Methode uDPU
|
||||||
BUILD_SUBTARGET:=cortexa53
|
BUILD_SUBTARGET:=cortexa53
|
||||||
@ -58,7 +51,6 @@ UBOOT_TARGETS:= \
|
|||||||
clearfog \
|
clearfog \
|
||||||
helios4 \
|
helios4 \
|
||||||
espressobin \
|
espressobin \
|
||||||
espressobin-emmc \
|
|
||||||
uDPU
|
uDPU
|
||||||
|
|
||||||
Build/Exports:=$(Host/Exports)
|
Build/Exports:=$(Host/Exports)
|
||||||
|
@ -1,64 +0,0 @@
|
|||||||
From cdcfd9211c805624a702b6ff81b9bd9515344749 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andre Heider <a.heider@gmail.com>
|
|
||||||
Date: Fri, 4 Sep 2020 16:34:22 +0200
|
|
||||||
Subject: [PATCH] arm64: dts: armada-3720-espressobin: use Linux
|
|
||||||
model/compatible strings
|
|
||||||
|
|
||||||
Fix the actual board vendor and ease synching dts files from Linux.
|
|
||||||
|
|
||||||
Signed-off-by: Andre Heider <a.heider@gmail.com>
|
|
||||||
---
|
|
||||||
arch/arm/dts/armada-3720-espressobin.dts | 4 ++--
|
|
||||||
board/Marvell/mvebu_armada-37xx/board.c | 8 ++++----
|
|
||||||
2 files changed, 6 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
--- a/arch/arm/dts/armada-3720-espressobin.dts
|
|
||||||
+++ b/arch/arm/dts/armada-3720-espressobin.dts
|
|
||||||
@@ -50,8 +50,8 @@
|
|
||||||
#include "armada-372x.dtsi"
|
|
||||||
|
|
||||||
/ {
|
|
||||||
- model = "Marvell Armada 3720 Community Board ESPRESSOBin";
|
|
||||||
- compatible = "marvell,armada-3720-espressobin", "marvell,armada3720", "marvell,armada3710";
|
|
||||||
+ model = "Globalscale Marvell ESPRESSOBin Board";
|
|
||||||
+ compatible = "globalscale,espressobin", "marvell,armada3720", "marvell,armada3710";
|
|
||||||
|
|
||||||
chosen {
|
|
||||||
stdout-path = "serial0:115200n8";
|
|
||||||
--- a/board/Marvell/mvebu_armada-37xx/board.c
|
|
||||||
+++ b/board/Marvell/mvebu_armada-37xx/board.c
|
|
||||||
@@ -88,14 +88,14 @@ int board_late_init(void)
|
|
||||||
if (env_get("fdtfile"))
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
- if (!of_machine_is_compatible("marvell,armada-3720-espressobin"))
|
|
||||||
+ if (!of_machine_is_compatible("globalscale,espressobin"))
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
/* If the memory controller has been configured for DDR4, we're running on v7 */
|
|
||||||
ddr4 = ((readl(A3700_CH0_MC_CTRL2_REG) >> A3700_MC_CTRL2_SDRAM_TYPE_OFFS)
|
|
||||||
& A3700_MC_CTRL2_SDRAM_TYPE_MASK) == A3700_MC_CTRL2_SDRAM_TYPE_DDR4;
|
|
||||||
|
|
||||||
- emmc = of_machine_is_compatible("marvell,armada-3720-espressobin-emmc");
|
|
||||||
+ emmc = of_machine_is_compatible("globalscale,espressobin-emmc");
|
|
||||||
|
|
||||||
if (ddr4 && emmc)
|
|
||||||
env_set("fdtfile", "marvell/armada-3720-espressobin-v7-emmc.dtb");
|
|
||||||
@@ -248,7 +248,7 @@ static int mii_multi_chip_mode_write(str
|
|
||||||
/* Bring-up board-specific network stuff */
|
|
||||||
int board_network_enable(struct mii_dev *bus)
|
|
||||||
{
|
|
||||||
- if (!of_machine_is_compatible("marvell,armada-3720-espressobin"))
|
|
||||||
+ if (!of_machine_is_compatible("globalscale,espressobin"))
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
/*
|
|
||||||
@@ -300,7 +300,7 @@ int ft_board_setup(void *blob, struct bd
|
|
||||||
int part_off;
|
|
||||||
|
|
||||||
/* Fill SPI MTD partitions for Linux kernel on Espressobin */
|
|
||||||
- if (!of_machine_is_compatible("marvell,armada-3720-espressobin"))
|
|
||||||
+ if (!of_machine_is_compatible("globalscale,espressobin"))
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
spi_off = fdt_node_offset_by_compatible(blob, -1, "jedec,spi-nor");
|
|
@ -1,368 +0,0 @@
|
|||||||
From a9ac1dd46a4fd11880be80227e1eb102e3c61dd8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andre Heider <a.heider@gmail.com>
|
|
||||||
Date: Fri, 4 Sep 2020 15:38:58 +0200
|
|
||||||
Subject: [PATCH] arm64: dts: armada-3720-espressobin: split common parts
|
|
||||||
to .dtsi
|
|
||||||
|
|
||||||
Move most of the dts to the new common armada-3720-espressobin.dtsi
|
|
||||||
file, just like Linux, but keep the current, downstream based, version.
|
|
||||||
|
|
||||||
The dts itself is imported from Linux.
|
|
||||||
|
|
||||||
Signed-off-by: Andre Heider <a.heider@gmail.com>
|
|
||||||
---
|
|
||||||
arch/arm/dts/armada-3720-espressobin.dts | 164 +--------------------
|
|
||||||
arch/arm/dts/armada-3720-espressobin.dtsi | 167 ++++++++++++++++++++++
|
|
||||||
2 files changed, 174 insertions(+), 157 deletions(-)
|
|
||||||
create mode 100644 arch/arm/dts/armada-3720-espressobin.dtsi
|
|
||||||
|
|
||||||
--- a/arch/arm/dts/armada-3720-espressobin.dts
|
|
||||||
+++ b/arch/arm/dts/armada-3720-espressobin.dts
|
|
||||||
@@ -1,170 +1,20 @@
|
|
||||||
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
||||||
/*
|
|
||||||
- * Device Tree file for Marvell Armada 3720 community board
|
|
||||||
- * (ESPRESSOBin)
|
|
||||||
+ * Device Tree file for Globalscale Marvell ESPRESSOBin Board
|
|
||||||
* Copyright (C) 2016 Marvell
|
|
||||||
*
|
|
||||||
- * Gregory CLEMENT <gregory.clement@free-electrons.com>
|
|
||||||
- * Konstantin Porotchkin <kostap@marvell.com>
|
|
||||||
+ * Romain Perier <romain.perier@free-electrons.com>
|
|
||||||
*
|
|
||||||
- * This file is dual-licensed: you can use it either under the terms
|
|
||||||
- * of the GPL or the X11 license, at your option. Note that this dual
|
|
||||||
- * licensing only applies to this file, and not this project as a
|
|
||||||
- * whole.
|
|
||||||
- *
|
|
||||||
- * a) This file is free software; you can redistribute it and/or
|
|
||||||
- * modify it under the terms of the GNU General Public License as
|
|
||||||
- * published by the Free Software Foundation; either version 2 of the
|
|
||||||
- * License, or (at your option) any later version.
|
|
||||||
- *
|
|
||||||
- * This file is distributed in the hope that it will be useful
|
|
||||||
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
||||||
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
||||||
- * GNU General Public License for more details.
|
|
||||||
- *
|
|
||||||
- * Or, alternatively
|
|
||||||
- *
|
|
||||||
- * b) Permission is hereby granted, free of charge, to any person
|
|
||||||
- * obtaining a copy of this software and associated documentation
|
|
||||||
- * files (the "Software"), to deal in the Software without
|
|
||||||
- * restriction, including without limitation the rights to use
|
|
||||||
- * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
||||||
- * sell copies of the Software, and to permit persons to whom the
|
|
||||||
- * Software is furnished to do so, subject to the following
|
|
||||||
- * conditions:
|
|
||||||
- *
|
|
||||||
- * The above copyright notice and this permission notice shall be
|
|
||||||
- * included in all copies or substantial portions of the Software.
|
|
||||||
- *
|
|
||||||
- * THE SOFTWARE IS PROVIDED , WITHOUT WARRANTY OF ANY KIND
|
|
||||||
- * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
||||||
- * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
||||||
- * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
||||||
- * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY
|
|
||||||
- * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
||||||
- * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
||||||
- * OTHER DEALINGS IN THE SOFTWARE.
|
|
||||||
+ */
|
|
||||||
+/*
|
|
||||||
+ * Schematic available at http://espressobin.net/wp-content/uploads/2017/08/ESPRESSObin_V5_Schematics.pdf
|
|
||||||
*/
|
|
||||||
|
|
||||||
/dts-v1/;
|
|
||||||
|
|
||||||
-#include "armada-372x.dtsi"
|
|
||||||
+#include "armada-3720-espressobin.dtsi"
|
|
||||||
|
|
||||||
/ {
|
|
||||||
model = "Globalscale Marvell ESPRESSOBin Board";
|
|
||||||
compatible = "globalscale,espressobin", "marvell,armada3720", "marvell,armada3710";
|
|
||||||
-
|
|
||||||
- chosen {
|
|
||||||
- stdout-path = "serial0:115200n8";
|
|
||||||
- };
|
|
||||||
-
|
|
||||||
- aliases {
|
|
||||||
- ethernet0 = ð0;
|
|
||||||
- i2c0 = &i2c0;
|
|
||||||
- spi0 = &spi0;
|
|
||||||
- };
|
|
||||||
-
|
|
||||||
- memory {
|
|
||||||
- device_type = "memory";
|
|
||||||
- reg = <0x00000000 0x00000000 0x00000000 0x20000000>;
|
|
||||||
- };
|
|
||||||
-
|
|
||||||
- vcc_sd_reg0: regulator@0 {
|
|
||||||
- compatible = "regulator-gpio";
|
|
||||||
- regulator-name = "vcc_sd0";
|
|
||||||
- regulator-min-microvolt = <1800000>;
|
|
||||||
- regulator-max-microvolt = <3300000>;
|
|
||||||
- regulator-type = "voltage";
|
|
||||||
- states = <1800000 0x1
|
|
||||||
- 3300000 0x0>;
|
|
||||||
- gpios = <&gpionb 4 GPIO_ACTIVE_HIGH>;
|
|
||||||
- };
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-&comphy {
|
|
||||||
- max-lanes = <3>;
|
|
||||||
- phy0 {
|
|
||||||
- phy-type = <PHY_TYPE_USB3_HOST0>;
|
|
||||||
- phy-speed = <PHY_SPEED_5G>;
|
|
||||||
- };
|
|
||||||
-
|
|
||||||
- phy1 {
|
|
||||||
- phy-type = <PHY_TYPE_PEX0>;
|
|
||||||
- phy-speed = <PHY_SPEED_2_5G>;
|
|
||||||
- };
|
|
||||||
-
|
|
||||||
- phy2 {
|
|
||||||
- phy-type = <PHY_TYPE_SATA0>;
|
|
||||||
- phy-speed = <PHY_SPEED_5G>;
|
|
||||||
- };
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-ð0 {
|
|
||||||
- status = "okay";
|
|
||||||
- pinctrl-names = "default";
|
|
||||||
- pinctrl-0 = <&rgmii_pins>, <&smi_pins>;
|
|
||||||
- phy-mode = "rgmii";
|
|
||||||
- phy_addr = <0x1>;
|
|
||||||
- fixed-link {
|
|
||||||
- speed = <1000>;
|
|
||||||
- full-duplex;
|
|
||||||
- };
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-&i2c0 {
|
|
||||||
- pinctrl-names = "default";
|
|
||||||
- pinctrl-0 = <&i2c1_pins>;
|
|
||||||
- status = "okay";
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-/* CON3 */
|
|
||||||
-&sata {
|
|
||||||
- status = "okay";
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-&sdhci0 {
|
|
||||||
- pinctrl-names = "default";
|
|
||||||
- pinctrl-0 = <&sdio_pins>;
|
|
||||||
- bus-width = <4>;
|
|
||||||
- cd-gpios = <&gpionb 3 GPIO_ACTIVE_LOW>;
|
|
||||||
- vqmmc-supply = <&vcc_sd_reg0>;
|
|
||||||
- status = "okay";
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-&spi0 {
|
|
||||||
- status = "okay";
|
|
||||||
- pinctrl-names = "default";
|
|
||||||
- pinctrl-0 = <&spi_quad_pins>;
|
|
||||||
-
|
|
||||||
- spi-flash@0 {
|
|
||||||
- #address-cells = <1>;
|
|
||||||
- #size-cells = <1>;
|
|
||||||
- compatible = "st,m25p128", "jedec,spi-nor";
|
|
||||||
- reg = <0>; /* Chip select 0 */
|
|
||||||
- spi-max-frequency = <50000000>;
|
|
||||||
- m25p,fast-read;
|
|
||||||
- };
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-/* Exported on the micro USB connector CON32 through an FTDI */
|
|
||||||
-&uart0 {
|
|
||||||
- pinctrl-names = "default";
|
|
||||||
- pinctrl-0 = <&uart1_pins>;
|
|
||||||
- status = "okay";
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-/* CON29 */
|
|
||||||
-&usb2 {
|
|
||||||
- status = "okay";
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-/* CON31 */
|
|
||||||
-&usb3 {
|
|
||||||
- status = "okay";
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-&pcie0 {
|
|
||||||
- pinctrl-names = "default";
|
|
||||||
- pinctrl-0 = <&pcie_pins>;
|
|
||||||
- reset-gpios = <&gpiosb 3 GPIO_ACTIVE_LOW>;
|
|
||||||
- status = "okay";
|
|
||||||
};
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/arch/arm/dts/armada-3720-espressobin.dtsi
|
|
||||||
@@ -0,0 +1,167 @@
|
|
||||||
+/*
|
|
||||||
+ * Device Tree file for Marvell Armada 3720 community board
|
|
||||||
+ * (ESPRESSOBin)
|
|
||||||
+ * Copyright (C) 2016 Marvell
|
|
||||||
+ *
|
|
||||||
+ * Gregory CLEMENT <gregory.clement@free-electrons.com>
|
|
||||||
+ * Konstantin Porotchkin <kostap@marvell.com>
|
|
||||||
+ *
|
|
||||||
+ * This file is dual-licensed: you can use it either under the terms
|
|
||||||
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
||||||
+ * licensing only applies to this file, and not this project as a
|
|
||||||
+ * whole.
|
|
||||||
+ *
|
|
||||||
+ * a) This file is free software; you can redistribute it and/or
|
|
||||||
+ * modify it under the terms of the GNU General Public License as
|
|
||||||
+ * published by the Free Software Foundation; either version 2 of the
|
|
||||||
+ * License, or (at your option) any later version.
|
|
||||||
+ *
|
|
||||||
+ * This file is distributed in the hope that it will be useful
|
|
||||||
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
||||||
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
||||||
+ * GNU General Public License for more details.
|
|
||||||
+ *
|
|
||||||
+ * Or, alternatively
|
|
||||||
+ *
|
|
||||||
+ * b) Permission is hereby granted, free of charge, to any person
|
|
||||||
+ * obtaining a copy of this software and associated documentation
|
|
||||||
+ * files (the "Software"), to deal in the Software without
|
|
||||||
+ * restriction, including without limitation the rights to use
|
|
||||||
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
||||||
+ * sell copies of the Software, and to permit persons to whom the
|
|
||||||
+ * Software is furnished to do so, subject to the following
|
|
||||||
+ * conditions:
|
|
||||||
+ *
|
|
||||||
+ * The above copyright notice and this permission notice shall be
|
|
||||||
+ * included in all copies or substantial portions of the Software.
|
|
||||||
+ *
|
|
||||||
+ * THE SOFTWARE IS PROVIDED , WITHOUT WARRANTY OF ANY KIND
|
|
||||||
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
||||||
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
||||||
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
||||||
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY
|
|
||||||
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
||||||
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
||||||
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
||||||
+ */
|
|
||||||
+
|
|
||||||
+/dts-v1/;
|
|
||||||
+
|
|
||||||
+#include "armada-372x.dtsi"
|
|
||||||
+
|
|
||||||
+/ {
|
|
||||||
+ chosen {
|
|
||||||
+ stdout-path = "serial0:115200n8";
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ aliases {
|
|
||||||
+ ethernet0 = ð0;
|
|
||||||
+ i2c0 = &i2c0;
|
|
||||||
+ spi0 = &spi0;
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ memory {
|
|
||||||
+ device_type = "memory";
|
|
||||||
+ reg = <0x00000000 0x00000000 0x00000000 0x20000000>;
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ vcc_sd_reg0: regulator@0 {
|
|
||||||
+ compatible = "regulator-gpio";
|
|
||||||
+ regulator-name = "vcc_sd0";
|
|
||||||
+ regulator-min-microvolt = <1800000>;
|
|
||||||
+ regulator-max-microvolt = <3300000>;
|
|
||||||
+ regulator-type = "voltage";
|
|
||||||
+ states = <1800000 0x1
|
|
||||||
+ 3300000 0x0>;
|
|
||||||
+ gpios = <&gpionb 4 GPIO_ACTIVE_HIGH>;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&comphy {
|
|
||||||
+ max-lanes = <3>;
|
|
||||||
+ phy0 {
|
|
||||||
+ phy-type = <PHY_TYPE_USB3_HOST0>;
|
|
||||||
+ phy-speed = <PHY_SPEED_5G>;
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ phy1 {
|
|
||||||
+ phy-type = <PHY_TYPE_PEX0>;
|
|
||||||
+ phy-speed = <PHY_SPEED_2_5G>;
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
+ phy2 {
|
|
||||||
+ phy-type = <PHY_TYPE_SATA0>;
|
|
||||||
+ phy-speed = <PHY_SPEED_5G>;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+ð0 {
|
|
||||||
+ status = "okay";
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&rgmii_pins>, <&smi_pins>;
|
|
||||||
+ phy-mode = "rgmii";
|
|
||||||
+ phy_addr = <0x1>;
|
|
||||||
+ fixed-link {
|
|
||||||
+ speed = <1000>;
|
|
||||||
+ full-duplex;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&i2c0 {
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&i2c1_pins>;
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+/* CON3 */
|
|
||||||
+&sata {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&sdhci0 {
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&sdio_pins>;
|
|
||||||
+ bus-width = <4>;
|
|
||||||
+ cd-gpios = <&gpionb 3 GPIO_ACTIVE_LOW>;
|
|
||||||
+ vqmmc-supply = <&vcc_sd_reg0>;
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&spi0 {
|
|
||||||
+ status = "okay";
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&spi_quad_pins>;
|
|
||||||
+
|
|
||||||
+ spi-flash@0 {
|
|
||||||
+ #address-cells = <1>;
|
|
||||||
+ #size-cells = <1>;
|
|
||||||
+ compatible = "st,m25p128", "jedec,spi-nor";
|
|
||||||
+ reg = <0>; /* Chip select 0 */
|
|
||||||
+ spi-max-frequency = <50000000>;
|
|
||||||
+ m25p,fast-read;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+/* Exported on the micro USB connector CON32 through an FTDI */
|
|
||||||
+&uart0 {
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&uart1_pins>;
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+/* CON29 */
|
|
||||||
+&usb2 {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+/* CON31 */
|
|
||||||
+&usb3 {
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+&pcie0 {
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&pcie_pins>;
|
|
||||||
+ reset-gpios = <&gpiosb 3 GPIO_ACTIVE_LOW>;
|
|
||||||
+ status = "okay";
|
|
||||||
+};
|
|
@ -1,91 +0,0 @@
|
|||||||
From 408bba2fb84ad0b02c3f9529065126b40899e256 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andre Heider <a.heider@gmail.com>
|
|
||||||
Date: Fri, 4 Sep 2020 15:44:41 +0200
|
|
||||||
Subject: [PATCH] arm64: dts: a3720: add support for espressobin with
|
|
||||||
populated emmc
|
|
||||||
|
|
||||||
Import armada-3720-espressobin-emmc.dts from Linux, but use sdhc1 for
|
|
||||||
emmc, since our dtsi is still based on downstream and sdhc0 is used for
|
|
||||||
the sd card.
|
|
||||||
|
|
||||||
Signed-off-by: Andre Heider <a.heider@gmail.com>
|
|
||||||
---
|
|
||||||
arch/arm/dts/Makefile | 1 +
|
|
||||||
arch/arm/dts/armada-3720-espressobin-emmc.dts | 44 +++++++++++++++++++
|
|
||||||
doc/README.marvell | 7 ++-
|
|
||||||
3 files changed, 50 insertions(+), 2 deletions(-)
|
|
||||||
create mode 100644 arch/arm/dts/armada-3720-espressobin-emmc.dts
|
|
||||||
|
|
||||||
--- a/arch/arm/dts/Makefile
|
|
||||||
+++ b/arch/arm/dts/Makefile
|
|
||||||
@@ -202,6 +202,7 @@ dtb-$(CONFIG_ARCH_TEGRA) += tegra20-harm
|
|
||||||
dtb-$(CONFIG_ARCH_MVEBU) += \
|
|
||||||
armada-3720-db.dtb \
|
|
||||||
armada-3720-espressobin.dtb \
|
|
||||||
+ armada-3720-espressobin-emmc.dtb \
|
|
||||||
armada-3720-turris-mox.dtb \
|
|
||||||
armada-3720-uDPU.dtb \
|
|
||||||
armada-375-db.dtb \
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/arch/arm/dts/armada-3720-espressobin-emmc.dts
|
|
||||||
@@ -0,0 +1,44 @@
|
|
||||||
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
|
|
||||||
+/*
|
|
||||||
+ * Device Tree file for Globalscale Marvell ESPRESSOBin Board with eMMC
|
|
||||||
+ * Copyright (C) 2018 Marvell
|
|
||||||
+ *
|
|
||||||
+ * Romain Perier <romain.perier@free-electrons.com>
|
|
||||||
+ * Konstantin Porotchkin <kostap@marvell.com>
|
|
||||||
+ *
|
|
||||||
+ */
|
|
||||||
+/*
|
|
||||||
+ * Schematic available at http://espressobin.net/wp-content/uploads/2017/08/ESPRESSObin_V5_Schematics.pdf
|
|
||||||
+ */
|
|
||||||
+
|
|
||||||
+/dts-v1/;
|
|
||||||
+
|
|
||||||
+#include "armada-3720-espressobin.dtsi"
|
|
||||||
+
|
|
||||||
+/ {
|
|
||||||
+ model = "Globalscale Marvell ESPRESSOBin Board (eMMC)";
|
|
||||||
+ compatible = "globalscale,espressobin-emmc", "globalscale,espressobin",
|
|
||||||
+ "marvell,armada3720", "marvell,armada3710";
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+/* U11 */
|
|
||||||
+&sdhci1 {
|
|
||||||
+ non-removable;
|
|
||||||
+ bus-width = <8>;
|
|
||||||
+ mmc-ddr-1_8v;
|
|
||||||
+ mmc-hs400-1_8v;
|
|
||||||
+ marvell,xenon-emmc;
|
|
||||||
+ marvell,xenon-tun-count = <9>;
|
|
||||||
+ marvell,pad-type = "fixed-1-8v";
|
|
||||||
+
|
|
||||||
+ pinctrl-names = "default";
|
|
||||||
+ pinctrl-0 = <&mmc_pins>;
|
|
||||||
+ status = "okay";
|
|
||||||
+
|
|
||||||
+ #address-cells = <1>;
|
|
||||||
+ #size-cells = <0>;
|
|
||||||
+ mmccard: mmccard@0 {
|
|
||||||
+ compatible = "mmc-card";
|
|
||||||
+ reg = <0>;
|
|
||||||
+ };
|
|
||||||
+};
|
|
||||||
--- a/doc/README.marvell
|
|
||||||
+++ b/doc/README.marvell
|
|
||||||
@@ -43,8 +43,11 @@ Build Procedure
|
|
||||||
In order to prevent this, the required device-tree MUST be set during compilation.
|
|
||||||
All device-tree files are located in ./arch/arm/dts/ folder.
|
|
||||||
|
|
||||||
- For other DB boards (MacchiatoBin, EspressoBin and 3700 DB board) compile u-boot with
|
|
||||||
- just default device-tree from defconfig using:
|
|
||||||
+ For the EspressoBin board with populated eMMC device use
|
|
||||||
+ # make DEVICE_TREE=armada-3720-espressobin-emmc
|
|
||||||
+
|
|
||||||
+ For other DB boards (MacchiatoBin, EspressoBin without soldered eMMC and 3700 DB board)
|
|
||||||
+ compile u-boot with just default device-tree from defconfig using:
|
|
||||||
|
|
||||||
# make
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user