mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-21 12:05:23 +00:00
layerscape: update ls-rcw to LSDK-18.06
The rcw source code had been migrated to codeaurora for LSDK-18.06 release and the future release. The source code had also involved ls1012ardb/ls1012afrdm/ ls1088ardb/ls2088ardb rcw, so we updated ls-rcw to LSDK-18.06, reworked the makefile and dropped ls-rcw-bin package in this patch. Also reworked ls-rcw patch to adapt to the latest source code. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
This commit is contained in:
parent
984cf8d89d
commit
89c4ed57b7
@ -1,99 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright 2017 NXP
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
include $(INCLUDE_DIR)/image.mk
|
|
||||||
|
|
||||||
PKG_NAME:=ls-rcw-bin
|
|
||||||
PKG_SOURCE_DATE:=2017-11-19
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
|
||||||
PKG_SOURCE_URL:=https://github.com/NXP/qoriq-rcw-bin.git
|
|
||||||
PKG_SOURCE_VERSION:=bf3ae3cb15829876007c553509501cdaa16745e7
|
|
||||||
PKG_MIRROR_HASH:=dc14a47e9529578c63d9ad2bf4e27ef565a055e4121ce2d1324c019f69074314
|
|
||||||
|
|
||||||
PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
|
|
||||||
PKG_FLAGS:=nonshared
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define rcw-bin/Default
|
|
||||||
TITLE:=
|
|
||||||
CONFIG:=
|
|
||||||
endef
|
|
||||||
|
|
||||||
define rcw-bin/ls1012ardb
|
|
||||||
TITLE=NXP LS1012ARDB RCW Binary
|
|
||||||
CONFIG=ls1012ardb/R_SPNH_3508/PBL_0x35_0x08_1000_250_1000_default.bin
|
|
||||||
endef
|
|
||||||
|
|
||||||
define rcw-bin/ls1088ardb
|
|
||||||
TITLE=NXP LS1088ARDB RCW Binary
|
|
||||||
CONFIG=ls1088ardb/FCQQQQQQQQ_PPP_H_0x1d_0x0d/PBL_QSPI_1600_700_2100_0x1d_0x0d.bin
|
|
||||||
endef
|
|
||||||
|
|
||||||
define rcw-bin/ls2088ardb
|
|
||||||
TITLE=NXP LS2088ARDB RCW Binary
|
|
||||||
CONFIG=ls2088ardb/FFFFFFFF_PP_HH_0x2a_0x41/PBL_0x2a_0x41_1800_700_1866_1600.bin
|
|
||||||
endef
|
|
||||||
|
|
||||||
define rcw-bin/ls1012afrdm
|
|
||||||
TITLE=NXP LS1012AFRDM RCW Binary
|
|
||||||
CONFIG=ls1012afrdm/N_SSNP_3305/PBL_0x33_0x05_800_250_1000_default.bin
|
|
||||||
endef
|
|
||||||
|
|
||||||
RCWS := \
|
|
||||||
ls1012ardb \
|
|
||||||
ls1088ardb \
|
|
||||||
ls2088ardb \
|
|
||||||
ls1012afrdm
|
|
||||||
|
|
||||||
define Package/rcw-bin/template
|
|
||||||
define Package/rcw-layerscape-$(1)
|
|
||||||
SECTION:=firmware
|
|
||||||
CATEGORY:=Firmware
|
|
||||||
DEPENDS:=@TARGET_layerscape
|
|
||||||
TITLE:=$(2)
|
|
||||||
VARIANT:=$(1)
|
|
||||||
endef
|
|
||||||
endef
|
|
||||||
|
|
||||||
define BuildRCWPackage
|
|
||||||
$(eval $(rcw-bin/Default))
|
|
||||||
$(eval $(rcw-bin/$(1)))
|
|
||||||
$(call Package/rcw-bin/template,$(1),$(TITLE))
|
|
||||||
endef
|
|
||||||
|
|
||||||
ifdef BUILD_VARIANT
|
|
||||||
$(eval $(call rcw-bin/$(BUILD_VARIANT)))
|
|
||||||
RCW_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
|
|
||||||
endif
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rcw-bin/install/default
|
|
||||||
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/$(RCW_CONFIG) $(STAGING_DIR_IMAGE)/$(1)-rcw.bin
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rcw-bin/install/template
|
|
||||||
define Package/rcw-layerscape-$(1)/install
|
|
||||||
$(call Package/rcw-bin/install/default,$(2))
|
|
||||||
endef
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(foreach r,$(RCWS), \
|
|
||||||
$(eval $(call Package/rcw-bin/install/template,$(r),$(r))) \
|
|
||||||
)
|
|
||||||
|
|
||||||
$(foreach r,$(RCWS), \
|
|
||||||
$(eval $(call BuildRCWPackage,$(r))) \
|
|
||||||
$(eval $(call BuildPackage,rcw-layerscape-$(r))) \
|
|
||||||
)
|
|
@ -6,87 +6,76 @@
|
|||||||
#
|
#
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/image.mk
|
|
||||||
|
|
||||||
PKG_NAME:=ls-rcw
|
PKG_NAME:=ls-rcw
|
||||||
PKG_SOURCE_DATE:=2017-12-01
|
PKG_VERSION:=lsdk-1806
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/qoriq-open-source/rcw.git
|
PKG_SOURCE_URL:=https://source.codeaurora.org/external/qoriq/qoriq-components/rcw
|
||||||
PKG_SOURCE_VERSION:=cbd5e66fcb850e821c8632578410ceba5733a49e
|
PKG_SOURCE_VERSION:=1f43bef4b4475d8e81c9b3b8c5bdd6c1ce8cfa6c
|
||||||
PKG_MIRROR_HASH:=4caad5e0ae2018a0a594f36e46e4a96698420956c64bb73656f380fd46733c3d
|
PKG_MIRROR_HASH:=a3b455bcc1f070c8e51f520e32b62cec5b05d772d7ae4a876d88fd5f278a7b1c
|
||||||
|
|
||||||
PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
|
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
|
||||||
|
|
||||||
PKG_FLAGS:=nonshared
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define rcw/Default
|
define Package/layerscape-rcw/Config
|
||||||
TITLE:=
|
define Package/layerscape-rcw-$(1)
|
||||||
CONFIG:=
|
SECTION:=firmware
|
||||||
|
CATEGORY:=Firmware
|
||||||
|
TITLE:=$(2)
|
||||||
|
DEPENDS:=@TARGET_layerscape
|
||||||
|
CONFIG:=$(3)
|
||||||
|
endef
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define rcw/ls1043ardb
|
define Package/layerscape-rcw/ls1012ardb
|
||||||
TITLE=RCW binary $(PKG_VERSION) for NXP ls1043ardb 64b/32b Dev Board
|
TITLE:=NXP LS1012ARDB RCW binary
|
||||||
CONFIG=ls1043ardb/RR_FQPP_1455/rcw_1600.bin
|
CONFIG:=ls1012ardb/R_SPNH_3508/rcw_1000_default.bin.swapped
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define rcw/ls1046ardb
|
define Package/layerscape-rcw/ls1012afrdm
|
||||||
TITLE=RCW binary $(PKG_VERSION) for NXP ls1046ardb 64b/32b Dev Board
|
TITLE:=NXP LS1012AFRDM RCW binary
|
||||||
CONFIG=ls1046ardb/RR_FFSSPPPH_1133_5559/rcw_1800_qspiboot.bin.swap
|
CONFIG:=ls1012afrdm/N_SSNP_3305/rcw_800.bin.swapped
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/layerscape-rcw/ls1043ardb
|
||||||
|
TITLE:=NXP LS1043ARDB RCW binary
|
||||||
|
CONFIG:=ls1043ardb/RR_FQPP_1455/rcw_1600.bin
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/layerscape-rcw/ls1046ardb
|
||||||
|
TITLE:=NXP LS1046ARDB RCW binary
|
||||||
|
CONFIG:=ls1046ardb/RR_FFSSPPPH_1133_5559/rcw_1800_qspiboot.bin.swapped
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/layerscape-rcw/ls1088ardb
|
||||||
|
TITLE:=NXP LS1088ARDB RCW binary
|
||||||
|
CONFIG:=ls1088ardb/FCQQQQQQQQ_PPP_H_0x1d_0x0d/rcw_1600_qspi.bin
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/layerscape-rcw/ls2088ardb
|
||||||
|
TITLE:=NXP LS2088ARDB RCW binary
|
||||||
|
CONFIG:=ls2088ardb/FFFFFFFF_PP_HH_0x2a_0x41/rcw_1800.bin
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/layerscape-rcw/Install
|
||||||
|
define Package/layerscape-rcw-$(1)/install
|
||||||
|
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/$(CONFIG) $(STAGING_DIR_IMAGE)/$(1)-rcw.bin
|
||||||
|
endef
|
||||||
endef
|
endef
|
||||||
|
|
||||||
RCWS := \
|
RCWS := \
|
||||||
|
ls1012ardb \
|
||||||
|
ls1012afrdm \
|
||||||
ls1043ardb \
|
ls1043ardb \
|
||||||
ls1046ardb
|
ls1046ardb \
|
||||||
|
ls1088ardb \
|
||||||
|
ls2088ardb
|
||||||
|
|
||||||
define Package/rcw/template
|
$(foreach rcw,$(RCWS), \
|
||||||
define Package/rcw-layerscape-$(1)
|
$(eval $(Package/layerscape-rcw/$(rcw))) \
|
||||||
SECTION:=firmware
|
$(eval $(call Package/layerscape-rcw/Config,$(rcw),$(TITLE),$(CONFIG))) \
|
||||||
CATEGORY:=Firmware
|
$(eval $(call Package/layerscape-rcw/Install,$(rcw))) \
|
||||||
DEPENDS:= @TARGET_layerscape
|
$(eval $(call BuildPackage,layerscape-rcw-$(rcw))) \
|
||||||
TITLE:=$(2)
|
|
||||||
URL:=http://git.freescale.com/git/cgit.cgi/ppc/sdk/rcw.git
|
|
||||||
VARIANT:=$(1)
|
|
||||||
MAINTAINER:=Jiang Yutang <jiangyutang1978@gmail.com>
|
|
||||||
endef
|
|
||||||
endef
|
|
||||||
|
|
||||||
define BuildRCWPackage
|
|
||||||
$(eval $(rcw/Default))
|
|
||||||
$(eval $(rcw/$(1)))
|
|
||||||
$(call Package/rcw/template,$(1),$(TITLE))
|
|
||||||
endef
|
|
||||||
|
|
||||||
ifdef BUILD_VARIANT
|
|
||||||
$(eval $(call rcw/$(BUILD_VARIANT)))
|
|
||||||
RCW_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
|
|
||||||
endif
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rcw/install/default
|
|
||||||
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/$(RCW_CONFIG) $(STAGING_DIR_IMAGE)/$(1)-rcw.bin
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rcw/install/template
|
|
||||||
define Package/rcw-layerscape-$(1)/install
|
|
||||||
$(call Package/rcw/install/default,$(2))
|
|
||||||
endef
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(foreach r,$(RCWS), \
|
|
||||||
$(eval $(call Package/rcw/install/template,$(r),$(r))) \
|
|
||||||
)
|
|
||||||
|
|
||||||
$(foreach r,$(RCWS), \
|
|
||||||
$(eval $(call BuildRCWPackage,$(r))) \
|
|
||||||
$(eval $(call BuildPackage,rcw-layerscape-$(r))) \
|
|
||||||
)
|
)
|
||||||
|
@ -1,31 +1,34 @@
|
|||||||
From ebded197f9c12168d61973043fd9ebd5d49528a8 Mon Sep 17 00:00:00 2001
|
From c87a500c45f36ad248b1298d63e590d1d7e74f12 Mon Sep 17 00:00:00 2001
|
||||||
From: Yangbo Lu <yangbo.lu@nxp.com>
|
From: Yangbo Lu <yangbo.lu@nxp.com>
|
||||||
Date: Mon, 25 Dec 2017 14:11:02 +0800
|
Date: Tue, 3 Jul 2018 11:06:47 +0800
|
||||||
Subject: [PATCH] rcw: add a python script for byte swapping
|
Subject: [PATCH] rcw: support byte swapping without tclsh tool
|
||||||
|
|
||||||
Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
||||||
---
|
---
|
||||||
Makefile | 2 ++
|
Makefile | 4 ----
|
||||||
byte_swap.py | 32 ++++++++++++++++++++++++++++++++
|
byte_swap.py | 32 ++++++++++++++++++++++++++++++++
|
||||||
2 files changed, 34 insertions(+)
|
qspi_swap.sh | 2 +-
|
||||||
|
3 files changed, 33 insertions(+), 5 deletions(-)
|
||||||
create mode 100755 byte_swap.py
|
create mode 100755 byte_swap.py
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index fb55c8b..27e3ba2 100644
|
index 9f0587e..393bb2c 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -11,6 +11,8 @@ all install clean:
|
@@ -13,10 +13,6 @@ TCLSH := $(shell command -v tclsh 2> /dev/null)
|
||||||
|
VER = $(shell git describe --tags)
|
||||||
|
|
||||||
|
all install clean:
|
||||||
|
-ifndef TCLSH
|
||||||
|
- $(error "tclsh is not available. please install it.")
|
||||||
|
- exit 1
|
||||||
|
-endif
|
||||||
@for board in $(BOARDS); do \
|
@for board in $(BOARDS); do \
|
||||||
$(MAKE) -C $$board $@ DESTDIR=$(DESTDIR)/$$board; \
|
$(MAKE) -C $$board $@ DESTDIR=$(DESTDIR)/$$board; \
|
||||||
done
|
done
|
||||||
+ chmod 755 ./byte_swap.py; \
|
|
||||||
+ ./byte_swap.py ls1046ardb/RR_FFSSPPPH_1133_5559/rcw_1800_qspiboot.bin 8
|
|
||||||
|
|
||||||
release: $(foreach board,$(BOARDS),rcw-$(board)-$(VER).tar.gz)
|
|
||||||
|
|
||||||
diff --git a/byte_swap.py b/byte_swap.py
|
diff --git a/byte_swap.py b/byte_swap.py
|
||||||
new file mode 100755
|
new file mode 100755
|
||||||
index 0000000..7ee4129
|
index 0000000..386310e
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/byte_swap.py
|
+++ b/byte_swap.py
|
||||||
@@ -0,0 +1,32 @@
|
@@ -0,0 +1,32 @@
|
||||||
@ -51,7 +54,7 @@ index 0000000..7ee4129
|
|||||||
+ tmp = file.read()
|
+ tmp = file.read()
|
||||||
+file.close()
|
+file.close()
|
||||||
+
|
+
|
||||||
+with open(file_name + '.swap','wb') as file:
|
+with open(file_name + '.swapped','wb') as file:
|
||||||
+ for i in range(0, len(tmp) - 1, byte):
|
+ for i in range(0, len(tmp) - 1, byte):
|
||||||
+ if(tmp[i:i+4].encode('hex')) == "08610040":
|
+ if(tmp[i:i+4].encode('hex')) == "08610040":
|
||||||
+ #print("PBI CRC command")
|
+ #print("PBI CRC command")
|
||||||
@ -60,7 +63,20 @@ index 0000000..7ee4129
|
|||||||
+ file.write(tmp[i:i+byte][::-1])
|
+ file.write(tmp[i:i+byte][::-1])
|
||||||
+file.close()
|
+file.close()
|
||||||
+
|
+
|
||||||
+print("Swapped file: " + file_name + '.swap')
|
+print("Swapped file: " + file_name + '.swapped')
|
||||||
|
diff --git a/qspi_swap.sh b/qspi_swap.sh
|
||||||
|
index 0b58e44..d23fd8b 100755
|
||||||
|
--- a/qspi_swap.sh
|
||||||
|
+++ b/qspi_swap.sh
|
||||||
|
@@ -9,7 +9,7 @@ do
|
||||||
|
if [ "$board_name" = "$current_dir" ]; then
|
||||||
|
if [ -e $filename ]; then
|
||||||
|
swapped_file="$filename.swapped"
|
||||||
|
- tclsh ../tools/byte_swap.tcl $filename $swapped_file 8
|
||||||
|
+ ../byte_swap.py $filename 8
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
done < $1
|
||||||
--
|
--
|
||||||
2.7.4
|
1.7.1
|
||||||
|
|
@ -79,7 +79,7 @@ endef
|
|||||||
|
|
||||||
define Device/ls1043ardb
|
define Device/ls1043ardb
|
||||||
DEVICE_TITLE := ls1043ardb-$(SUBTARGET)
|
DEVICE_TITLE := ls1043ardb-$(SUBTARGET)
|
||||||
DEVICE_PACKAGES += rcw-layerscape-ls1043ardb uboot-layerscape-$(SUBTARGET)-ls1043ardb \
|
DEVICE_PACKAGES += layerscape-rcw-ls1043ardb uboot-layerscape-$(SUBTARGET)-ls1043ardb \
|
||||||
layerscape-fman-ls1043ardb layerscape-ppa-ls1043ardb
|
layerscape-fman-ls1043ardb layerscape-ppa-ls1043ardb
|
||||||
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1043a-rdb-sdk
|
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1043a-rdb-sdk
|
||||||
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
|
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
|
||||||
@ -94,7 +94,7 @@ TARGET_DEVICES += ls1043ardb
|
|||||||
|
|
||||||
define Device/ls1046ardb
|
define Device/ls1046ardb
|
||||||
DEVICE_TITLE := ls1046ardb-$(SUBTARGET)
|
DEVICE_TITLE := ls1046ardb-$(SUBTARGET)
|
||||||
DEVICE_PACKAGES += rcw-layerscape-ls1046ardb uboot-layerscape-$(SUBTARGET)-ls1046ardb \
|
DEVICE_PACKAGES += layerscape-rcw-ls1046ardb uboot-layerscape-$(SUBTARGET)-ls1046ardb \
|
||||||
layerscape-fman-ls1046ardb layerscape-ppa-ls1046ardb
|
layerscape-fman-ls1046ardb layerscape-ppa-ls1046ardb
|
||||||
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1046a-rdb-sdk
|
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1046a-rdb-sdk
|
||||||
FILESYSTEMS := ubifs
|
FILESYSTEMS := ubifs
|
||||||
@ -114,7 +114,7 @@ TARGET_DEVICES += ls1046ardb
|
|||||||
|
|
||||||
define Device/ls1012ardb
|
define Device/ls1012ardb
|
||||||
DEVICE_TITLE := ls1012ardb-$(SUBTARGET)
|
DEVICE_TITLE := ls1012ardb-$(SUBTARGET)
|
||||||
DEVICE_PACKAGES += rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb \
|
DEVICE_PACKAGES += layerscape-rcw-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb \
|
||||||
kmod-ppfe layerscape-ppfe layerscape-ppa-ls1012ardb
|
kmod-ppfe layerscape-ppfe layerscape-ppa-ls1012ardb
|
||||||
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-rdb
|
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-rdb
|
||||||
FILESYSTEMS := ubifs
|
FILESYSTEMS := ubifs
|
||||||
@ -134,7 +134,7 @@ TARGET_DEVICES += ls1012ardb
|
|||||||
|
|
||||||
define Device/ls1012afrdm
|
define Device/ls1012afrdm
|
||||||
DEVICE_TITLE := ls1012afrdm-$(SUBTARGET)
|
DEVICE_TITLE := ls1012afrdm-$(SUBTARGET)
|
||||||
DEVICE_PACKAGES += rcw-layerscape-ls1012afrdm uboot-layerscape-$(SUBTARGET)-ls1012afrdm \
|
DEVICE_PACKAGES += layerscape-rcw-ls1012afrdm uboot-layerscape-$(SUBTARGET)-ls1012afrdm \
|
||||||
kmod-ppfe layerscape-ppfe layerscape-ppa-ls1012afrdm
|
kmod-ppfe layerscape-ppfe layerscape-ppa-ls1012afrdm
|
||||||
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-frdm
|
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-frdm
|
||||||
FILESYSTEMS := ubifs
|
FILESYSTEMS := ubifs
|
||||||
@ -155,7 +155,7 @@ TARGET_DEVICES += ls1012afrdm
|
|||||||
ifeq ($(SUBTARGET),armv8_64b)
|
ifeq ($(SUBTARGET),armv8_64b)
|
||||||
define Device/ls1088ardb
|
define Device/ls1088ardb
|
||||||
DEVICE_TITLE := ls1088ardb-$(SUBTARGET)
|
DEVICE_TITLE := ls1088ardb-$(SUBTARGET)
|
||||||
DEVICE_PACKAGES += rcw-layerscape-ls1088ardb uboot-layerscape-$(SUBTARGET)-ls1088ardb \
|
DEVICE_PACKAGES += layerscape-rcw-ls1088ardb uboot-layerscape-$(SUBTARGET)-ls1088ardb \
|
||||||
layerscape-mc-ls1088ardb layerscape-dpl-ls1088ardb restool \
|
layerscape-mc-ls1088ardb layerscape-dpl-ls1088ardb restool \
|
||||||
layerscape-ppa-ls1088ardb
|
layerscape-ppa-ls1088ardb
|
||||||
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1088a-rdb
|
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1088a-rdb
|
||||||
@ -178,7 +178,7 @@ TARGET_DEVICES += ls1088ardb
|
|||||||
|
|
||||||
define Device/ls2088ardb
|
define Device/ls2088ardb
|
||||||
DEVICE_TITLE := ls2088ardb-$(SUBTARGET)
|
DEVICE_TITLE := ls2088ardb-$(SUBTARGET)
|
||||||
DEVICE_PACKAGES += rcw-layerscape-ls2088ardb uboot-layerscape-$(SUBTARGET)-ls2088ardb \
|
DEVICE_PACKAGES += layerscape-rcw-ls2088ardb uboot-layerscape-$(SUBTARGET)-ls2088ardb \
|
||||||
layerscape-mc-ls2088ardb layerscape-dpl-ls2088ardb restool \
|
layerscape-mc-ls2088ardb layerscape-dpl-ls2088ardb restool \
|
||||||
layerscape-ppa-ls2088ardb
|
layerscape-ppa-ls2088ardb
|
||||||
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls2088a-rdb
|
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls2088a-rdb
|
||||||
|
Loading…
Reference in New Issue
Block a user