mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 13:48:06 +00:00
libs/zlib: bump to latest stable release 1.2.12 (CVE-2018-25032)
List of changes since previous release from 2018 is quite long: * Fix crc32.c to compile local functions only if used. * Check for cc masquerading as gcc or clang in configure. * Remove destructive aspects of make distclean. * Separate out address sanitizing from warnings in configure. * Eliminate use of ULL constants. * Add fallthrough comments for gcc. * Clean up minizip to reduce warnings for testing. * Fix unztell64() in minizip to work past 4GB. (Daniël Hörchner) * minizip warning fix if MAXU32 already defined. (gvollant) * Replace black/white with allow/block. (theresa-m) * Fix indentation in minizip's zip.c. * Improve portability of contrib/minizip. * Correct typo in blast.c. * Change macro name in inflate.c to avoid collision in VxWorks. * Clarify gz* function interfaces, referring to parameter names. * Fix error in comment on the polynomial representation of a byte. * Fix memory leak on error in gzlog.c. * Avoid adding empty gzip member after gzflush with Z_FINISH. * Explicitly note that the 32-bit check values are 32 bits. * Use ARM crc32 instructions if the ARM architecture has them. * Add use of the ARMv8 crc32 instructions when requested. * Correct comment in crc32.c. * Don't bother computing check value after successful inflateSync(). * Use atomic test and set, if available, for dynamic CRC tables. * Speed up software CRC-32 computation by a factor of 1.5 to 3. * Add crc32_combine_gen() and crc32_combine_op() for fast combines. * Add tables for crc32_combine(), to speed it up by a factor of 200. * Fix the zran.c example to work on a multiple-member gzip file. * Add gznorm.c example, which normalizes gzip files. * Show all the codes for the maximum tables size in enough.c. * Clarify that prefix codes are counted in enough.c. * Use inline function instead of macro for index in enough.c. * Clean up code style in enough.c, update version. * Use a macro for the printf format of big_t in enough.c. * Use a structure to make globals in enough.c evident. * Assure that the number of bits for deflatePrime() is valid. * Fix a bug that can crash deflate on some input when using Z_FIXED. * Correct the initialization requirements for deflateInit2(). * Emphasize the need to continue decompressing gzip members. * Add legal disclaimer to README. * Fix deflateEnd() to not report an error at start of raw deflate. * Remove old assembler code in which bugs have manifested. * Make the names in functions declarations identical to definitions. * Avoid an undefined behavior of memcpy() in _tr_stored_block(). * Avoid undefined behaviors of memcpy() in gz*printf(). * Avoid an undefined behavior of memcpy() in gzappend(). * Avoid the use of ptrdiff_t. * Handle case where inflateSync used when header never processed. * Don't compute check value for raw inflate if asked to validate. * Add address checking in clang to -w option of configure. * Return an error if the gzputs string length can't fit in an int. * Small speedup to inflate [psumbera]. * Update use of errno for newer Windows CE versions. * Avoid some conversion warnings in gzread.c and gzwrite.c. * Have Makefile return non-zero error code on test failure. * Avoid a conversion error in gzseek when off_t type too small. * Fix CLEAR_HASH macro to be usable as a single statement. * Fix bug when window full in deflate_stored(). * Limit hash table inserts after switch from stored deflate. * Permit a deflateParams() parameter change as soon as possible. * Cygwin does not have _wopen(), so do not create gzopen_w() there. Removed 006-fix-compressor-crash-on-certain-inputs.patch which was hotfix for CVE-2018-25032 and is now included in this release. This release is not available on @SF (yet?) so the sources are now pulled from GitHub. Fixes: CVE-2018-25032 Signed-off-by: Petr Štetiar <ynezz@true.cz>
This commit is contained in:
parent
09f6200198
commit
8839a939ee
@ -8,12 +8,13 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=zlib
|
PKG_NAME:=zlib
|
||||||
PKG_VERSION:=1.2.11
|
PKG_VERSION:=1.2.12
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=@SF/libpng http://www.zlib.net
|
PKG_SOURCE_URL:=https://github.com/madler/zlib
|
||||||
PKG_HASH:=4ff941449631ace0d4d203e3483be9dbc9da454084111f97ea0a2114e19bf066
|
PKG_MIRROR_HASH:=a162fc219763635f0c1591ec515d4b08684e4b0bfb4b1c8e65e4eab18d597c27
|
||||||
|
PKG_SOURCE_VERSION:=21767c654d31d2dccdde4330529775c6c5fd5389
|
||||||
|
|
||||||
PKG_LICENSE:=Zlib
|
PKG_LICENSE:=Zlib
|
||||||
PKG_LICENSE_FILES:=README
|
PKG_LICENSE_FILES:=README
|
||||||
|
@ -21,11 +21,9 @@ https://bugs.chromium.org/p/chromium/issues/detail?id=688601
|
|||||||
4 files changed, 166 insertions(+), 8 deletions(-)
|
4 files changed, 166 insertions(+), 8 deletions(-)
|
||||||
create mode 100644 contrib/arm/neon_adler32.c
|
create mode 100644 contrib/arm/neon_adler32.c
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index 0fe939df..8e75f664 100644
|
|
||||||
--- a/CMakeLists.txt
|
--- a/CMakeLists.txt
|
||||||
+++ b/CMakeLists.txt
|
+++ b/CMakeLists.txt
|
||||||
@@ -7,6 +7,7 @@ set(VERSION "1.2.11")
|
@@ -7,6 +7,7 @@ set(VERSION "1.2.12")
|
||||||
|
|
||||||
option(ASM686 "Enable building i686 assembly implementation")
|
option(ASM686 "Enable building i686 assembly implementation")
|
||||||
option(AMD64 "Enable building amd64 assembly implementation")
|
option(AMD64 "Enable building amd64 assembly implementation")
|
||||||
@ -94,23 +92,18 @@ index d0be4380..45ebaa4b 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
/* ========================================================================= */
|
/* ========================================================================= */
|
||||||
diff --git a/contrib/README.contrib b/contrib/README.contrib
|
|
||||||
index a411d5c3..3fd1d202 100644
|
|
||||||
--- a/contrib/README.contrib
|
--- a/contrib/README.contrib
|
||||||
+++ b/contrib/README.contrib
|
+++ b/contrib/README.contrib
|
||||||
@@ -12,6 +12,9 @@ amd64/ by Mikhail Teterin <mi@ALDAN.algebra.com>
|
@@ -8,6 +8,9 @@ ada/ by Dmitriy Anisimkov <anisim
|
||||||
asm code for AMD64
|
Support for Ada
|
||||||
See patch at http://www.freebsd.org/cgi/query-pr.cgi?pr=bin/96393
|
See http://zlib-ada.sourceforge.net/
|
||||||
|
|
||||||
+arm/ by Adenilson Cavalcanti <cavalcantii@chromium.org>
|
+arm/ by Adenilson Cavalcanti <cavalcantii@chromium.org>
|
||||||
+ ARM optimizations (NEON and ARMv8 code).
|
+ ARM optimizations (NEON and ARMv8 code).
|
||||||
+
|
+
|
||||||
asm686/ by Brian Raiter <breadbox@muppetlabs.com>
|
blast/ by Mark Adler <madler@alumni.caltech.edu>
|
||||||
asm code for Pentium and PPro/PII, using the AT&T (GNU as) syntax
|
Decompressor for output of PKWare Data Compression Library (DCL)
|
||||||
See http://www.muppetlabs.com/~breadbox/software/assembly.html
|
|
||||||
diff --git a/contrib/arm/neon_adler32.c b/contrib/arm/neon_adler32.c
|
|
||||||
new file mode 100644
|
|
||||||
index 00000000..f173a74f
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/contrib/arm/neon_adler32.c
|
+++ b/contrib/arm/neon_adler32.c
|
||||||
@@ -0,0 +1,137 @@
|
@@ -0,0 +1,137 @@
|
||||||
|
@ -1,343 +0,0 @@
|
|||||||
From 5c44459c3b28a9bd3283aaceab7c615f8020c531 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mark Adler <madler@alumni.caltech.edu>
|
|
||||||
Date: Tue, 17 Apr 2018 22:09:22 -0700
|
|
||||||
Subject: [PATCH] Fix a bug that can crash deflate on some input when using
|
|
||||||
Z_FIXED.
|
|
||||||
|
|
||||||
This bug was reported by Danilo Ramos of Eideticom, Inc. It has
|
|
||||||
lain in wait 13 years before being found! The bug was introduced
|
|
||||||
in zlib 1.2.2.2, with the addition of the Z_FIXED option. That
|
|
||||||
option forces the use of fixed Huffman codes. For rare inputs with
|
|
||||||
a large number of distant matches, the pending buffer into which
|
|
||||||
the compressed data is written can overwrite the distance symbol
|
|
||||||
table which it overlays. That results in corrupted output due to
|
|
||||||
invalid distances, and can result in out-of-bound accesses,
|
|
||||||
crashing the application.
|
|
||||||
|
|
||||||
The fix here combines the distance buffer and literal/length
|
|
||||||
buffers into a single symbol buffer. Now three bytes of pending
|
|
||||||
buffer space are opened up for each literal or length/distance
|
|
||||||
pair consumed, instead of the previous two bytes. This assures
|
|
||||||
that the pending buffer cannot overwrite the symbol table, since
|
|
||||||
the maximum fixed code compressed length/distance is 31 bits, and
|
|
||||||
since there are four bytes of pending space for every three bytes
|
|
||||||
of symbol space.
|
|
||||||
---
|
|
||||||
deflate.c | 74 ++++++++++++++++++++++++++++++++++++++++---------------
|
|
||||||
deflate.h | 25 +++++++++----------
|
|
||||||
trees.c | 50 +++++++++++--------------------------
|
|
||||||
3 files changed, 79 insertions(+), 70 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/deflate.c b/deflate.c
|
|
||||||
index 425babc00..19cba873a 100644
|
|
||||||
--- a/deflate.c
|
|
||||||
+++ b/deflate.c
|
|
||||||
@@ -255,11 +255,6 @@ int ZEXPORT deflateInit2_(strm, level, method, windowBits, memLevel, strategy,
|
|
||||||
int wrap = 1;
|
|
||||||
static const char my_version[] = ZLIB_VERSION;
|
|
||||||
|
|
||||||
- ushf *overlay;
|
|
||||||
- /* We overlay pending_buf and d_buf+l_buf. This works since the average
|
|
||||||
- * output size for (length,distance) codes is <= 24 bits.
|
|
||||||
- */
|
|
||||||
-
|
|
||||||
if (version == Z_NULL || version[0] != my_version[0] ||
|
|
||||||
stream_size != sizeof(z_stream)) {
|
|
||||||
return Z_VERSION_ERROR;
|
|
||||||
@@ -329,9 +324,47 @@ int ZEXPORT deflateInit2_(strm, level, method, windowBits, memLevel, strategy,
|
|
||||||
|
|
||||||
s->lit_bufsize = 1 << (memLevel + 6); /* 16K elements by default */
|
|
||||||
|
|
||||||
- overlay = (ushf *) ZALLOC(strm, s->lit_bufsize, sizeof(ush)+2);
|
|
||||||
- s->pending_buf = (uchf *) overlay;
|
|
||||||
- s->pending_buf_size = (ulg)s->lit_bufsize * (sizeof(ush)+2L);
|
|
||||||
+ /* We overlay pending_buf and sym_buf. This works since the average size
|
|
||||||
+ * for length/distance pairs over any compressed block is assured to be 31
|
|
||||||
+ * bits or less.
|
|
||||||
+ *
|
|
||||||
+ * Analysis: The longest fixed codes are a length code of 8 bits plus 5
|
|
||||||
+ * extra bits, for lengths 131 to 257. The longest fixed distance codes are
|
|
||||||
+ * 5 bits plus 13 extra bits, for distances 16385 to 32768. The longest
|
|
||||||
+ * possible fixed-codes length/distance pair is then 31 bits total.
|
|
||||||
+ *
|
|
||||||
+ * sym_buf starts one-fourth of the way into pending_buf. So there are
|
|
||||||
+ * three bytes in sym_buf for every four bytes in pending_buf. Each symbol
|
|
||||||
+ * in sym_buf is three bytes -- two for the distance and one for the
|
|
||||||
+ * literal/length. As each symbol is consumed, the pointer to the next
|
|
||||||
+ * sym_buf value to read moves forward three bytes. From that symbol, up to
|
|
||||||
+ * 31 bits are written to pending_buf. The closest the written pending_buf
|
|
||||||
+ * bits gets to the next sym_buf symbol to read is just before the last
|
|
||||||
+ * code is written. At that time, 31*(n-2) bits have been written, just
|
|
||||||
+ * after 24*(n-2) bits have been consumed from sym_buf. sym_buf starts at
|
|
||||||
+ * 8*n bits into pending_buf. (Note that the symbol buffer fills when n-1
|
|
||||||
+ * symbols are written.) The closest the writing gets to what is unread is
|
|
||||||
+ * then n+14 bits. Here n is lit_bufsize, which is 16384 by default, and
|
|
||||||
+ * can range from 128 to 32768.
|
|
||||||
+ *
|
|
||||||
+ * Therefore, at a minimum, there are 142 bits of space between what is
|
|
||||||
+ * written and what is read in the overlain buffers, so the symbols cannot
|
|
||||||
+ * be overwritten by the compressed data. That space is actually 139 bits,
|
|
||||||
+ * due to the three-bit fixed-code block header.
|
|
||||||
+ *
|
|
||||||
+ * That covers the case where either Z_FIXED is specified, forcing fixed
|
|
||||||
+ * codes, or when the use of fixed codes is chosen, because that choice
|
|
||||||
+ * results in a smaller compressed block than dynamic codes. That latter
|
|
||||||
+ * condition then assures that the above analysis also covers all dynamic
|
|
||||||
+ * blocks. A dynamic-code block will only be chosen to be emitted if it has
|
|
||||||
+ * fewer bits than a fixed-code block would for the same set of symbols.
|
|
||||||
+ * Therefore its average symbol length is assured to be less than 31. So
|
|
||||||
+ * the compressed data for a dynamic block also cannot overwrite the
|
|
||||||
+ * symbols from which it is being constructed.
|
|
||||||
+ */
|
|
||||||
+
|
|
||||||
+ s->pending_buf = (uchf *) ZALLOC(strm, s->lit_bufsize, 4);
|
|
||||||
+ s->pending_buf_size = (ulg)s->lit_bufsize * 4;
|
|
||||||
|
|
||||||
if (s->window == Z_NULL || s->prev == Z_NULL || s->head == Z_NULL ||
|
|
||||||
s->pending_buf == Z_NULL) {
|
|
||||||
@@ -340,8 +373,12 @@ int ZEXPORT deflateInit2_(strm, level, method, windowBits, memLevel, strategy,
|
|
||||||
deflateEnd (strm);
|
|
||||||
return Z_MEM_ERROR;
|
|
||||||
}
|
|
||||||
- s->d_buf = overlay + s->lit_bufsize/sizeof(ush);
|
|
||||||
- s->l_buf = s->pending_buf + (1+sizeof(ush))*s->lit_bufsize;
|
|
||||||
+ s->sym_buf = s->pending_buf + s->lit_bufsize;
|
|
||||||
+ s->sym_end = (s->lit_bufsize - 1) * 3;
|
|
||||||
+ /* We avoid equality with lit_bufsize*3 because of wraparound at 64K
|
|
||||||
+ * on 16 bit machines and because stored blocks are restricted to
|
|
||||||
+ * 64K-1 bytes.
|
|
||||||
+ */
|
|
||||||
|
|
||||||
s->level = level;
|
|
||||||
s->strategy = strategy;
|
|
||||||
@@ -552,7 +589,7 @@ int ZEXPORT deflatePrime (strm, bits, value)
|
|
||||||
|
|
||||||
if (deflateStateCheck(strm)) return Z_STREAM_ERROR;
|
|
||||||
s = strm->state;
|
|
||||||
- if ((Bytef *)(s->d_buf) < s->pending_out + ((Buf_size + 7) >> 3))
|
|
||||||
+ if (s->sym_buf < s->pending_out + ((Buf_size + 7) >> 3))
|
|
||||||
return Z_BUF_ERROR;
|
|
||||||
do {
|
|
||||||
put = Buf_size - s->bi_valid;
|
|
||||||
@@ -1113,7 +1150,6 @@ int ZEXPORT deflateCopy (dest, source)
|
|
||||||
#else
|
|
||||||
deflate_state *ds;
|
|
||||||
deflate_state *ss;
|
|
||||||
- ushf *overlay;
|
|
||||||
|
|
||||||
|
|
||||||
if (deflateStateCheck(source) || dest == Z_NULL) {
|
|
||||||
@@ -1133,8 +1169,7 @@ int ZEXPORT deflateCopy (dest, source)
|
|
||||||
ds->window = (Bytef *) ZALLOC(dest, ds->w_size, 2*sizeof(Byte));
|
|
||||||
ds->prev = (Posf *) ZALLOC(dest, ds->w_size, sizeof(Pos));
|
|
||||||
ds->head = (Posf *) ZALLOC(dest, ds->hash_size, sizeof(Pos));
|
|
||||||
- overlay = (ushf *) ZALLOC(dest, ds->lit_bufsize, sizeof(ush)+2);
|
|
||||||
- ds->pending_buf = (uchf *) overlay;
|
|
||||||
+ ds->pending_buf = (uchf *) ZALLOC(dest, ds->lit_bufsize, 4);
|
|
||||||
|
|
||||||
if (ds->window == Z_NULL || ds->prev == Z_NULL || ds->head == Z_NULL ||
|
|
||||||
ds->pending_buf == Z_NULL) {
|
|
||||||
@@ -1148,8 +1183,7 @@ int ZEXPORT deflateCopy (dest, source)
|
|
||||||
zmemcpy(ds->pending_buf, ss->pending_buf, (uInt)ds->pending_buf_size);
|
|
||||||
|
|
||||||
ds->pending_out = ds->pending_buf + (ss->pending_out - ss->pending_buf);
|
|
||||||
- ds->d_buf = overlay + ds->lit_bufsize/sizeof(ush);
|
|
||||||
- ds->l_buf = ds->pending_buf + (1+sizeof(ush))*ds->lit_bufsize;
|
|
||||||
+ ds->sym_buf = ds->pending_buf + ds->lit_bufsize;
|
|
||||||
|
|
||||||
ds->l_desc.dyn_tree = ds->dyn_ltree;
|
|
||||||
ds->d_desc.dyn_tree = ds->dyn_dtree;
|
|
||||||
@@ -1925,7 +1959,7 @@ local block_state deflate_fast(s, flush)
|
|
||||||
FLUSH_BLOCK(s, 1);
|
|
||||||
return finish_done;
|
|
||||||
}
|
|
||||||
- if (s->last_lit)
|
|
||||||
+ if (s->sym_next)
|
|
||||||
FLUSH_BLOCK(s, 0);
|
|
||||||
return block_done;
|
|
||||||
}
|
|
||||||
@@ -2056,7 +2090,7 @@ local block_state deflate_slow(s, flush)
|
|
||||||
FLUSH_BLOCK(s, 1);
|
|
||||||
return finish_done;
|
|
||||||
}
|
|
||||||
- if (s->last_lit)
|
|
||||||
+ if (s->sym_next)
|
|
||||||
FLUSH_BLOCK(s, 0);
|
|
||||||
return block_done;
|
|
||||||
}
|
|
||||||
@@ -2131,7 +2165,7 @@ local block_state deflate_rle(s, flush)
|
|
||||||
FLUSH_BLOCK(s, 1);
|
|
||||||
return finish_done;
|
|
||||||
}
|
|
||||||
- if (s->last_lit)
|
|
||||||
+ if (s->sym_next)
|
|
||||||
FLUSH_BLOCK(s, 0);
|
|
||||||
return block_done;
|
|
||||||
}
|
|
||||||
@@ -2170,7 +2204,7 @@ local block_state deflate_huff(s, flush)
|
|
||||||
FLUSH_BLOCK(s, 1);
|
|
||||||
return finish_done;
|
|
||||||
}
|
|
||||||
- if (s->last_lit)
|
|
||||||
+ if (s->sym_next)
|
|
||||||
FLUSH_BLOCK(s, 0);
|
|
||||||
return block_done;
|
|
||||||
}
|
|
||||||
diff --git a/deflate.h b/deflate.h
|
|
||||||
index 23ecdd312..d4cf1a98b 100644
|
|
||||||
--- a/deflate.h
|
|
||||||
+++ b/deflate.h
|
|
||||||
@@ -217,7 +217,7 @@ typedef struct internal_state {
|
|
||||||
/* Depth of each subtree used as tie breaker for trees of equal frequency
|
|
||||||
*/
|
|
||||||
|
|
||||||
- uchf *l_buf; /* buffer for literals or lengths */
|
|
||||||
+ uchf *sym_buf; /* buffer for distances and literals/lengths */
|
|
||||||
|
|
||||||
uInt lit_bufsize;
|
|
||||||
/* Size of match buffer for literals/lengths. There are 4 reasons for
|
|
||||||
@@ -239,13 +239,8 @@ typedef struct internal_state {
|
|
||||||
* - I can't count above 4
|
|
||||||
*/
|
|
||||||
|
|
||||||
- uInt last_lit; /* running index in l_buf */
|
|
||||||
-
|
|
||||||
- ushf *d_buf;
|
|
||||||
- /* Buffer for distances. To simplify the code, d_buf and l_buf have
|
|
||||||
- * the same number of elements. To use different lengths, an extra flag
|
|
||||||
- * array would be necessary.
|
|
||||||
- */
|
|
||||||
+ uInt sym_next; /* running index in sym_buf */
|
|
||||||
+ uInt sym_end; /* symbol table full when sym_next reaches this */
|
|
||||||
|
|
||||||
ulg opt_len; /* bit length of current block with optimal trees */
|
|
||||||
ulg static_len; /* bit length of current block with static trees */
|
|
||||||
@@ -325,20 +320,22 @@ void ZLIB_INTERNAL _tr_stored_block OF((deflate_state *s, charf *buf,
|
|
||||||
|
|
||||||
# define _tr_tally_lit(s, c, flush) \
|
|
||||||
{ uch cc = (c); \
|
|
||||||
- s->d_buf[s->last_lit] = 0; \
|
|
||||||
- s->l_buf[s->last_lit++] = cc; \
|
|
||||||
+ s->sym_buf[s->sym_next++] = 0; \
|
|
||||||
+ s->sym_buf[s->sym_next++] = 0; \
|
|
||||||
+ s->sym_buf[s->sym_next++] = cc; \
|
|
||||||
s->dyn_ltree[cc].Freq++; \
|
|
||||||
- flush = (s->last_lit == s->lit_bufsize-1); \
|
|
||||||
+ flush = (s->sym_next == s->sym_end); \
|
|
||||||
}
|
|
||||||
# define _tr_tally_dist(s, distance, length, flush) \
|
|
||||||
{ uch len = (uch)(length); \
|
|
||||||
ush dist = (ush)(distance); \
|
|
||||||
- s->d_buf[s->last_lit] = dist; \
|
|
||||||
- s->l_buf[s->last_lit++] = len; \
|
|
||||||
+ s->sym_buf[s->sym_next++] = dist; \
|
|
||||||
+ s->sym_buf[s->sym_next++] = dist >> 8; \
|
|
||||||
+ s->sym_buf[s->sym_next++] = len; \
|
|
||||||
dist--; \
|
|
||||||
s->dyn_ltree[_length_code[len]+LITERALS+1].Freq++; \
|
|
||||||
s->dyn_dtree[d_code(dist)].Freq++; \
|
|
||||||
- flush = (s->last_lit == s->lit_bufsize-1); \
|
|
||||||
+ flush = (s->sym_next == s->sym_end); \
|
|
||||||
}
|
|
||||||
#else
|
|
||||||
# define _tr_tally_lit(s, c, flush) flush = _tr_tally(s, 0, c)
|
|
||||||
diff --git a/trees.c b/trees.c
|
|
||||||
index 4f4a65011..decaeb7c3 100644
|
|
||||||
--- a/trees.c
|
|
||||||
+++ b/trees.c
|
|
||||||
@@ -416,7 +416,7 @@ local void init_block(s)
|
|
||||||
|
|
||||||
s->dyn_ltree[END_BLOCK].Freq = 1;
|
|
||||||
s->opt_len = s->static_len = 0L;
|
|
||||||
- s->last_lit = s->matches = 0;
|
|
||||||
+ s->sym_next = s->matches = 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
#define SMALLEST 1
|
|
||||||
@@ -948,7 +948,7 @@ void ZLIB_INTERNAL _tr_flush_block(s, buf, stored_len, last)
|
|
||||||
|
|
||||||
Tracev((stderr, "\nopt %lu(%lu) stat %lu(%lu) stored %lu lit %u ",
|
|
||||||
opt_lenb, s->opt_len, static_lenb, s->static_len, stored_len,
|
|
||||||
- s->last_lit));
|
|
||||||
+ s->sym_next / 3));
|
|
||||||
|
|
||||||
if (static_lenb <= opt_lenb) opt_lenb = static_lenb;
|
|
||||||
|
|
||||||
@@ -1017,8 +1017,9 @@ int ZLIB_INTERNAL _tr_tally (s, dist, lc)
|
|
||||||
unsigned dist; /* distance of matched string */
|
|
||||||
unsigned lc; /* match length-MIN_MATCH or unmatched char (if dist==0) */
|
|
||||||
{
|
|
||||||
- s->d_buf[s->last_lit] = (ush)dist;
|
|
||||||
- s->l_buf[s->last_lit++] = (uch)lc;
|
|
||||||
+ s->sym_buf[s->sym_next++] = dist;
|
|
||||||
+ s->sym_buf[s->sym_next++] = dist >> 8;
|
|
||||||
+ s->sym_buf[s->sym_next++] = lc;
|
|
||||||
if (dist == 0) {
|
|
||||||
/* lc is the unmatched char */
|
|
||||||
s->dyn_ltree[lc].Freq++;
|
|
||||||
@@ -1033,30 +1034,7 @@ int ZLIB_INTERNAL _tr_tally (s, dist, lc)
|
|
||||||
s->dyn_ltree[_length_code[lc]+LITERALS+1].Freq++;
|
|
||||||
s->dyn_dtree[d_code(dist)].Freq++;
|
|
||||||
}
|
|
||||||
-
|
|
||||||
-#ifdef TRUNCATE_BLOCK
|
|
||||||
- /* Try to guess if it is profitable to stop the current block here */
|
|
||||||
- if ((s->last_lit & 0x1fff) == 0 && s->level > 2) {
|
|
||||||
- /* Compute an upper bound for the compressed length */
|
|
||||||
- ulg out_length = (ulg)s->last_lit*8L;
|
|
||||||
- ulg in_length = (ulg)((long)s->strstart - s->block_start);
|
|
||||||
- int dcode;
|
|
||||||
- for (dcode = 0; dcode < D_CODES; dcode++) {
|
|
||||||
- out_length += (ulg)s->dyn_dtree[dcode].Freq *
|
|
||||||
- (5L+extra_dbits[dcode]);
|
|
||||||
- }
|
|
||||||
- out_length >>= 3;
|
|
||||||
- Tracev((stderr,"\nlast_lit %u, in %ld, out ~%ld(%ld%%) ",
|
|
||||||
- s->last_lit, in_length, out_length,
|
|
||||||
- 100L - out_length*100L/in_length));
|
|
||||||
- if (s->matches < s->last_lit/2 && out_length < in_length/2) return 1;
|
|
||||||
- }
|
|
||||||
-#endif
|
|
||||||
- return (s->last_lit == s->lit_bufsize-1);
|
|
||||||
- /* We avoid equality with lit_bufsize because of wraparound at 64K
|
|
||||||
- * on 16 bit machines and because stored blocks are restricted to
|
|
||||||
- * 64K-1 bytes.
|
|
||||||
- */
|
|
||||||
+ return (s->sym_next == s->sym_end);
|
|
||||||
}
|
|
||||||
|
|
||||||
/* ===========================================================================
|
|
||||||
@@ -1069,13 +1047,14 @@ local void compress_block(s, ltree, dtree)
|
|
||||||
{
|
|
||||||
unsigned dist; /* distance of matched string */
|
|
||||||
int lc; /* match length or unmatched char (if dist == 0) */
|
|
||||||
- unsigned lx = 0; /* running index in l_buf */
|
|
||||||
+ unsigned sx = 0; /* running index in sym_buf */
|
|
||||||
unsigned code; /* the code to send */
|
|
||||||
int extra; /* number of extra bits to send */
|
|
||||||
|
|
||||||
- if (s->last_lit != 0) do {
|
|
||||||
- dist = s->d_buf[lx];
|
|
||||||
- lc = s->l_buf[lx++];
|
|
||||||
+ if (s->sym_next != 0) do {
|
|
||||||
+ dist = s->sym_buf[sx++] & 0xff;
|
|
||||||
+ dist += (unsigned)(s->sym_buf[sx++] & 0xff) << 8;
|
|
||||||
+ lc = s->sym_buf[sx++];
|
|
||||||
if (dist == 0) {
|
|
||||||
send_code(s, lc, ltree); /* send a literal byte */
|
|
||||||
Tracecv(isgraph(lc), (stderr," '%c' ", lc));
|
|
||||||
@@ -1100,11 +1079,10 @@ local void compress_block(s, ltree, dtree)
|
|
||||||
}
|
|
||||||
} /* literal or match pair ? */
|
|
||||||
|
|
||||||
- /* Check that the overlay between pending_buf and d_buf+l_buf is ok: */
|
|
||||||
- Assert((uInt)(s->pending) < s->lit_bufsize + 2*lx,
|
|
||||||
- "pendingBuf overflow");
|
|
||||||
+ /* Check that the overlay between pending_buf and sym_buf is ok: */
|
|
||||||
+ Assert(s->pending < s->lit_bufsize + sx, "pendingBuf overflow");
|
|
||||||
|
|
||||||
- } while (lx < s->last_lit);
|
|
||||||
+ } while (sx < s->sym_next);
|
|
||||||
|
|
||||||
send_code(s, END_BLOCK, ltree);
|
|
||||||
}
|
|
Loading…
Reference in New Issue
Block a user