mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-21 12:05:23 +00:00
tfa-layerscape: fix fiptool's build
A missing '\' caused the remaining parameters not to be passed to make. This fixes the following error: | gcc -c [...] fiptool.c -o fiptool.o | In file included from fiptool.h:16, | from fiptool.c:19: |fiptool_platform.h:19:11: fatal error: openssl/sha.h: No such file or directory | 19 | # include <openssl/sha.h> | | ^~~~~~~~~~~~~~~ |compilation terminated. |make[3]: *** [Makefile:58: fiptool.o] Error 1 as the HOST_CFLAGS are no longer passed. then, HOST_CFLAGS is specified as a command argument, this is a specific problem of our built since appending these needs the override directive. Fixes: df28bfe03247 ("tfa-layerscape: Change to github and use the latest tag") Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
This commit is contained in:
parent
3f9526957b
commit
857345496b
@ -25,7 +25,7 @@ HOST_CFLAGS += -Wall -Werror -pedantic -std=c99
|
|||||||
define Host/Compile
|
define Host/Compile
|
||||||
$(MAKE) -C \
|
$(MAKE) -C \
|
||||||
$(HOST_BUILD_DIR)/tools/fiptool \
|
$(HOST_BUILD_DIR)/tools/fiptool \
|
||||||
PLAT_FIPTOOL_HELPER_MK="$(HOST_BUILD_DIR)/tools/nxp/plat_fiptool/plat_fiptool.mk"
|
PLAT_FIPTOOL_HELPER_MK="$(HOST_BUILD_DIR)/tools/nxp/plat_fiptool/plat_fiptool.mk" \
|
||||||
CFLAGS="$(HOST_CFLAGS)" \
|
CFLAGS="$(HOST_CFLAGS)" \
|
||||||
LDFLAGS="$(HOST_LDFLAGS)" \
|
LDFLAGS="$(HOST_LDFLAGS)" \
|
||||||
HOSTCCFLAGS="$(HOST_CFLAGS)"
|
HOSTCCFLAGS="$(HOST_CFLAGS)"
|
||||||
|
@ -88,3 +88,19 @@
|
|||||||
@${ECHO_BLANK_LINE}
|
@${ECHO_BLANK_LINE}
|
||||||
@echo "Built $@ successfully"
|
@echo "Built $@ successfully"
|
||||||
@${ECHO_BLANK_LINE}
|
@${ECHO_BLANK_LINE}
|
||||||
|
--- a/tools/nxp/plat_fiptool/plat_fiptool.mk 2023-05-20 22:28:28.079945619 +0200
|
||||||
|
+++ b/tools/nxp/plat_fiptool/plat_fiptool.mk 2023-05-20 22:26:59.443307771 +0200
|
||||||
|
@@ -22,11 +22,11 @@ INCLUDE_PATHS += -I${PLAT_DEF_UUID_OID_C
|
||||||
|
$(shell rm ${PLAT_DEF_UUID_CONFIG_FILE_PATH}/${PLAT_DEF_UUID_CONFIG_FILE_NAME}.o)
|
||||||
|
|
||||||
|
ifeq (${PLAT_DEF_OID},yes)
|
||||||
|
-HOSTCCFLAGS += -DPLAT_DEF_OID
|
||||||
|
+override HOSTCCFLAGS += -DPLAT_DEF_OID
|
||||||
|
endif
|
||||||
|
|
||||||
|
ifeq (${PLAT_DEF_UUID},yes)
|
||||||
|
-HOSTCCFLAGS += -DPLAT_DEF_FIP_UUID
|
||||||
|
+override HOSTCCFLAGS += -DPLAT_DEF_FIP_UUID
|
||||||
|
PLAT_OBJECTS += ${PLAT_DEF_UUID_CONFIG_FILE_PATH}/${PLAT_DEF_UUID_CONFIG_FILE_NAME}.o
|
||||||
|
endif
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user