mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-01 16:58:22 +00:00
ath25: refresh patches for kernel 5.4
Refresh patches to make them apply to kernel 5.4. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Signed-off-by: maurerr <mariusd84@gmail.com>
This commit is contained in:
parent
306ddb6dfe
commit
82769df02e
@ -52,7 +52,7 @@
|
|||||||
if (!ath25_board.radio)
|
if (!ath25_board.radio)
|
||||||
--- a/drivers/gpio/Kconfig
|
--- a/drivers/gpio/Kconfig
|
||||||
+++ b/drivers/gpio/Kconfig
|
+++ b/drivers/gpio/Kconfig
|
||||||
@@ -105,6 +105,13 @@ config GPIO_AMDPT
|
@@ -113,6 +113,13 @@ config GPIO_AMDPT
|
||||||
driver for GPIO functionality on Promontory IOHub
|
driver for GPIO functionality on Promontory IOHub
|
||||||
Require ACPI ASL code to enumerate as a platform device.
|
Require ACPI ASL code to enumerate as a platform device.
|
||||||
|
|
||||||
@ -68,14 +68,14 @@
|
|||||||
depends on (ARCH_ASPEED || COMPILE_TEST) && OF_GPIO
|
depends on (ARCH_ASPEED || COMPILE_TEST) && OF_GPIO
|
||||||
--- a/drivers/gpio/Makefile
|
--- a/drivers/gpio/Makefile
|
||||||
+++ b/drivers/gpio/Makefile
|
+++ b/drivers/gpio/Makefile
|
||||||
@@ -29,6 +29,7 @@ obj-$(CONFIG_GPIO_ALTERA) += gpio-alte
|
@@ -30,6 +30,7 @@ obj-$(CONFIG_GPIO_ALTERA) += gpio-alt
|
||||||
obj-$(CONFIG_GPIO_ALTERA_A10SR) += gpio-altera-a10sr.o
|
|
||||||
obj-$(CONFIG_GPIO_AMD8111) += gpio-amd8111.o
|
obj-$(CONFIG_GPIO_AMD8111) += gpio-amd8111.o
|
||||||
|
obj-$(CONFIG_GPIO_AMD_FCH) += gpio-amd-fch.o
|
||||||
obj-$(CONFIG_GPIO_AMDPT) += gpio-amdpt.o
|
obj-$(CONFIG_GPIO_AMDPT) += gpio-amdpt.o
|
||||||
+obj-$(CONFIG_GPIO_AR5312) += gpio-ar5312.o
|
+obj-$(CONFIG_GPIO_AR5312) += gpio-ar5312.o
|
||||||
obj-$(CONFIG_GPIO_ARIZONA) += gpio-arizona.o
|
obj-$(CONFIG_GPIO_ARIZONA) += gpio-arizona.o
|
||||||
obj-$(CONFIG_GPIO_ATH79) += gpio-ath79.o
|
|
||||||
obj-$(CONFIG_GPIO_ASPEED) += gpio-aspeed.o
|
obj-$(CONFIG_GPIO_ASPEED) += gpio-aspeed.o
|
||||||
|
obj-$(CONFIG_GPIO_ATH79) += gpio-ath79.o
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/drivers/gpio/gpio-ar5312.c
|
+++ b/drivers/gpio/gpio-ar5312.c
|
||||||
@@ -0,0 +1,121 @@
|
@@ -0,0 +1,121 @@
|
||||||
@ -202,7 +202,7 @@
|
|||||||
+subsys_initcall(ar5312_gpio_init);
|
+subsys_initcall(ar5312_gpio_init);
|
||||||
--- a/arch/mips/Kconfig
|
--- a/arch/mips/Kconfig
|
||||||
+++ b/arch/mips/Kconfig
|
+++ b/arch/mips/Kconfig
|
||||||
@@ -175,6 +175,7 @@ config ATH25
|
@@ -189,6 +189,7 @@ config ATH25
|
||||||
select CEVT_R4K
|
select CEVT_R4K
|
||||||
select CSRC_R4K
|
select CSRC_R4K
|
||||||
select DMA_NONCOHERENT
|
select DMA_NONCOHERENT
|
||||||
|
@ -75,7 +75,7 @@
|
|||||||
* workaround. Attempt to jump to the mips reset location -
|
* workaround. Attempt to jump to the mips reset location -
|
||||||
--- a/drivers/gpio/Kconfig
|
--- a/drivers/gpio/Kconfig
|
||||||
+++ b/drivers/gpio/Kconfig
|
+++ b/drivers/gpio/Kconfig
|
||||||
@@ -105,6 +105,13 @@ config GPIO_AMDPT
|
@@ -113,6 +113,13 @@ config GPIO_AMDPT
|
||||||
driver for GPIO functionality on Promontory IOHub
|
driver for GPIO functionality on Promontory IOHub
|
||||||
Require ACPI ASL code to enumerate as a platform device.
|
Require ACPI ASL code to enumerate as a platform device.
|
||||||
|
|
||||||
@ -91,14 +91,14 @@
|
|||||||
default y if SOC_AR5312
|
default y if SOC_AR5312
|
||||||
--- a/drivers/gpio/Makefile
|
--- a/drivers/gpio/Makefile
|
||||||
+++ b/drivers/gpio/Makefile
|
+++ b/drivers/gpio/Makefile
|
||||||
@@ -29,6 +29,7 @@ obj-$(CONFIG_GPIO_ALTERA) += gpio-alte
|
@@ -30,6 +30,7 @@ obj-$(CONFIG_GPIO_ALTERA) += gpio-alt
|
||||||
obj-$(CONFIG_GPIO_ALTERA_A10SR) += gpio-altera-a10sr.o
|
|
||||||
obj-$(CONFIG_GPIO_AMD8111) += gpio-amd8111.o
|
obj-$(CONFIG_GPIO_AMD8111) += gpio-amd8111.o
|
||||||
|
obj-$(CONFIG_GPIO_AMD_FCH) += gpio-amd-fch.o
|
||||||
obj-$(CONFIG_GPIO_AMDPT) += gpio-amdpt.o
|
obj-$(CONFIG_GPIO_AMDPT) += gpio-amdpt.o
|
||||||
+obj-$(CONFIG_GPIO_AR2315) += gpio-ar2315.o
|
+obj-$(CONFIG_GPIO_AR2315) += gpio-ar2315.o
|
||||||
obj-$(CONFIG_GPIO_AR5312) += gpio-ar5312.o
|
obj-$(CONFIG_GPIO_AR5312) += gpio-ar5312.o
|
||||||
obj-$(CONFIG_GPIO_ARIZONA) += gpio-arizona.o
|
obj-$(CONFIG_GPIO_ARIZONA) += gpio-arizona.o
|
||||||
obj-$(CONFIG_GPIO_ATH79) += gpio-ath79.o
|
obj-$(CONFIG_GPIO_ASPEED) += gpio-aspeed.o
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/drivers/gpio/gpio-ar2315.c
|
+++ b/drivers/gpio/gpio-ar2315.c
|
||||||
@@ -0,0 +1,233 @@
|
@@ -0,0 +1,233 @@
|
||||||
|
@ -1,22 +1,22 @@
|
|||||||
--- a/drivers/net/ethernet/atheros/Makefile
|
--- a/drivers/net/ethernet/atheros/Makefile
|
||||||
+++ b/drivers/net/ethernet/atheros/Makefile
|
+++ b/drivers/net/ethernet/atheros/Makefile
|
||||||
@@ -8,3 +8,4 @@ obj-$(CONFIG_ATL2) += atlx/
|
@@ -9,3 +9,4 @@ obj-$(CONFIG_ATL2) += atlx/
|
||||||
obj-$(CONFIG_ATL1E) += atl1e/
|
obj-$(CONFIG_ATL1E) += atl1e/
|
||||||
obj-$(CONFIG_ATL1C) += atl1c/
|
obj-$(CONFIG_ATL1C) += atl1c/
|
||||||
obj-$(CONFIG_ALX) += alx/
|
obj-$(CONFIG_ALX) += alx/
|
||||||
+obj-$(CONFIG_NET_AR231X) += ar231x/
|
+obj-$(CONFIG_NET_AR231X) += ar231x/
|
||||||
--- a/drivers/net/ethernet/atheros/Kconfig
|
--- a/drivers/net/ethernet/atheros/Kconfig
|
||||||
+++ b/drivers/net/ethernet/atheros/Kconfig
|
+++ b/drivers/net/ethernet/atheros/Kconfig
|
||||||
@@ -5,7 +5,7 @@
|
@@ -6,7 +6,7 @@
|
||||||
config NET_VENDOR_ATHEROS
|
config NET_VENDOR_ATHEROS
|
||||||
bool "Atheros devices"
|
bool "Atheros devices"
|
||||||
default y
|
default y
|
||||||
- depends on PCI
|
- depends on (PCI || ATH79)
|
||||||
+ depends on (PCI || ATH25)
|
+ depends on (PCI || ATH25 || ATH79)
|
||||||
---help---
|
---help---
|
||||||
If you have a network (Ethernet) card belonging to this class, say Y.
|
If you have a network (Ethernet) card belonging to this class, say Y.
|
||||||
|
|
||||||
@@ -78,4 +78,10 @@ config ALX
|
@@ -87,4 +87,10 @@ config ALX
|
||||||
To compile this driver as a module, choose M here. The module
|
To compile this driver as a module, choose M here. The module
|
||||||
will be called alx.
|
will be called alx.
|
||||||
|
|
||||||
@ -1713,7 +1713,7 @@
|
|||||||
+
|
+
|
||||||
void __init ath25_serial_setup(u32 mapbase, int irq, unsigned int uartclk)
|
void __init ath25_serial_setup(u32 mapbase, int irq, unsigned int uartclk)
|
||||||
{
|
{
|
||||||
struct uart_port s;
|
#ifdef CONFIG_SERIAL_8250_CONSOLE
|
||||||
--- a/arch/mips/include/asm/mach-ath25/ath25_platform.h
|
--- a/arch/mips/include/asm/mach-ath25/ath25_platform.h
|
||||||
+++ b/arch/mips/include/asm/mach-ath25/ath25_platform.h
|
+++ b/arch/mips/include/asm/mach-ath25/ath25_platform.h
|
||||||
@@ -71,4 +71,15 @@ struct ar231x_board_config {
|
@@ -71,4 +71,15 @@ struct ar231x_board_config {
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/mtd/devices/Kconfig
|
--- a/drivers/mtd/devices/Kconfig
|
||||||
+++ b/drivers/mtd/devices/Kconfig
|
+++ b/drivers/mtd/devices/Kconfig
|
||||||
@@ -130,6 +130,10 @@ config MTD_BCM47XXSFLASH
|
@@ -114,6 +114,10 @@ config MTD_BCM47XXSFLASH
|
||||||
registered by bcma as platform devices. This enables driver for
|
registered by bcma as platform devices. This enables driver for
|
||||||
serial flash memories.
|
serial flash memories.
|
||||||
|
|
||||||
@ -13,7 +13,7 @@
|
|||||||
help
|
help
|
||||||
--- a/drivers/mtd/devices/Makefile
|
--- a/drivers/mtd/devices/Makefile
|
||||||
+++ b/drivers/mtd/devices/Makefile
|
+++ b/drivers/mtd/devices/Makefile
|
||||||
@@ -16,6 +16,7 @@ obj-$(CONFIG_MTD_M25P80) += m25p80.o
|
@@ -15,6 +15,7 @@ obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataf
|
||||||
obj-$(CONFIG_MTD_MCHP23K256) += mchp23k256.o
|
obj-$(CONFIG_MTD_MCHP23K256) += mchp23k256.o
|
||||||
obj-$(CONFIG_MTD_SPEAR_SMI) += spear_smi.o
|
obj-$(CONFIG_MTD_SPEAR_SMI) += spear_smi.o
|
||||||
obj-$(CONFIG_MTD_SST25L) += sst25l.o
|
obj-$(CONFIG_MTD_SST25L) += sst25l.o
|
||||||
|
@ -212,7 +212,7 @@
|
|||||||
+MODULE_ALIAS("platform:" DRIVER_NAME);
|
+MODULE_ALIAS("platform:" DRIVER_NAME);
|
||||||
--- a/drivers/watchdog/Kconfig
|
--- a/drivers/watchdog/Kconfig
|
||||||
+++ b/drivers/watchdog/Kconfig
|
+++ b/drivers/watchdog/Kconfig
|
||||||
@@ -1647,6 +1647,13 @@ config PIC32_DMT
|
@@ -1830,6 +1830,13 @@ config PIC32_DMT
|
||||||
To compile this driver as a loadable module, choose M here.
|
To compile this driver as a loadable module, choose M here.
|
||||||
The module will be called pic32-dmt.
|
The module will be called pic32-dmt.
|
||||||
|
|
||||||
@ -228,7 +228,7 @@
|
|||||||
# POWERPC Architecture
|
# POWERPC Architecture
|
||||||
--- a/drivers/watchdog/Makefile
|
--- a/drivers/watchdog/Makefile
|
||||||
+++ b/drivers/watchdog/Makefile
|
+++ b/drivers/watchdog/Makefile
|
||||||
@@ -166,6 +166,7 @@ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
|
@@ -161,6 +161,7 @@ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
|
||||||
obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt.o
|
obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt.o
|
||||||
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
||||||
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/mtd/redboot.c
|
--- a/drivers/mtd/parsers/redboot.c
|
||||||
+++ b/drivers/mtd/redboot.c
|
+++ b/drivers/mtd/parsers/redboot.c
|
||||||
@@ -30,6 +30,8 @@
|
@@ -16,6 +16,8 @@
|
||||||
#include <linux/mtd/partitions.h>
|
#include <linux/mtd/partitions.h>
|
||||||
#include <linux/module.h>
|
#include <linux/module.h>
|
||||||
|
|
||||||
@ -9,7 +9,7 @@
|
|||||||
struct fis_image_desc {
|
struct fis_image_desc {
|
||||||
unsigned char name[16]; // Null terminated name
|
unsigned char name[16]; // Null terminated name
|
||||||
uint32_t flash_base; // Address within FLASH of image
|
uint32_t flash_base; // Address within FLASH of image
|
||||||
@@ -60,6 +62,7 @@ static int parse_redboot_partitions(stru
|
@@ -67,6 +69,7 @@ static int parse_redboot_partitions(stru
|
||||||
const struct mtd_partition **pparts,
|
const struct mtd_partition **pparts,
|
||||||
struct mtd_part_parser_data *data)
|
struct mtd_part_parser_data *data)
|
||||||
{
|
{
|
||||||
@ -17,7 +17,7 @@
|
|||||||
int nrparts = 0;
|
int nrparts = 0;
|
||||||
struct fis_image_desc *buf;
|
struct fis_image_desc *buf;
|
||||||
struct mtd_partition *parts;
|
struct mtd_partition *parts;
|
||||||
@@ -225,14 +228,15 @@ static int parse_redboot_partitions(stru
|
@@ -234,14 +237,15 @@ static int parse_redboot_partitions(stru
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
@ -35,7 +35,7 @@
|
|||||||
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
||||||
if (nulllen > 0) {
|
if (nulllen > 0) {
|
||||||
strcpy(nullname, nullstring);
|
strcpy(nullname, nullstring);
|
||||||
@@ -251,6 +255,8 @@ static int parse_redboot_partitions(stru
|
@@ -260,6 +264,8 @@ static int parse_redboot_partitions(stru
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
for ( ; i<nrparts; i++) {
|
for ( ; i<nrparts; i++) {
|
||||||
@ -44,7 +44,7 @@
|
|||||||
parts[i].size = fl->img->size;
|
parts[i].size = fl->img->size;
|
||||||
parts[i].offset = fl->img->flash_base;
|
parts[i].offset = fl->img->flash_base;
|
||||||
parts[i].name = names;
|
parts[i].name = names;
|
||||||
@@ -284,6 +290,13 @@ static int parse_redboot_partitions(stru
|
@@ -293,6 +299,13 @@ static int parse_redboot_partitions(stru
|
||||||
fl = fl->next;
|
fl = fl->next;
|
||||||
kfree(tmp_fl);
|
kfree(tmp_fl);
|
||||||
}
|
}
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
--- a/drivers/mtd/redboot.c
|
--- a/drivers/mtd/parsers/redboot.c
|
||||||
+++ b/drivers/mtd/redboot.c
|
+++ b/drivers/mtd/parsers/redboot.c
|
||||||
@@ -79,12 +79,18 @@ static int parse_redboot_partitions(stru
|
@@ -88,12 +88,18 @@ static int parse_redboot_partitions(stru
|
||||||
static char nullstring[] = "unallocated";
|
|
||||||
#endif
|
parse_redboot_of(master);
|
||||||
|
|
||||||
+ buf = vmalloc(master->erasesize);
|
+ buf = vmalloc(master->erasesize);
|
||||||
+ if (!buf)
|
+ if (!buf)
|
||||||
@ -19,7 +19,7 @@
|
|||||||
return -EIO;
|
return -EIO;
|
||||||
}
|
}
|
||||||
offset -= master->erasesize;
|
offset -= master->erasesize;
|
||||||
@@ -97,10 +103,6 @@ static int parse_redboot_partitions(stru
|
@@ -106,10 +112,6 @@ static int parse_redboot_partitions(stru
|
||||||
goto nogood;
|
goto nogood;
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
@ -30,7 +30,7 @@
|
|||||||
|
|
||||||
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
|
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
|
||||||
master->name, offset);
|
master->name, offset);
|
||||||
@@ -173,6 +175,11 @@ static int parse_redboot_partitions(stru
|
@@ -182,6 +184,11 @@ static int parse_redboot_partitions(stru
|
||||||
}
|
}
|
||||||
if (i == numslots) {
|
if (i == numslots) {
|
||||||
/* Didn't find it */
|
/* Didn't find it */
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
--- a/drivers/mtd/redboot.c
|
--- a/drivers/mtd/parsers/redboot.c
|
||||||
+++ b/drivers/mtd/redboot.c
|
+++ b/drivers/mtd/parsers/redboot.c
|
||||||
@@ -58,6 +58,22 @@ static inline int redboot_checksum(struc
|
@@ -65,6 +65,22 @@ static void parse_redboot_of(struct mtd_
|
||||||
return 1;
|
directory = dirblock;
|
||||||
}
|
}
|
||||||
|
|
||||||
+static uint32_t mtd_get_offset_erasesize(struct mtd_info *mtd, uint64_t offset)
|
+static uint32_t mtd_get_offset_erasesize(struct mtd_info *mtd, uint64_t offset)
|
||||||
@ -23,7 +23,7 @@
|
|||||||
static int parse_redboot_partitions(struct mtd_info *master,
|
static int parse_redboot_partitions(struct mtd_info *master,
|
||||||
const struct mtd_partition **pparts,
|
const struct mtd_partition **pparts,
|
||||||
struct mtd_part_parser_data *data)
|
struct mtd_part_parser_data *data)
|
||||||
@@ -74,6 +90,7 @@ static int parse_redboot_partitions(stru
|
@@ -81,6 +97,7 @@ static int parse_redboot_partitions(stru
|
||||||
int namelen = 0;
|
int namelen = 0;
|
||||||
int nulllen = 0;
|
int nulllen = 0;
|
||||||
int numslots;
|
int numslots;
|
||||||
@ -31,7 +31,7 @@
|
|||||||
unsigned long offset;
|
unsigned long offset;
|
||||||
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
||||||
static char nullstring[] = "unallocated";
|
static char nullstring[] = "unallocated";
|
||||||
@@ -186,7 +203,10 @@ static int parse_redboot_partitions(stru
|
@@ -195,7 +212,10 @@ static int parse_redboot_partitions(stru
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -43,7 +43,7 @@
|
|||||||
struct fis_list *new_fl, **prev;
|
struct fis_list *new_fl, **prev;
|
||||||
|
|
||||||
if (buf[i].name[0] == 0xff) {
|
if (buf[i].name[0] == 0xff) {
|
||||||
@@ -262,12 +282,13 @@ static int parse_redboot_partitions(stru
|
@@ -271,12 +291,13 @@ static int parse_redboot_partitions(stru
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
for ( ; i<nrparts; i++) {
|
for ( ; i<nrparts; i++) {
|
||||||
@ -59,7 +59,7 @@
|
|||||||
strcpy(names, fl->img->name);
|
strcpy(names, fl->img->name);
|
||||||
#ifdef CONFIG_MTD_REDBOOT_PARTS_READONLY
|
#ifdef CONFIG_MTD_REDBOOT_PARTS_READONLY
|
||||||
if (!memcmp(names, "RedBoot", 8) ||
|
if (!memcmp(names, "RedBoot", 8) ||
|
||||||
@@ -297,7 +318,9 @@ static int parse_redboot_partitions(stru
|
@@ -306,7 +327,9 @@ static int parse_redboot_partitions(stru
|
||||||
fl = fl->next;
|
fl = fl->next;
|
||||||
kfree(tmp_fl);
|
kfree(tmp_fl);
|
||||||
}
|
}
|
||||||
|
Loading…
x
Reference in New Issue
Block a user