wolfssl: update to 4.8.1-stable

Changes from 4.7.0:
  Fix one high (OCSP verification issue) and two low vulnerabilities
  Improve compatibility layer
  Other improvements and fixes

For detailed changes refer to https://github.com/wolfSSL/wolfssl/releases

Signed-off-by: Ivan Pavlov <AuthorReflex@gmail.com>
This commit is contained in:
Ivan Pavlov 2021-09-05 23:08:35 +03:00 committed by Hauke Mehrtens
parent ba59466bf4
commit 7d92bb0509
4 changed files with 11 additions and 18 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=wolfssl PKG_NAME:=wolfssl
PKG_VERSION:=4.7.0-stable PKG_VERSION:=4.8.1-stable
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION) PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
PKG_HASH:=b0e740b31d4d877d540ad50cc539a8873fc41af02bd3091c4357b403f7106e31 PKG_HASH:=50db45f348f47e00c93dd244c24108220120cb3cc9d01434789229c32937c444
PKG_FIXUP:=libtool libtool-abiver PKG_FIXUP:=libtool libtool-abiver
PKG_INSTALL:=1 PKG_INSTALL:=1

View File

@ -13,8 +13,6 @@ SP_ASM_MUL_ADD2 and SP_ASM_SQR_ADD.
wolfcrypt/src/sp_int.c | 6 +++--- wolfcrypt/src/sp_int.c | 6 +++---
2 files changed, 23 insertions(+), 12 deletions(-) 2 files changed, 23 insertions(+), 12 deletions(-)
diff --git a/wolfcrypt/src/asm.c b/wolfcrypt/src/asm.c
index b7f53d073..a37e75e02 100644
--- a/wolfcrypt/src/asm.c --- a/wolfcrypt/src/asm.c
+++ b/wolfcrypt/src/asm.c +++ b/wolfcrypt/src/asm.c
@@ -698,33 +698,39 @@ __asm__( \ @@ -698,33 +698,39 @@ __asm__( \
@ -64,7 +62,7 @@ index b7f53d073..a37e75e02 100644
#define SQRADDAC(i, j) \ #define SQRADDAC(i, j) \
__asm__( \ __asm__( \
@@ -733,7 +739,9 @@ __asm__( \ @@ -733,7 +739,9 @@ __asm__(
"addl %%eax,%0 \n\t" \ "addl %%eax,%0 \n\t" \
"adcl %%edx,%1 \n\t" \ "adcl %%edx,%1 \n\t" \
"adcl $0,%2 \n\t" \ "adcl $0,%2 \n\t" \
@ -75,7 +73,7 @@ index b7f53d073..a37e75e02 100644
#define SQRADDDB \ #define SQRADDDB \
__asm__( \ __asm__( \
@@ -743,7 +751,10 @@ __asm__( \ @@ -743,7 +751,10 @@ __asm__(
"addl %6,%0 \n\t" \ "addl %6,%0 \n\t" \
"adcl %7,%1 \n\t" \ "adcl %7,%1 \n\t" \
"adcl %8,%2 \n\t" \ "adcl %8,%2 \n\t" \
@ -87,11 +85,9 @@ index b7f53d073..a37e75e02 100644
#elif defined(TFM_X86_64) #elif defined(TFM_X86_64)
/* x86-64 optimized */ /* x86-64 optimized */
diff --git a/wolfcrypt/src/sp_int.c b/wolfcrypt/src/sp_int.c
index 6070faaa9..d26702e47 100644
--- a/wolfcrypt/src/sp_int.c --- a/wolfcrypt/src/sp_int.c
+++ b/wolfcrypt/src/sp_int.c +++ b/wolfcrypt/src/sp_int.c
@@ -477,7 +477,7 @@ static WC_INLINE sp_int_digit sp_div_word(sp_int_digit hi, sp_int_digit lo, @@ -476,7 +476,7 @@ static WC_INLINE sp_int_digit sp_div_wor
"addl %%eax, %[l] \n\t" \ "addl %%eax, %[l] \n\t" \
"adcl %%edx, %[h] \n\t" \ "adcl %%edx, %[h] \n\t" \
"adcl $0 , %[o] \n\t" \ "adcl $0 , %[o] \n\t" \
@ -100,7 +96,7 @@ index 6070faaa9..d26702e47 100644
: [a] "r" (va), [b] "r" (vb) \ : [a] "r" (va), [b] "r" (vb) \
: "eax", "edx", "cc" \ : "eax", "edx", "cc" \
) )
@@ -503,7 +503,7 @@ static WC_INLINE sp_int_digit sp_div_word(sp_int_digit hi, sp_int_digit lo, @@ -502,7 +502,7 @@ static WC_INLINE sp_int_digit sp_div_wor
"addl %%eax, %[l] \n\t" \ "addl %%eax, %[l] \n\t" \
"adcl %%edx, %[h] \n\t" \ "adcl %%edx, %[h] \n\t" \
"adcl $0 , %[o] \n\t" \ "adcl $0 , %[o] \n\t" \
@ -109,7 +105,7 @@ index 6070faaa9..d26702e47 100644
: [a] "r" (va), [b] "r" (vb) \ : [a] "r" (va), [b] "r" (vb) \
: "eax", "edx", "cc" \ : "eax", "edx", "cc" \
) )
@@ -542,7 +542,7 @@ static WC_INLINE sp_int_digit sp_div_word(sp_int_digit hi, sp_int_digit lo, @@ -541,7 +541,7 @@ static WC_INLINE sp_int_digit sp_div_wor
"addl %%eax, %[l] \n\t" \ "addl %%eax, %[l] \n\t" \
"adcl %%edx, %[h] \n\t" \ "adcl %%edx, %[h] \n\t" \
"adcl $0 , %[o] \n\t" \ "adcl $0 , %[o] \n\t" \
@ -118,6 +114,3 @@ index 6070faaa9..d26702e47 100644
: [a] "m" (va) \ : [a] "m" (va) \
: "eax", "edx", "cc" \ : "eax", "edx", "cc" \
) )
--
2.31.1

View File

@ -1,6 +1,6 @@
--- a/wolfssl/wolfcrypt/settings.h --- a/wolfssl/wolfcrypt/settings.h
+++ b/wolfssl/wolfcrypt/settings.h +++ b/wolfssl/wolfcrypt/settings.h
@@ -2255,7 +2255,7 @@ extern void uITRON4_free(void *p) ; @@ -2274,7 +2274,7 @@ extern void uITRON4_free(void *p) ;
#endif #endif
/* warning for not using harden build options (default with ./configure) */ /* warning for not using harden build options (default with ./configure) */

View File

@ -11,7 +11,7 @@ RNG regardless of the built settings for wolfssl.
--- a/wolfcrypt/src/ecc.c --- a/wolfcrypt/src/ecc.c
+++ b/wolfcrypt/src/ecc.c +++ b/wolfcrypt/src/ecc.c
@@ -10293,21 +10293,21 @@ void wc_ecc_fp_free(void) @@ -10938,21 +10938,21 @@ void wc_ecc_fp_free(void)
#endif /* FP_ECC */ #endif /* FP_ECC */
@ -37,7 +37,7 @@ RNG regardless of the built settings for wolfssl.
--- a/wolfssl/wolfcrypt/ecc.h --- a/wolfssl/wolfcrypt/ecc.h
+++ b/wolfssl/wolfcrypt/ecc.h +++ b/wolfssl/wolfcrypt/ecc.h
@@ -584,10 +584,8 @@ WOLFSSL_API @@ -616,10 +616,8 @@ WOLFSSL_API
void wc_ecc_fp_free(void); void wc_ecc_fp_free(void);
WOLFSSL_LOCAL WOLFSSL_LOCAL
void wc_ecc_fp_init(void); void wc_ecc_fp_init(void);