mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
wolfssl: update to 5.5.4-stable
Remove upstreamed:
- 001-Fix-enable-devcrypto-build-error.patch
Refresh patch:
- 100-disable-hardening-check.patch
Release notes:
https://github.com/wolfSSL/wolfssl/releases/tag/v5.5.4-stable
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 04634b2d82
)
This commit is contained in:
parent
158a33591d
commit
77e2a24e62
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=wolfssl
|
||||
PKG_VERSION:=5.5.3-stable
|
||||
PKG_VERSION:=5.5.4-stable
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
|
||||
PKG_HASH:=fd3135b8657d09fb96a8aad16585da850b96ea420ae8ce5ac4d5fdfc614c2683
|
||||
PKG_HASH:=b7ee150e49def77c765bc02aac92ddeb0bebefd4cb12aa263d8f95e405221fb8
|
||||
|
||||
PKG_FIXUP:=libtool libtool-abiver
|
||||
PKG_INSTALL:=1
|
||||
|
@ -1,33 +0,0 @@
|
||||
From dc9f46a3be00b5e82684a158605189d1278e324c Mon Sep 17 00:00:00 2001
|
||||
From: Eric Blankenhorn <eric@wolfssl.com>
|
||||
Date: Wed, 12 Oct 2022 16:05:17 -0500
|
||||
Subject: [PATCH] Fix --enable-devcrypto build error for sys without u_int8_t
|
||||
type
|
||||
|
||||
---
|
||||
wolfcrypt/src/port/devcrypto/README.md | 2 +-
|
||||
wolfcrypt/src/port/devcrypto/wc_devcrypto.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/wolfcrypt/src/port/devcrypto/README.md
|
||||
+++ b/wolfcrypt/src/port/devcrypto/README.md
|
||||
@@ -22,7 +22,7 @@ modprobe cryptodev
|
||||
For default build with all supported features use:
|
||||
|
||||
```
|
||||
-./configure --enable-cryptodev
|
||||
+./configure --enable-devcrypto
|
||||
```
|
||||
|
||||
Or for more control over features used:
|
||||
--- a/wolfcrypt/src/port/devcrypto/wc_devcrypto.c
|
||||
+++ b/wolfcrypt/src/port/devcrypto/wc_devcrypto.c
|
||||
@@ -122,7 +122,7 @@ int wc_DevCryptoCreate(WC_CRYPTODEV* ctx
|
||||
case CRYPTO_SHA2_512_HMAC:
|
||||
ctx->sess.cipher = 0;
|
||||
ctx->sess.mac = type;
|
||||
- ctx->sess.mackey = (u_int8_t*)key;
|
||||
+ ctx->sess.mackey = (byte*)key;
|
||||
ctx->sess.mackeylen = keySz;
|
||||
break;
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/wolfssl/wolfcrypt/settings.h
|
||||
+++ b/wolfssl/wolfcrypt/settings.h
|
||||
@@ -2455,7 +2455,7 @@ extern void uITRON4_free(void *p) ;
|
||||
@@ -2496,7 +2496,7 @@ extern void uITRON4_free(void *p) ;
|
||||
#endif
|
||||
|
||||
/* warning for not using harden build options (default with ./configure) */
|
||||
|
Loading…
Reference in New Issue
Block a user