ipq40xx: 5.15: refresh kernel patches

Refresh kernel patches.

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Reviewed-by: Robert Marko <robert.marko@sartura.hr>
This commit is contained in:
Ansuel Smith 2022-03-28 00:12:55 +02:00 committed by Sungbo Eo
parent 7c692f685b
commit 7517955eac
13 changed files with 26 additions and 26 deletions

View File

@ -83,16 +83,16 @@ Signed-off-by: John Crispin <john@phrozen.org>
if (!f) if (!f)
return -EINVAL; return -EINVAL;
@@ -1278,7 +1301,7 @@ static int clk_cpu_div_set_rate(struct c @@ -1277,7 +1300,7 @@ static int clk_cpu_div_set_rate(struct c
const struct freq_tbl *f;
u32 mask; u32 mask;
int ret;
- f = qcom_find_freq(pll->freq_tbl, rate); - f = qcom_find_freq(pll->freq_tbl, rate);
+ f = qcom_find_freq_close(pll->freq_tbl, rate); + f = qcom_find_freq_close(pll->freq_tbl, rate);
if (!f) if (!f)
return -EINVAL; return -EINVAL;
@@ -1305,6 +1328,7 @@ static unsigned long @@ -1304,6 +1327,7 @@ static unsigned long
clk_cpu_div_recalc_rate(struct clk_hw *hw, clk_cpu_div_recalc_rate(struct clk_hw *hw,
unsigned long parent_rate) unsigned long parent_rate)
{ {
@ -100,7 +100,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
struct clk_fepll *pll = to_clk_fepll(hw); struct clk_fepll *pll = to_clk_fepll(hw);
u32 cdiv, pre_div; u32 cdiv, pre_div;
u64 rate; u64 rate;
@@ -1325,7 +1349,11 @@ clk_cpu_div_recalc_rate(struct clk_hw *h @@ -1324,7 +1348,11 @@ clk_cpu_div_recalc_rate(struct clk_hw *h
rate = clk_fepll_vco_calc_rate(pll, parent_rate) * 2; rate = clk_fepll_vco_calc_rate(pll, parent_rate) * 2;
do_div(rate, pre_div); do_div(rate, pre_div);

View File

@ -13,7 +13,7 @@ Signed-off-by: Ram Chandra Jangir <rjangir@codeaurora.org>
--- a/drivers/clk/qcom/gcc-ipq4019.c --- a/drivers/clk/qcom/gcc-ipq4019.c
+++ b/drivers/clk/qcom/gcc-ipq4019.c +++ b/drivers/clk/qcom/gcc-ipq4019.c
@@ -1736,6 +1736,17 @@ static const struct qcom_reset_map gcc_i @@ -1735,6 +1735,17 @@ static const struct qcom_reset_map gcc_i
[GCC_TCSR_BCR] = {0x22000, 0}, [GCC_TCSR_BCR] = {0x22000, 0},
[GCC_MPM_BCR] = {0x24000, 0}, [GCC_MPM_BCR] = {0x24000, 0},
[GCC_SPDM_BCR] = {0x25000, 0}, [GCC_SPDM_BCR] = {0x25000, 0},

View File

@ -22,7 +22,7 @@ Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
--- a/arch/arm/boot/compressed/head.S --- a/arch/arm/boot/compressed/head.S
+++ b/arch/arm/boot/compressed/head.S +++ b/arch/arm/boot/compressed/head.S
@@ -602,6 +602,41 @@ not_relocated: mov r0, #0 @@ -624,6 +624,41 @@ not_relocated: mov r0, #0
bic r4, r4, #1 bic r4, r4, #1
blne cache_on blne cache_on

View File

@ -13,7 +13,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
--- a/drivers/mmc/host/sdhci-msm.c --- a/drivers/mmc/host/sdhci-msm.c
+++ b/drivers/mmc/host/sdhci-msm.c +++ b/drivers/mmc/host/sdhci-msm.c
@@ -2191,7 +2191,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat @@ -2445,7 +2445,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
static const struct sdhci_ops sdhci_msm_ops = { static const struct sdhci_ops sdhci_msm_ops = {
.reset = sdhci_msm_reset, .reset = sdhci_msm_reset,

View File

@ -21,7 +21,7 @@
static void qcom_scm_set_download_mode(bool enable) static void qcom_scm_set_download_mode(bool enable)
{ {
bool avail; bool avail;
@@ -1256,6 +1270,13 @@ static int qcom_scm_probe(struct platfor @@ -1320,6 +1334,13 @@ static int qcom_scm_probe(struct platfor
if (download_mode) if (download_mode)
qcom_scm_set_download_mode(true); qcom_scm_set_download_mode(true);

View File

@ -34,7 +34,7 @@
+} +}
+ +
/** /**
* qcom_scm_call() - Sends a command to the SCM and waits for the command to * scm_legacy_call() - Sends a command to the SCM and waits for the command to
* finish processing. * finish processing.
@@ -160,10 +182,16 @@ int scm_legacy_call(struct device *dev, @@ -160,10 +182,16 @@ int scm_legacy_call(struct device *dev,

View File

@ -24,7 +24,7 @@ Reviewed-by: Grant Grundler <grundler@chromium.org>
--- a/include/linux/netdevice.h --- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h +++ b/include/linux/netdevice.h
@@ -765,6 +765,16 @@ struct xps_map { @@ -771,6 +771,16 @@ struct xps_map {
#define XPS_MIN_MAP_ALLOC ((L1_CACHE_ALIGN(offsetof(struct xps_map, queues[1])) \ #define XPS_MIN_MAP_ALLOC ((L1_CACHE_ALIGN(offsetof(struct xps_map, queues[1])) \
- sizeof(struct xps_map)) / sizeof(u16)) - sizeof(struct xps_map)) / sizeof(u16))
@ -40,8 +40,8 @@ Reviewed-by: Grant Grundler <grundler@chromium.org>
+#endif +#endif
/* /*
* This structure holds all XPS maps for device. Maps are indexed by CPU. * This structure holds all XPS maps for device. Maps are indexed by CPU.
*/ *
@@ -1445,6 +1455,9 @@ struct net_device_ops { @@ -1477,6 +1487,9 @@ struct net_device_ops {
const struct sk_buff *skb, const struct sk_buff *skb,
u16 rxq_index, u16 rxq_index,
u32 flow_id); u32 flow_id);

View File

@ -1,8 +1,8 @@
--- a/drivers/net/mdio/Kconfig --- a/drivers/net/mdio/Kconfig
+++ b/drivers/net/mdio/Kconfig +++ b/drivers/net/mdio/Kconfig
@@ -27,6 +27,13 @@ config OF_MDIO @@ -41,6 +41,13 @@ config ACPI_MDIO
help help
OpenFirmware MDIO bus (Ethernet PHY) accessors ACPI MDIO bus (Ethernet PHY) accessors
+config AR40XX_PHY +config AR40XX_PHY
+ tristate "Driver for Qualcomm Atheros IPQ40XX switches" + tristate "Driver for Qualcomm Atheros IPQ40XX switches"
@ -16,12 +16,12 @@
config MDIO_DEVRES config MDIO_DEVRES
--- a/drivers/net/mdio/Makefile --- a/drivers/net/mdio/Makefile
+++ b/drivers/net/mdio/Makefile +++ b/drivers/net/mdio/Makefile
@@ -21,6 +21,8 @@ obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i. @@ -23,6 +23,8 @@ obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i.
obj-$(CONFIG_MDIO_THUNDER) += mdio-thunder.o obj-$(CONFIG_MDIO_THUNDER) += mdio-thunder.o
obj-$(CONFIG_MDIO_XGENE) += mdio-xgene.o obj-$(CONFIG_MDIO_XGENE) += mdio-xgene.o
+obj-$(CONFIG_AR40XX_PHY) += ar40xx.o +obj-$(CONFIG_AR40XX_PHY) += ar40xx.o
+ +
obj-$(CONFIG_MDIO_BUS_MUX) += mdio-mux.o obj-$(CONFIG_MDIO_BUS_MUX) += mdio-mux.o
obj-$(CONFIG_MDIO_BUS_MUX_BCM6368) += mdio-mux-bcm6368.o
obj-$(CONFIG_MDIO_BUS_MUX_BCM_IPROC) += mdio-mux-bcm-iproc.o obj-$(CONFIG_MDIO_BUS_MUX_BCM_IPROC) += mdio-mux-bcm-iproc.o
obj-$(CONFIG_MDIO_BUS_MUX_GPIO) += mdio-mux-gpio.o

View File

@ -25,7 +25,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
--- a/drivers/net/phy/Kconfig --- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig +++ b/drivers/net/phy/Kconfig
@@ -320,6 +320,12 @@ config AT803X_PHY @@ -346,6 +346,12 @@ config AT803X_PHY
Currently supports the AR8030, AR8031, AR8033, AR8035 and internal Currently supports the AR8030, AR8031, AR8033, AR8035 and internal
QCA8337(Internal qca8k PHY) model QCA8337(Internal qca8k PHY) model
@ -40,8 +40,8 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
help help
--- a/drivers/net/phy/Makefile --- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile +++ b/drivers/net/phy/Makefile
@@ -86,6 +86,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc/ @@ -90,6 +90,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_NATIONAL_PHY) += national.o obj-$(CONFIG_NXP_C45_TJA11XX_PHY) += nxp-c45-tja11xx.o
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
obj-$(CONFIG_QSEMI_PHY) += qsemi.o obj-$(CONFIG_QSEMI_PHY) += qsemi.o
+obj-$(CONFIG_QCA807X_PHY) += qca807x.o +obj-$(CONFIG_QCA807X_PHY) += qca807x.o

View File

@ -12,7 +12,7 @@ Subject: SoC: add qualcomm syscon
obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
--- a/drivers/soc/qcom/Kconfig --- a/drivers/soc/qcom/Kconfig
+++ b/drivers/soc/qcom/Kconfig +++ b/drivers/soc/qcom/Kconfig
@@ -189,6 +189,13 @@ config QCOM_SOCINFO @@ -190,6 +190,13 @@ config QCOM_SOCINFO
Say yes here to support the Qualcomm socinfo driver, providing Say yes here to support the Qualcomm socinfo driver, providing
information about the SoC to user space. information about the SoC to user space.

View File

@ -39,11 +39,11 @@
+ }; + };
+ +
rng@22000 { rng@22000 {
status = "ok"; status = "okay";
}; };
@@ -74,14 +101,6 @@ @@ -74,14 +101,6 @@
pinctrl-names = "default"; pinctrl-names = "default";
status = "ok"; status = "okay";
cs-gpios = <&tlmm 54 0>; cs-gpios = <&tlmm 54 0>;
- -
- mx25l25635e@0 { - mx25l25635e@0 {
@ -58,7 +58,7 @@
serial@78af000 { serial@78af000 {
@@ -109,5 +128,41 @@ @@ -109,5 +128,41 @@
wifi@a800000 { wifi@a800000 {
status = "ok"; status = "okay";
}; };
+ +
+ mdio@90000 { + mdio@90000 {

View File

@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/arch/arm/boot/dts/Makefile --- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot/dts/Makefile
@@ -902,11 +902,65 @@ dtb-$(CONFIG_ARCH_QCOM) += \ @@ -951,11 +951,75 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-ipq4018-ap120c-ac.dtb \ qcom-ipq4018-ap120c-ac.dtb \
qcom-ipq4018-ap120c-ac-bit.dtb \ qcom-ipq4018-ap120c-ac-bit.dtb \
qcom-ipq4018-jalapeno.dtb \ qcom-ipq4018-jalapeno.dtb \
@ -85,4 +85,4 @@ Signed-off-by: John Crispin <john@phrozen.org>
+ qcom-ipq4029-mr33.dtb \ + qcom-ipq4029-mr33.dtb \
qcom-ipq8064-ap148.dtb \ qcom-ipq8064-ap148.dtb \
qcom-ipq8064-rb3011.dtb \ qcom-ipq8064-rb3011.dtb \
qcom-msm8660-surf.dtb \ qcom-msm8226-samsung-s3ve3g.dtb \

View File

@ -103,7 +103,7 @@
}; };
@@ -89,11 +115,11 @@ @@ -89,11 +115,11 @@
status = "ok"; status = "okay";
cs-gpios = <&tlmm 12 0>; cs-gpios = <&tlmm 12 0>;
- m25p80@0 { - m25p80@0 {