mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 13:48:06 +00:00
ipq40xx: add MikroTik cAP ac support
This adds support for the MikroTik RouterBOARD RBcAPGi-5acD2nD (cAP ac), a indoor dual band, dual-radio 802.11ac wireless AP, two 10/100/1000 Mbps Ethernet ports. See https://mikrotik.com/product/cap_ac for more info. Specifications: - SoC: Qualcomm Atheros IPQ4018 - RAM: 128 MB - Storage: 16 MB NOR - Wireless: · Built-in IPQ4018 (SoC) 802.11b/g/n 2x2:2, 2.5 dBi antennae · Built-in IPQ4018 (SoC) 802.11a/n/ac 2x2:2, 2.5 dBi antennae - Ethernet: Built-in IPQ4018 (SoC, QCA8075) , 2x 1000/100/10 port, PoE in and passive PoE out Unsupported: - PoE out Installation: Boot the initramfs image via TFTP and then flash the sysupgrade image using "sysupgrade -n" Signed-off-by: Alar Aun <alar.aun@gmail.com>
This commit is contained in:
parent
93d91197b9
commit
70eedac9b3
@ -45,6 +45,7 @@ ALLWIFIBOARDS:= \
|
|||||||
linksys_ea8300 \
|
linksys_ea8300 \
|
||||||
linksys_mr8300-v0 \
|
linksys_mr8300-v0 \
|
||||||
luma_wrtq-329acn \
|
luma_wrtq-329acn \
|
||||||
|
mikrotik_cap-ac \
|
||||||
mikrotik_hap-ac2 \
|
mikrotik_hap-ac2 \
|
||||||
mikrotik_hap-ac3 \
|
mikrotik_hap-ac3 \
|
||||||
mikrotik_sxtsq-5-ac \
|
mikrotik_sxtsq-5-ac \
|
||||||
@ -135,6 +136,7 @@ $(eval $(call generate-ipq-wifi-package,glinet_gl-s1300,GL.iNet GL-S1300))
|
|||||||
$(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
|
$(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
|
||||||
$(eval $(call generate-ipq-wifi-package,linksys_mr8300-v0,Linksys MR8300))
|
$(eval $(call generate-ipq-wifi-package,linksys_mr8300-v0,Linksys MR8300))
|
||||||
$(eval $(call generate-ipq-wifi-package,luma_wrtq-329acn,Luma WRTQ-329ACN))
|
$(eval $(call generate-ipq-wifi-package,luma_wrtq-329acn,Luma WRTQ-329ACN))
|
||||||
|
$(eval $(call generate-ipq-wifi-package,mikrotik_cap-ac,Mikrotik cAP ac))
|
||||||
$(eval $(call generate-ipq-wifi-package,mikrotik_hap-ac2,Mikrotik hAP ac2))
|
$(eval $(call generate-ipq-wifi-package,mikrotik_hap-ac2,Mikrotik hAP ac2))
|
||||||
$(eval $(call generate-ipq-wifi-package,mikrotik_hap-ac3,Mikrotik hAP ac3))
|
$(eval $(call generate-ipq-wifi-package,mikrotik_hap-ac3,Mikrotik hAP ac3))
|
||||||
$(eval $(call generate-ipq-wifi-package,mikrotik_sxtsq-5-ac,MikroTik SXTsq 5 ac))
|
$(eval $(call generate-ipq-wifi-package,mikrotik_sxtsq-5-ac,MikroTik SXTsq 5 ac))
|
||||||
|
BIN
package/firmware/ipq-wifi/board-mikrotik_cap-ac.qca4019
Normal file
BIN
package/firmware/ipq-wifi/board-mikrotik_cap-ac.qca4019
Normal file
Binary file not shown.
@ -52,6 +52,13 @@ engenius,ens620ext)
|
|||||||
ucidef_set_led_netdev "lan1" "LAN1" "green:lan1" "eth0"
|
ucidef_set_led_netdev "lan1" "LAN1" "green:lan1" "eth0"
|
||||||
ucidef_set_led_netdev "lan2" "LAN2" "green:lan2" "eth1"
|
ucidef_set_led_netdev "lan2" "LAN2" "green:lan2" "eth1"
|
||||||
;;
|
;;
|
||||||
|
mikrotik,cap-ac)
|
||||||
|
ucidef_set_led_default "power" "POWER" "blue:power" "1"
|
||||||
|
ucidef_set_led_default "user" "USER" "green:user" "0"
|
||||||
|
ucidef_set_led_switch "eth1" "ETH1" "green:eth1" "switch0" "0x20"
|
||||||
|
ucidef_set_led_switch "eth2" "ETH2" "green:eth2" "switch0" "0x10"
|
||||||
|
ucidef_set_led_wlan "wlan2g" "WLAN2G" "green:wlan2g" "phy0tpt"
|
||||||
|
ucidef_set_led_wlan "wlan5g" "WLAN5G" "green:wlan5g" "phy1tpt"
|
||||||
mikrotik,hap-ac3)
|
mikrotik,hap-ac3)
|
||||||
ucidef_set_led_netdev "wan" "WAN" "green:wan" "eth1"
|
ucidef_set_led_netdev "wan" "WAN" "green:wan" "eth1"
|
||||||
ucidef_set_led_switch "lan1" "LAN1" "green:lan1" "switch0" "0x10"
|
ucidef_set_led_switch "lan1" "LAN1" "green:lan1" "switch0" "0x10"
|
||||||
|
@ -50,6 +50,10 @@ ipq40xx_setup_interfaces()
|
|||||||
openmesh,a62)
|
openmesh,a62)
|
||||||
ucidef_set_interfaces_lan_wan "eth1" "eth0"
|
ucidef_set_interfaces_lan_wan "eth1" "eth0"
|
||||||
;;
|
;;
|
||||||
|
mikrotik,cap-ac)
|
||||||
|
ucidef_add_switch "switch0" \
|
||||||
|
"0t@eth0" "4:lan" "5:wan"
|
||||||
|
;;
|
||||||
asus,rt-ac42u|\
|
asus,rt-ac42u|\
|
||||||
asus,rt-ac58u|\
|
asus,rt-ac58u|\
|
||||||
mikrotik,hap-ac2|\
|
mikrotik,hap-ac2|\
|
||||||
@ -190,6 +194,7 @@ ipq40xx_setup_macs()
|
|||||||
wan_mac=$(mtd_get_mac_ascii devinfo hw_mac_addr)
|
wan_mac=$(mtd_get_mac_ascii devinfo hw_mac_addr)
|
||||||
lan_mac=$(macaddr_add "$wan_mac" 1)
|
lan_mac=$(macaddr_add "$wan_mac" 1)
|
||||||
;;
|
;;
|
||||||
|
mikrotik,cap-ac |\
|
||||||
mikrotik,hap-ac2|\
|
mikrotik,hap-ac2|\
|
||||||
mikrotik,hap-ac3)
|
mikrotik,hap-ac3)
|
||||||
wan_mac=$(cat /sys/firmware/mikrotik/hard_config/mac_base)
|
wan_mac=$(cat /sys/firmware/mikrotik/hard_config/mac_base)
|
||||||
|
@ -18,6 +18,9 @@ cilab,meshpoint-one)
|
|||||||
compex,wpj428)
|
compex,wpj428)
|
||||||
ucidef_add_gpio_switch "sim_card_select" "SIM card select" "3" "0"
|
ucidef_add_gpio_switch "sim_card_select" "SIM card select" "3" "0"
|
||||||
;;
|
;;
|
||||||
|
mikrotik,cap-ac)
|
||||||
|
ucidef_add_gpio_switch "poe_passtrough" "POE passtrough enable" "414" "0"
|
||||||
|
;;
|
||||||
mikrotik,hap-ac3)
|
mikrotik,hap-ac3)
|
||||||
ucidef_add_gpio_switch "poe_passtrough" "PoE Passthrough" "452" "0"
|
ucidef_add_gpio_switch "poe_passtrough" "PoE Passthrough" "452" "0"
|
||||||
;;
|
;;
|
||||||
|
@ -112,6 +112,7 @@ case "$FIRMWARE" in
|
|||||||
caldata_valid "202f" || caldata_extract "ART" 0x1000 0x2f20
|
caldata_valid "202f" || caldata_extract "ART" 0x1000 0x2f20
|
||||||
ath10k_patch_mac $(macaddr_add $(get_mac_binary "/sys/bus/i2c/devices/0-0050/eeprom" 0x66) 2)
|
ath10k_patch_mac $(macaddr_add $(get_mac_binary "/sys/bus/i2c/devices/0-0050/eeprom" 0x66) 2)
|
||||||
;;
|
;;
|
||||||
|
mikrotik,cap-ac |\
|
||||||
mikrotik,hap-ac2 |\
|
mikrotik,hap-ac2 |\
|
||||||
mikrotik,hap-ac3)
|
mikrotik,hap-ac3)
|
||||||
wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
|
wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
|
||||||
@ -190,6 +191,7 @@ case "$FIRMWARE" in
|
|||||||
caldata_valid "202f" || caldata_extract "ART" 0x5000 0x2f20
|
caldata_valid "202f" || caldata_extract "ART" 0x5000 0x2f20
|
||||||
ath10k_patch_mac $(macaddr_add $(get_mac_binary "/sys/bus/i2c/devices/0-0050/eeprom" 0x66) 3)
|
ath10k_patch_mac $(macaddr_add $(get_mac_binary "/sys/bus/i2c/devices/0-0050/eeprom" 0x66) 3)
|
||||||
;;
|
;;
|
||||||
|
mikrotik,cap-ac |\
|
||||||
mikrotik,hap-ac2 |\
|
mikrotik,hap-ac2 |\
|
||||||
mikrotik,hap-ac3 |\
|
mikrotik,hap-ac3 |\
|
||||||
mikrotik,sxtsq-5-ac)
|
mikrotik,sxtsq-5-ac)
|
||||||
|
@ -138,6 +138,7 @@ platform_do_upgrade() {
|
|||||||
CI_KERNPART="part.safe"
|
CI_KERNPART="part.safe"
|
||||||
nand_do_upgrade "$1"
|
nand_do_upgrade "$1"
|
||||||
;;
|
;;
|
||||||
|
mikrotik,cap-ac|\
|
||||||
mikrotik,hap-ac2|\
|
mikrotik,hap-ac2|\
|
||||||
mikrotik,lhgg-60ad|\
|
mikrotik,lhgg-60ad|\
|
||||||
mikrotik,sxtsq-5-ac)
|
mikrotik,sxtsq-5-ac)
|
||||||
|
@ -0,0 +1,250 @@
|
|||||||
|
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
|
||||||
|
/* Copyright (c) 2020, Robert Marko <robimarko@gmail.com> */
|
||||||
|
|
||||||
|
#include "qcom-ipq4019.dtsi"
|
||||||
|
#include <dt-bindings/gpio/gpio.h>
|
||||||
|
#include <dt-bindings/input/input.h>
|
||||||
|
#include <dt-bindings/soc/qcom,tcsr.h>
|
||||||
|
|
||||||
|
/ {
|
||||||
|
model = "MikroTik cAP ac";
|
||||||
|
compatible = "mikrotik,cap-ac";
|
||||||
|
|
||||||
|
memory {
|
||||||
|
device_type = "memory";
|
||||||
|
reg = <0x80000000 0x08000000>;
|
||||||
|
};
|
||||||
|
|
||||||
|
chosen {
|
||||||
|
stdout-path = "serial0:115200n8";
|
||||||
|
};
|
||||||
|
|
||||||
|
aliases {
|
||||||
|
led-boot = &led_user;
|
||||||
|
led-failsafe = &led_user;
|
||||||
|
led-running = &led_user;
|
||||||
|
led-upgrade = &led_user;
|
||||||
|
};
|
||||||
|
|
||||||
|
soc {
|
||||||
|
rng@22000 {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
counter@4a1000 {
|
||||||
|
compatible = "qcom,qca-gcnt";
|
||||||
|
reg = <0x4a1000 0x4>;
|
||||||
|
};
|
||||||
|
|
||||||
|
tcsr@1949000 {
|
||||||
|
compatible = "qcom,tcsr";
|
||||||
|
reg = <0x1949000 0x100>;
|
||||||
|
qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
|
||||||
|
};
|
||||||
|
|
||||||
|
ess_tcsr@1953000 {
|
||||||
|
compatible = "qcom,tcsr";
|
||||||
|
reg = <0x1953000 0x1000>;
|
||||||
|
qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
|
||||||
|
};
|
||||||
|
|
||||||
|
tcsr@1957000 {
|
||||||
|
compatible = "qcom,tcsr";
|
||||||
|
reg = <0x1957000 0x100>;
|
||||||
|
qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
|
||||||
|
};
|
||||||
|
|
||||||
|
crypto@8e3a000 {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
watchdog@b017000 {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
ess-switch@c000000 {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
edma@c080000 {
|
||||||
|
status = "okay";
|
||||||
|
qcom,poll_required = <0>;
|
||||||
|
qcom,num_gmac = <1>;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
keys {
|
||||||
|
compatible = "gpio-keys";
|
||||||
|
|
||||||
|
reset {
|
||||||
|
label = "reset";
|
||||||
|
gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
|
||||||
|
linux,code = <KEY_RESTART>;
|
||||||
|
};
|
||||||
|
|
||||||
|
mode {
|
||||||
|
label = "mode";
|
||||||
|
gpios = <&tlmm 5 GPIO_ACTIVE_LOW>;
|
||||||
|
linux,code = <KEY_LIGHTS_TOGGLE>;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
leds {
|
||||||
|
compatible = "gpio-leds";
|
||||||
|
|
||||||
|
power {
|
||||||
|
label = "blue:power";
|
||||||
|
gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
|
||||||
|
default-state = "keep";
|
||||||
|
};
|
||||||
|
|
||||||
|
led_user: user {
|
||||||
|
label = "green:user";
|
||||||
|
gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
|
||||||
|
panic-indicator;
|
||||||
|
};
|
||||||
|
|
||||||
|
wlan2g {
|
||||||
|
label = "green:wlan2g";
|
||||||
|
gpios = <&tlmm 1 GPIO_ACTIVE_HIGH>;
|
||||||
|
};
|
||||||
|
|
||||||
|
wlan5g {
|
||||||
|
label = "green:wlan5g";
|
||||||
|
gpios = <&tlmm 58 GPIO_ACTIVE_HIGH>;
|
||||||
|
};
|
||||||
|
|
||||||
|
eth1 {
|
||||||
|
label = "green:eth1";
|
||||||
|
gpios = <ðphy4 1 GPIO_ACTIVE_HIGH>;
|
||||||
|
};
|
||||||
|
|
||||||
|
eth2 {
|
||||||
|
label = "green:eth2";
|
||||||
|
gpios = <ðphy3 1 GPIO_ACTIVE_HIGH>;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
&tlmm {
|
||||||
|
serial_pins: serial_pinmux {
|
||||||
|
mux {
|
||||||
|
pins = "gpio60", "gpio61";
|
||||||
|
function = "blsp_uart0";
|
||||||
|
bias-disable;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
spi_0_pins: spi_0_pinmux {
|
||||||
|
pin {
|
||||||
|
function = "blsp_spi0";
|
||||||
|
pins = "gpio55", "gpio56", "gpio57";
|
||||||
|
drive-strength = <2>;
|
||||||
|
bias-disable;
|
||||||
|
};
|
||||||
|
pin_cs {
|
||||||
|
function = "gpio";
|
||||||
|
pins = "gpio54";
|
||||||
|
drive-strength = <2>;
|
||||||
|
bias-disable;
|
||||||
|
output-high;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
&blsp_dma {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
&blsp1_spi1 {
|
||||||
|
status = "okay";
|
||||||
|
|
||||||
|
pinctrl-0 = <&spi_0_pins>;
|
||||||
|
pinctrl-names = "default";
|
||||||
|
cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
|
||||||
|
|
||||||
|
flash@0 {
|
||||||
|
reg = <0>;
|
||||||
|
compatible = "jedec,spi-nor";
|
||||||
|
spi-max-frequency = <40000000>;
|
||||||
|
|
||||||
|
partitions {
|
||||||
|
compatible = "fixed-partitions";
|
||||||
|
#address-cells = <1>;
|
||||||
|
#size-cells = <1>;
|
||||||
|
|
||||||
|
partition@0 {
|
||||||
|
label = "Qualcomm";
|
||||||
|
reg = <0x0 0x80000>;
|
||||||
|
read-only;
|
||||||
|
};
|
||||||
|
|
||||||
|
partition@80000 {
|
||||||
|
compatible = "mikrotik,routerboot-partitions";
|
||||||
|
#address-cells = <1>;
|
||||||
|
#size-cells = <1>;
|
||||||
|
label = "RouterBoot";
|
||||||
|
reg = <0x80000 0x80000>;
|
||||||
|
read-only;
|
||||||
|
|
||||||
|
hard_config {
|
||||||
|
read-only;
|
||||||
|
};
|
||||||
|
|
||||||
|
dtb_config {
|
||||||
|
read-only;
|
||||||
|
};
|
||||||
|
|
||||||
|
soft_config {
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
partition@100000 {
|
||||||
|
compatible = "mikrotik,minor";
|
||||||
|
label = "firmware";
|
||||||
|
reg = <0x100000 0xf00000>;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
&blsp1_uart1 {
|
||||||
|
status = "okay";
|
||||||
|
|
||||||
|
pinctrl-0 = <&serial_pins>;
|
||||||
|
pinctrl-names = "default";
|
||||||
|
};
|
||||||
|
|
||||||
|
&cryptobam {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
&mdio {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
&gmac0 {
|
||||||
|
vlan_tag = <0 0x3f>;
|
||||||
|
};
|
||||||
|
|
||||||
|
ðphy3 {
|
||||||
|
gpio-controller;
|
||||||
|
#gpio-cells = <2>;
|
||||||
|
};
|
||||||
|
|
||||||
|
ðphy4 {
|
||||||
|
gpio-controller;
|
||||||
|
#gpio-cells = <2>;
|
||||||
|
};
|
||||||
|
|
||||||
|
&wifi0 {
|
||||||
|
status = "okay";
|
||||||
|
|
||||||
|
qcom,ath10k-calibration-variant = "MikroTik-cAP-ac";
|
||||||
|
};
|
||||||
|
|
||||||
|
&wifi1 {
|
||||||
|
status = "okay";
|
||||||
|
|
||||||
|
qcom,ath10k-calibration-variant = "MikroTik-cAP-ac";
|
||||||
|
};
|
@ -20,6 +20,15 @@ define Device/mikrotik_nand
|
|||||||
IMAGE/nand-sysupgrade.bin := sysupgrade-tar | append-metadata
|
IMAGE/nand-sysupgrade.bin := sysupgrade-tar | append-metadata
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Device/mikrotik_cap-ac
|
||||||
|
$(call Device/mikrotik_nor)
|
||||||
|
DEVICE_MODEL := cAP ac
|
||||||
|
SOC := qcom-ipq4018
|
||||||
|
DEVICE_PACKAGES := ipq-wifi-mikrotik_cap-ac -kmod-ath10k-ct \
|
||||||
|
kmod-ath10k-ct-smallbuffers
|
||||||
|
endef
|
||||||
|
TARGET_DEVICES += mikrotik_cap-ac
|
||||||
|
|
||||||
define Device/mikrotik_hap-ac2
|
define Device/mikrotik_hap-ac2
|
||||||
$(call Device/mikrotik_nor)
|
$(call Device/mikrotik_nor)
|
||||||
DEVICE_MODEL := hAP ac2
|
DEVICE_MODEL := hAP ac2
|
||||||
|
@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||||||
|
|
||||||
--- a/arch/arm/boot/dts/Makefile
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
+++ b/arch/arm/boot/dts/Makefile
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
@@ -902,11 +902,72 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
@@ -902,11 +902,73 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
||||||
qcom-apq8074-dragonboard.dtb \
|
qcom-apq8074-dragonboard.dtb \
|
||||||
qcom-apq8084-ifc6540.dtb \
|
qcom-apq8084-ifc6540.dtb \
|
||||||
qcom-apq8084-mtp.dtb \
|
qcom-apq8084-mtp.dtb \
|
||||||
@ -31,6 +31,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||||||
+ qcom-ipq4018-gl-ap1300.dtb \
|
+ qcom-ipq4018-gl-ap1300.dtb \
|
||||||
+ qcom-ipq4018-jalapeno.dtb \
|
+ qcom-ipq4018-jalapeno.dtb \
|
||||||
+ qcom-ipq4018-meshpoint-one.dtb \
|
+ qcom-ipq4018-meshpoint-one.dtb \
|
||||||
|
+ qcom-ipq4018-cap-ac.dtb \
|
||||||
+ qcom-ipq4018-hap-ac2.dtb \
|
+ qcom-ipq4018-hap-ac2.dtb \
|
||||||
+ qcom-ipq4018-sxtsq-5-ac.dtb \
|
+ qcom-ipq4018-sxtsq-5-ac.dtb \
|
||||||
+ qcom-ipq4018-nbg6617.dtb \
|
+ qcom-ipq4018-nbg6617.dtb \
|
||||||
|
Loading…
Reference in New Issue
Block a user