From 6a661d7fe316a55deacd25b6df7fa245b5cb7cda Mon Sep 17 00:00:00 2001
From: Luka Perkov <luka@openwrt.org>
Date: Mon, 28 Dec 2015 04:56:33 +0000
Subject: [PATCH] uboot-imx6: add support for i.MX6q SABRE board

U-boot ships with the `mx6qsabresd` configuration file to configure a
bootloader suitable for booting the Freescale i.MX6q SABRE evaluation board
from SD card. Expose this option in the uboot-imx6 Makefile.

Signed-off-by: Keno Fischer <keno@juliacomputing.com>

SVN-Revision: 48014
---
 package/boot/uboot-imx6/Makefile | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index 7074da9f0d4..1e926238d87 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -28,6 +28,10 @@ define uboot/Default
   IMAGE:=
 endef
 
+define uboot/mx6qsabresd
+  TITLE:=U-Boot for SABRE i.MX6Quad board
+endef
+
 define uboot/nitrogen6dl
   TITLE:=U-Boot for Nitrogen6x i.MX6Dual-Lite 1GB board
 endef
@@ -65,6 +69,7 @@ define uboot/wandboard_solo
 endef
 
 UBOOTS := \
+	mx6qsabresd \
 	nitrogen6dl \
 	nitrogen6dl2g \
 	nitrogen6q \