gdb: Update to version 15.2

See news file for changes:
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=blob_plain;f=gdb/NEWS;hb=gdb-15.1-release

Link: https://github.com/openwrt/openwrt/pull/16665
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
Hauke Mehrtens 2024-10-10 22:13:40 +02:00
parent 1cd7708eb3
commit 654983ea11
7 changed files with 15 additions and 15 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=gdb PKG_NAME:=gdb
PKG_VERSION:=14.1 PKG_VERSION:=15.2
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gdb PKG_SOURCE_URL:=@GNU/gdb
PKG_HASH:=d66df51276143451fcbff464cc8723d68f1e9df45a6a2d5635a54e71643edb80 PKG_HASH:=83350ccd35b5b5a0cba6b334c41294ea968158c573940904f00b92f76345314d
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1 PKG_INSTALL:=1

View File

@ -2,7 +2,7 @@ See http://sourceware.org/bugzilla/show_bug.cgi?id=14523
--- a/gdbsupport/signals.cc --- a/gdbsupport/signals.cc
+++ b/gdbsupport/signals.cc +++ b/gdbsupport/signals.cc
@@ -348,6 +348,11 @@ gdb_signal_from_host (int hostsig) @@ -347,6 +347,11 @@ gdb_signal_from_host (int hostsig)
else if (64 <= hostsig && hostsig <= 127) else if (64 <= hostsig && hostsig <= 127)
return (enum gdb_signal) return (enum gdb_signal)
(hostsig - 64 + (int) GDB_SIGNAL_REALTIME_64); (hostsig - 64 + (int) GDB_SIGNAL_REALTIME_64);

View File

@ -1,6 +1,6 @@
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -1400,13 +1400,13 @@ if test -z "$LD"; then @@ -1401,13 +1401,13 @@ if test -z "$LD"; then
fi fi
fi fi
@ -17,7 +17,7 @@
AC_LANG_PUSH(C++) AC_LANG_PUSH(C++)
AC_LINK_IFELSE([AC_LANG_SOURCE([ AC_LINK_IFELSE([AC_LANG_SOURCE([
#if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5) #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
@@ -1836,7 +1836,7 @@ AC_ARG_WITH(stage1-ldflags, @@ -1837,7 +1837,7 @@ AC_ARG_WITH(stage1-ldflags,
# trust that they are doing what they want. # trust that they are doing what they want.
if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \ if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
-a "$have_static_libs" = yes; then -a "$have_static_libs" = yes; then
@ -26,18 +26,18 @@
fi]) fi])
AC_SUBST(stage1_ldflags) AC_SUBST(stage1_ldflags)
@@ -1865,7 +1865,7 @@ AC_ARG_WITH(boot-ldflags, @@ -1866,7 +1866,7 @@ AC_ARG_WITH(boot-ldflags,
# statically. But if the user explicitly specified the libraries to # statically. But if the user explicitly specified the libraries to
# use, trust that they are doing what they want. # use, trust that they are doing what they want.
if test "$poststage1_libs" = ""; then if test "$poststage1_libs" = ""; then
- poststage1_ldflags="-static-libstdc++ -static-libgcc" - poststage1_ldflags="-static-libstdc++ -static-libgcc"
+ poststage1_ldflags="-static-libstdc++" + poststage1_ldflags="-static-libstdc++"
fi]) fi])
AC_SUBST(poststage1_ldflags) case $target in
*-darwin2* | *-darwin1[[56789]]*)
--- a/configure --- a/configure
+++ b/configure +++ b/configure
@@ -5413,14 +5413,14 @@ if test -z "$LD"; then @@ -5414,14 +5414,14 @@ if test -z "$LD"; then
fi fi
fi fi
@ -56,7 +56,7 @@
ac_ext=cpp ac_ext=cpp
ac_cpp='$CXXCPP $CPPFLAGS' ac_cpp='$CXXCPP $CPPFLAGS'
ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5' ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
@@ -8464,7 +8464,7 @@ else @@ -8465,7 +8465,7 @@ else
# trust that they are doing what they want. # trust that they are doing what they want.
if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \ if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
-a "$have_static_libs" = yes; then -a "$have_static_libs" = yes; then
@ -65,7 +65,7 @@
fi fi
fi fi
@@ -8500,7 +8500,7 @@ else @@ -8501,7 +8501,7 @@ else
# statically. But if the user explicitly specified the libraries to # statically. But if the user explicitly specified the libraries to
# use, trust that they are doing what they want. # use, trust that they are doing what they want.
if test "$poststage1_libs" = ""; then if test "$poststage1_libs" = ""; then

View File

@ -27,7 +27,7 @@ gdb/ChangeLog:
--- a/gdbsupport/signals-state-save-restore.cc --- a/gdbsupport/signals-state-save-restore.cc
+++ b/gdbsupport/signals-state-save-restore.cc +++ b/gdbsupport/signals-state-save-restore.cc
@@ -38,7 +38,7 @@ save_original_signals_state (bool quiet) @@ -37,7 +37,7 @@ save_original_signals_state (bool quiet)
int i; int i;
int res; int res;

View File

@ -24,7 +24,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
--- a/gdbserver/linux-low.cc --- a/gdbserver/linux-low.cc
+++ b/gdbserver/linux-low.cc +++ b/gdbserver/linux-low.cc
@@ -5481,7 +5481,7 @@ linux_process_target::request_interrupt @@ -5525,7 +5525,7 @@ linux_process_target::request_interrupt
{ {
/* Send a SIGINT to the process group. This acts just like the user /* Send a SIGINT to the process group. This acts just like the user
typed a ^C on the controlling terminal. */ typed a ^C on the controlling terminal. */

View File

@ -19,7 +19,7 @@ Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
--- a/gdb/mips-linux-nat.c --- a/gdb/mips-linux-nat.c
+++ b/gdb/mips-linux-nat.c +++ b/gdb/mips-linux-nat.c
@@ -31,7 +31,7 @@ @@ -30,7 +30,7 @@
#include "gdb_proc_service.h" #include "gdb_proc_service.h"
#include "gregset.h" #include "gregset.h"

View File

@ -18,7 +18,7 @@ Upstream-Status: Pending
--- a/gdb/mips-linux-nat.c --- a/gdb/mips-linux-nat.c
+++ b/gdb/mips-linux-nat.c +++ b/gdb/mips-linux-nat.c
@@ -42,6 +42,11 @@ @@ -41,6 +41,11 @@
#define PTRACE_GET_THREAD_AREA 25 #define PTRACE_GET_THREAD_AREA 25
#endif #endif